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CHAPTER 1: GENERAL ADVICE ON THE USE OF 

buildingEXODUS 
Chapters 1-7 offer basic advice on some of the more important aspects of using the 

buildingEXODUS model.  They cover the main areas required to simulate an evacuation:  

 

Representing the Building (CHAPTER 2:);  
 

Representing the Population (CHAPTER 3:);  
 

Representing the Procedural/Behavioural Response (CHAPTER 4:);  
 

Representing the Environmental Conditions (CHAPTER 5:);   
 

Running Simulations (CHAPTER 6:);  
 

Producing Results (CHAPTER 7:).  
 

 

Chapters 1-7 should take the user from the beginning of the analytical process to the point where 

they have results ready for analysis, and provide some guidance on how best to employ the 

model in the process. 

 

It should be remembered that the buildingEXODUS model is just a tool (albeit a sophisticated 

one) to aid the engineer/user in answering questions of interest. As with all tools, the end results 

produced are as much to do with the expertise of the user (and the data available) as they are 

with the tool itself. It is important for the user to apply the model responsibly: to ensure that the 

data employed is appropriate; that the settings enabled are credible to match real-world factors 

with simulated conditions; and that the conclusions drawn are reliable. The user needs sufficient 

expertise in order to use the model in this responsible manner. It is strongly recommended that 

all users read and refer to the documentation provided; to take out User Support Contracts (see 

the User Guide, Chapter 1); and, where possible, attend one of the training courses that are 

available from your supplier or the developers. It is relatively easy for the user to produce 

results; however, this does not mean that they are useful, credible or accurate. 

 

Various parameters and variables are assigned pre-set DEFAULT values throughout the 

EXODUS software. While every effort has been made to assign sensible default values, it is 

unlikely that these will be suitable for all applications; indeed, given then range of potential 

scenarios to which buildingEXODUS can be employed, this is not realistic. It is therefore 

essential that the user reviews these default values and ensures that they are appropriate for the 

intended application; i.e., that they accurately translate real world factors into the simulated world. 

In virtually all cases where default values have been set, the user has the option to alter these 

values.  Whenever default values are changed, users should ensure that the new values do not 

violate any of the principles or assumptions of the buildingEXODUS software. The user should 

also ensure that the model settings and the data provided reflect the real world conditions being 

simulated and can be therefore defended as credible, reliable and conservative. 

 

The buildingEXODUS model has been developed over a number of years into a comprehensive 

and flexible tool. This gives the user the ability to address a range of different scenarios and 

represent an array of behavioural and procedural responses. It also often allows the user a number 

of different approaches to achieve the same objective. It is vital that the user understands and 

justifies the selection of an approach – both to ensure that they apply the approach correctly and 
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consistently, but also so that third parties viewing the results can understand their actions and 

assess them appropriately. Chapters 1-7 should help the user select between the different 

approaches available and identify which of the actions taken require explanation. 

 

1.1 Modelling Overview 

The modelling process requires that real world objects and events are simulated within the 

simulated environment. By definition, the ability of a simulation tool to generate a modelled 

world requires a simplification of the real world. This is often further simplified during the 

representation of a particular scenario (see Figure 1-1).  

 

 
Figure 1-1: The difference between the real and modelled worlds. 

 

It is critical that the user is aware of this simplification, and where the impact of the simplification 

is most significant. This will allow the user to configure the simulations in the most credible 

manner and then have more confidence in the results produced.  

 

The process starts with a problem that requires engineering questions to be posed. These are then 

translated into scenarios that require representation within the buildingEXODUS model. The 

model is then used to simulate these scenarios and derive results that answer these questions. 

These results, along with the expertise of the user, then help derive conclusions that inform real 

world recommendations (see Figure 1-2). 

 

The modelled world can be broadly broken into two key components: representation of objects 

and the impact of these objects on performance – on the results produced. This requires the user 

to define and configure the interaction of the modelled objects within the model that then establish 

performance levels in the form of simulation results. From these results, the user is then able to 

draw real world conclusions and make recommendations.  
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Figure 1-2: The transition from real world problems, to modelled world analysis, to 

real world recommendations. 

 

Given the nature of the model, we are most interested in the performance of the evacuating 

population; e.g., how they exit the building. This performance can be compared to the 

development of the fire, the structural integrity of the building, the procedures in place, the actions 

of emergency responders (indeed, the impact of these elements can, to some degree, be 

represented), but the fundamental goal is to simulate the response of the population. This response 

can be determined individually (i.e., left to the model to predict aspects of response) or imposed 

as if following a pre-determined procedure and response (i.e., imposed to ensure response 

allowing engineering questions to be answered).  

 

At its most basic level, the evacuee performance can be broken down into four key elements:  the 

response phase; the attainable speed; flow characteristics; and the route usage. There are many 

internal and external factors that influence performance; however, the performance of these 

factors can be represented using these key elements. For instance, the presence of staff may 

directly influence the response phase and route usage; an impairment may influence the attainable 

speed (and indirectly route usage); the presence of smoke may influence all four elements (see 

Table 1-1). 

 

In the next sections, the description will be broadly broken down into representing real world 

objects and then simulating their effect on performance. Where appropriate this effect will be 

described using a simple schematic (see Table 1-1), shaded to clearly denote the nature of this 

effect and therefore what factors should be addressed in the simulated environment. 
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Table 1-1: Schematic of the impact on performance. 

BEHAVIOURAL COMPONENTS IN BASIC ENGINEERING ASSESSMENT 

RESPONSE 
PHASE 

ATTAINABLE 
SPEED 

FLOW 
CHARACTERISTICS 

ROUTE  
USAGE 

 

In addition, guidance will be provided on which of the EXODUS modes are active to enable 

the functionality described; i.e., whether Geometry, Population, Scenario and/or Simulation 

mode is active. 
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CHAPTER 2: REPRESENTING THE BUILDING 
 

2.1 Specifying the Geometry 

Specifying the geometry defines the structural perimeter and separates the structure internally. 

This defines the space within the structure, the connectivity between these spaces and the 

capacity to occupy and move between the spaces. In the model, this boundary provides the shell 

within which the nodal network will be generated. It is therefore an essential first step in 

representing the building within which the evacuees will be moving and acting.  

 

Specifying the geometry of a complex structure can be a lengthy process. Wherever possible it 

is recommended that the user imports the boundary of the structure from geometry files in third 

party formats such as those used by CAD packages, BIM/IFC or CFD models (i.e. DXF, IFC, 

FDS or SMF). Where this is not possible the interactive tools provided will enable even the 

most complex of structures to be constructed.  

 

2.1.1 Using DXF Files In buildingEXODUS 

Active Mode: Geometry 

 

NOTE:  

In this section, some prior knowledge of CAD usage is assumed. 

 

The purpose of DXF files in buildingEXODUS is to provide a boundary for the Node Flood 

tool. Ideally, only the walls in a DXF file should be present for buildingEXODUS.  For this 

reason, much data usually contained in DXF files is unnecessary and should be removed prior 

to using the file.  The steps given below represent the approach that the authors have found to 

produce the best results. 

 

1. Within the CAD package, create a new layer entitled “EXODUS”. 

2. Switch on all the layers available for the floor to be modelled. 

3. Ensure the scale is ONE UNIT PER UNIT OF MEASUREMENT (e.g. millimetres, 

centimetres, metres, inches, feet or yards). 

4. Use the POLYLINE function to trace the boundaries to be modelled (internal and 

external). 

5. Switch off the “EXODUS” layer and turn all the other layers on. 

6. Select the whole geometry and delete it. 

7. Switch on the “EXODUS” layer. 

8. Move the enclosure so that the bottom-left corner of the enclosure is at the origin (0,0) 

so that the enclosure is in the positive quadrant. 

9. Export the enclosure to a DXF file. 

 

NOTE: 

The process outlined above is required to produce a DXF file suitable to represent a SINGLE 

floor in buildingEXODUS.  

 

NOTE: 

EACH floor modelled (derived from a CAD file) should be saved as a SEPARATE DXF file. 
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On importing boundary data from third party geometry files (i.e. DXF, IFC, FDS or SMF),  the 

model interprets the data and creates its own internal version of the structure (an .EGX file).  

In any subsequent loading of the same geometry, the model will use its own file format, greatly 

reducing loading times. The internal representation will be identical in appearance and in its 

impact upon the simulation to the original third party geometry file. Once buildingEXODUS 

has generated its own internal version of the boundary (i.e. EGX), the original third party 

geometry file is no longer required. 

 

 
Figure 2-1: Enabling the selection of Lines via Gra. Ctrl Options.   

 

NOTE: 

In addition to editing the lines of an imported third party geometry (i.e. DXF, IFC, FDS or 

SMF), it is also possible to manipulate the Boundary Lines of a buildingEXODUS defined 

geometry. 

 

Additionally, the EGX file format allows the user to edit the underlying structure imported from 

third party geometry files (i.e. DXF, IFC, FDS or SMF). Unwanted lines that occasionally 

appear in imported geometry files (particularly DXF files) may be selected, moved, edited or 

deleted from the file.  The ability to select lines (and thereby edit/manipulate them) can be 

achieved via the Display Control dialogue box. This is accessible by selecting  Gra. Control 

Options from the Display option in the View menu (see Figure 2-1). 

 

  
(a) (b) 

Figure 2-2: Modifying a boundary imported from a third party geometry file (i.e. DXF). 

 

The DXF file in Figure 2-2(a) has been imported into buildingEXODUS. Here the user wishes 

to remove several of the lines within the DXF file to reflect numerous changes to the actual 

structure. This is achieved in Figure 2-2(b), where individual lines have been selected and 

deleted, thereby altering the structure of the geometry. 
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Figure 2-3: The manipulation of an individual line imported from a third party 

geometry file (i.e. DXF). 

 

Additionally the user has the ability to add to the underlying structure imported from a third 

party geometry file (i.e. DXF, IFC, FDS or SMF). This can be achieved through manipulating 

the existing lines within the imported boundary. Initially the Boundary Lines option should be 

selected in an identical manner as in the previous example. Then when a specific line has been 

selected, instead of deleting the line, it may instead be moved or resized (see Figure 2-3). 

 

NOTE: 

This allows design variants to be quickly produced from the same underlying boundary 

imported from third party geometry files (i.e. DXF, IFC, FDS or SMF). 

 

2.1.2 Manual creation of the geometry boundary using Line objects. 

Active Mode: Geometry 

 

In some circumstances an irregular shape may require representation, without the presence of 

boundary imported from a third party geometry file. The irregular shape could be manually 

generated on a node by node basis, although this will take an inordinate amount of time to 

complete. To speed up this process, this can be achieved within the model using the Line object. 

Effectively, the user generates individual lines, which in combination form the outline of the 

geometry. Although this then acts as a boundary for the geometry, which can then be flooded 

with nodes, as described previously. These lines can be accessed through the Tools menu, 

through selecting the Line option via the Generate sub-menu (see Figure 2-4(a)). These are 

generated by dragging the Lines out across the workspace area. These Line objects can be edited 

by allowing their selection (via double-clicking on the  button and then enabling Line 

selection in the Display Control dialogue box). The Line that requires editing can then be 

selected, by double-clicking on it, producing the Line dialogue box displayed in (see Figure 

2-4(b)). 

 

NOTE: 

Lines can also be added to existing boundaries imported from third party geometry files (i.e. 

DXF, IFC, FDS or SMF) to quickly produce design variants. 
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(a) (b) 

Figure 2-4: (a) Selecting the Line object. (b) Editing the Line attributes. 

 

Once an enclosed boundary has been created the area can then be flooded with nodes as if it 

were a boundary from an imported third party geometry file (see Figure 2-5(a)), producing an 

enclosure that can be traversed by evacuees (see Figure 2-5(b)). 

 

  
(a) (b) 

Figure 2-5: (a) Selecting Node Flood. (b) Node Flooding the enclosure. 

 

It can be useful when analysing results to identify the location from which a section of the 

population commenced their evacuation (i.e. examine the starting locations of the occupants, in 

order to see whether particular trends in terms of evacuation times/survival may be influenced 

by the area in which they commenced their evacuation). This can be easily achieved by selecting 

groups of nodes and giving them meaningful names. Once the simulation is completed, and the 

results are echoed to the simulation file, the starting location of the individual will then reflect 

the name provided. 
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2.1.3 Modelling space with nodes 

Active Mode: Geometry 

 

buildingEXODUS models space through a system of four sided nodes. By default each node is 

square, measuring 0.5m along each edge. The centre of each node is connected by a system of 

horizontal and vertical arcs measuring 0.5m (default value) and diagonal arcs measuring 

0.7071m (default value). It is the length of these arcs that define the size of the node. Changing 

the length of the arc affects the size of the node. While the default arc length can be altered this 

should only be contemplated in small local regions and it should remain within the limits 

between 0.3m to 1.0m. Using arc lengths outside these limits invalidates the key assumption of 

fitting one person per node.  Globally changing the arc length can have repercussions on other 

model parameters. 

 

NOTE: 

The default conflict times are appropriate for the default mesh spacing.  If a geometry is meshed 

with a spacing different to the default value, it may prove necessary to reassess and redefine 

the conflict times and travel speed distributions. This may prove necessary as changes to the 

mesh may impact the range of packing densities in heavily congested areas allowed by the 

model.  If the mesh spacing is reduced it may prove necessary to increase the conflict times 

reflecting the greater time involved in resolving these conflicts. 

 

Some complex geometries, such as those with curved walls, cannot easily be represented using 

rectangular nodes and may require small approximations to be made along the boundary.  The 

best manner to do this is to use the Node Flood function available in GEOMETRY MODE.  This 

is found by going to the Tools menu and selecting the Construction sub-menu.  This option will 

automatically make any approximations necessary. Node Flood simply covers an area with 

nodes until it reaches a boundary, be it either manually defined or imported from third party 

geometry files. Wherever possible it is recommended that the user directly imports the boundary 

of structures from third party geometry files (i.e. DXF, IFC, FDS or SMF). 

 

It should be noted that the Node Flood function always attempts to place a grid of 0.5m x 0.5m 

nodes across the enclosure.  If the user is unsatisfied with any approximations made by the 

Node Flood function, the nodes may be redistributed manually.  For example, consider a 

rectangular room measuring 3m x 5.4m.  In such a case, the Node Flood function would place 

6 nodes across the 3m boundary and 10 nodes across the other. 

 

This results in a 0.4m discrepancy in the measurement of the 5.4 m side.  It should be noted this 

discrepancy would typically result in an error of between 0.33 seconds (assuming a travel speed 

of 1.2 m/s) and 0.5 seconds (assuming a travel speed of 0.8 m/s) in the time taken for a person 

to traverse this distance.  It is suggested that for most cases this be ignored. However, the 

discrepancy may be corrected using the following method.  

 

While in GEOMETRY mode select the Physical Dist. option from the Tools menu. Proceed to 

disconnect all the arcs connecting the nodes in the offending row. Move the nodes to the desired 

location and manually reconnect all the nodes with the appropriate arcs. As the Physical Dist. 

option was selected, the new arcs will automatically possess the correct distances.  
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NOTE:  

Arc lengths should be checked to ensure that they are within permissible limits. 

 

Furthermore, slightly different nodal distributions may result from Node Flooding the geometry 

depending on the initial cursor location that starts the Node Flood process. In the majority of 

cases these differences will be insignificant. However, in certain situations such as in narrow 

regions of the geometry (e.g. a narrow corridor or door opening) too few or too many nodes 

may be created for the space available.  

 

NOTE: 

 It is strongly advised that as part of the checking procedure these regions are examined after 

a flood fill to ensure that the correct number of nodes have been created.  

 

If upon examination an unsatisfactory node distribution has been created within a sub region, 

selectively delete the nodes in the region in question and repeat the node flood procedure or 

manually position the required number of nodes.  Once the new region has been flooded, 

manually connect the nodes in the newly flooded region to the remainder of the nodal mesh.  

 

A consequence of using a default arc length of 0.5m is that the packing density of people within 

a buildingEXODUS simulation is restricted to a maximum of 4 people/m2. buildingEXODUS 

can therefore only be used with confidence in modelling situations involving population densities 

up to 4 persons/m2.  Situations within a simulated geometry that maintain packing densities of 4 

people/m2 for long periods of time should be closely reviewed and their significance assessed. A 

useful way of noting the occurrence of high population densities is to observe the simulation using 

the Contour option (found under the View menu in SIMULATION mode) and selecting Pop 

Density. 

 

KEY POINTS: REPRESENTATION  
 

 Boundary geometry limits the spread of the nodal network.  

 It does not directly influence the performance of the evacuees. 

 Nodal network represents occupiable space and connectivity. 

 It directly influences the occupancy levels, population densities, the routes that can 

be followed and the distances that need to be travelled. 

 

2.2 Building – Influencing Response 

In the previous sections, methods were discussed to bound and represent the occupiable space. 

In the following sections the nature of this space and its impact on performance is discussed; 

i.e., the methods available to the user to configure the terrain to produce reasonable evacuee 

performance. 

 

2.2.1 Modelling obstacles 

Active mode: Geometry 

 

buildingEXODUS can represent two types of obstacle:  those which are considered normally  

insurmountable (e.g. high shelving units) and those which are surmountable (e.g. seat row).  An 

insurmountable object is any object which evacuees will be forced to travel around, rather than 

go over.   Insurmountable obstacles are not explicitly modelled in buildingEXODUS; instead, 
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the nodes where these objects would be located are deleted.  For example, consider the 

geometry shown in Figure 2-6.  In this case, a simple geometry is shown with a rectangular area 

missing near the middle of the geometry, thus representing an insurmountable object. In 

contrast, surmountable obstacles can be considered as an object that individuals would 

preferably avoid but may travel over if necessary. 

 

 
Figure 2-6: Simple geometry with an insurmountable obstacle 

 

During an evacuation, whenever possible, people will tend to keep a small distance away from 

insurmountable objects. People will not attempt to travel too close to the object - the object 

effectively has a boundary layer that an evacuee attempts to avoid.  For example, consider a 

large table in a simple geometry. People evacuating from such a geometry would not brush up 

against the table, rather they would take a path around it. This situation can be modelled in 

buildingEXODUS by applying a halo of Boundary nodes around insurmountable objects.  

Evacuees will avoid Boundary nodes where possible, but in some cases - such as in crowds - 

they may be forced to travel very close to the obstacle.  In such cases, the speed of the evacuee 

travelling over the Boundary nodes is reduced to their walk speed.  Depicted in Figure 2-7 is a 

simple geometry with an insurmountable object near the centre of the compartment. In case (a), 

a halo of Boundary nodes has been applied around the edge of the obstacle, thus diverting the 

path around the object.  In case (b), the Boundary nodes have been removed and the evacuee 

moves directly along the edge of the object. 

 

This technique should also be applied along wall edges, as this will prevent evacuees travelling 

too close to walls wherever possible. 

 

 
(a) (b) 

Figure 2-7: An evacuee path around an insurmountable obstacle (a) with and (b) 

without boundary nodes. 

 

NOTE: 

Alternatively, nodes can be deleted to prevent locations next to a boundary being occupied. 

Although this is a conservative approach, it may preclude certain types of movement. 
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It is possible to automatically generate Boundary nodes through selecting the Generate item 

from the Auto Boundary Nodes sub-menu located on the Generate sub-menu (via the Tools 

menu).  This allows the rapid setting of Boundary nodes throughout the geometry, along walls 

and insurmountable obstacles.  However, some caution should be taken when using the 

automatic generation of Boundary nodes. The technique determines whether a Boundary node 

is required according to the connectivity and configuration of the individual nodes. Therefore, 

at points of restricted nodal connectivity that satisfy the configurational requirements of the 

algorithm, e.g. in thin corridors, etc., Boundary nodes will be automatically positioned (see 

Figure 2-8). If desired the Boundary nodes generated during this procedure can be removed by 

selecting Auto Boundary Nodes sub-menu and then Remove. This then allows the Boundary 

nodes to be regenerated by following the procedure defined above.  

 

NOTE: 

When using the Auto Boundary Nodes / Generate tool, only nodes that are vertically or 

horizontally connected to the node examined are included in the calculation.  This limits the 

number of cases in which Boundary nodes will be introduced into the geometry. This also 

enables the algorithm to be used in situations where the connectivity of the nodes has been 

artificially reduced for some reason. 

 

This is not normally a problem as it is justifiable that within such restricted geometries that 

evacuees may be forced to reduce their movement rates in order to pass.  It is recommended 

that when using Boundary nodes, the geometry be checked to ensure that they are placed in 

appropriate regions.  

 

 
Figure 2-8: Automatic setting of Boundary Nodes around a wall and obstacle within a 

geometry.  

 

NOTE: 

Once the Auto Boundary Nodes / Generate function has been performed, any subsequent 

changes to the underlying structure of the geometry will not be reflected in the Boundary node 

distribution (e.g. the removal of nodes will not automatically generate Boundary nodes). To 

model the updated geometry accurately the automatic placement of Boundary nodes should be 

reapplied after changes in the geometry. 
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It is possible to alter the graphical interface to turn ON or OFF the visible representation of 

Boundary nodes. This is available through selecting Gra. Ctrl Options in SIMULATION mode 

as shown in Figure 2-9. This is useful as it allows the visible display of Boundary nodes during 

a simulation when the other node types are turned off, creating a less cluttered visual 

environment. 

 

 
Figure 2-9: Selection of Ctrl Options 
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2.2.2 Arc Obstacles 

Active mode: Geometry 

 

By implementing Boundary nodes, the user is able to represent a location that would tend to be 

avoided by evacuees if they have the opportunity; if they are not able to avoid the location then 

their travel speed is reduced. The user also has the option of increasing the Obstacle values 

associated with Arcs connecting nodal locations. This will reduce the travel speed of the 

evacuee (see the User Guide, Chapter 3); however the evacuees will not attempt to avoid the 

location. This is very useful for representing terrain that has an impact on movement, but that 

is frequently used (e.g., a ramp), or a particularly severe example of a typical egress component 

(e.g., a stair that has a low level ceiling that influences performance). 

 

NOTE:  

It is possible to represent non-standard egress components (e.g., ramps), using a combination 

of the features highlighted above. In effect, the user will be representing the effect that the 

component has, as opposed to accurately depicting the component itself. 
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2.2.3 Obstacle Zones 

Active Modes: Scenario 

 

This function enables the user to group together sets of nodes into zones in order to dynamically 

alter the Obstacle values of their connecting arcs during the simulation - in effect, the user is 

able to configure the manner in which the structural conditions change and how this change 

may then influence the performance of the evacuating population.  
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2.2.4 External Exits 

Active Modes: Geometry, Scenario 

 

External exits are used to represent the reduced flow and movement produced through the 

presence of a doorway out of the structure. It allows the user to cap the flow performance (e.g., 

as required in some regulations), allow the model to predict performance and retrieve 

performance data.  

 

External exits are modelled in buildingEXODUS in terms of lanes.  A lane is simply the space 

required by an occupant (width) to travel through the constriction.  buildingEXODUS assumes 

a default lane width through an exit to be 0.5m. While some studies [19] have suggested that 

lane widths may be wider, these studies were not conducted under emergency evacuation 

conditions and may not therefore accurately reflect the nature of emergency egress movement. 

 

The number of arcs assigned to an exit should thus represent the number of lanes through the 

exit.  To determine the appropriate number of arcs to attach to an exit simply divide the width 

of the exit by 0.5m (assuming default width is used).  The result represents the number of arcs 

to attach to the exit.  This is quite simple for exit widths that are exactly divisible by 0.5 

however, how should exits that are not exactly divisible, be treated?  There are several ways of 

tackling this problem, all of which have their advantages and disadvantages. These are: 

 

(1) Always round the fractional component down to the lower whole number i.e. ignore the 

fractional component.  This will tend to produce conservative results (longer evacuation 

times) by utilising exits with smaller apertures.   

(2) Always round the fractional component to the nearest 0.5m.  This approach produces 

conservative results when rounding down and optimistic results (shorter evacuation times) 

when rounding up. 

(3) Whether adopting option (1) or (2), modify the user specified (unit flow rate) UFR to reflect 

the expected maximum Flow Rate (NOTE: Flow Rate = UFR x Width). This is achieved as 

follows, if the actual width of an exit is larger than the simulated exit (i.e. rounding the 

fractional component down), compensate by increasing the user specified UFR, and 

conversely, reduce the UFR if the simulated exit is wider than the actual exit (i.e. rounding 

the fractional component up). Consider the following examples: 
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EXAMPLE (1): Consider an exit that is 1.7 m wide and the HMSO UFR is to be applied. 

This will produce an expected maximum flow rate of: 

 

1.7 m x 1.33 occ/m/s  =  2.261 occ/s 

 

If we choose to represent this exit using three 0.5 m arcs (i.e. round down the width) we 

must increase the UFR to achieve the same maximum flow rate of 2.261 occ/s. Thus, the 

UFR that is applied to the exit with three arcs should be 1.507 occ/m/s (i.e. 2.261/1.5), 

thereby producing: 

 

1.5 m x 1.507 occ/m/s = 2.261 occ/s. 

 

EXAMPLE (2): Consider an exit that is 1.9 m wide and the HMSO UFR is to be applied. 

This will produce an expected maximum flow rate of, 

 

1.9 m x 1.33 occ/m/s  =  2.527 occ/s 

 

If we choose to represent this exit using four 0.5 m arcs (i.e. round up the width) we must 

decrease the UFR to achieve the same maximum flow rate of 2.527 occ/s. Thus, the UFR 

that is applied to the exit with four arcs should be 1.264 occ/m/s (2.527/2.0), thereby 

producing: 

 

2.0 m x 1.264 occ/m/s = 2.527 occ/s. 

 

This technique is only viable when using a user specified UFR (i.e. not applicable in free-flow 

conditions).  When modifying these parameters it is recommended to conduct careful 

parametric analysis to assess the sensitivity of the results to the changes (see Chapter 8). 

 

While option (1) is the method recommended in most cases, the best solution is to explore each 

of the alternatives and perform sensitivity analysis by appropriately increasing or decreasing 

the number of arcs connected to an exit.   

 

When a user defined UFR is chosen that is very large (e.g. the highest UFR available within 

buildingEXODUS, 999 occ/m/s), the exit behaves as if it is under free-flow conditions. In this 

case buildingEXODUS determines the flow rate achieved based on the width of the exit and its 

behaviour rules. In free-flow situations, buildingEXODUS can produce UFRs of the order of 2 

occ/m/s. While this may appear large when compared with the HMSO approved rate, it is in 

line with the upper end of the Fruin measured flow rates [19] and other experimental 

observations [37,44,45,50]. Although this allows the flow conditions to emerge in a more 

naturalistic manner, it may not conform to regulatory requirements; i.e., the flow rates stipulated 

in the regulatory framework may be more stringent than those that emerge during model 

predictions. In these situations, the flow rates should be capped in accordance with the 

regulatory requirements. 

 

The variation of flow rate with exit size for free-flow and pre-defined UFRs is demonstrated by 

considering the following hypothetical situation.  Consider a 9m x 9m compartment containing 

300 randomly generated occupants.  The compartment has a single external exit that is 

systematically increased from 1.0m to 3.0m in 0.5m increments and the external exit is operated 

under free-flow conditions and with HMSO and Fruin prescribed UFRs. Each scenario is run 
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five times in order to arrive at a distribution of evacuation times and flow rates. Thus, for each 

exit width 15 simulations are performed. The average flow rate and average UFR achieved for 

each of the exit widths are depicted in Figure 2-11.  Note that the relationship between the 

average flow rate and the exit width is approximately linear and that the relationship between 

the average UFR and the exit width is almost constant.  The slope of the flow rate graph (Figure 

2-11a) determines the achieved average flow rate per metre (average UFR) for each exit 

specification.  If the 1m exit is excluded, this produces achieved average UFRs of 2.25 occ/m/s 

for free flow conditions, 1.15 occ/m/s for Fruin UFR and 1.05 occ/m/s for HMSO UFR. 

 

As an example of the behaviour of external exits using free-flow and prescribed UFRs 

consider the following results.  These simulations attempt to reproduce a series of 

experiments conducted by Stapelfeldt [44] and reported by Paulsen et al [45].  Interested 

readers are referred to references [37,50] for a more complete discussion.  The experiment 

involved placing 100 police cadets in a compartment containing a single exit. In the case 

examined here, the compartment had an exit measuring 1.5m. The data reported in Paulsen 

et al [45] concerns the evacuation of the room under ‘normal’ conditions, without simulated 

'panic'/increased motivation to evacuate, or the effects of hazards.  In the buildingEXODUS 

simulations, a 3.0m x 8.5m enclosure and a population of 100 males with the default Drive 

attribute was specified. In the Paulsen report [45], the experimental evacuation time for the 

1.5m exit is quoted as 30 seconds. This was apparently for a single trial. Five repeat runs of 

buildingEXODUS produced evacuation times for each UFR as shown in Table 2-1.  

 

Table 2-1: buildingEXODUS generated mean evacuation times (seconds) for the 

1.5m exit case. Results in parenthesis indicate the distribution produced by the 

repetition of the simulation. 

Experiment  HMSO  Hankin Fruin  Polus  Free-Flow 

30.0 
55.5 

 [55.2-55.8] 

51.4  

[50.6-52.1] 

46.8  

[45.9-48.2] 

54.3  

[53.9-54.7] 

29.0  

[26.4-31.6] 

 

From examining Table 2-1 it is clear that the prescribed UFRs significantly over predict the 

experimental evacuation time by between 56% (Fruin UFR) and 85% (HMSO UFR). In 

contrast, the free-flow results produce the best agreement with experimental results. These 

vary from under predicting the evacuation time by 3.6 seconds (i.e. 12%) to over predicting 

the evacuation time by 1.6 seconds (i.e. 5.3%).  The mean result produced under free-flow 

conditions under predicts the measured evacuation time by only 1.0 second (i.e. 3.3%). 

 

 
Figure 2-10: buildingEXODUS predicted unit flow rate determined in 5 second 

intervals for the free-flow case. 
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The free-flow condition produces significantly larger flow rates than those imposed by the 

prescribed UFRs. The instantaneous unit flow rates predicted by buildingEXODUS over 5 

second intervals are depicted in Figure 2-10.  Based on the mean evacuation time, under 

free-flow conditions, buildingEXODUS achieved an average UFR of 2.30 occ/m/s. This 

UFR is in line with those measured in the experiment. Indeed, from the original evacuation 

experiments the flow rates generated were calculated to be approximately 2.22 occ/m/s.  

These average UFRs are significantly higher than those achieved using the predefined 

UFRs, which varied from 1.20 occ/m/s (HMSO) to 1.43 occ/m/s (Fruin). 

 

  
(a) (b) 

Figure 2-11: buildingEXODUS predicted average flow rate (a) and average UFR (b) 

for an external exit in the 9m x 9m compartment with 300 occupants. 

 

The current range of pre-defined UFR values built into buildingEXODUS are derived from the 

values cited in the literature and are based on open exits. Due to a lack of reliable data, the 

current implementation of buildingEXODUS does not account for different types of exit, for 

example free-swinging, turnstile etc. The predefined UFR values may not be suitable for these 

other types of exits.  Users may however experiment with different values using the User 

Defined option for UFR. 

 

The flow of the potential map can be managed by modifying the Potential attribute associated 

with an External Exit. As discussed in the User Guide, Chapters 3 and 5, the Potential attribute 

associated with an External Exit seeds the potential map, which is then generated in relation to 

the Potential value associated with the exits. If the Local Potential option has been selected, 

the evacuating population will then make use of the potential map to navigate around the 

structure. The user is able to manage the Potential attributes on an individual object basis, or 

using the Potential Assignment tool available in Scenario Mode under the Tools menu. Those 

objects that can influence the spread of the potential map appear in the associated dialogue box. 

The name of the object (be it an external exit, internal exit, etc.) appears along with the current 

Potential associated with the object. This can be modified (see Figure 2-12). The new value 

will be used as the seed for the potential map during the calculation of the map at the start of 

the simulation.  
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Figure 2-12: Potential Assignment Tool. 
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2.2.5 Internal Exits  

Active Modes: Geometry, Scenario 

 

The use of Internal Exit nodes is the recommended manner of representing internal doorways 

and narrowings when it is necessary to control the flow rate of individuals through internal exits 

or when it is desirable to control the potential map within a compartment.  

 

In order to control the potential map within an internal compartment or control the flow rate 

through an internal exit it is recommended that Internal exit nodes should be placed in the exit.   

 

Once the correct number of nodes and arc lengths have been determined, the user identifies the 

entire area of the exit and then selects the Internal Exit tool from the Generate sub-menu 

positioned on the Tools menu (see Figure 2-13). Once defined, these nodes will automatically 

act as a single internal exit. Diagonal connections should be used within internal exits. Unlike 

the use of Attractor/Discharge nodes, the use of diagonal arcs is recommended allowing a 

greater freedom of evacuee movement. 
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Figure 2-13: Creation of an Internal exit.  

 

In some circumstances, when the automatic Node Flood procedure is used, it is possible that 

the appropriate number of nodes may not be placed within an internal opening (see Section 

2.1.3) or that the exit width (i.e. arc lengths) is incorrect.  It is therefore recommended that the 

user check that internal exits have been correctly specified.  It is vital that the exit width be 

correctly represented.  Once again, it is generally preferred to round down the exit width than 

round up as this produces conservative results, although a sensitivity analysis concerning these 

assumptions may be appropriate. 

 

The exit potential and the UFR are only required to be specified on one of the constituent nodes 

describing the internal exit. The Potential attached to the Internal Exit affects the usage of the 

exit, i.e. the smaller the potential the more attractive the exit.  

 

NOTE:  

It is important that all nodes within an Internal Exit are connected. That is, a single Internal 

Exit object, made up of several nodes, can only represent a single exit. 

 

The constituent nodes should cover both sides of the opening that is being defined as an internal 

exit (see Figure 2-16). Any restriction in the flow rate that is placed on movement through the 

exit is incurred when entering the exit for the first time (moving from a Free-Space node to an 

Internal Exit node). This is particularly important as unlike the application of 

Attractor/Discharge nodes, the delaying impact of Internal Exits are bi-directional, rather than 

being dependent upon the configuration of the Attractor/Discharge nodes. This can be seen 

from the following example.  

 

A simple geometry is generated, forcing individuals to pass through an internal opening towards 

an exit (see Figure 2-14). This internal opening is represented using the Internal Exit function 

(creating an internal exit of 1.5m). It is attributed with the HMSO flow rate.  A 1.5m connection 

to an exit is either located at the western end of the geometry (see Figure 2-14(a)) or the eastern 

end of the geometry (see Figure 2-14(b)).  In both cases the external exit is effectively attributed 

with free-flow conditions (no delays are included) so as not to impact upon the overall 
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evacuation times. The geometry is modified so that the evacuees are forced to travel across the 

internal exit in both directions, during the scenarios examined.  

 

  
(a) (b) 

Figure 2-14: The two versions of the geometry examined 

 

Twenty individuals are located in the compartment most distant from the external exit. To 

maintain the original conditions, these are moved in relation to the external exit (see Figure 

2-14). The individuals respond instantly. 

 

During the first scenario (see Figure 2-14(a)), the average evacuation time generated was 21.7 

seconds, when the evacuees were moving from right to left. During the second scenario (see 

Figure 2-14(b)), the average evacuation time generated was 21.9 seconds, when the evacuees 

were moving from west to east (i.e. left to right).  This demonstrates that the direction in which 

the evacuees are travelling across the Internal Exit does not impact significantly upon the results 

produced, demonstrating the consistency of the method. 

 

NOTE: 

When placing Internal Exit nodes on facing walls it is advisable that the Internal Exit nodes for 

the exits are not connected to each other.  At least one Free-Space node should separate the 

Internal Exit nodes (see Figure 2-15). In some circumstances the nature of the geometry may 

force the user to place Internal Exits adjacent to each other. In such circumstances the user 

should examine the impact upon the evacuation of such an action.  

 

  
(a) (b) 

Figure 2-15: (a) The recommended method to connect Internal exits. (b) Less reliable 

means of Internal exit connection. 

 

The model will function with the imposition of a single row of Internal Exit nodes.  However, 

this configuration will not provide consistent results for bi-directional flows. For instance, with 

the recommended placement of Internal Exit nodes (see Figure 2-16) individuals moving in 

either direction will experience a similar imposed flow restriction.  If only a single row of nodes 

is positioned, the delays experienced by the individuals will be dependent upon the nature of 
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the geometry.  For instance, the exact location of the nodes, whether they are inside or outside 

of the internal exit, may have an impact upon the results produced.  

 

 
Figure 2-16: Placement of the Internal Exit. 

 

An example is provided to demonstrate the differences in the results that might be produced 

through using a single row of Internal Exit nodes to represent an internal exit (see Figure 2-17). 

Again 20 evacuees are located in the western compartment, so that they are forced to cross the 

internal exit (1.5m in width) en route to the single external exit (with a 1.5m connection to the 

main geometry). The Internal Exit has HMSO flow rate attributed to it, while the external exit 

effectively has a free-flow rate applied to it (i.e. no delays). 

 

  
(a) (b) 

Figure 2-17: The internal exit is located on the eastern side of the opening (a) and the 

western side of the opening (b). 

 

When the Internal Exit is positioned on the eastern side of the opening the average evacuation 

time generated is 21.3 seconds (see Figure 2-17(a)).  When the Internal Exit is positioned on 

the western side of the opening the average evacuation time generated is 22.7 seconds (a 6.5% 

increase in the times, see Figure 2-17(b)).  This is due to the greater capacity of interaction if 

the Internal Exit nodes are placed on the western side of the exit and therefore increasing the 

number of conflict resolutions.  Furthermore, unless two rows of nodes are used, flows entering 

the internal compartment will be affected differently to flows leaving the compartment.  

 

On Internal Exits, flow is calculated on a lane-basis. A lane is simply the space required by an 

individual (width) to travel through the constriction.  buildingEXODUS assumes a default lane 
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width through an exit to be 0.5m. While some studies [19] have suggested that lane widths may 

be wider, these studies were not conducted under emergency evacuation conditions and may 

not therefore accurately reflect the nature of emergency egress movement.  When using the 

default Free Space nodes, these widths do not directly impact upon flow rate calculations. 

However, they have an indirect effect through the distances that the individual might be 

expected to travel through the exit. Therefore the nodal dimensions should accurately reflect 

the dimensions of the geometry. 

 

The number of arcs assigned to an exit should thus represent the number of lanes through the 

exit.  To determine the appropriate number of arcs to attach to an exit simply divide the width 

of the exit by 0.5m (assuming default width is used).  The result represents the number of arcs 

to attach to the exit.  This is quite simple for exit widths that are exactly divisible by 0.5 

however, how should exits that are not exactly divisible, be treated?  There are several ways of 

tackling this problem, all of which have their advantages and disadvantages. These are: 

 

Always round the fractional component down to the lower whole number i.e. ignore the 

fractional component.  This will tend to produce conservative results (longer evacuation 

times) by utilising exits with smaller apertures.   

Always round the fractional component to the nearest 0.5m.  This approach produces 

conservative results when rounding down and optimistic results (shorter evacuation times) 

when rounding up. 

Whether adopting option (1) or (2), modify the user specified (unit flow rate) UFR to reflect 

the expected maximum Flow Rate (NOTE: Flow Rate = UFR x Width). This is achieved as 

follows, if the actual width of an exit is larger than the simulated exit (i.e. rounding the 

fractional component down), compensate by increasing the user specified UFR, and 

conversely, reduce the UFR if the simulated exit is wider than the actual exit (i.e. rounding 

the fractional component up). The reader should examine Example (1) on page 8.13 for 

further guidance.  

 

This technique is only viable when using a user specified UFR (i.e. not applicable in free-flow 

conditions).  When modifying these parameters it is recommended to conduct careful 

parametric analysis to assess the sensitivity of the results to the changes (see Chapter 8). 

 

While option (1) is the method recommended in most cases, the best solution is to explore each 

of the alternatives and perform sensitivity analysis by appropriately increasing or decreasing 

the number of arcs connected to an exit.   

 

When a user defined UFR is chosen that is very large (e.g. the highest UFR available within 

buildingEXODUS, 999 occ/m/s), the exit behaves as if it is under free-flow conditions. In this 

case buildingEXODUS determines the flow rate achieved based on the width of the exit and its 

behaviour rules. In free-flow situations, buildingEXODUS can produce UFRs of the order of 2 

occ/m/s. While this may appear large when compared with the HMSO approved rate, it is in 

line with the upper end of the Fruin measured flow rates [19] and other experimental 

observations [37,44,45,50]. 
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NOTE: 

The performance of Internal Exits are not independent of each other. The insertion of Internal 

Exits can influence the manner in which the potential map flows throughout a space. In effect, 

this can influence the direction in which the exit is used. The user should carefully examine how 

people make use of the Internal Exits prior to producing results. 

 

It should be remembered that the Internal Exit could also be used to influence the potential map 

through the biasing of the Potential of the exit.  Once the Potential of a constituent node within 

an Internal Exit has been modified, all of the other nodes within the exit are also altered. 

Therefore nodes within an Internal Exit are equi-potential.  This is important as the main goal 

of the individual, in this instance, is to pass through the opening, overriding other behavioural 

preferences. Potentials can therefore be compared between Internal Exits but not within them.  

However, this will not influence the movement of evacuees using the Target Exit system or the 

Occupant Exit Knowledge system.  

 

As described in the Theory Manual and User Guide, Chapter 5, Internal Exits are able to provide 

bi-directional flow. However, the bi-directional flow will not be simultaneous but will instead 

be dependent upon the user manipulating the Direction attribute of the Internal Exit. It is 

imperative that the user examines the evacuee movement in relation to the Internal Exits prior 

to the generation of results. Although the model makes an estimate as to the desired direction 

of travel through the Internal Exit (the initial flow direction in an Internal Exit will be towards 

its nearest active External Exit), this may not necessarily tally with the wishes of the user. 

Therefore, the user may have to manipulate the Direction attribute attached to the Internal Exit 

to alter the evacuee movement. The user may wish to do this anyway (along with disabling the 

Local Potential option on the BEHAVIOUR OPTIONS dialogue box) during a series of 

simulations to determine the impact of different circulation patterns upon the outcome of the 

simulated evacuation. 

 

For example, in Figure 2-18 the initial direction of the flow for the two Internal Exits is 

demonstrated. However, this may not satisfactorily reflect how the user wishes the resident 

population to behave. To correct this, the flow direction of the northern Internal Exit is reversed 

(see Figure 2-18). Once this task has been performed the resident individuals will then flow 

'out' of the compartment and will then be sensitive to the biasing applied to the Internal Exits 

(i.e. the actual use of the Internal Exits by the resident people can be regulated by altering the 

relative biasing of the Internal Exits).  
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Figure 2-18:(left) Initial pass of the model. (right) User has altered flow direction of 

northern Internal Exit. 

 

It should also be remembered that the Direction of flow affects evacuee movement in 

conjunction with the Potential biasing attached to the exits.  

 

The use of the Direction of an Internal Exit should be examined carefully. When the population 

is forced to follow a procedure then they will not refer to the Potential Map but will instead use 

the Distance Map. Under such conditions, the Direction attributed to the Internal Exits will 

have no bearing on their movement. This should be borne in mind when the user enforces pre-

defined procedures on the evacuating population, as they will use the Distance Map to follow 

these procedures. The delays incurred at the Internal Exits will still be maintained but the 

Direction of the Internal Exit will have no impact as the evacuees will not be following the 

potential map. 
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2.2.6 Use of Attractor/Discharge Nodes To Modify The Potential Map 

Active Modes: Geometry, Scenario 

 

Attractor and Discharge nodes are intended to influence performance rather than represent 

physical objects. They operate in exactly the same way as free-space nodes, but Attractor nodes 

may be used to re-seed the potential map in an internal compartment.  However, this technique 

need not apply only to internal compartments, the potential map for a region within a 

compartment can also be altered. This may be necessary in situations where the potential map 

does not adequately represent the situation being simulated. For instance, potentials may not 

spread as required around corners in rooms (see Figure 2-19). If the Potential Map is employed, 

this spread will directly influence evacuee movement. In the situation depicted, the potentials 

are relatively small in the long section of the "L" on the side closest to the doors and relatively 

large on the side furthest from the door (see Table 4-1). This would result in people gathering 

on the side of the room with the smaller potential. They would in effect be attempting to take 

the shortest path out. If the simulation were attempting to model people who were familiar with 

the structure this may be an acceptable approach (It still may be considered unacceptable that 
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evacuees would be in close proximity to the enclosure boundary for a period of time). If 

however the individuals were not familiar with the structure and if adequate signage were not 

available they may not necessarily take the shortest path. 

 

NOTE: 

The biasing of the potential map using Attractor/Discharge nodes will not affect the movement 

of evacuees attributed with Target Exits or when they are using the Local Familiarity system 

and are therefore dependent upon their own exit Knowledge (OEK). 

 

This can be avoided by placing a row of Attractor/Discharge Nodes along the face of the room 

as shown in Figure 2-19. The indicated nodes should be changed to Attractor/Discharge nodes 

in GEOMETRY mode using the Substitute command, and the potential set to appropriate values 

in SCENARIO mode. If the potential of the Attractor nodes are all set to an identical value (e.g. 

100.0) individuals will not preferentially select one side of the compartment over the other. 

 

 
Figure 2-19:  Use of Attractor/Discharge nodes to control flow within a region 

 

NOTE:  

It is recommended that Attractor/ Discharge nodes should only be connected using horizontal 

or vertical arcs. 

 

This technique can simply be viewed as modifying the global potential map, i.e. the individuals’ 

global escape route is modified.  Hence, it may also be used to assist in representing the 

influence of staff on the course of an evacuation.   

 

The user is able to apply flow rates to Attractor / Discharge nodes to restrict flow. With the 

introduction of Internal Exit nodes that are designed specifically to model internal exits, the 

manipulation of evacuee movement in complex areas of the geometry is the primary use of 

Attractor and Discharge nodes. 

 

Once the correct number of nodes and arc lengths have been determined the nodes just inside 

the compartment are replaced with Attractor nodes and the nodes just outside the compartment 

are replaced with Discharge nodes using the Substitute command.  Each Attractor node must 

be connected to a corresponding Discharge node with a single arc. Diagonal connections should 

NOT be used with Attractor/Discharge nodes.  The use of diagonal arcs can cause anomalous 

results in both evacuee movement and the calculation of the potential bias attributed to the 

Attractor node. An example of a 1.7m internal exit is shown in Figure 2-20.  Individuals will 
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be attracted to the internal exit via the Attractor node – which is usually located within the 

internal compartment - and directed to pass to the Discharge node.  Individuals will only pass 

from Attractor to Discharge node and so the flow is essentially uni-directional. 

 

Both the exit potential and the UFR need to be specified on EACH of the Attractor nodes 

describing the internal exit.  The potential on the Attractor nodes has the same effect as the 

potential on an external exit i.e. the smaller the potential the more attractive it becomes.  

Furthermore, as described in Section 2.2.6, each node in the exit need not have the same 

potential. It is possible for example to decrease the potential towards the centre of the internal 

exit thereby preferentially attracting evacuees to the centre of the exit. The user is then making 

the centre of the opening more attractive than the edges, in contrast to the default position where 

each location is equally attractive. 

 

 
Figure 2-20: Possible buildingEXODUS geometry for a 1.7m internal exit 

 

  

IMPACT OF ATTRACTOR/DISCHARGE NODES 

RESPONSE 
PHASE 

ATTAINABLE 
SPEED 

FLOW 
CHARACTERISTICS 

ROUTE  
USAGE 

 

2.3 Vertical Egress Components (Stairs and Escalators) 

By their very nature, vertical egress components (VEC) are three-dimensional objects, thus they 

are difficult to conceptualise in two dimensions. Constructing VEC within buildingEXODUS 

thus requires careful consideration.  There are two distinct methods to represent staircases: the 

semi-automatic method using standard nodes; the transit node method. The transit node 

approach can also be used to represent escalators. There are several differences between the 

two approaches: (a) the transit node approach is considered to be simpler; (b) the transit 

approach can represent both stairs and escalators; (c) transit nodes can represent the selection 

between VEC in addition to the behaviour on a VEC. Given this added functionality and ease 

of use, it is recommended that where possible and where sufficient user expertise exists, Transit 

nodes are used. 
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2.3.1 Staircase Representation - Standard Nodes 

Active Modes: Geometry, Simulation 

 

Until recently, the only method of representing staircases was to generate individual stair nodes 

in a semi-automated manner (see the User Guide, Chapter 3). This is a flexible approach to 

representing staircases. However, an additional method has now been produced based on the 

use of Transit Nodes (see User Guide, Chapter 3 and Section 2.4). This simplifies the generation 

of stairs, increasing the level of functionality and also allowing other egress types to be 

represented. 

 

The semi-automatic method provided for generating staircases has an option for utilising the 

“effective width” of the staircase (effectively reducing the number of lanes).  It is suggested 

that when comparing buildingEXODUS predictions with prescriptive legislation, this option 

may need to be ignored as this behaviour may not necessarily be considered within the code. 

 

Staircases should generally be placed as near as possible to their actual location.  In cases where 

spiral staircases apply, each level of the spiral should be placed in the actual floor in which it is 

positioned.  Where spiral staircases have only one entry point and still traverse more than one 

floor, place the staircase at the level of entry, and split each spiral.  To connect such spirals, use 

the Level Con procedure (or the Link procedure, if preferred) as if connecting separate floors. 

More detailed guidance on the creation of stairs in buildingEXODUS can be found in Chapter 

3 of the User Guide. 

 

To prevent problems in movement along staircases (specifically related to overtaking), each 

node within a riser is interpreted as equally attractive. Therefore, if an individual is moving 

up/down a staircase, the riser ahead of them will be attractive, whereas the riser behind the 

individual and the riser currently occupied will not appear as attractive. This prevents evacuee 

movement being skewed on staircases. This behaviour interacts with the other behavioural rules 

that are applied to staircase movement (e.g. evacuee preference for the edges of staircases, the 

STAGGERED and PACKED regime). 

 

To control the flow of the Potential Map around each floor, the user may utilise the Floor 

Potential Map feature in Simulation mode. Once this is implemented, the user may effectively 

control the attractiveness of each connection to another floor, by supplying the potential values 

for the nodes connecting one floor to another. Therefore the evacuees on each floor can then 

move according to the attributes of each floor rather than the location of the eventual exit point. 

Alternatively, the user may instead place Attractor/Discharge nodes at the head of each 

staircase on each floor to control their movement.  In this way the potential map within a floor 

can be controlled.  If this is not done, the potential map on each floor will be governed by the 

spreading potential from the exit points on the lower floor (see Figure 2-21).  This may not be 

suitable as the use of staircases can be affected by familiarity in the same way as the choice of 

exit. 

 

NOTE: 

It should be noted that this type of manipulation will have no impact on the path of the evacuees 

if the Distance Map system is used. 
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Figure 2-21: Application of Attractor / Discharge nodes to a staircase.  

 

NOTE: 

Once a multi-storey geometry is generated it is recommended that evacuee behaviour on 

staircases be examined prior to full use of the model, ensuring appropriate connectivity and 

arc lengths.   

 

NOTE: 

The Attractor / Discharge nodes should be located where the Landing (or adjacent Free-Space 

nodes) is attached to the staircase. Therefore, no Stair nodes should be removed. Attractor / 

Discharge nodes should not be placed inside the connecting room/corridor as this poses 

problems concerning the connectivity of the Attractor/ Discharge nodes with the surroundings 

Free-Space nodes. 

 

Once the stair creation has been commenced, the Physical Dist flag will be disabled and the 

Default Arc setting will be automatically adjusted to reflect the depth of a tread. This enables 

more flexibility in the initial positioning of the staircase. The user should always examine the 

arc distances between the staircase and the connected floors of the geometry to prevent the 

occurrence of anomalous distances. 

 

2.3.2 Modelling Stair Flow Rates Using Standard Nodes 

The stair movement within buildingEXODUS is quite rich in human behaviour. Namely: 

 

1) Stair travel speeds are dependent on whether individuals are going up or down. 

2) Stair speeds are dependent on age. 

3) Stair speeds are dependent on gender. 

4) Different types of behaviour regimes exist for stairs: PACKED and STAGGERED. 

5) Individuals will favour the handrails and therefore will try and cut in whenever possible 

to take the handrails. 

 

Item (5) will cause conflicts and will tend to slow down the general flow rate on the stair  (this 

is why if you have separate lanes on the staircase that you will find faster flow rates are 

produced). 
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The behavioural options enabled depend on the requirements of the user: whether they wish to 

model realistic movement or whether they wish to achieve prescribed flow-rates.  Therefore, 

there is a need to be quite selective about the setting of age and gender distribution.  For 

example, if you have a large number of a particular gender plus a skewed age range.  This can 

slow/speed up the general stair flow rate. By selecting an appropriate population (i.e. a more 

mobile population) results nearer to the regulatory values can be achieved. 

 

Also, the stair behaviour flags such as Stair Packing and Stair Edge Pref can have a marked 

impact.  With Stair Packing enabled a greater load can be serviced (with individuals utilising a 

greater proportion of the stair space) on the stair case and a greater flow rate can subsequently 

be generated.  Secondly, there is the tendency for people to prefer the hand rails.  Since they 

tend to state that there is a simple linear relationship between stair width and flow rate, higher 

flow-rates are attainable if the tendency for people to prefer the handrails has been disabled.  In 

addition, by modelling the staircase as separate lanes, the flow rates generated will be increased 

due to the reduced level of interaction.  

 

Therefore, if it is required to get closer to the rate prescribed the following is suggested: 

1) Model the stairs as individual lanes or switch off the preference for handrails (i.e. Stair Edge 

Pref.) in the Behaviour Control dialogue box. 

2) Alter your age and gender distribution so that you have the required population range. 

3) Leave the age and gender distributions as they are but alter the default stair speeds so that 

they are tuned to provide you with the regulation flow rates. 
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2.4 Transit Nodes 

Active Modes: Geometry, Scenario, Simulation 

 

Staircases, escalators, travelators, corridors and metered gates can now be represented by 

employing Transit Nodes. Apart from simplifying the representation, this approach also allows 

the objects to be grouped influencing the evacuee selection of such egress components using 

the Transit Node Grouping dialogue box in Scenario Mode via the Tools menu. Importantly, 

the use of Transit Nodes allows route decisions to be influenced by nearby egress components 

(i.e. staircases), additional output data to be produced, the capping of component performance, 

and easier construction of the structure. This allows the evacuees to make selections given the 

presence of adjacent egress components. This is achieved in much the same way as biasing 

External Exits – by biasing Staircase Potentials to encourage/discourage use. Importantly, it 

also allows the user to cap the achievable flow rates, adhering to regulatory or scenario 

constraints. In effect, the user can select between predicting the flow generated or imposing it. 
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Figure 2-22: Grouping Transit Nodes.  

 

When employing Transit Nodes several engineering questions need to be remembered: 

 Will the performance of the component be predicted (e.g., from the interaction of those 

using the component and the physical constraints posed by the component), or imposed? 

If it is to be predicted, the performance achieved should be produced by the evacuating 

population; if it is to be imposed then a flow rate should be set. 

 Will evacuees be able to select between egress components, such as stairs and 

escalators? If so, then the components between which the evacuees can choose should 

be grouped. Otherwise they should be left as operating independently. This can be 

achieved by toggling the Transit Node Grouping check box in Simulation Mode, via the 

Behavioural Options dialogue box. 

 Will people be using the stair space efficiently or inefficiently? This will influence 

whether the population is moving in a Staggered or Packed format. The exact manner 

in which agents use the space can be set at the global or local level. 

 

Results produced by the Transit Node representation of a stair should be equivalent to 

comparable staircases produced using the (now deprecated) stair node method. However, this 

approach does allow a broader range of components to be represented and allows additional 

behaviours (such as the selection between these components) to be simulated. 
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2.5 Source Nodes 

Source Nodes can be used to generate people during a buildingEXODUS simulation, rather 

than generating them prior to the start of the simulation. This allows populations to increase 

during the simulation. There are numerous applications of Source Nodes including the ability 

to represent people entering the structure during routine building operations, representing 

scheduled arrivals at a transport terminal, and simulating incident responders entering a 

structure. The Source capability allows the user to represent ingress into the space broadening 

the behaviours that can be represented.  
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In many situations, the user may not be fully aware of the starting locations of the occupant 

population. It can then be useful to predict these locations by simulating ingress and circulation 

- in order to estimate the initial conditions for an emergency. Source nodes are a key capability 

in this regard. 

 

Source Nodes are also useful for testing the geometrical representation. It can be used to validate 

the constraints placed on a geometry, along with the connectivity between spaces. It may be 

that it is not possible to locate a population in a particular space; i.e., that there is insufficient 

floor space to do so. Therefore, by including Source Nodes, a larger population can be generated 

and the egress component in question can be scrutinised. 

 

The user should consider several issues when implementing Source nodes. Firstly, a population 

is generated using the Source node. This can be generated using a basic set of definitions 

(producing a default population according to a rate of generation), or through user-specified 

populations with itineraries (this functionality has now been greatly expanded, see the User 

Guide, Chapter 4). Care should be shown in the nature of these populations and whether the 

populations produced are representative of the populations specified. Secondly, it should be 

possible for the specified generation rates to be met; i.e., that there is space around the Source 

Node for people to be generated at the desired speed and then move away. Thirdly, the exact 

configuration of the Source Node(s) used to generate the population should be explored. It may 

be that in some scenarios that the results produced are sensitive to this configuration. Fourthly, 

it may be useful to colour code the populations emerging from different source nodes in order 

to keep track of their influence. 
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2.6 Signs 

Active Modes: Geometry, Scenario 

 

The representation of signage within EXODUS has two key functions: (1) it allows the user to 

assess the areas from which a sign can be seen through the generation of a Visibility Catchment 

Area, and (2) it allows the information provided by the sign to potentially be used and then 

influence evacuee performance. Each of these will now briefly be discussed. 

 

2.6.1 Using Visibility Catchment Areas 

A sign’s VCA represents the area from which it is physically possible to see the sign. This does 

not mean that the sign will be necessarily seen by an individual – only that it is physically 

possible to see it. This information can be useful to the user in establishing where signage 

should be placed to ensure that it is viewed by the appropriate number of people. In producing 

the VCA for a sign, the user should: 
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(1) Ensure that the sign is positioned in such a way as to ensure that the sign tip resides on the 

node where the VCA will expand from. 

(2) Confirm that the VCA has been appropriately generated. This can be achieved by opening 

the Zone Edit dialogue box in Scenario Mode, selecting Visibility Signs from the Zone Type 

drop down list, and then examining the VCA panels that appear. 

(3) Obtain information on the area covered by the VCA from the Zone Info dialogue box, 

available by double-clicking the panel associated with the VCA of a sign. 

 

2.6.2 Occupant Performance in Relation to Signs 

A sign may influence an evacuee’s behaviour in a number of ways: 

 

Adaptive Exit Selection 

 

 If Local Familiarity is enabled, a Signage System has been selected and Avoid 

Congestion is enabled, a sign can simulate the evacuee’s awareness of the conditions 

around an exit and then allow them to make informed/uninformed decisions as to 

whether the level of congestion warrants action. This is described in detail in the Theory 

Manual. 

 

Signage Driven Behaviour: 

 

 If Local Familiarity is enabled and a Signage System (Empirical or Predictive) has been 

selected, a sign may add a previously unknown exit to an evacuee’s Exit Awareness list. 

 If either the Potential Map is used or Local Familiarity is enabled and a Signage System 

has been selected then signs that form chains of information can influence the path that 

the occupants follow and can also guide them to use an arbitrary exit. Signs can either 

point to other signs or directly to an exit or nodal location in the geometry. The exact 

manner in which signage chains can be formed and how the information on a sign is 

interpreted is described in detail in the Theory Manual. 

 

Agent Driven Behaviour: 

 

 Irrespective of whether the Local Familiarity or Potential Map system is employed if 

an occupant has predetermined tasks to visit unfamiliar locations and a Signage System has 

been selected then the occupant can utilise the signage system for guidance towards those 

locations. 

 

When generating these behaviours the user should take the following actions to ensure that the 

appropriate response is produced 
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 Check that the VCAs are appropriately associated with the signs. The spread of the VCA 

from the signs within the system may be extremely valuable in itself, identifying where 

blind spots exist within the structure. 

 Ensure that that the signs are assigned appropriate information depending on their use. 

For Signage Driven Behaviour each sign is made to point to another sign or to an exit. 

For Agent Driven Behaviour the signs must point for each target to the target’s nodal 

location and to a direction towards this location specified by a node.  

 Note that a sign can operate in both modes and be used for both Signage and Agent 

Driven Behaviour at the same time.  

 Ensure that the correct combination of behavioural switches is selected, i.e. Local 

Familiarity or Potential Map 

 Produce results when the signs are deemed active and when they are not, allowing direct 

comparison.  

 When establishing the impact of signs, remember that the fact that an individual is in a 

VCA does not automatically ensure that they will see the sign and use the information 

in it. 

 The recommended Signage System to use is the Empirical as this is the only one based 

on actual data. 
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2.7 Redirection Nodes 

Active Modes: Geometry, Scenario 

 

Redirection nodes are decision points that allow the inclusion of sub-itineraries into circulating 

individuals during the simulation. The purpose of the Redirection node is to redirect individuals 

that have had the Redirection node specified as a target. This is achieved by the node having a 

set of itineraries associated with it, with associated probabilities, which passing people will 

inherit if they cross or approach the node in question. In effect, Redirection nodes allow the 

routes adopted by occupants to be modified during the simulation process itself. This can insert 

some conditional/stochastic decisions into the simulation process, and allows the user to 

represent complex circulation and evacuation behaviour. For instance, encountering a 

Redirection node can (1) insert a new short-term target into an itinerary; (2) conditionally insert 

a short-term target; (3) perform no function, dependent on the use of dummy objectives. 

Redirection nodes only work with those evacuees that have an existing itinerary that includes 

the Redirection node as a target. 
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2.8 Queues 

Active Modes: Scenario 

 

Queue objects can be used to artificially manage access to facilities within the geometry, 

choreograph the congestion produced and the selection process between grouped 

services/facilities. Where the use and impact of these facilities is beyond basic delays, the 

Queue object is recommended. This functionality allows the user to assign complex delay 

distributions, manage the approach to the service/facility itself, but also allow occupants to 

select between several facilities that may be offering the same service; e.g., selecting between 

facilities that are grouped together based on how busy they are, the level of congestion that 

might be experienced, etc. These facilities have an impact during routine and emergency 

movement, and on the transition between the two scenarios. 

 

Queue objects are generated individually and located by the user. Distributions can then be 

associated to each Queue, including a bounded uniform distribution, pre-defined distributions, 

and user defined distributions. The Server functionality associated with the Queue object can 

have its Delay Type configured accordingly. In addition, the manner in which people queue at 

the service can be modified by the user using the Route attribute in a similar manner to that 

used to produced itineraries (see Figure 2-23). This will then influence the route adopted as 

people approach the service, but also the manner in which others interact with the subsequent 

queue produced; i.e., whether blockages are caused, etc. This will not only allow design variants 

to be produced relating to the number and location of key services, but also their impact upon 

the occupant population. 

 

  
(a) (b) 

Figure 2-23: Nature of queues expected from adjacent queue servers. 

 

The user has the option to allow occupants to select between groups of servers; i.e., to assess 

the equivalent services provided according to a pre-defined criteria (see the User Guide, Chapter 

5). This is implemented using a Redirection node that has the Queue objects as alternative 

objectives. Instead of assigning probabilities to determine the objective selection, criteria can 

be selected based on the time spent in the queue, etc. (see Figure 2-24). In effect, this allows 

the user to impose to basic queue selection according to local conditions (e.g., queue conditions) 

at adjacent services. 
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(a) (b) 

Figure 2-24: (a) Redirection node is associated with Queue objects; (b) Selection between 

queues made according to speed of queue movement. 

 

When implementing Queue objects the user should always check that the desired route and 

delay distributions are applied. As with all itinerary-based functionalities (e.g., Redirection 

nodes), it is worth confirming that the appropriate itineraries are generated, are associated with 

the correct sub-populations and that these itineraries are then followed. In effect, the user should 

confirm that the queuing system produced is behaving as expected, and having the desired 

impact on the population's behaviour.  

 

  

IMPACT OF QUEUE FUNCTIONALITY 

RESPONSE 
PHASE 

ATTAINABLE 
SPEED 

FLOW 
CHARACTERISTICS 

ROUTE  
USAGE 

 

KEY POINTS: IMPACT  
 

 It is possible to change the nature of the population and their response through the 

representation of the geometry. 

 It is important that the user has an understanding of this impact and the interaction 

between this functionality and the other functionality employed to represent evacuee 

response. 

 This should be tested prior to results being generated. 
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CHAPTER 3: REPRESENTING THE POPULATION 
 

Creating populations for complex structures can be a time consuming process.  In these cases, 

it is suggested that sections of the structure are populated separately wherever possible.  This 

allows the user to export several populations for the same region without having to re-select the 

region.  This in turn makes it easier to build up complex populations by importing smaller sub-

populations into each region. 

 

3.1 Specifying the Population - Population Attributes 

Active Mode: Population 

 

The initial step regarding the occupant population is to accurately represent the size and 

distribution of the population. The population can then be modified and configured to suit. In 

reality, the user may configure the population prior to them being generated. For instance, 

attributes can be managed from dialogue boxes associated with the Population Panels. This 

enables the user to select areas within the geometry and then generate a specified number of 

people to be located within that area and then configure them as required. Often the generation 

of a population in this manner will be sufficient; however, in some applications the population 

will have to be manipulated at the individual level – to ensure location, performance, or 

susceptibility. 

 

The features within the model that allow the generation and distribution of populations are now 

described, followed by the features available to manipulate individual characteristics.  

 

It is useful to have a detailed understanding of the nature of the population distribution prior to 

constructing the geometry. This will provide an understanding of the population densities 

involved, indicating the nodal network required (i.e., the number of nodes needed to support 

the occupant loading). The manner in which the population is distributed in reality will be 

highly dependent upon the size and nature of the space: 

(1) In multi-floor geometries, where the occupancy levels/distribution of each floor is 

known, populations will at least have to be generated for each floor. That is, the entire 

floor can be populated in a single action. 

(2) Where floors are compartmentalized, populations may need to be generated for each 

compartment. 

(3) Where populations are non-uniform throughout the geometry according to the use of 

the building, separate populations may need to be examined. 

 

All of these factors, and many more, may influence the populating of a space. 

 

At a basic level, a population can be generated through the following methods. The selection 

between these methods is driven by the level of information available and the scenarios being 

represented: 

(1) Random Block – where the number of people in a space is not necessarily known – only 

that the maximum level of occupancy is required; 

(2) Random Generate – where the number of people in a space is known, but the default 

populations can be assumed; 

(3) Population Panel – where the number of people in a space is known, and some 

additional information is available to further configure the population. 
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To test a space occupied to the maximum possible density, the Random Block feature should be 

used. This might be useful in bounding the analysis – the congestion produced. The quickest 

way to generate a population over an entire geometry is to use the Random Generate function.  

However, this has the drawback of not being able to target the attributes of the evacuees, but it 

does allow a speedy initial evaluation of a geometry. The user can also edit the attributes of 

people generated in this way, thus tailoring them to specific requirements. As indicated above, 

Population Panels should be used for more control over the population generated. 

 

3.1.1 Manipulating the Population 

Active Mode: Population 

 

It is often necessary, once the population is generated, to make minor modifications. This can 

be required to generate new scenarios, or to ensure that a distribution of results is produced for 

the current scenario. These modifications require two separate actions: moving people, and 

modifying the attributes of the population. The deletion or generation people will also, 

obviously, influence the population size.   

 

The generation, modification and distribution of occupants are described in detail in both the 

Theory Manual and Chapter 4 of the User Guide. A brief summary is presented here to remind 

the user of the functionality available in generating, modifying and redistributing the 

population. 

Generating the population 

 Random Generate – useful for getting a general understanding of impact of the number 

of people in a space, where little is known about the population’s other attributes 

 Random Block – useful for testing the performance given that a space is fully occupied 

 Population Panels – useful when the nature of the population needs to be specified  

Modifying the Population  

 Substitute – useful when a (sub-) population has to have a single attribute replaced with 

a known value 

 Substitute Range – useful when a (sub-) population has to have a number of attributes 

perturbed within set values 

Redistributing the population 

 Randomise – useful when the manner in which a population is redistributed within a 

space is not as important as the fact that their initial location has been changed 

 Swap Location – useful when the identity of the occupants needs to be swapped, but not 

the set of starting locations used 

 Swap/Randomise on Seats – useful when only those occupants seated should be affected 

by the changes 

 

This functionality allows changes to be made to the underlying conditions, producing new 

scenarios or reflecting that the information relating to the population and their initial conditions 

is incomplete and imperfect.  
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KEY POINTS: REPRESENTATION  
 

 The population can be modified and redistributed. 

 These actions can be used to produce new scenarios or reflect the imperfect 

understanding of the initial conditions. 

 These actions can affect the entire population or sub-sections of it. 

 

3.2 Influencing Response - Person Attributes 

In this section, some of the core evacuee attributes are discussed briefly. These can have a direct 

or indirect impact on the behaviour exhibited by the evacuating population. 

 

3.2.1 Response time: 

Active Mode: Population 

 

This attribute reflects the time spent by an individual before starting to evacuate. It includes the 

time involved in all pre-evacuation activities i.e., time expended in recognising the alarm cue 

and time expended in preparing to move off.  It is an extremely important variable as the 

response time in some circumstances may be greater than the actual travel time.  

 

Within the model, Response Times can be set to a specific value, be randomly produced between 

a specified range according to a uniform random distribution, or be generated in accordance 

with a user-defined distribution (using Distribution Curves, see the User Guide, Chapter 4). 

These methods can be employed at the individual or population level. 
 

The Response Time is generally dependent on the: 

(i) nature of the structure (e.g., complexity, size, etc.), 

(ii) type of occupancy (e.g., hotel, residence, office, etc.), 

(iii) state and ability of the individuals (e.g. state of awareness i.e. sleep/awake, drunk/sober; 

mobility, age, familiarity, social affiliation, role, etc.), 

(iv) actions of the surrounding population; 

(v) exposure to cues (e.g., smoke) and other environmental conditions, 

(vi) quality of the management system (e.g. regular fire drills, etc.), 

(vii) type of alarm system (e.g. bell, recorded message, live message, etc). 
 

These factors should be considered when establishing representative response times. These can 

then be included in the model on a population or individual basis. For instance, sub-sections of 

the population may be subject to different conditions – different notification systems, different 

visual cues, etc. Therefore, some of these factors can be represented implicitly by providing 

different Response Times to different sections of the population. 

 

Typical response times can vary from seconds (individuals are awake, trained, familiar with 

building, alarm systems and procedures) to many minutes (situations where individual may 

require assistance) [53].  

 

While a great deal of work has been conducted concerning the response to an alarm system and 

the amount of time that individuals are prepared to delay prior to evacuating [72-77], little can 

be definitively stated concerning the appropriate range of response times to use in a simulation.  

What follows is a brief description of some published research concerning response to alarms.  
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This information is intended to assist the user to identify areas of potential relevance and 

possibly provide sensible suggestions for values that might be used during a simulation.  More 

importantly, it should identify the factors that the user should take into consideration when 

specifying response times. 

 

It must be emphasised that the user will have specialist knowledge concerning the alarm system 

to be implemented and the general scenario of the situation under investigation.  This will be 

vital in shaping the design of the response time distribution to be implemented. The majority of 

the research conducted is based on the evacuee response to alarms in the built environment. 

However, this work is still useful in demonstrating the variation that can be expected according 

to the alarm system in use, the resident population and the type of structure within which the 

evacuation takes place. 

 

The majority of the data-sets available represent compiled reports of evacuee response, as 

opposed to a comprehensive discussion or the presentation of raw data. A selection of this 

compiled data is presented below. However, there are a number of data-sets available that also 

present a more complete representation of the response distribution. This is useful as it provides 

fairly strong (and consistent) evidence that the response distribution is typically log-normal. 

Data was collected from the World Trade Center incident [133,134]. This included information 

gathered from the news media, along with reported material. The data gather provided a 

reasonably consistent distribution of response times between the different sources, and 

presented a log-normal curve (see Figure 3-1).  

 

 
Figure 3-1: Response Times collected from the BDAG and HEED projects. 

 

As part of an NFPA-sponsored project in the United States [136], Response Time data was 

specifically collected from a series of evacuation drills. These included the evacuation of two 

mid-rise office blocks that employed two different procedures in an attempt to inform the 

population of the incident. One included a voice notification system (with a modest amount of 

training and preparation), while the other included a tone alarm with a large number of active 

staff (and with a high level of preparation and training). It is apparent that the results produced 

were similar and both generated broadly log-normal distributions (see Figure 3-2). 
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Figure 3-2: Response Times collected from US office drills conducted as part of the 

NFPA project. Red curve tone alarm/trained participants; black curve, voice alarm, 

untrained participants. 

 

As part of the same project, a university facility in the UK was evacuated. This university library 

had a tonal notification system and a number of staff who engaged in the emergency procedure 

once the alarm sounded. The population responded, on average, after 100 seconds. Again, a 

log-normal distribution was produced (see Figure 3-3). 
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Figure 3-3: Response Times collected from the UK university drills conducted as part of 

the NFPA project. 

 

An egress drill was conducted in Brazil where students were informed and guided out of a 

university facility by staff; there was no notification system in place. Although the staff and 

students were completely untrained and unprepared they responded quickly to the call to 

evacuate. This may have been due to them never having experienced a false alarm. The results 

produced are shown in Figure 3-4 where they are compared against the data shown in Figure 

3-3. The Brazilian Response Times were produced entirely through the actions of staff. The 

data presented in Figure 3-3 was reduced to represent only those evacuees that were prompted 

by members of staff. As can be seen in Figure 3-4, the results produced are similar, and form a 

log-normal distribution. 
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Figure 3-4: Response Times collected from the UK university drills conducted as part of 

the NFPA project. 

 

Purser produced evacuation data in conjunction with the University of Ulster [136]. An example 

of this was the observation of an unannounced egress drill conducted from a retail store, with 

10 exits available around the building periphery.  People responded between 4 and 110 seconds 

(averaging 40 seconds), while people evacuated in between 4 and 170 seconds (averaging 

approximately 60 seconds). The pre-evacuation (response) time distribution is again log-normal 

(see Figure 3-5). 

 

 
Figure 3-5: Response Times collected by Purser and the University of Ulster [136]. 
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Proulx collected response time from unannounced trial evacuations from mid-rise apartments, 

each consisting of approximately 100 rooms and involving between 100 and 200 people [137-

140]. The buildings were fitted with bell-alarms and required a full evacuation to be conducted. 

All of the occupants across the four buildings had responded by 15 – 25 minutes. Again the 

nature of this response formed a log-normal curve (see Figure 3-6). 

 

 
Figure 3-6: Response Times collected by Proulx [137-140]. 

 

A larger set of data is available providing a greater estimate of the ranges and average response 

times to be expected. There are a number of sources that describe occupant response times 

based on the key underlying factors present; e.g., the nature of the event, the occupancy type, 

the alarm type and the procedure. Three examples are presented that report multiple data-sets. 

Fahy and Proulx [141] collected data from a number of previous studies. These are presented 

in terms of the occupancy type and the nature of the event (see Table 3-1). It is apparent that 

there is a wide range of results produced, both in terms of the distributions and the average 

values. Fahy and Proulx also provided the number of data points on which each data-set was 

based. This allows the reader to establish how representative and credible the data-set actually 

is. 

  



Chapter 3 – Representing the Population 

 

© 2017 University of Greenwich 51 

 

Table 3-1:Data compiled by Fahy and Proulx [141]. 

Occupancy 

# 

data-

points 

Min 

(min) 

Max 

(min) 

Median 

(min) 

Mean 

(min) 
Event 

High-Rise Hotel 536 0 290 60  MGM Grand fire 

High-Rise Hotel 47 0 120 5  WestChase Hotel fire 

High-Rise 

office 
85 0 245 5 11.3 WTC incident 

High-Rise 

office 
46 0 185 10 28.4 WTC incident 

High-Rise 

office 
107 1 6 1  Fire 

High-Rise 

office 
12 0.5 2.3 1 1.2 Unannounced drill 

Mid-Rise 

building 
92 0 4 0.6 0.6 Unannounced drill 

Mid-Rise 

building 
161 0 5 0.9 1.1 Unannounced drill 

One-story 

department 

store 

95 0 1 0.3 0.4 Unannounced drill 

Three-story 

department 

store 

122 0 1.6  0.6 Unannounced drill 

One-story 

department 

store 

122 0.1 1.7  0.5 Unannounced drill 

One-story 

department 

store 

71 0 1  0.4 Unannounced drill 

High-rise 

apartment 
 0   10.5 Forest Laneway fire 

High-rise 

apartment 
219 0 720  10.5 Forest Laneway fire 

High-rise 

apartment 
33 0.3 10.2 1.3 2.8 Unannounced drill 

High-rise 

apartment 
93 0.4 18.6 3.6 5.3 Unannounced drill 

High-rise 

apartment 
27 1 20  8 Fire 

Mid-rise 

apartment 
42 0.6 14 1.4 2.5 Unannounced drill 

Mid-rise 

apartment 
55 0.5 21 4.4 8.4 Unannounced drill 

Mid-rise 

apartment 
77 0.3 24 7.7 9.7 Unannounced drill 

Mid-rise 

apartment 
80 0.3 12 2.5 3.1 Unannounced drill 
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Training 

Facility 
566 0.2 5 1.1  Testing sleeping subjects 

 

Lord et al collected together data from a wide range of sources including Charters, Proulx, Fahy, 

Brennan, and Purser [142]. Lord et al combined this data and then categorized it according to 

whether the structures involved were offices or apartments. The results produced are shown in 

Table 3-2. The data produced by Lord et al suggests a difference in the response time 

distributions produced during evacuations from offices and apartments. 

 

Table 3-2:Data compiled by Lord et al [142]. 

Occupancy 
Number of 

data-points 

Min 

(min) 

Max 

(min) 

Mean 

(min) 

Office 536 0 28.4 1.2 

Apartment 341 0.1 24.5 6 

 

Gwynne examined collected response times produced by large unassociated groups; i.e. groups 

not just based around familial or social groups. The conditions present during these trials were 

representative of those present in non-domestic settings and public spaces (see Table 3-3). The 

project focused on the effectiveness of notification systems and procedures employed in context 

with the conditions under which they would normally be applied. The effectiveness of these 

notification systems was established by observing a variety of different egress trials and a 

smaller number of contrived situations. A number of case studies were conducted, each 

involving the observation of an evacuation. These observations were made in order to assess 

the time taken for the population to respond to the notification system in place and their 

subsequent behaviour.  
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Table 3-3:Data compiled by Gwynne [135]. 

Primary Trials Notification  

System 

Nature of the Drill Pre-Evac. 

Data Points 

Pre-Evac 

Times (ec) 

1 – Office Voice / Staff Partial (specific area) 

/Unannounced 
72 141.3 

[40-426] 

2 – Library/Admin 

(UK) 

Tone /Staff Full/Unannounced 153 102 

[5-290] 

3 – Office T-3/Staff Full/ Unannounced 348 101.4 

[19-269] 

4 – Library/Admin 

(UK) 

Voice Partial (specific area) 

/ Unannounced 
15 52.2 

[20-89] 

5 – Library/Admin 

(UK) 

T-3 Partial (specific area) 

/Unannounced. 
10 N/A 

6-7 – University  

Residences 

T-3 Full/ Unannounced 73 48.9 

[9-104] 

8 Hospital Tone/Voice Partial (Staff only) 

/ Unannounced 
n/a N/A 

9 Hotel Tone Partial (Staff only, ltd. 

area)/ Unannounced 
17 61.3 

[20-141] 

10-14 Distribution  

Depots 

Mixed – Primarily 

Tone 

Full/ Unannounced n/a 76.4* 

[60-107] 

15 Library 

Facilities 

(Brazil) 

Staff Full/ Unannounced. 18 38.7 

[8-70] 

*Overall evacuation times for five different buildings 

 

The importance of ‘information’ was apparent throughout the trials. In this context, information 

refers to knowledge of the existence of an incident, the threat posed by it, and the required 

response. During the trials this information was provided in several ways: through training and 

practice drills prior to the event; through a notification system during the event; and/or through 

members of staff during the event. Irrespective of the method used, a minimum level of 

information was required to enable the population to respond and to respond appropriately. 

Ideally, all of the described methods would be available. None of the trials examined employed 

all of these methods to the required degree. 

 

The response of an individual to an alarm is strongly affected by their ability to distinguish 

between the occurrence of a fire alarm and other forms of alarm.  In situations where there is a 

proliferation of alarm systems, the ability of a population to determine the occurrence of a fire 

alarm is adversely affected.  In the work of Tong and Canter [73,74] 45% of the sample 

population (taken from a street survey of 71 random individuals) could not distinguish between 

the occurrence of a fire alarm and a number of other less vital warning systems (e.g. car alarms, 

security alarms etc.). This potential lack of response is made worse when the alarm is not 

supported by additional cues, such as the presence of smoke or instructions from a member of 

staff.  This was noted by Geyer et al [75] who found that only 13% of respondents questioned 

who were initially made aware of an event by the alarm, believed that the sound of a fire bell 

was a real emergency.  

  



Chapter 3 – Representing the Population 

 

© 2017 University of Greenwich 54 

 

To compensate for the inability of individuals to distinguish between different forms of alarm, 

more sophisticated approaches than the traditional bell alarm may be introduced, such as 

modern information warning systems. The introduction of an information warning system may 

not only increase the likelihood of a prompt response but may also increase the probability of 

them responding appropriately. In other occurrences, public address systems are used to 

augment a standard alarm bell system. These are used to supply additional information 

considered necessary for safe evacuation, and have been found to be far more effective than the 

more traditional bell alarm [76].  If the user was attempting to model a structure that included 

the more technologically advanced forms of alarm system, the individual response, reflected in 

the response time distribution of the population, could be significantly affected. However, if 

the information provided by the system is unclear, the system may prove a hindrance rather 

than making evacuee response more efficient. Therefore, when attempting to simulate the 

Response Times of evacuees, the type of alarm used within the simulated structure should be 

borne in mind. 

 

As well as the ability to differentiate between the forms of alarm, the ability to receive the 

information imparted is also vital. The position of the alarms, especially traditional alarm bells, 

should be carefully examined to determine their impact on the population prior to the 

evacuation. Of particular interest is the effectiveness of the alarm in notifying the evacuees of 

the incident and imparting an optimum level of information concerning the event. 

 

Proulx has conducted numerous examinations concerning the response to the sounding of an 

alarm [79].  An experiment was conducted in four apartment buildings in Canada to examine 

the response to the sounding of alarm bells (although some variation existed in the systems 

used).  Proulx pointed out the importance of understanding the nature of the population, the 

circumstances in which the alarm is heard and the type of alarm used.  From Figure 3-7 variation 

can be seen from the response to the alarm system according to the location of individuals, with 

response times generally ranging between 0-26 minutes. 

 

  
Figure 3-7: Response time distribution for people in apartment blocks in Canada [79]. It 

is apparent that the response times are in the order of minutes rather than seconds. 

 

Although the result distributions are relatively similar (0-26 minutes) the average scores are 

different in respect to the evacuee location, indicating that the perception of the alarm was in 

fact related to location of individual evacuees.  

 

The buildings were 6-7 storeys high and contained between 8-130 apartments, having an 

average population of 150 people consisting of adults, children, the elderly and individuals with 

disabilities. Each of the structures employed different fire protection equipment and was 
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populated by different proportions of the young, the elderly, the disabled, etc. Building 1 had a 

two-stage fire alarm system and a PA system. An alarm was located outside of each apartment. 

The other three buildings had single stage 'bell' alarms. These were dispersed through the 

corridors of the buildings. The response of the individuals to the alarms differed between the 

buildings.  Proulx pointed out that this difference would have been affected by the exact location 

of the alarms within the building. 

 

In their examination of the reaction to different forms of alarm warnings including PA systems, 

Proulx and Sime found some significant differences in the results generated [72,76].  Their 

examination concerned the efficiency of the evacuation from a sub-surface train station, given 

the alarm system used. Through examining the reaction to the sounding of a traditional bell 

alarm and to the provision of different levels of information across a public announcement 

system, a difference in the nature of the response was established (see Table 3-4). 

 

Table 3-4:Data produced during examination of response to different alarm types [72]. 

Evacuation Time to start to 

move* 

Time to clear station** 

Bell only 8 min. 15 sec. 
Exercise ended 

14 min. 47 sec. 

P.A.(told to evacuate) 1 min. 15 sec. 10 min. 30 sec. 

P.A.(told to evacuate and the 

existence and location of the fire) 
1 min. 30 sec. 5 min. 45 sec. 

*The time to start to move was calculated when half or more or the immobile crowd had started to move. 

** The time to clear the station was the moment when no-one could be seen standing on the platforms, near the 

escalators or on the Concourse level. 

 

From this example the provision of information and the detail of the information provided is 

demonstrated as being a significant factor in the response of the evacuee population. The 

findings of Proulx and Sime were supported by tests conducted at the Fire Research Station 

who found that only 13% of those examined responded to an alarm bell, 45-55% responded to 

alarms involving textual messages, while 70% responded to voice or picture alarms [77,78]. 

 

The individual’s interpretation of the seriousness of the alarm, i.e. whether the alarm reflects 

an actual incident, is an important influence on the response. In an examination of responses to 

the evacuation of a multi-storey structure, Tong and Canter [73,74] studied the responses of 

individuals. Of the individuals who did not respond to the alarm, 23% of them believed that the 

alarm was a test, 14% believed it was a malfunction, and 2% believed it was a malicious false 

alarm. The user might examine (in an existing building) the occurrence of false alarms, etc. and 

factor them into a scenario used to examine an evacuation of the structure (via altering the 

individual response time). 

 

Although the research described here might not reflect the exact condition that the user is 

attempting to model, it should highlight the factors that should be considered when defining the 

response times of the population.  It is suggested that a number of response time distributions 

are examined, in order to derive an understanding of how the system is likely to respond to a 

range of situations.   The following cases should be included as part of the study.   Initially, the 

evacuees should respond instantly providing a baseline result. Secondly, an intermediate 

scenario should be examined using an estimate of the expected response. Finally, a conservative 

or worst-case scenario should be examined. It should be noted that it is not necessarily the case 
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that a reduction in response time will result in a reduced overall evacuation time. This will be 

dependent upon the nature of the geometry, the population density and the location of the 

population. 

  

It is not suggested that the Response Time attribute should be entirely based upon the alarm 

system implemented within a structure. Numerous other factors influence response times 

including the commitment of the individual to the task previously being performed and the 

previous experiences of the individual with evacuation (fire drills, training, false alarms, etc.).  

Here, the impact of the alarm system is used as an example to demonstrate the complexity of 

the subject. 

 

From the data examined several factors have been determined as being significant in 

determining response times. These include the type of alarm used, the evacuee’s location in 

relation to the incident and the exposure of the individual to several cues supporting the 

existence of an incident. These factors should be considered when distributing response times 

to evacuees.  

 

It is suggested that when distributing response times, that individuals in small natural groups 

should be given a narrow range of response times.  For example, a small group of interacting 

people in a room are likely to begin to egress at roughly the same time. Conversely, a large 

group of unrelated people for example, dinners in a restaurant are likely to have a wider range 

of response times.  However, it is essential to note that the nature of the activity and the nature 

of the structure also have a major impact on the response time distribution. For example, a large 

crowd of unrelated people within an open plan cinema auditorium are likely to have a narrow 

band of response times, whereas a large number of people residing in a hotel are likely to have 

a wide range of response times. 

 

In buildingEXODUS, the response time may only be overridden when the fire hazards of 

Temperature and Smoke Concentration (and indeed the impact of radiative flux under certain 

conditions) exceed a level defined by the user.  The Response Time attribute can be used to 

incorporate the effects of different types of alarm systems, for example it is generally 

considered that a simple alarm bell is not as effective in motivating evacuees to flee as a live 

voice based system.  The Response Time attribute can also be used when simulating phased 

evacuation scenarios from large premises or reflecting the fact that some evacuees may require 

assistance to evacuate. 

 

NOTE:  

If the user has access to range values and some understanding of the distribution of the response 

times between the range, then the distribution can be approximated using the Response Curve 

facility. It may also be possible to interpolate within the known range of values, should an 

indicative average value be known: the Response Curve facility could then be used to impose a 

log-normal distribution between the known range. Although this practice is imperfect and not 

necessarily recommended, it may provide a more reasonable estimate of the response 

distribution than assuming a uniform distribution. 

 

 
IMPACT OF RESPONSE TIMES 

RESPONSE 
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FLOW 
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ROUTE  
USAGE 
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3.2.2  Patience: 

Active Mode: Population 

 

In reality, there is a tendency for people to continue performing an action unless convinced to 

do otherwise – it cannot be assumed that people will automatically disengage from an act and 

evacuate. This is reflected in the model, where it is assumed that people have a preference to 

maintain their current activity. The Patience attribute represents the threshold point at which, 

under certain conditions, the evacuee will change their activity – change their target, for 

instance. The Patience attribute is used to control extreme behaviour.  High patience values 

will prolong the onset of Extreme behaviour; conversely, low values of patience will result in 

individuals rapidly displaying Extreme behaviour.  It will also affect the movement of 

individuals between exits (when no pre-defined procedure is in place), during congestion and 

behaviour on staircases (see the Theory Manual). It is suggested that values in the region 1 to 

15 seconds are utilised in order to produce a range of responses.  Generally, Extreme behaviour 

is not expected to exert a major influence on evacuations involving large geometries, however 

it does alter local behaviour dramatically and will alter the relative order of people who 

successfully evacuate. In situations involving heat and toxic gases, it may also influence the 

fatality distribution. 

 

When applying pre-defined procedures, it is important that the evacuees do not lose the 

itineraries attributed to them, otherwise they will not necessarily follow the procedure as 

expected. The following of these itineraries can be enforced by setting the Maintain Itinerary 

flag in the Behaviour Options dialogue box.  
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3.2.3  Mobility: 

Active Mode: Population 

 

The Mobility attribute reflects the extent to which internal or external factors influence 

movement. The level of disability in a population can be quite large.  For instance, in a recent 

survey conducted in Northern Ireland [32] suggests that 12% of the population suffers from 

some kind of locomotion disability.  While this figure is higher than that found in other regions 

of the UK, it suggests that when performing evacuation simulations it is prudent to consider 

that a significant proportion of the population may suffer from some level of movement 

disability.  The Mobility attribute is designed to reflect levels of physical disability affecting 

motion.  If this attribute is less than the default value of 1.0, it reduces the speed attribute in 

order to reduce the physical ability of the person.  Thus when modelling individuals with 

impaired movement abilities, it is possible to either use Travel Speeds directly, or use “normal” 

values for these and decrease the Mobility attribute appropriately.   
 

In performing evacuation simulations, it is useful to consider the mobility of an individual with 

locomotion disabilities to be dependent on the nature of the movement aid.  As a guide to typical 

values for evacuees with movement disabilities, see Table 3-5.  This data was generated as part 

on an FRS sponsored study into mobility capabilities of disabled people [32].  Tests were 

conducted in several day care centres involving participants with a wide range of disabilities, 

severity of disability, gender and age.  The participants were asked to walk unassisted along a 
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horizontal route measuring approximately 50m.  The values in Table 3-5 refer to unimpeded 

performance degradation.  These values were determined by comparing the mean travel speed 

for the class of movement disability with the mean travel speed for the class without movement 

disability. 
 

Understanding the implications and impact of disability levels extends beyond the less-able 

populations and might impact upon large sections of the population.  

 

NOTE: 

The mobility is also affected by FIC, FIN and Smoke (irritant and non irritant). Level C only. 

 

Table 3-5: Mean suggested mobility and travel speed attribute values for evacuees with 

movement disabilities (based on data from [32]) 

Movement Aid Number of Subjects Mean Travel Speed (m/s) Mean Mobility 

Electric Wheelchair 2 0.89 0.72 

Manual Wheelchair 12 0.69 0.56 

Crutches 6 0.94 0.76 

Walking Stick 33 0.81 0.65 

Walking Frame 5 0.51 0.42 

Rollator 5 0.61 0.49 

No Aid 52 0.93 0.75 

No Disability 19 1.24 1.0 

 

NOTE: 

The Mobility attribute only reflects a degradation in travel speed. It does not take into account 

the additional space occupied by movement aids such as wheelchairs. 
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3.2.4 Travel Speeds: 

Active Mode: Population 

 

The internal clock governing buildingEXODUS operates each 1/12 of a second.  Individuals 

are allowed to move every two ticks of the clock (every 1/6th of a second). Thus if the time 

required to move from one location to another is smaller than 1/6 of a second errors may occur.  

This will occur if, (a) very small arc lengths are used, or (b) very high travel speeds are used.  

As the arc length governs the size of a node and represents the space occupied by a person, very 

small values should not be used.  Values less than 0.3m may be considered as invalid.  Taking 

this value as the minimum possible puts a ceiling on the maximum travel speed as 1.8m/s.  If 

the minimum arc length has the default value of 0.5m, this increases the maximum speed to 3.0 

m/s. As a comparison, 10.4 m/s represents a world record speed over the distance of 200m.  

 

For calculations involving movement rates, it is often recommended that average fast walk 

speeds in low density enclosures be taken as 1.2 m/s. Research into unimpeded walk speeds 

suggests that average walk speeds are in fact age and gender dependent. In a study by Ando et 

al [33] concerning crowd movement in railway stations, Ando and his colleagues measured 

unimpeded walk speeds for a number of people of both sexes and of a variety of ages. They 

found that for both males and females the walk speed peaked at about 20 years of age and males 
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outpaced females at all ages (this was possibly due to the longer strides of males compared to 

females). The maximum walk speed for males was approximately 1.6 m/s and for females 1.4 

m/s. From these observations, Ando et al constructed a set of curves showing travel speed as a 

function of age and gender. These have been redrawn in piecewise linear form in Figure 3-8. 

From this data it is possible to extract the relations shown in Table 3-7, although these are only 

quoted as a rough guide. A range of different travel speed data is shown in Table 3-6. However, 

although these values range, the value of 1.2m/s still represents an adequate (conservative) 

estimate of typical free movement speeds. As is apparent, these values reduce as population 

density increases; however, within the EXODUS model the impact of population density is 

represented through conflict resolution (see the Theory Manual) rather than reduced travel 

speeds. 

 

Table 3-6: Travel Speed Observations [141] 

Occupancy Speed Condition Direction 

Transport 

Terminal [19] 

265 ft/min – 1.35 

m/s 
No Density Flat 

Normal 

Conditions [51] 
1.0 m/s  No Density Flat 

Mid-rise drill 
[145] 

0.47 m/s  

(0.34-1.08 m/s) 
No Density Stairs descend 

Mid-rise drill 
[145] 

0.44 m/s  

(0.32 – 0.56 m/s) 
No Density Stairs descend 

Mid-rise drill 
[145] 

0.41 m/s  

(0.30 – 0.47 m/s) 
No Density Stairs descend 

High-rise [147] 
1.05 m/s  

(0.57 -1.2 m/s) 
No Density Stairs descend 

High-rise [147] 
0.95 m/s  

(0.56 – 1.12 m/s) 
No Density Stairs descend 

Public Places 
[19] 

0.51-1.27 m/s Density Flat 

Public Places 
[19] 

0.36 – 0.76 m/s Density Stairs 

Public Places 
[51] 

0.28 m/s Density Flat  

Public Places 
[51] 

0.17 – 0.27 m/s Density Stair descend 

Theatres and 

educational [51] 

0.25 – 0.33m/s  

[max 2.33 m/s] 
Density Flat 

Industrial 

Buildings [51] 

0.42 – 0.56 m/s 

[max 2.33 m/s] 
Density Flat 

Transport 

Terminals [51] 

0.33 – 0.83 m/s 

[max – 2.1 m/s] 
Density Flat 

Descending 

Stairs [51] 

0.33 – 0.42 m/s 

[max 1.28 m/s] 
Density Stairs 

  



Chapter 3 – Representing the Population 

 

© 2017 University of Greenwich 60 

High-rise 

building drill 
[146] 

0.61 m/s Density (1.3 p/m2) Stair/ full lighting 

High-rise 

building drill 
[146] 

0.70 m/s Density (1.25 p/m2) Stair/ reduced lighting 

High-rise 

building drill 
[146] 

0.72 m/s Density (1.00 p/m2) 
Stair/ Photolum material 

and reduced lighting 

High-rise 

building drill 
[146] 

0.57m/s Density (2.05 p/m2) Stair/ Photolum material 

Mid-rise drill 
[148] 

0.78 m/s Density Stairs descend 

Mid-rise drill 
[148] 

0..93 m/s Density Stairs descend 

Hotel Exercise 
[143] 

1.5 [0.6-4 m/s] Density Flat (day time) 

Hotel Exercise 
[143] 

1.1 [0.3-1.6 m/s] Density Flat (day time) 

Hotel Exercise 
[143] 

1.5 [ 0.5 – 3.8 m/s] Density Flat (night time) 

 

In some prescriptive codes, persons using walking aids (not wheelchairs) are generally assumed 

to travel at about half the speed of non-disabled persons.   The data quoted above can be used 

as an indication of travel speeds for non-disabled persons.  As an alternative, the travel speeds 

for disabled persons quoted in part 3 can be used.  Finally, the default stair speeds should be 

used as a guide only for specifying stair speeds.  The values supplied should be considered as 

maximum values. 

 

Table 3-7: Mean suggested travel speed functions for evacuees (based on data from [33]) 

Gender Age (years) Speed (m/s) 

Male 

2 - 5 0.16 * age + 0.30 

5 - 12.5 0.06 * age + 0.80 

12.5 - 18.8 0.008 * age + 1.45 

18.8 - 39.2 -0.01 * age + 1.78 

39.2 - 70 -0.009 * age + 1.75 

Female 

2 - 8.3 0.06 * age + 0.50 

8.3 - 13.3 0.04 * age + 0.67 

13.3 - 22.25 0.02 * age + 0.94 

22.25 - 37.5 -0.018 * age + 1.78 

37.5 - 70 -0.01 * age + 1.45 
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Figure 3-8: Walking speeds as a function of age and gender, based on the curves from 

Ando et al [33] 
 

For people with movement disability, stairs pose a particular problem.  People with particular 

movement aids, such as wheelchairs, cannot use stairs unaided.  However, a study has been 

conducted [32] (see part (3) above), where people with particular walking aids were asked to 

ascend and descend stairs unassisted.  The values in Table 3-8 refer to unimpeded performance 

degradation.  Where possible, the staircases incorporated a landing and consisted of no less than 

12 steps.  Values of the Mobility attribute were determined by comparing the mean travel speed 

for the class of movement aid, with the travel speed for the class without a movement disability.  

 

NOTE:  

The reduced rates do not account for the other effects that may be attributed to an impairment. 

 

Table 3-8: Stair movement rates for evacuees with movement disabilities (based on data 

from [32]) 

     

Ascending Stairs 

     

Movement Aid Mean Speed (m/s) Range (m/s) Subjects Mean Mobility 

Crutches 0.22 0.13-0.31 2 0.31 

Walking Stick 0.34 0.18-0.49 9 0.49 

No Aid 0.41 0.14-0.60 18 0.59 

No Disability 0.70 0.55-0.82 4 1.0 

     

Descending Stairs 

     

Movement Aid Mean Speed (m/s) Range (m/s) Subjects Mean Mobility 

Crutches 0.22 - 1 0.31 

Walking Stick 0.32 0.11-0.49 10 0.46 

No Aid 0.33 0.13-0.70 18 0.47 

No Disability 0.70 0.53-0.90 4 1.0 
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3.2.5  Agility: 

Active Mode: Population 



Chapter 3 – Representing the Population 

 

© 2017 University of Greenwich 62 

 

The Agility value should be set with reference to the Obstacle values for the geometry. The 

Agility is used to determine if a person can “go over” a surmountable obstacle. It is important 

when distributing Agility values to ensure that all individuals have an Agility value above or 

equal to the default obstacle value for arcs.  If this is not the case, evacuees may not be able to 

move. 

 

NOTE: 

The agility is also affected by FIC, FIN and irritant Smoke. Level C only. 
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3.2.6  Age/Height/Weight/Gender: 

Active Mode: Population 

 

These attributes are used primarily for the purpose of categorising people. However, the age 

and gender attributes are used in automatically assigning default stair travel speeds, while the 

gender attribute is used in assigning default values for drive, travel speed and agility.  The 

height attribute also has an important impact upon the intake of toxins and convected heat from 

the environment when receiving data from a CFAST hazard data file.  In this case, an option 

can be set that effectively determines that a person comes into contact with the hot layer when 

the height of the hot layer (as determined by CFAST) descends to the height of the person (user 

defined attribute).   It is recommended that this option only be used in situations where evacuee 

heights are thought to have a significant influence on the outcome or in circumstances where 

the default option (uniform influence of 1.7m) is thought to be non representative. 

 

It should also be noted that it is possible to modify the actual assigned values of these variables 

to any value the user desires. It is thus possible to have seemingly absurd settings, which suggest 

for example that a 99-year-old female has the same evacuation capabilities as an 18 year male.  

 

The Height and Weight attribute of a randomly generated population is dependent upon the Age 

and Gender of the evacuee. This data should be treated as indicative of the expected height and 

weight of an individual rather than as an accurate representation. The user should provide 

additional information if this factor is considered important and should not solely rely on the 

data within the model. 
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3.2.7  Drive: 

Active Mode: Population, Simulation 

 

The Drive distribution can be interpreted as representing the individual’s motivation to escape 

in relation to the rest of the population. Individuals with a relatively high degree of motivation 
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relative to others are attempting to exit by implementing a short-term optimal route; contesting 

and probably winning all conflicts en route. In contrast, individuals with a relatively low degree 

of motivation relative to others are less resolute in maintaining an unbroken travel path and give 

way to the more motivated individuals. It should be remembered that within buildingEXODUS, 

an individual’s motivation or drive can be assigned on the basis of age, gender etc., or on the 

perceived seriousness of the situation.  

 

The Drive attribute is used to resolve spatial conflicts. In resolving conflicts it is the relative 

value of the drive that is important. Thus, for a given population, drives in the range 1 to 10 are 

no different to drives in the range 21 to 30 or 101 to 110. Conflicts generally occur in crowded 

situations as evacuees are more likely to interact. The particular distribution of drive used can 

greatly affect the order in which people evacuate. The local behaviour is therefore strongly 

dependent on drive. Global evacuation trends are also affected in so far as conflicts tend to slow 

down an evacuation.  

 

The smaller the range of drives, the more likely people are to be involved in conflicts that take 

longer to resolve. If the population has a wide range of drives, the conflicts are likely to be 

resolved relatively quickly. For example, a population consisting of 100 people with drive 

ranging from 1 to 5 are more likely to be involved in longer conflicts than the same number of 

people with drive ranging from 1 to 20.  

 

Under conditions where a diverse population can be expected, the default setting for the drive 

distribution may be appropriate. This results in a drive distribution of some 67%. This 

effectively results in the normalised difference between the population maximum and minimum 

drives being 67%.  This results in a wide mixture of individuals and a wide mixture of possible 

conflict resolution outcomes.  

 

NOTE: 

Once the drive distribution is set, the drive of each individual remains constant throughout the 

simulation, it does not alter according to the nature of the particular conflict.   

 

Finally, in situations involving heat and toxic gases, the drive distribution may also influence 

the fatality distribution as losers of conflicts may be exposed to higher concentrations of fire 

hazards for longer periods of time. 

 

TIP: 

It is suggested that the default values for drive are used until the user has developed experience 

in using buildingEXODUS.  
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KEY POINTS: IMPACT  
 

 Individual attributes can be used to affect performance and the emergent conditions 

produced locally. 

 Modifying attributes can represent variations in the evacuee performance after the 

population has already been generated. 

 Modifying attributes can be used to produced different scenarios, and influence all 

four key components of evacuee performance. 
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CHAPTER 4: REPRESENTING PROCEDURAL/BEHAVIOURAL 

RESPONSE 
 

The user has a number of options available to them in order to represent the general response 

of the population – whether this represents the individual behavioural response or the assumed 

imposition or a procedure. This can be based on (1) configuring the occupant population (as 

described in the previous section), (2) using different methods to represent route selection, and 

(3) checking different behavioural/ procedural options in Simulation mode. Using these options 

allows the user to either engineer the response of the population (i.e., answering specific 

engineering questions), or allow the model to predict evacuee response and then examine the 

emergent conditions that appear. Each of these approaches has merit and may be employed in 

different forms of analysis. Points (2) and (3) are discussed below.  

 

The key controls relating to the behavioural and procedural response are available via the 

Behaviour Control dialogue box. This is shown in Figure 4-1 along with some basic description 

of the controls provided. These options (in conjunction with those present in the Hazard Control 

dialogue box) control all aspects of the evacuee response: the time to respond, the speeds 

achievable, the routes/behaviours adopted and also the physical susceptibility/sensitivity of the 

evacuees to the surrounding environmental conditions and available information. 

 

 
 

(a) Route tab (b) Behaviour tab 
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(c) Environment tab (d) Signage tab 

 
(e) Lifts tab 

Figure 4-1: Behavioural Options and general description. 
 

EXODUS is a flexible and comprehensive simulation tool. As such, it provides a number of 

facilities/functions for the user to represent evacuee movement and navigation. This presents a 

number of modelling benefits, not least of which is the range of different situations that can be 

represented within the model; e.g., non-emergency/emergency, evacuation/circulation/ 

preparation, etc. However, the user should be mindful that these functions can interact and can 

influence the results produced. Table 4-1 presents a simple overview of these interactions 

focusing on evacuee navigation. It is certainly not exhaustive, but does provide some insight 

into how the features interact and the impact that they may have. The key issue that arises from 

this is that the user should have a clear understanding of the features being used and the manner 

in which they interact prior to generating any results. 
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Table 4-1: Impact of navigation mechanism on other behaviours. 

 

Method Used to Determine an Evacuee’s Route  

Evacuee Uses 
Nearest Exit 

Assumes Local 
Potential is flagged 

 

Evacuee Uses Target 
Exit/Itineraries 

Either Local Potential 
or Local Familiarity can 

be flagged 

 

Evacuee Uses 
Occupant Exit 

Knowledge 
Assumes Local 

Familiarity flagged 

 
Evacuee Follows  
Potential Map 

Evacuee Follows  
Distance Map 

Evacuee Follows  
Distance Map 

EXODUS 
Object/Attribute 

Impact of Object/Attribute on Occupant Behaviour and Movement 

External Exit Potential 

Influences the 
catchment area of each 

exit. The catchment 
area determines the 

area from which people 
will be drawn to the 
exit, assuming they 

have not been assigned 
a target. 

No impact No impact 

External Exit 
Attractiveness 

No Impact  No Impact 

Determines the 
probability of whether 
an occupant is familiar 

with an exit. If the 
occupant is familiar, the 
exit will appear in their 
list of viable exits and 

then they can make use 
of it. 

External Exit Flow rate 

Constrains achievable 
flow performance 
through the exit 

according to the level 
specified.  

Constrains achievable flow 
performance through the 
exit according to the level 

specified. 

Constrains achievable 
flow performance 
through the exit 

according to the level 
specified. 

External  Exit Activity 

Determines the draw of 
the exit – whether 

people move towards 
the exit. 

  

Determines the draw of 
the exit – whether people 
move towards their target 

exit. 
 

Determines the draw of 
the exit – whether 

people move towards 
the exit with which they 

are familiar. 
 

External  Exit Status 

Determines whether 
people can leave via the 

exit. 
 

Determines whether 
people can leave via their 

target exit. 
 

Determines whether 
people can leave via the 
exit with which they are 

familiar. 
 

External Exit Times 

A sequence of event 
times that determines 

whether the door opens 
or closes according to 

its current status. 

A sequence of event times 
that determines whether 
the door opens or closes 
according to its current 

status. 

A sequence of event 
times that determines 

whether the door opens 
or closes according to 

its current status. 
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Redirection Nodes No impact 

May insert new tasks into 
existing itinerary.  

Occupant with existing 
itinerary then has more 

tasks to complete before 
exiting. 

No impact 

Direction Nodes 

Forces occupant to 
move in a specific 

direction through a 
component, such as a 

corridor 

Forces occupant to move 
in a specific direction 

through a component, 
such as a corridor 

Forces occupant to 
move in a specific 

direction through a 
component, such as a 

corridor 

Internal Exit direction 

Determines which 
direction occupants 

approach the internal 
exit – influences the 

spread of the potential 
map in relation to the 

internal exit. 

No Impact 

 
 
 

No Impact 

Internal Exit potential 

Influences the 
catchment area of each 

exit. The catchment 
area determines the 

area from which people 
will be drawn to the 
exit, assuming they 

have not been assigned 
a target. 

No Impact 

 
 
 

No Impact 

Internal Exit flow 

Constrains achievable 
flow performance 

through the internal 
exit according to the 

level specified. 

Constrains achievable 
flow performance 

through the internal exit 
according to the level 

specified. 

Constrains achievable 
flow performance 

through the internal 
exit according to the 

level specified. 

Attractor/Discharge 

Influences the path 
adopted by occupants 
as they navigate about 

the geometry by 
modifying the potential 
map according to user 

input. Can also 
constrain achievable 

flow performance 
according to the level 

specified. 

No impact on route 
adopted. 

Can constrain achievable 
flow performance 

according to the level 
specified. 

No impact on route 
adopted. 

Can constrain 
achievable flow 

performance according 
to the level specified. 

Transit Node  

Determines movement 
according to terrain 

represented (e.g., stair, 
escalator, etc.), either 

through flow 
constraints or simulated 

movement behaviour 
 

Determines movement 
according to terrain 

represented (e.g., stair, 
escalator, etc.), either 

through flow constraints 
or simulated movement 

behaviour 

Determines movement 
according to terrain 

represented (e.g., stair, 
escalator, etc.), either 

through flow 
constraints or simulated 

movement behaviour 

Transit Node Biasing 

Influence selection 
between grouped 
transit nodes – for 

instance between an 

Influence selection 
between grouped transit 

nodes – for instance 
between an adjacent stair 

and escalator 

Influence selection 
between grouped 
transit nodes – for 

instance between an 
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adjacent stair and 
escalator 

adjacent stair and 
escalator 
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Seat / Boundary Nodes 

Reduces speed and 
influences local 

navigation – evacuees 
attempt to avoid nodes 

to maintain speed 

Reduces speed and 
influences local navigation 

– evacuees attempt to 
avoid nodes to maintain 

speed 

Reduces speed and 
influences local 

navigation – evacuees 
attempt to avoid nodes 

to maintain speed 

Signs 

May influence the 
routes adopted, 

depending on the 
settings employed. 

No Impact 

May influence the 
routes adopted and the 

exits with which an 
individual is familiar and 
uses, depending on the 

settings employed. 

Simulation Flag Impact of Simulation Flag Selection on Occupant Behaviour and Movement 

Smoke Redirection 

Allows occupant to 
move through or 

redirect away from 
smoke when confronted  

No impact, unless 
itinerary has been 

completed and individual 
then defaults to mapping 
system being employed. 

At this stage their 
behaviour will be dictated 
by this mapping system. 

Allows occupant to 
move through or 

redirect away from 
smoke when confronted 

Adaption to Congestion 

Allows occupant to 
redirect away from a 
congested exit should 

an alternative be 
available. Calculation 
based on simplified 

congestion calculation. 
No signs/VCA are 

necessary. 

No impact, unless 
itinerary has been 

completed and individual 
then defaults to mapping 
system being employed. 

At this stage their 
behaviour will be dictated 
by this mapping system. 

Allows occupant to 
redirect away from a 
congested exit should 

an alternative be 
available. Calculation 
based on congestion 

calculation using VCA. 

Natural Movement / 
Wall Proximity/  

Occupants attempts to 
maintain distance from 
other people, from the 

boundary and also 
attempts to maintain 

direction of travel 

Occupants attempts to 
maintain distance from 
other people, from the 

boundary and also 
attempts to maintain 

direction of travel 

Occupants attempts to 
maintain distance from 
other people, from the 

boundary and also 
attempts to maintain 

direction of travel 

Seat Jumping 

Allows the occupant to 
climb over seat backs 

when their Patience has 
expired. 

Allows the occupant to 
climb over seat backs 

when their Patience has 
expired. 

Allows the occupant to 
climb over seat backs 

when their Patience has 
expired. 

Stagger 

Produces sub-optimal 
movement forcing 

occupants to stagger 
when they walk through 

sufficiently dense 
smoke 

Produces sub-optimal 
movement forcing 

occupants to stagger 
when they walk through 
sufficiently dense smoke 

Produces sub-optimal 
movement forcing 

occupants to stagger 
when they walk through 

sufficiently dense 
smoke 

Social Response 

Evacuees potentially 
communicate Response 
Time with those sharing 

a gene. 

Evacuees potentially 
communicate Response 

Time and Target Exit with 
those sharing a gene. 

Evacuees potentially 
communicate Response 

Time and Exit 
Knowledge with those 

sharing a gene. 

Social Movement 

Evacuees potentially 
communicate Response 

Time, Target Exit and 
Itinerary with those 

sharing a gene. 

Evacuees potentially 
communicate Response 

Time, Itinerary and Target 
Exit with those sharing a 

gene. 

Evacuees potentially 
communicate Response 
Time Itinerary, Target 

Exit and Exit Knowledge 
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with those sharing a 
gene. 
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Extreme 
Behaviour/Impatience 

In conjunction with the 
person’s Patience 

attribute, allows person 
to step away from 

target in order to seek 
out other routes 

In conjunction with the 
person’s Patience 

attribute, allows person 
to step away from target 
in order to seek out other 

routes 

In conjunction with the 
person’s Patience 

attribute, allows person 
to step away from 

target in order to seek 
out other routes 

Crawling 

Occupant crawls to 
avoid smoke, reducing 
speed and simulated 

occupant height in the 
process 

Occupant crawls to avoid 
smoke, reducing speed 
and simulated occupant 

height in the process 

Occupant crawls to 
avoid smoke, reducing 
speed and simulated 

occupant height in the 
process 

 

As mentioned above, this table is only a general guide. Where the user is in doubt it is critical 

that they test the interaction between functions and features prior to generating real results. In 

addition, the user should view the simulations in action to visually establish that the response 

is credible. This is particularly important should the user intend to eventually use Batch Mode. 

 

4.1 Occupant Itinerary List 

Active Mode: Population, Simulation 

 

In reality, people may perform procedures or perform actions prior to moving towards a place 

of safety. In addition, there may be situations (non-emergency scenarios, sections of the 

population are not at risk, etc.), where people continue to act without evacuating. The OIL 

represents procedures or activities that the individual may conduct prior to or during the 

evacuation. These may include safety procedures (e.g. shut down activities), or general 

activities (e.g. collect, object, perform task, etc).  More specifically, these may include the 

implicit modelling of the performance of tasks that might be predicted by the user.  For instance, 

the movement of staff during the evacuation of a medical area would involve a number of pre-

set activities and may therefore be represented within the model with some confidence.   

 

This feature may be used to examine the impact of these evacuee actions upon the outcome of 

an evacuation.  For instance, in conjunction with the Maintain Itinerary option (on the Route 

tab of the Behaviour Options dialogue box in Simulation mode) the importance of staff 

members’ adherence to a pre-defined set of actions may be examined, especially in deteriorating 

environments. 

 

NOTE:  

A Target Exit can be included in the itinerary as the final task. Therefore, just as an itinerary 

can be thought of as a procedure that needs to be completed prior to evacuating, assigning a 

target exit is effectively ensuring that an individual follows a particular procedure (i.e., moving 

to a specified exit), albeit a simple one. 

 

This feature may also be used to represent the anticipated movement of evacuees prior to their 

evacuation (i.e., when they are simply pedestrians).  For instance, within a train station, people 

may move towards a sign, remain there for a period of time and then move off.  The ability to 

implicitly model this behaviour is useful in that the general trends of circulation movement may 

be relevant to the outcome of an evacuation, providing localised area of congestion, for 

instance. 
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The OIL may be used at several different levels. By attributing the list of tasks to individuals 

manually, the user is identifying specific individuals whose predictable actions and location 

may have some impact upon the simulation.  If a pre-defined procedure is used, these evacuees 

will not follow it, but will instead adhere to the itinerary that has been specified for them. 

 

Even in this instance, the itinerary can be created specifically for the individual or can be 

imported from a generally available itinerary (through the Itinerary window) and imported into 

the individual. 

 

Alternatively, the itinerary can be applied to a population panel or to a population, prior to its 

generation, through the Population Panel facility. Again, this is facilitated through the Itinerary 

window. This is particularly powerful as it allows itineraries to be created according to specified 

probabilities. 

 

As an example, consider a situation in which a specific individual (e.g. staff member) has to 

perform a specific task during the evacuation while the rest of the population may undertake 

any of three other types of tasks.  This individual is defined and their task is assigned to them 

manually, thereby guaranteeing that the evacuee will perform the required task.  The remainder 

of the population can be constructed using the Population Panel method to represent specific 

sub-populations, each of which can be assigned the three tasks using an appropriate probability 

distribution (see Figure 4-2). 

 

 
Figure 4-2: Example distribution of tasks between sub-populations. 

 

Using this approach, the identified staff member will carry out his specific task while the other 

members of the population will be assigned the remaining three tasks according to the 

probability distributions.  

 

As mentioned previously, the use of itineraries should be made in the knowledge that it might 

influence the performance of evacuation procedures. Those evacuees that are given user-

defined itineraries will not adopt the automated procedures generated. 

 

NOTE:  

Once the individual is attributed with an Itinerary List in Population mode, the list does not 

change between simulations. 

 

NOTE: 

Probabilities assigned to the various tasks in the ITINERARY SELECTION dialogue box must 

add up to 1.0.  If the user requires a proportion of the population not to have tasks, then dummy 

tasks can be created that have no targets or delays associated with them. 

 

The user may wish to have members of a population perform no task prior to commencing their 

evacuation. This can be achieved by using ‘dummy’ itineraries that contain no nodal locations 

(i.e. as in Figure 4-2 except with no nodal locations supplied). Once the list of itineraries is then 

interrogated (see Figure 4-2) the population will have the possibility of performing no task 

(actually having an itinerary of no nodal locations). 
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The itinerary function allows buildingEXODUS model to be used to simulate non-emergency 

situations as well as complex user-defined evacuation procedures.  By providing the individuals 

with a set of tasks to perform and appropriately setting movement rate attributes, individuals 

may be made to move through a structure as if under normal circumstances.  This may be useful 

when examining flow of people during general circulation of the structure. 

 

NOTE:  

It is possible to delay occupants once they occupy their specified target locations.  However 

sensitivity analysis would be required to understand the consequences of doing so in relation 

to the geometry being modelled. 

 

 
Figure 4-3: Directing occupants to specific target nodes.  The hatched area represents 

the possible locations for the Target nodes. The dashed arrows represent the potential 

occupant paths. 

 

For instance, two groups of four nodes can be selected as described in Figure 4-3. Each of these 

eight nodes can be represented as a task on a separate itinerary. The occupants generated within 

the sub-compartment (using the Population Panel) will be made to adopt one of these target 

nodes. The eventual probability of them doing so is user controlled.  No delay should be applied 

to the Target Nodes in this instance, as the user is only interested in manipulating occupant 

movement rather than delaying their progress. The increased sophistication of this mechanism 

(through the use of stochastic processes) enables a far richer set of behaviours to develop, 

including contra-flow movement due to the occupant goals not being based upon their starting 

location. 
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(a) (b) (c) 

Figure 4-4: (a) Five occupants are located in the sub-compartment. (b) Target node 

locations are defined. One group guaranteeing movement towards the external exit. The 

other two groups moving occupants towards the upper internal exit and then preventing 

their return to the sub-compartment. (c) the paths adopted by the evacuating occupants. 

 

As can be seen from Figure 4-4 the attachment of these itineraries to five occupants located 

inside the sub-compartment causes the occupant population to use both of the two internal 

openings. The choice of the internal exit is not simply based on location, but involves the 

probabilistic adoption of an itinerary generating a more complex form of movement.  

 

The itinerary functionality has been developed to include a number of new tasks (see Table 

4-2). These can be assigned to a person individually, as part of a population, through Source or 

Redirection nodes, via signage and (where viable) through communication. 

 

Table 4-2: Itinerary tasks. 

Itinerary Task Purpose Mechanism Associated 

Terms 

Delay Implicitly represent 

people performing tasks 

and the associated 

delay. 

Nodal location identified, along with range. 

People occupy nodal location (fall within range) 

for a specified time then move on. Task can be 

shared by group members. 

Range(m)/ 

Min(s)/ 

Max(s) 

Delay Zone Implicitly represent 

people performing tasks 

and the associated 

delay. 

Compartment zone associated with itinerary. 

People move into compartment. Occupy location 

for a specified time then move on. Task can be 

shared by group members. 

Min(s)/ 

Max(s) 

Wait Implicitly represent 

people performing tasks 

and the simulated time 

of completion. 

Nodal location identified, along with range. 

People occupy nodal location when they fall 

within this range until a specified time then move 

on. Are able to mill around within specified range 

until this time. Task can be shared by group 

members. 

Range(m)/ 

Time (s) 

Wait Zone Implicitly represent 

people performing tasks 

and the simulated time 

of completion. 

Compartment zone associated with itinerary. 

People move into compartment. Occupy location 

until a specified time then move on. Are able to 

mill around within specified range until this time. 

Task can be shared by group members. 

Range (m)/ 

Time (s) 

Way Point Route modification 

through identifying 

locations that need to be 

visited by individual. 

Nodal location identified. People deemed to have 

occupied nodal location for a specified time if 

they fall within specified distance of the location, 

then move on. Task can be shared by group 

members. 

Range (m) 
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Queue Ensure that the 

individual  recognizes a 

queue and then uses it 

according to the 

attributes of the 

associated route and 

server. 

Head towards server location (via pre-

determined route if specified), then act as 

indicated by the server node. Task can be shared 

by group members. 

 

Form Group Represent individuals 

moving to a location 

then forming a group 

and then waiting until 

specified number of 

people forming group 

arrives before 

continuing on. 

Nodal location specified. Gene associated with 

group specified unless previously assigned. 

Number of people in group specified. When this 

number of people arrive, the people in the group 

are attributed with a gene, and they then move off 

to perform the next task. Task cannot be shared 

by group members. 

Group ID/ Size 

Zone Form 

Group 

Represent individuals 

moving to a zonal 

location then forming a 

group and then wait 

until rest of group 

arrives before 

continuing on. 

Compartment zone associated with itinerary. 

Gene associated with group specified. Number of 

people in group specified. When this number of 

people arrive and are located in the zone, the 

people in the group are attributed within a gene, 

and they then move off to perform the next task. 

Task cannot be shared by group members. 

Group ID/ 

Number 

Leave Group Individual leaves group 

when task is 

encountered. 

Nodal location specified, although not used to 

guide individual. Task cannot be shared by group 

members. 

 

All Leave 

Group 

Group is disbanded. Nodal location specified, although not used to 

guide individual. Task can be shared by group 

members. 

 

Remove Person leaves 

simulation on arrival. 

Nodal location specified. Individual moves to 

nodal location. On occupying location, 

individual leaves simulation and is assumed not 

to have any further influence. 

 

Discount Individual is no longer 

recorded as being an 

evacuee. 

As Remove, nodal location specified. Individual 

moves to nodal location. On occupying location, 

individual leaves simulation However, can still 

perform within simulation; however, 

performance is not included in data representing 

evacuee performance. 

 

Discount Mill Individual is no longer 

recorded as being an 

evacuee and starts 

milling. 

This task behaves in the same manner as the 

Discount task (see above), however the 

individual will commence milling when 

executed. 

 

Wait For Individual is instructed 

to wait for a specified 

number of group 

members to join them 

before continuing on 

with future tasks. 

Nodal location specified. Individual moves to 

nodal location. On occupying location, 

individual waits for the specified number of other 

group members to arrive. While waiting, the 

individual can mill within specified range. Once 

the specified number of group members have 

arrived, the group can then move off. 

Range (m)/ 

Number 

Find Via 

Signage 

Naïve individual 

requires instructions in 

order to find target 

location. Individual will 

follow guidance from 

sign specified. 

Individual will follow 

guidance until next sign 

or objective 

encountered. 

Nodal location specified identifying eventual 

objective, along with the initial direction of 

movement (in the form of an additional task). 

 

Task 

specifying 

event 

objective, and 

a task 

specifying the 

initial 

direction of 

movement. 
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Collect Person Implicitly represent a 

person (or group of 

people) collecting an 

individual from a given 

location.  

Nodal location identified. People go to the nodal 

location in order to collect the individual located 

on the node. Once at the node the person waits 

until the required number of people have arrived. 

This number comprises both the person on the 

nodal target and ALL people with associated 

Collect Person tasks  targeting the node.  Once 

the required number of people have arrived at the 

node they are all then assigned a specified Gene 

ID value. Task can be shared by group members. 

Gene  ID/ Size 

Drop Off 

Person 

Implicitly represent a 

person dropping off a 

previously collected 

individual at a given 

location. 

Nodal location specified. This task can only be 

used in conjunction with Collect Person task. 

Once a person has collected an individual via the 

Collect Person task, the collected individual can 

then be dropped off at a given nodal location. 

Task can be shared by group members. 

 

Coordinated 

Delay 

Implicitly represent a 

person (or group of 

people) undertaking a 

joint task and the 

associated delay. 

Nodal location identified. People go to the nodal 

location and wait until the required number of 

people have arrived. This number comprises 

ALL people with associated Coordinated Delay 

tasks  targeting the node.  Once the required 

number of people have arrived at the node they 

all then experience a random delay (between the 

min and max times defined) then move on. Task 

can be shared by group members. 

Min(s)/Max(s)  

 /Size  

Lift Bank Represents individuals 

catching a lift/elevator 

and defines the 

conditions (i.e. the total 

wait time and 

congestion) that they 

are prepared to tolerate 

in order to do so. 

Lift Shaft Opening transit node identified. On 

reaching the catchment area for the transit node 

group of lifts of which the Lift Shaft Opening 

transit node is a member, the individual first 

checks to see if both a lift within the group is still 

servicing the given floor and that the congestion 

level within the catchment area is less than their 

defined Congestion Threshold value. If either 

condition is not met then the occupant will drop 

the Lift Bank task and either follow the potential 

map to their nearest exit or automatically be 

redirected to stairs on the floor (depending on the 

behavioural settings). If both conditions are met 

however the occupant will start waiting for a lift. 

This results in a Lift Wait task being 

automatically assigned to the occupant  (see 

below). Task can be shared by group members. 

Wait Time(s)/ 

Congestion 

Threshold 

(occ/m2) 
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Lift Wait Represents agents 

waiting for a 

lift/elevator within the 

catchment area of a 

given lift bank  

This is an automated task generated when an 

agent with a Lift Bank task (see above) enters a 

defined lift catchment area.  If a lift within the 

group is still servicing the given floor and the 

congestion level within the catchment area is less 

than the occupants defined Congestion 

Threshold value upon entering the area the 

occupant will be randomly assigned to one of Lift 

Shaft Opening transit nodes within the lift bank. 

This Lift Shaft Opening transit node represents 

the location where they agent will initially wait 

for the lift. If the total amount of time spent 

waiting for the lift exceeds the Wait Time defined 

within the preceding Lift Bank task the occupant 

will abandon the Lift Wait task (i.e. they will 

abandon trying to use the lift). Task can be shared 

by group members. When sharing this task 

agents will share the Lift Shaft Opening wait 

location however they may not share the 

subsequent Way Point task assigning the agent to 

board the lift. Hence agents may not actually 

travel in the same lift to their designated floor. 

 

 

The use of these itinerary tasks allow the user to produce an array of behaviours beyond agents 

moving directly to an exit. In effect, the user is able to represent a range of non-emergency 

circulation behaviours and emergency procedures/responses, potentially leading to more 

complex conditions emerging.  

 

 
IMPACT OF OIL 

RESPONSE 
PHASE 

ATTAINABLE 
SPEED 

FLOW 
CHARACTERISTICS 

ROUTE  
USAGE 

 

4.2 Manipulation of Occupant Egress Routes Using Occupant Exit Knowledge system 

In complex multi-use structures, the occupant familiarity with the structure and their awareness 

of the location and accessibility of exits is largely dependent upon the nature of their use of the 

building. It is not simply dependent upon their location at the time of the evacuation, as is 

assumed by the majority of regulatory codes (as well as the Potential Map system). The route 

normally adopted by an occupant as well as the frequency of their use of the building will 

impact upon the eventual exit usage. In such circumstances more complicated exit usage will 

develop, according to the occupant’s understanding of the geometry. The use of the Potential 

Map system (see Section 3.1), although able to represent the different levels of exit use, is 

sometimes not sufficiently flexible to represent exit usage of this complexity, especially where 

exit awareness is not dependent upon location. 

 

The occupants’ awareness can be determined by attributing individuals or groups (through the 

Substitute facility) with a specific list of exits. This allows the user to control completely the 

nature of the familiarity levels. This is particularly useful in representing structures where rigid 

usage is evident or where occupants are located in restricted areas. Alternatively, the occupant 

population can be attributed with an understanding on a probabilistic basis that may fluctuate 

between simulations. This is useful when the population is more mobile, familiarity is not 

localised, when occupant populations are less well-defined or indeed when field data is 

available concerning exit usage. Through using both means it would be possible to allow 
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members of staff a complete understanding of a structure, while a non-resident population may 

have their exit awareness determined probabilistically. To guarantee the occupant awareness of 

all of the available exits, the user can either manually create the occupant’s exit list or use the 

Population Panel where a probability of 1.0 can be supplied for each exit. 

 

The alteration of an exit point’s Attractiveness index does not have the same impact upon 

movement as the adjustment of the Potential of an exit (described in 6.1). By adjusting the 

potential of an exit, the user is adjusting the potential map that is used by the population to 

navigate. Therefore the scale of the potential attributed to the exits will impact upon the egress 

route adopted by the individuals. The adjustment of the Exit Attractiveness of an exit will only 

affect the possibility of the individual being familiar with that particular exit. Once calculated, 

the subsequent decisions are determined according to the underlying distance of the individual 

from the exit with which they are familiar. Care should be taken by the user when setting the 

probabilities of the individual exit familiarity to sensibly reflect either experimental data or 

observed movement patterns. An individual should always have at least one exit in their exit 

list. 

 

When attributing exits with an Attractiveness index it should be remembered that the figure 

supplied is the probability of the occupant being aware of the exit. Therefore an occupant will 

be more likely to be familiar with an exit with a familiarity index of 75 than he would be with 

an exit that had a familiarity index of 25.  The familiarity index should always be between 0 

and 100. If a figure less than or equal to 0 is supplied, then the occupant will never be familiar 

with the exit. If a figure of greater than 100 is supplied then the occupant will always be familiar 

with the exit. 

 

 
Figure 4-5: An example geometry and associated exit familiarity. 

 

The user also has additional control over the occupant’s use of the exits through the definition 

of the exit’s usage (e.g. whether it is in constant use or is an emergency exit). The occupant’s 

behaviour not only reflects their familiarity with the structure, but also with their regular use of 

the structure. Occupants will prefer to use those exits that are in regular use, unless the 

conditions are signified as being Extreme (therefore, occupants will use exits in constant use 

that are in their list of exits, otherwise they will resort to emergency exits). Under the Extreme 

behavioural regime, all of the exits that are known to the occupant will be available as viable 

exit routes. This reflects the occupant’s general propensity not to use emergency exits. It is 

recognised that even under evacuation conditions that some emergency exits will not be used. 
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This factor should be taken into consideration in assigning the probabilities prior to the 

simulation. 

 

To demonstrate the impact of these features an example is depicted in Figure 4-5. Four exits 

are available to the 200 occupants within the structure. The centrally positioned main exit is 

familiar to all of the occupants within the structure, as it has a familiarity index of 100; i.e., a 

100% chance of being aware of an exit – not necessary guarantee the use of it. This might 

represent the fact that this is the main entrance to the structure and is therefore used as a normal 

point of ingress. Two secondary exits are available to the north-east and to the south-west of 

the structure. This might represent exits that are not generally known to the less frequent users 

of the structure, but would be known to occupants who are experienced users of the building. 

Finally, an emergency exit exists in the north-western end of the building. This exit is not 

normally used during regular circulation and is subsequently less well known to the general 

population although may be considered by experienced users of the building during an 

emergency. 

 

 
Use of north-east exit (top left) and north-west exit (top right) 

 
Use of main exit (central left) and southern exit (bottom left) 

Figure 4-6: Starting locations of people who would make use of various exits within the 

structure during normal conditions. 

 

In Figure 4-6 an example of the exit usage during the Normal behavioural regime is provided. 

Each square appearing within the geometry denotes the starting location of an occupant using 

the exit identified. The main exit is used by the vast majority of the occupants as it provides the 

nearest viable point of exit, both due to its attractiveness guaranteeing occupant familiarity and 

the nature of the geometry. The two secondary exits are used by far fewer occupants due to 

their reduced attractiveness.  The emergency exit is not used, as the occupant movement takes 

place under Normal conditions (i.e. not Extreme) and other exits in constant use are available. 
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Use of north-east exit (top left) and north-west exit (top right) 

 
Use of main exit (central left) and southern exit (bottom left) 

Figure 4-7: Starting locations of people who would make use of various exits within the 

structure during extreme conditions. 

 

In contrast, when the Extreme behavioural regime is enabled, simulating an emergency 

scenario, a number of occupants decide to use the emergency exit as can be seen from Figure 

4-7. Again, each square appearing within the geometry denotes the starting location of an 

occupant using the exit identified. Therefore, under evacuation conditions, where the normal 

social constraints on exit usage are less adhered to, emergency exits may become a more viable 

option. This would differ between structures. 

 

Care should be taken in deciding the methods used to impose the exit familiarity upon the 

population. The three methods that are available may interact (as they can with the imposition 

of target exits) during the creation of a population.  

 

 Occupants that have been attributed with an exit list manually, do not have them 

overridden by any other means of familiarity (such as by the automatic means relying 

upon Exit Attractiveness). 

 Occupants that have been attributed with a Target Exit will be attributed with an 

automatically calculated exit list (according to the attractiveness of the exits), but will 

still initially head towards their specified exit, which will form part of their exit list. 

 Occupants that have not manually been attributed with an exit list will be attributed with 

an automatically calculated exit list (according to the attractiveness of the exits). 

 Irrespective of the existence of occupant exit lists, these will only be used if the Local 

Familiarity check box is enabled in the Behaviour Options dialogue box (on the 

RuleBase menu in Simulation mode). Otherwise the Potential Map system will be used. 
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4.3 Setting Potentials (For use with Potential map System) 

Exit potentials and internal exit potentials control the spread of the global potential map.  

Increasing the exit potential of an exit decreases the catchment area of an exit, i.e. makes the 

exit less favourable.  Conversely, decreasing the potential of an exit makes it more attractive.  

The important point to consider is that the attractiveness of one exit can be measured against 

another by the relative values of their potential.  For example, two exits both with a potential 

of 0.0, have the same level of attractiveness as two exits with both exit potentials set at 100.0.  

This also applies to exit points with different potentials; it is the difference between the exit 

potential values that is important rather than the absolute size of the potential levels. As before, 

these calculations will only occur if no pre-defined procedures are selected. 

 

TIP: 

When setting exit potentials, use either the Map or Contour function (both available in Scenario 

mode), as they allow the catchment areas of each exit to be viewed. 

 

 
IMPACT OF POTENTIAL 

RESPONSE 
PHASE 

ATTAINABLE 
SPEED 

FLOW 
CHARACTERISTICS 

ROUTE  
USAGE 
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CHAPTER 5: REPRESENTING THE ENVIRONMENT 
 

5.1 Representing the Hazard within the Model 

 

5.1.1 Setting User Defined Hazards 

The process of setting fire hazards can be a laborious task.  It is suggested that when utilised, 

the number of physical zones over which the hazards are spread is kept to a minimum.  

Furthermore, it is easier if the zones are “fitted” to the enclosure, for example, each room in an 

enclosure may be considered a zone.  It is also of benefit to use simple formulations (e.g. linear 

or time2) to spread the hazards. 

 

Whenever using fire hazards, it is suggested that an initial set of zones are used to initialise the 

specific hazard starting values at the values required.  This will ensure that all previous fire 

hazard values are removed. 

 

If a physical zone is to have different fixed values or more than one equation over different time 

spans, these must be defined as separate hazards.   

 

It is essential to perform sensitivity analysis on any fire hazards present, as the outcomes of 

simulations may be sensitive to minor changes in the hazard distribution.  

 

5.1.2 Setting CFAST/SMARTFIRE Hazards 

It is suggested that the numbering of the physical regions within both CFAST/SMARTFIRE 

(i.e. compartments) and EXODUS (i.e. zones) be kept consistent.  Although not compulsory, 

consistency in the numbering of the physical regions will greatly simplify the process of 

creating hazard scenarios, since the hazard “Compartment1” will simply be assigned to 

“Zone1”, “Compartment2” to “Zone2” etc.  This will in turn greatly reduce the likelihood of 

errors occurring. 

 

It is important to remember that it is not necessary to model the entire structure within 

CFAST/SMARTFIRE.  CFAST is only capable of modelling 30 compartments, and so in many 

instances only the compartments of primary interest (i.e. those closest to the source of the fire) 

will be modelled. Although the SMARTFIRE model is not restricted in the same manner, the 

overheads associated with the running of CFD models also require expedient usage of the 

model. 

 

Data relating to the values of the environment variables present within each compartment at 

every user defined time increment is stored within a corresponding external data file.  EXODUS 

loads the environment data at successive time increments from the external file during the 

simulation run.  The process of loading data from external files has an associated time overhead, 

which will result in slowing down the simulation.  The greater the number of compartments, 

and the smaller the time increment used the greater the slowdown that will be experienced. 
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5.1.3 Setting CFAST or SMARTFIRE Hazards 

EXODUS is only designed to work in conjunction with history files generated using CFAST 

(version 4.0.1 up to version 5.1.1) or data files generated using the SMARTFIRE CFD model 

version 4.0 and above.  Attempting to load a history file generated using previous versions of 

CFAST or a data file from earlier versions of SMARTFIRE will result in an error being 

displayed.  CFAST can be downloaded from the NIST web site [102].  

 

Users wishing to load hazard data generated using CFAST versions greater than 5.1.1 are  

required to convert the ASCII data output file (.OUT) (produced automatically by CFAST upon 

completion of any given run) into a corresponding data file in the SMARTFIRE file format 

prior to loading, see the User Guide, Section 5.3.9 Loading Existing CFAST and SMARTFIRE 

Hazards. 

 

The transfer of SMARTFIRE data into EXODUS requires that the data is averaged and 

parcelled in a manner that EXODUS can then employ. The user should be aware that the process 

is not seamless and that some resolution will be lost in the process. Spot checks should be 

conducted to ensure consistency. Where there is concern conservative assumptions should be 

made.  

 

Care should be shown when configuring the zones and SMARTFIRE hazards. The 

SMARTFIRE data is converted into a format that is usable by the EXODUS model. However, 

it is the user’s responsibility to ensure that the fire data is appropriately associated with the 

correct locations. If this is not the case then the fire will develop incorrectly, producing 

unreasonable results. 

 

5.2 Environment - Configuring the Impact on Evacuee Performance 

Once the environment is represented within the simulation, the environmental conditions can 

then influence evacuee performance should they encounter them. For the environmental 

conditions to have any influence over the results produced, the Hazard Model option should be 

enabled within the Hazard Control dialogue box. A number of other controls are available to 

modify and limit the impact of the environmental conditions; however, these are redundant if 

the Hazard Model option is not checked. 

 

5.3 Environmental Options 

Smoke Redirection allows evacuees to decide locally whether they wish to pass through smoke 

or redirect to another exit, should the option be available. The likelihood of them doing so will 

be down to a number of factors, including the data-set selected. It is strongly recommended that 

once the Smoke Redirection option has been enabled that the Smoke Stagger option should also 

be enabled. This option allows occupants to manoeuvre around the smoke, making small 

adjustments to their egress path. This prevents occupants from reacting inappropriately to the 

smoke barrier and detecting potential paths where they do not exist. In the vast majority of cases 

this type of error will not occur. However, for consistency the Smoke Stagger movement should 

be enabled at all times. It should be recognised that if the user is attempting to more accurately 

model the occupant behaviour in response to smoke, all aspects of this behaviour should be 

represented.  
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5.3.1 General Advice Concerning the Use of Redirective Behaviour 

When implementing behaviour involving redirection in response to smoke, the user should be 

aware of the limitations of the data-sets provided. Bryan analysed data from 335 incidents, 

involving 584 occupant interviews originally conducted by fire personnel. These incidents 

primarily occurred in residential enclosures [64].  Wood investigated 952 fires in the United 

Kingdom, interviewing 2,193 occupants, 50% of whom were involved in residential incidents, 

while the rest were involved in non-residential incidents (e.g. factories, shops, institutions, 

etc.[63,64]).  

 

Although the data-sets are limited, Bryan and Wood did attempt to quantify their findings and 

provide information concerning the proportion of people electing to redirect when faced with a 

given smoke concentration.  From Wood’s data 88% of the sample claimed to have been 

involved in situations involving smoke.  Of these, 40% did not necessarily have to move 

through the smoke.  The remaining 60% encountered a smoke barrier that needed to be 

negotiated to reach their primary objective.  Of these people a proportion turned back, according 

to the density of the smoke [63,64]. Bryan found that 62.7% moved through smoke and 18% 

redirected, again according to the density of the smoke [63,64].  The data relates to the 

conditions faced by those occupants that decided to redirect away from smoke.  

 

Unfortunately, the full context of the redirection data was not provided [63,64].  It is therefore 

not known how the data was influenced by factors such as structural familiarity or exit 

availability or social factors.  However, considering evacuation scenarios involving residential 

premises, it may be assumed that occupants will be familiar with their surroundings and 

therefore less likely to be discouraged from attempting to redirect away from smoke due to a 

lack of exit knowledge.  Furthermore, it may be argued that residential premises are less likely 

to provide alternative means of escape, making it less likely that occupants will elect to redirect.  

However, this may not be the case in scenarios that occur in less familiar more complex 

environments, such as shopping centres, hotels, etc.  As the Wood and Bryan data-sets are 

primarily concerned with residential premises, they should be used with caution in other 

applications. 

 

The Wood and Bryan data-sets refer to the proportion of occupants that redirected given specific 

smoke conditions.  However, these figures do not reflect a number of important factors 

including the possibility of the occupant encountering smoke more than once or the previous 

actions of the occupants involved.  Most importantly, the data only describes the likelihood of 

an occupant redirecting during an entire evacuation rather than in a specific instance when the 

occupant is faced with smoke.  A number of assumptions were required within the model in 

order to compensate for these issues. 
 

The behaviour is then only triggered once the occupants are confronted by a barrier of smoke 

and when the location of their primary target exit forces them to move through the smoke.  This 

limits the number of occupants that might be affected by this behaviour, automatically 

discounting occupants that are located near to the smoke but do not necessarily need to move 

through it.  Rather than using a data-set to describe the global probability of an occupant 

redirecting according to smoke, the data-set is only used during this specific set of 

circumstances.  This therefore reflects the self-selecting nature of the original data-sets; the 

percentages used in the model represent the comparative likelihood of redirection given an 

encounter with smoke of a specific extinction coefficient.  The results generated by the model 

using this data should then only broadly reflect the trends of the Bryan and Wood data-sets 

rather than replicate them exactly.  The nature of the scenario will determine the exact outcome 

of the occupant behaviour. 
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It is recommended that when attempting to model non-residential scenarios that the Local 

Familiarity system is used. This may have a noticeable impact upon the number of occupants 

redirecting away from a smoke-filled environment. Occupants involved in an evacuation from 

an unfamiliar structure (represented by a reduced number of exits in the occupant’s exit list) 

will have far fewer alternative exit routes. This may result in the occupant not being able to 

redirect and therefore being forced to move through the smoke-filled environment. Reduced 

exit awareness will therefore reduce the number of occupants redirecting. This may therefore 

be a means by which to represent evacuations from non-residential structures, where exit 

familiarity might impinge upon occupant redirection. 

 

An example is provided to better illustrate this relatively complex behaviour.  Three occupants 

(A, B, and C) are positioned inside a simple geometry (see Figure 5-1).  Within the geometry, 

three exits are available (exit_1, exit_2 and exit_3, see Figure 5-1).  Exit_2 provides the main 

passageway into the building, while Exit_1 and Exit_3 are used less frequently and are not 

globally familiar to the population.  Occupant C has been attributed with a target exit (Exit_2) 

by the user, while Occupants A and B have been manually attributed with an exit list 

(guaranteeing a level of familiarity) to represent their familiarity with the structure.  Occupant 

A is familiar with exit 1 and 2, while Occupant B is familiar with exit 2 and 3. 

 

A fire has started in the corridor leading to exit_2, preventing access without interacting with 

the smoke (see Figure 5-1).  The smoke is modelled as having an extinction coefficient of 1.0/m 

and therefore is a relatively severe smoke hazard. 

 

To represent the likelihood of redirection, the user has selected the ‘Avg’ data-set, and the 

default settings are used for the visibility coefficient (with  set to 2.0).  Each occupant views 

the smoke as posing a significant threat, as it affords them only 2m of visibility (assuming an 

extinction coefficient of 1.0/m), with all of the occupants being further than 2m from their initial 

target exit.   

 

Occupant C approaches the smoke.  Once ‘adjacent’ (i.e. occupying a node that is adjacent to 

the smoke barrier), the smoke redirection behaviour is enabled and the situation is analysed.  

Given that the occupant has been attributed with a target exit, the smoke redirection process 

ceases and the occupant maintains his route.  Occupants A and B approach the smoke, except 

that this time, they are aware of alternative routes that do not entail passing through the smoke.  

In both cases, they decide to redirect (according to the ‘Avg’ data-set, both occupants would 

have approximately a 27% probability of redirecting).  However, given that they have different 

building familiarity levels, they redirect in different directions (towards exit_1 and exit_3). 

These paths are considered appropriate, as they do not entail the occupant passing through the 

same barrier of smoke. 
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Figure 5-1: Two possible smoke redirection outcomes for three occupants confronted 

with a smoke barrier.  Each occupant has a different level of familiarity with the 

building. 

 

If the example were to be run again, it would be likely that different results would be produced. 

However, Occupant C, attributed with the target exit will always continue on through the 

smoke, irrespective of the conditions.  A possible alternative outcome is that Occupant A again 

redirects, however Occupant B decides to maintain his route and pass through the smoke.  This 

example demonstrates the probabilistic nature of this behaviour. 

 

5.3.2 Using the User-defined Redirection Function 

The user is able to define their own function to describe the probability of occupants redirecting 

away from a smoke barrier, according to the visibility afforded by the smoke-filled 

environment. The user does this by supplying several data-points in the User-Defined 

Redirection dialogue box, available via the Behaviour Options dialogue box.  Each data-point 

will consist of a visibility level and a percentage. This percentage then represents the likelihood 

of the occupant redirecting at that particular visibility (and therefore an extinction coefficient). 

The set of points will then be linearly interpolated so that simple functions connect each of the 

data-points, up until the final data-point which is taken to represent the highest extinction 

coefficient and above. 

 

 
Figure 5-2: Probabilities of Redirection supplied by the user. 
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As an example, examine Figure 5-2. Here the user has supplied eight data-points. At visibility 

levels greater than 25m, the occupant is assumed not to redirect. At visibility levels of 2m and 

less, the occupant has a 40% probability of redirecting. The linear interpolation between these 

points forms the function described in Figure 5-3. 

 

 
Figure 5-3: The interpolated function. 

 

This type of formulation allows the probabilities of redirection to be calculated at a more refined 

level than would previously have been the case. The User-Defined function interacts with the 

Gender Influence factor in the same manner as the other possible data-sets (see Section  5.3.4). 

 

NOTE: 

When using the User-Defined option to specify redirection probabilities, if the user provides 

less than eight data-points for the redirection function, the function will still operate within the 

boundaries provided.  Also, if the data-points are not provided in ascending order of visibility, 

then the model will sort them into a usable order. 

 

5.3.3 Adjusting the visibility coefficient 

The default position of the Visibility Coefficient () is 2.0. This is used in the conversion from 

the Extinction Coefficient (K) to the visibility afforded to the occupant, such that 

 

𝑉 =
𝜆

Κ
 

 

The suggested value of 2.0 is derived from the work of Jin. However, numerous other values 

are provided by Jin [17,18]. The value should be selected with care as it is used in the calculation 

to see whether the occupants will redirect when confronted by smoke.   
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Table 5-1: Possible Values for the Visibility Coefficient  

 Researcher Visibility 

Coefficient 

Jin (conservative tenability) 2.0 

OD [23] 2.3 

Jin (reflecting) 3.0  

Jin (light/darkness) 4.5 

Jin (light-emitting sign) 8.0  

 

The figures shown in Table 5-1 are taken from experimental work. The user is able to supply 

their own data.  However, given the importance of these figures upon other occupant behaviour 

(e.g. redirection), the user is advised to examine the impact of providing their own data. 

 

5.3.4 Adjustment of Gender Influence (Default Position- On) 

The influence of the occupant’s gender over their decision to redirect has been factored into the 

redirective function to take into account the findings of researchers such as Brennan, who 

discovered that females were more likely to redirect away from smoke than males. This was 

designed specifically to be used with the data-sets provided as they do not specifically address 

the gender issue. If the user is specifying their own data-set which already addresses this issue 

more specifically or the user is using a single sex population, then the Gender Influence may 

be disabled. 

 

5.3.5 Use of Smoke Stagger  

When the Smoke Staggering behaviour is enabled the user should expect that the evacuation 

times should generally increase. This is because of the increased distance that the evacuees are 

expected to travel. However, when the simulation involves high-density populations, this 

increase in the overall evacuation times may be minimal due to the reduction in the resolution 

of conflicts caused by the evacuees straying from their optimal path. The increase in evacuation 

times may also be minimal when evacuees are able to assist their navigation through moving 

along the perimeter of the geometry. In all cases the user should expect that the extent of the 

individual staggering will increase as the smoke conditions worsen. No other environmental 

factors (e.g. temperature, CO level, etc.) impinge upon their navigational capabilities within the 

model. The impact of other environmental factors upon their navigational capabilities are not 

represented within the model due to a lack of appropriate data. The impact of smoke is bounded, 

with no additional increase in the level of staggering after an extinction coefficient of 0.5/m. at 

this stage either the evacuee’s staggering does not worsen (Crawling has been disabled, see the 

Theory Manual) or the evacuee is forced to crawl (Crawling is enabled, see the Theory Manual). 

 

5.3.6 Use of Crawling 

The user has the option of selecting Crawl, requiring evacuees to crawl beneath the smoke 

conditions once they have deteriorated to a sufficient degree. Depending on nature of the 

incident this may influence the time that individuals arrive at a place of safety and the number 

of fatalities. Given that the number of people that revert to crawling behaviour will not be 

known in advance, it is advised that the simulations are run with this option enabled and 

disabled, to ensure that the impact is well understood. 
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5.3.7 Manipulation of Hazard Control Options 

A number of options are available to the user for them to manage the environmental impact 

upon the evacuees. They are able to manage which of the FED components are considered, the 

heat model employed, the impact of radiative heat flux, which of the environmental conditions 

influence travel speeds, the impact of individual heights upon exposure, the influence of 

hyperventilation, and the impact that the environmental conditions have upon the evacuee’s 

initial response time. Therefore, the user is able to manage the physiological, physical and 

psychological impact of the environment upon the evacuee. The options selected should be 

guided by the environmental conditions represented, the manner in which the evacuees are 

expected to interact with the environment, and the specifics of the population. Irrespective of 

the options selected, the user should be able to support the assumptions made – either through 

supporting research, scenario-specific information and/or because the results produced are 

conservative.  

 

 
Figure 5-4: The Hazard Control dialogue box. 

 

The Radiative Flux threshold (Dr) has some important consequences on the impact of the 

environment conditions upon the evacuees. When using values of Dr greater than 80, it is 

important to consider not only the number of people predicted to be incapacitated but the likely 

injuries among the survivors.  To take this into account it is necessary to consider the dose of 

thermal radiation received.  According to Hymes et al [81], a thermal dose of 210 – 700 

s(kW/m2)4/3 is the threshold for second degree blistering of exposed skin.  To determine the 

thermal dose received by an individual, simply multiply the FIHr received by the Dr used in 

the radiation formulation.  For example, if a Dr of 1000 is used in the radiation formulation and 

an evacuee is predicted to have an FIHr of 0.31, then the dose of thermal radiation received is 

0.31 X 1000 = 310 s(kW/m2)4/3.  Thus it can be expected that this evacuee has received second 

degree blistering of exposed skin. 

 

In addition, the use of Person Height is included as this has an impact upon the results generated 

when using the CFAST model. 
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The user should ensure that the Hazard Model is enabled, if the user is interested in the impact 

of the environment upon the evacuee’s progression. This switch should therefore be checked 

prior to the commencement of the simulation. 

 

The impact of these options will be highly sensitive to the scenario. Therefore, sensitivity 

analyses should be conducted to establish this impact and then the results finally used. 

 

 
IMPACT OF ENVIRONMENTAL CONDITIONS 

RESPONSE 
PHASE 

ATTAINABLE 
SPEED 

FLOW 
CHARACTERISTICS 

ROUTE  
USAGE 
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CHAPTER 6: RUNNING SIMULATIONS 
 

6.1 Interactive Simulations 

Users should note that while the software has no in-built restriction concerning the number of 

floors or size of population which can be simulated, there are limits as to the size of problem 

that is practical to run on a given computer. Generally, the larger the geometry - either in terms 

of number of floors or physical size of floors - and the larger the population, the longer it will 

take to load and run the simulation. Chapter 1 of the User Guide provides recommendations 

and guidelines as to the expected runtimes on a variety of computers.  

 

TIP: 

It is strongly recommended that if large structures and/or large populations are to be simulated, 

the PC preferred requirements should be greatly exceeded. 

 

NOTE: 

The fastest way to run a buildingEXODUS simulation interactively is to display all the people 

in Block Shape, maximise the geometry window and ensure the whole geometry can be seen, 

i.e. no zoom. This means that each person will be represented by a square icon which is faster 

to draw than the person silhouette icon.  Running simulations with these options can speed up 

calculations.   

 

When wishing to view evacuation dynamics in close detail, it is more useful to have the Person 

Shape switched on, as this allows the direction of movement to be viewed.  Reducing the 

number of events for exits may further increase the speed of simulations.  Each time such an 

opening or closing event occurs, the potential map may require re-calculation thus slowing the 

simulation. 

 

The level of Zoom at which the geometry is placed also impacts on the speed of simulation.  At 

high zoom levels, i.e. high magnification, a simulation may be slowed significantly.  To ensure 

the maximum speed, ensure the zoom factor allows the whole geometry to be seen in the 

window. 

 

On some occasions, the speed at which the simulation runs may be too fast for the user’s 

requirements. In such cases the user is able to slow down the graphical output of the model 

using the Speed Control option on the Simulation menu in SIMULATION MODE. Once selected 

the user is then able to set the rate of the output speed using the corresponding Rate value.  

 

6.2 Batch-mode Simulations 

When running multiple jobs using the batch mode editor, it is suggested that all of the cases to 

be examined should first be saved as separate files. For example, in the Batch Control dialogue 

box (see Figure 6-2) it is possible to load a specific geometry followed by the required 

population, followed by another geometry etc. A number of files are then combined to produce 

each scenario. It is preferable to save such cases separately i.e. save the population with the 

geometry. This means that only the geometry file needs to be loaded.  This results in a 

performance advantage and experience has shown that it helps when analysing the results 

produced by Batch-Mode. 
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Figure 6-1: Batch Control functionality.  

 

The Batch Mode dialogue box allows the user to approximate the functionality provided in the 

interaction mode. This allows the user to load geometries, populations, scenario/behavioural 

settings, modify population locations, and manage the data output (see Figure 6-1). It is strongly 

recommended that the user checks the conditions produced during the batch simulations (i.e., 

perform spot checks of the simulation in interactive mode, or by examining the movies 

produced during Batch Mode) to ensure that the conditions are reasonable.  

 

NOTE:  

When running simulations in Batch mode, if a randomisation of the population is required it 

must be remembered that this will operate on the whole geometry, or the full set of seat nodes, 

depending on the option selected.  If a randomisation is required in a particular region this 

must be done in interactive mode and saved to a new file for the batch mode to operate on. 

 

 
Figure 6-2: Example Batch Control dialogue box where user-defined and pre-defined 

libraries are used.  

 

As there are numerous options that can be set in the Behavioural model (see Section 6.4) for 

each simulation, rather than require the user to flag numerous options on the Batch Control 

dialogue box, it is possible to load a pre-defined library of settings that completely define the 

settings for the simulation (see Figure 6-2). These libraries may be drawn from those provided 
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with buildingEXODUS (e.g. the Circulation, Default, Drill or Evacuation libraries) or be 

previously defined by the user.  In this manner, relatively detailed libraries can be designed by 

the user and re-used in a number of situations. This should also reduce the potential for 

omissions and increase the consistency between simulation conditions. 

 

 
Figure 6-3: The selection of a user-defined library within Batch mode. 

 

NOTE: 

The user also now has access to the SFE script file functionality that extends the Batch Mode 

capabilities. The reader is referred to the User Guide, Appendix F for further details. 

 

6.3 Behaviour Options and the Use of Option Libraries 

Due to the sophisticated nature of the buildingEXODUS behavioural model, it is possible to 

represent a variety of scenarios reflecting the severity of the conditions, the information levels 

of the evacuees involved and the nature of the evacuee response. Given that the user has the 

ability to control the exact behavioural scheme applied within a simulation, it is advised that 

the user should always declare the assumptions and behavioural options used. This 

transparency in the simulation process will reduce potential difficulties in the repetition of the 

simulation conditions as well as any ambiguity in the behavioural basis of the simulation.  These 

details are provided for the user in the output file if selected via the PARAM button on the DATA 

OUTPUT CONTROL dialogue box.  

 

Given the number of options available to the user, this process may take some time. To assist 

in the process and reduce the time necessary, the user is able to save these settings and apply 

them to any subsequent simulation. Numerous model options have been gathered together to 

provide a simple and consistent interface for the user. In this manner it is felt that the user is 

less likely to overlook relevant options when constructing the simulation. For instance, the user 

may be attempting to represent the behaviour of evacuees during a minor incident (e.g. a Drill). 

Under these circumstances the evacuees might be expected to evacuate in a relatively subdued 

manner. Reflecting these assumptions, the user might then select: 

 

 Normal behaviour, 
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 No hazard model,  

 Instant response. 

 

Alternatively the user may attempt to represent what they consider to be optimal evacuation 

conditions under a deteriorating environment. This may involve using the following options: 

 

 Extreme Behaviour, 

 Hazard Model, 

 Staggering enabled, 

 Instant Response. 

  

Given that the user conducts numerous examinations involving different structures, these 

scenarios may be re-used, ensuring a reliable (and reusable) definition of optimal, circulatory, 

etc. conditions. Therefore through importing these options into a simulation the user may 

maintain a level of consistency throughout their work.  

 

NOTE: 

The Behaviour Option Library can also be used in Batch Mode (see Section 6.2). 

 

To assist in the design of a scenario the options have been grouped together. This not only 

reduces the number of actions required by the user, but will also reduce the likelihood of 

oversights and omissions due to the more logical nature of the dialogue box construction. 

 

In complicated scenarios, the exact definition of these controls will have taken some thought 

and time to construct. To prevent the user having to continually input these settings the user is 

able to store these settings (and the Hazard and File option settings) into an output file. Once 

the user has completed setting all of the options the Option Libraries flag should be selected 

from the RuleBase menu. This provides the user with a dialogue box so that the details can be 

saved in an .ESO file (Exodus Setting Options).  

 

It is advised that where a number of the behavioural options are used simultaneously, that the 

user examines the outcome of the simulation closely before running the model in Batch Mode. 

This is important as the interaction of the behavioural options is complex and may not always 

produce intuitive results (especially to a new user). 

 

6.4 Behavioural Options 

The Behavioural Options refer to those options that impact upon the occupant’s decision-

making process. These include Extreme Behaviour, Specified Response, Seat Jumping, Stair 

Packing and the Impatient option. Each of these options may affect the outcome of the 

evacuation for each occupant.  

 

For instance, a Specified Response of 0 seconds is particularly useful once a diverse population 

has been generated and the user is interested in the population’s immediate response, without 

necessarily having to substitute 0 for all of the individual Response Times. Also, the Impatient 

flag is useful if the user wishes to guarantee the occupant’s ability to become Extreme during 

an evacuation.  
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It should be remembered that these options will affect both the manner and ability of occupants 

to evacuate. The user should understand the impact of these options prior to their selection and 

if possible should justify their choices. 

 

Furthermore a number of options that control the occupant’s response to the environment are 

available from this dialogue box, the ability of the evacuee to crawl, the individual’s ability to 

stagger when engulfed in smoke and the evacuee’s ability to redirect in response to a smoke-

filled environment. 

 

Again, whenever these options are enabled/disabled the user should record this and make it 

clear on presenting any results. The options chosen will also be reproduced in the output file 

for each simulation. (The user may enable this by selecting the Data Output Options from the 

RuleBase menu). 
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CHAPTER 7: PRODUCING RESULTS/OUTPUT 
 

buildingEXODUS is able to produce a range of different results. These can be configured by 

the user to suit the needs of the application. The results can be produced in following formats: 

Textual – Raw data are produced by EXODUS.  This data is then used directly, or analysed 

using third-party software (such as MS Excel). 

 

Key Uses – Fundamental representation of high-level and low-level results, e.g., 

evacuation times, individual congestion 

Method – Extracted from SIM file(s) manually, using askEXODUS or using third party 

software. 

 

Figures – The user may export graphs produced within EXODUS (e.g., via screen-grabs), or 

reproduce the results generated using the data directly interpreted through third party software, 

or indirectly once the results produced have been first manipulated in some way. Data can be 

produced specifically for the generation of graphs, or the user can produce their own customised 

graphs. 

Key Use – visual representation of results, development of simulated conditions, 

demonstration of relationships between variables. 

Method – Extracted from screen, or derived from SIM file. 

 

Graphical – Stills of the simulated conditions can be produced by grabbing the conditions 

shown on the screen. 

Key Use – support description of simulated conditions with graphical evidence (e.g., 

presence of congestion around an exit). 

Method – Images directly from screen. 

 

Movies / Animations – Movies of the simulated conditions can be produced allowing a 

reproduction of the simulated conditions to be reviewed. These can be produced in EMX and 

RUX formats. 

Key Use – support description of the evolving conditions. For instance, the build up of 

congestion at an exit. 

Method – Representation of evolving conditions grabbed from screen using third party 

software, or dedicated movies produced using EXODUS movie facility. 

 

VR animations – The vrEXODUS post-processor software allows the simulated results to be 

represented in a virtual reality environment. 

Key Use – support description of the evolving conditions. For instance, the build up of 

congestion at an exit. 

Method – Use of vrEXODUS. 

 

Some of the key functionalities used in producing this data are now described. 

  



Chapter 7 – Producing Results/Output 

 

© 2017 University of Greenwich 98 

 

7.1 Data Options 

The user can configure the results that are echoed to the SIM file; i.e., the results that are 

produced by the model. The results can be configured using the Data Output Control dialogue 

box (see Figure 7-1). This allows the user to select the individual static attributes, the 

experiential variables, and the hazard-related attributes that are reported in the SIM file. These 

results can be separated according to the nodal types on which they were experienced (see 

Figure 7-1 (b)).  This is very useful in understanding the experiences of the evacuee as they 

traversed different egress components; e.g., when they were traversing staircases, or corridors. 

 

   
(a) (b) (c) 

Figure 7-1: Data Output Control dialogue box. 

 

As well as data produced from the simulation, some results can be derived from this raw data. 

This includes the ratio of time spent responding, in congestion, and travelling to a place of 

safety. These are particularly useful in diagnosing the key factors that contribute to the overall 

evacuation time. 

 

The user can also manage the data that is specifically generated for producing graphs. This data 

can be produced for exits, zones, or census entities. Graphs can then be produced to reflect the 

developing conditions at those locations (see Figure 7-2(a)). Irrespective of the data produced, 

it is important that the simulated conditions are accurately described and then that this 

description accompanies the data. The user is able to generate the initial conditions (and 

associated assumptions) using the Input Parameter dialogue box (see Figure 7-2(b)). This 

produces information on the population, fire, hazard and behavioural options. This information 

is useful both for the user to understand the initial conditions in a simulation, but also to present 

to a third party in describing the context in which the results were produced. 
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(a) (b) 

Figure 7-2: (a) Graph Control dialogue box; (b) Input Parameter dialogue box. 

 

The data produced in the SIM file represents an overall assessment of the results produced; e.g., 

averages, totals, etc. The model can also produce the evolving attribute levels as they progress 

over time. The user can select the attributes of interest and the time intervals at which they want 

the information produced. Once selected (see Figure 7-3), a trace is produced displaying the 

changing values of the attributes selected. 

 

 
Figure 7-3: Tracer Output Control dialogue box. 

 

7.2 Graphical Options 

The user has the ability to control the appearance of buildingEXODUS during simulations to 

allow the results to be more presentable and more easily understood. Much of this is discussed 

in the User Guide, Chapter 6. Some of the additional functionalities are presented here along 

with the applications that might be of use. 

 

During a simulation, the view is normally fixed. The user is then faced with a window onto the 

same section of the structure until they move the view to somewhere else. The user can now 

follow a specific individual. As the individual moves, so the apparent view changes to keep up 

with them. This is achieved by enabling the Pax Follow option in Simulation Mode (via the 

Simulation Menu). The user selects the evacuee in which they are interested. Then, once the 
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evacuee responds, the view frame moves to ensure that the evacuee is in view at all times. This 

is useful in demonstrating the route adopted by an individual during an evacuation and the 

conditions that they experienced. The changing view point is evident in Figure 7-4. The views 

shown are those apparent in the EXODUS window. The change between the two views is due 

to the model updating the view as opposed to the user moving the view manually. 

 

 
Figure 7-4: EXODUS Viewpoints changes as individual moves. 

 

Through the manipulation of the DISPLAY CONTROL dialogue box, depicted in Figure 7-5, 

the user is able to configure the appearance of (and which objects may be selected) within the 

simulation. This is particularly useful during the presentation of complex simulations. Here, the 

geometry may include numerous terrain types (stairs, seats, census regions, etc).   
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Figure 7-5: Display Control dialogue box. 

 

Some of these terrain types may have a physical impact upon the outcome of the simulation, 

whereas others may be imported into the simulation to gather additional information for the 

user. Irrespective of this, for presentation purposes, the user may prefer to demonstrate the 

population evacuating through a relatively uncluttered structure (in Boundary mode, for 

instance), concentrating upon the individual movement, rather than examining all of the terrain 

types across which the individual passes (see Figure 7-6). 

 

 
Figure 7-6:The evacuee behaviour is not affected by the display options. On the left, the 

seats are clearly visible, whereas on the right the visibility of the seats has been disabled. 

 

It is also apparent that the individual’s behaviour is not affected by the Display Options selected 

by the user from Figure 7-5. The paths adopted by the evacuees are identical, irrespective of 

whether the Seat nodes are visible or not visible.  
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7.3 Analysis Options 

The user has the ability to control the appearance of evacuees during a simulation according 

either to the performance of particular behavioural actions or in response to environmental 

conditions (see Figure 7-7).  

 

 
Figure 7-7: Selecting Analysis Options in Simulation Mode. 

 

This enables the behaviour of the evacuee to be put into context with their surroundings and 

simplifies the identity of the performance of specific behavioural actions. For example, in 

Figure 7-8 evacuees experiencing Extreme behaviour can be clearly identified. 

 

 
Figure 7-8: Note the change in the evacuee colour as evacuees become EXTREME 

(pictured as the dark squares, appears red on the buildingEXODUS screen) 

 

Alternatively, the user may be interested in viewing where the individuals are acquiring high 

FED doses or where extensive congestion occurs, forcing individuals to become Extreme. This 

may then assist the user in determining and demonstrating problem areas within a geometry and 

also demonstrate the effectiveness of potential remedies. 

 

By allowing the user control over the representation of the evacuee, the user is able to engineer 

the graphical output to suit their requirements and their interests. 

 

7.3.1 Contour Options 

The Contour options available to the user (in concert with the visual options) allow a more 

detailed analysis of the evacuation.  Each of the options available provides a better 

understanding of the evacuee response. For instance: 
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Contour Type Information Potential Use 

Potential 
Demonstrates the flow of the 

potential throughout the geometry 

Examine possible evacuee movement and 

assists in spotting anomalies in the Potential 

Map 

Population 

Density 

Demonstrates the number of evacuees 

in relation to nodal connectivity. 
Identifies bottlenecks and areas of high density 

Smoke 
Demonstrates the extinction 

coefficient at a particular location. 

Identifies areas of danger and assists in placing 

evacuee’s behaviour in context. 

Temperature 
Demonstrates the temperature at a 

particular location. 

Identifies areas of danger and assists in placing 

evacuee’s behaviour in context. 

FootFall 

Demonstrates the number of 

individuals that have passed across a 

location during the entire simulation 

Determine areas whose alteration may 

significantly affect the outcome of the 

simulation 

Potential Route 

Map 

Displays the direction of the flow of 

the Potential Map 
Spot errors in the potential map 

Dist. Route Map Demonstrates the shortest route from 

any given location to the currently 

selected target 

Examine possible evacuee movement 

Congestion Demonstrates the areas of significant 

congestion that occurred throughout 

the entire simulation 

Identifies bottle necks and areas of persistent 

high density 

 

It should be noted that with any of the Contour options enabled, there is a slow-down in the 

performance of the model, simply due to the additional graphical output required. It is 

recommended that the user only enables the Smoke or Temperature Contour function to clarify 

particular events rather than maintaining this type of graphical output constantly. This should 

minimise the impact that this function will have upon the run time. 

 

NOTE: 

The constant use of the Smoke or Temperature Contour function during a simulation may 

severely slow the execution of the simulation.  It is strongly recommended that use of the Smoke 

or Temperature Contour function only be used for demonstration purposes or for clarification 

purposes.  

 

The Smoke and Temperature Contours have an additional feature whereby instead of the nodes 

within the smoke and temperature zones being displayed, the zones themselves are displayed. 

This produces a much higher quality image of the zones, possibly more suitable for the 

presentation of results, but may (although not necessarily) reduce the playback speed. 

 

7.4 askEXODUS  

The askEXODUS tool has been developed to aid in the extraction of data from multiple output 

files (i.e. .SIM) and in the preparation of data into spreadsheet packages.  The askEXODUS 

data extraction tool enables the user to select the data required and then extract the data from 

the simulation files specified (see Figure 7-9). In this manner, the laborious task of extracting 

data from individual files can be avoided allowing the data to be gathered consistently and 

simultaneously. The use of this tool is recommended as it minimises the possibility of user error 

and reduces the user work-load. The user is referred to the askEXODUS User Guide for further 

details and instruction in its use. 
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Figure 7-9: The askEXODUS data analysis tool. 
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CHAPTER 8: INTERPRETING RESULTS 
 

8.1 Overview 

This chapter presents a set of guidelines to assist the user in the responsible application of 

buildingEXODUS and makes further suggestions as to how to interpret the results produced by 

buildingEXODUS and reliably present them.  

 

The main theme in this chapter is that a single run of buildingEXODUS does not provide 

sufficient grounds upon which to base firm conclusions concerning the evacuation efficiency 

of the enclosure. Rather, it is essential to perform parametric studies before any conclusions 

can be made. This generally involves repeated runs of the model with changes to the key model 

parameters in order to identify key trends in evacuation behaviour. While repeated runs are 

necessary, short run times enable the safety engineer to investigate many different scenarios 

quickly and efficiently. 

 

The need to perform repeated simulations should come as no surprise as even under the most 

controlled experimental conditions, no evacuation exercise involving crowds of real people will 

produce identical results if the exercise is repeated - even if the same people are used. Hence it 

is unwise to make definitive statements such as “the evacuation time for the structure will be 

187.7 seconds” on the basis of a simple one off analysis - be it experimental or numerical. For 

any structure/population/environment combination, the evacuation performance is likely to 

follow some form of distribution as indicated in Figure 8-1. Any one observation of evacuation 

performance could fall anywhere on the curve. The differences in the results produced can be 

due to internal, stochastic factors (e.g., the use of random number generators to produce 

different decisions), simulation factors (low-level evacuee decisions producing different 

interactions), and/or user actions (e.g., the randomisation/manipulation of evacuee starting 

positions). 

 

 
Figure 8-1: Hypothetical distribution of the total evacuation time for a given 

structure/population/environment combination 
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KEY POINT:  

ONE DATA-POINT IS NOT SUFFICIENT 

 

However, what can be achieved is an understanding of how the structure/population/ 

environment system is likely to behave given a set of pre-defined conditions. Hence, for a given 

configuration and specific type of scenario, it is possible to determine a range of evacuation 

performance likely to be achieved. This should then produce a representative distribution of 

results. 

 

Furthermore, it is possible to identify likely problem areas and suggest improvements in 

structure design and evacuation procedures which will overcome the identified problem areas.  

This is achieved by studying the nature of the predicted evacuation dynamics.  This is somewhat 

dependent on the nature of the intended application and the manner in which the scenario has 

been specified (e.g. whether a deteriorating environment is represented, which evacuation 

procedure is modelled, etc.). It should be remembered that buildingEXODUS is capable of 

producing a large variety of outputs, not simply the total evacuation time. For instance, 

buildingEXODUS may be used to reveal, the location of bottlenecks, exit delay characteristics, 

exit start times, exit finish times, exiting history, flow through internal exits (e.g. linking a room 

to a corridor or another room), which exits are likely to be used, which exits are heavily used, 

if there is sufficient exit capacity in certain locations, etc. These will be reflected in simulated 

(or derived) results; for instance, the time to respond, the time spent in congestion, route 

loading, the time spent travelling, etc. Just as a single simulation is not enough to draw 

conclusions confidently, a single scenario will not provide a reliable understanding of the 

robustness of the safety levels associated with a structure, a procedure or any scenario factor 

associated with safety performance.  

 

The graduated approach (i.e., the gradual manipulation of key parameters to produce new 

scenarios), should always be based on the representation of credible real world conditions. In 

effect, the graduated approach should represent the translation of real world factors into a 

simulated environment; i.e., into the buildingEXODUS model. This process should help focus 

the production of simulated scenarios and also guide the explanation of the underlying scenario 

conditions. Ideally, it should be possible for a third party to trace the simulation assumptions 

back to real world factors. This approach can also help limit the large number of permutations 

that can be produced given the number of variables identified. Just as credible and relevant 

parameters should be examined, the manner in which these are combined should represent 

either credible scenarios, bounding scenarios, or scenarios of specific interest. These scenarios 

should be justified and explained. This should help limit the number of scenarios examined to 

a manageable number and reduce the level of ambiguity over the basis of their examination. 

 

NOTE: 

By simply focusing on the total evacuation time it is possible to overlook an important - perhaps 

undesirable - feature of the evacuation dynamics. Also, by only focusing on the total evacuation 

time it is also possible to miss the underlying causes that produced this evacuation time. 
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KEY POINT:  

Total Evacuation Time is only one indicator and provides no explanation of the underlying 

causes. A range of other statistics are available including data on individual performance (e.g., 

CWT, Distance Travelled, etc.), and the proportion of time spent performing key egress 

activities (e.g., queuing, moving, responding). 

 

KEY POINT:  

There is no single scenario that can alone provide a reliable indication of the safety 

performance of a structure, a population or a procedure. 

 

8.2 Graduated Approach to Performing Simulations 

When faced with the analysis of a complex evacuation scenario it is essential to develop an 

understanding of how each of the components contributes to the overall evacuation dynamics. 

It is suggested that a graduated and systematic approach be adopted in the analysis of such 

problems. Here, each pass through the problem introduces an additional level of complexity or 

the manipulation of a represented factor.  It may also be necessary to review and alter some of 

the pre-set default values.  In reality, it may not be possible to examine all of the factors 

identified. These factors should then be prioritised according to the significance of their impact 

and their relevance to the project at hand. This will likely be an iterative process involving 

simulated results, expertise and experience. 

 

8.2.1 Component Considerations 

 

8.2.1.1 Geometric Considerations 

When simulating evacuations from structures that contain many complex internal structures it 

is advisable to perform several simulations with increasing degrees of complexity. Internal 

structures can include a range of different egress components that can be configured to affect 

attainable speeds, route selection, occupiable space, and flow characteristics. These include 

exits, obstacles, stairs, etc. For instance, the first simulations should be performed without any 

of the obstructions present, the next set of simulations should include the obstructions, and the 

next set should include the use of obstacle nodes. In this way the relevant importance of these 

factors can be assessed.  

 

If the user is interested in observing the impact of using different types of exit then the relevant 

data for each of the types of exit should be included and then the scenarios should be varied as 

described in the previous paragraph for each exit type. If this is not done, and the exit systems 

are only examined under only certain circumstances, then the potential 

advantages/disadvantages identified for each exit system could then only be anticipated with 

any confidence in those specific circumstances rather than in a general sense. 

 

8.2.1.2 Behavioural Considerations 

In Simulation mode numerous behavioural options are available. It is advisable to repeat 

simulations with these options on/off in order to gauge their relevance to the scenario under 

consideration and their impact on the results produced. The user should always clearly define 

the behavioural options enabled prior to the description or analysis of results.  
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The accuracy and appropriateness of the data-sets implemented within the behavioural model 

should not be taken for granted. They are provided to give the user a basis for representing 

evacuee behaviour. It should never be assumed that through the implementation of a 

behavioural data-set that the model will automatically be able to accurately predict the specific 

response of an individual. What can be represented is the impact upon the overall simulation 

times of the performance of a given behaviour by a proportion of the population. This impact 

can be established by providing a distribution of results ranging from when the individuals do 

not perform a particular behavioural action to when a proportion (or all) of the population 

perform the action. Conclusions can then be drawn from the results concerning the significance 

of the behaviour upon the outcome of the simulation.  

 

The evacuee behaviour can be influenced by the setting of behavioural switches that influence 

both short-term and long-term behavioural decisions (i.e., how people behave during a 

particular evacuation scenario), and the application of different evacuation procedures that 

determine more fundamentally the long-term decisions adopted (i.e., the nature of the procedure 

employed to a particular fire scenario). The combination of the behavioural switches and the 

evacuation procedure adopted should be made with care, as although, ideally, every 

combination should be examined, in reality, some of the combinations would make no sense. 

 

In the most basic engineering terms, there are only a finite number of key components that 

influence evacuee movement; i.e., the movement towards a position of safety. These 

components listed below exclude many behavioural, environmental, and structural 

considerations. As such, these four components should be considered the basic elements of an 

engineering analysis that address evacuee movement to a place of safety. In reality many other 

factors may also be addressed. The four movement components are: 

(1) the time that it takes people to initiate response;  

(2) the attainable speed of movement;  

(3) the congestion/flow characteristics that limit this performance; and  

(4) and the egress routes used during movement.  

 

It is recognised that in reality these four components are related. It is also apparent that (3) is 

an emergency component produced by the other three components; however, these four 

components can be represented, to different degrees of sophistication, in any attempt at 

examining egress performance – from hand-based calculations to sophisticated computational 

tools such as buildingEXODUS. The manipulation of these four components allows a basic set 

of scenarios to be generated. Part of the challenge of the engineering process is translating real 

world factors into movement (or more broadly behavioural) components that can be represented 

within the simulated environment; i.e., producing credible scenarios that can be examined using 

buildingEXODUS. This requires these four components to take on different settings which, 

when combined, produce different scenarios (as described in [149]. Alternative values for the 

components include  
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(1) Response time 

Instantaneous response – population is assumed to respond immediately and 

simultaneously. Useful for bounding the scenario conditions and typically contributing to 

the congestion levels produced. 

Estimated current response – the response times are expected from the current 

procedural/behavioural conditions, informed by the most appropriate data available. 

Affected response – alternative responses based on environmental, behavioural, procedural 

conditions specific to the scenario being examined. 

Modified response – expected response times given procedural modifications; e.g., new 

notification system, new staff activities, etc. 

(2) Travel speeds 

Typical population – travel speeds associated with general unimpeded population. 

Sub-populations of Interest – travel speeds including those with impairments, encumbrance 

issues, etc. 

Modified – travel speeds include scenario-specific considerations, such as the presence of 

deteriorating environmental conditions, procedural requirements, etc. 

(3) Flow characteristics 

Flow constraints imposed – the achievable flow rates at key bottlenecks/structural 

constraints/narrowings/exits limited according to the data available or according to 

regulatory/client instructions. 

Free flow/Predicted conditions – flow rates are generated by the model. 

(4) Egress routes employed  

Use shortest routes – the population is assumed to use the nearest exit available. 

Use routes according to regulation– the population is assumed to use the exits based on 

regulatory assumptions. 

Use routes according to design – the routes are used according to the intended design 

capacity.  

Use routes according to familiarity – routes are used according to routine use of the 

building.  

Use routes according to conditions – the routes usage is influenced by the presence of 

deteriorating environmental conditions, structural damage, etc. 

Use routes according to procedure – evacuees are assumed to follow instruction, or act 

according to their training.  

 

These are only suggested component values. They are purely provided to help inform the 

production of credible scenarios for engineering analysis and are certainly not a complete set 

of component values that would necessarily encompass any engineering analysis. They are 

instead a set of general component values that might be considered and that would produce a 

broad range of scenario conditions. 

 

8.2.1.3 Fire Atmospheres (software level C only) 

Simulations involving individuals passing through fire atmospheres should first be run with 

each separate component of the fire atmosphere, i.e. smoke, heat and toxic gases. Some 

iterations will be required here to determine which of the fire scenarios and behavioural 

responses lead to the evacuees interacting with the fire effluent. A base case should also be run 

in which all the fire hazards are deactivated. This will enable the relevant contribution of each 

component on the overall evacuation to be assessed. This contribution (i.e., the impact that it 

has upon evacuee performance), can be physiological (influencing well-being), physical 

(influencing travel speed), and behavioural (influencing response and route selection).  
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Furthermore, several choices are available as to the exact formulation of FED model to use (see 

the Theory Manual). Users have the choice of using the Purser or Speitel formulation of the 

heat equation and two choices regarding the formulation of the VCO2 component. These 

choices may produce very different outcomes in the number of casualties sustained in an 

evacuation. For a given set of fire conditions, the Speitel formulation of the heat component 

with the VCO2 parameter in the CO equation set to 1 will generate the minimum number of 

casualties. The Purser formulation of the heat equation will generate the maximum number of 

casualties. 

 

When using external data files generated by the CFAST/SMARTFIRE model, the user should 

describe the assumptions on which the original CFAST/SMARTFIRE model was generated. 

This may not necessarily extend to including all of the details provided to the 

CFAST/SMARTFIRE model, but should include a general comparison between the geometry 

/hazard as represented in the CFAST/SMARTFIRE model, in the buildingEXODUS model and 

in reality. In addition, the original assumptions concerning the fire (initial size, speed of growth, 

etc.) should be detailed and the basis for these assumptions. This process will both clarify the 

results and prevent the occurrence of misunderstandings. 

 

KEY POINT:  

Modifying the underlying variable produces new scenarios, therefore widening the envelope of 

conditions examined.  

 

8.2.2 Repeated Simulations 

 

8.2.2.1 Re-running a simulation 

Due to the stochastic nature of the decision process employed in buildingEXODUS, re-runs of 

a particular scenario will not necessarily produce identical results. When simulations are 

repeated in this way, differences in the overall results are usually small - typically several 

seconds. However, significant differences for individuals involved in the simulation may occur. 

For instance, a person may be the 45th person out in the first run and 60th person out in the 

second run. It is thus advisable to repeat the simulation several times to ensure that significant 

differences do not occur and that there is consistency in the observed major trends. 

 

8.2.2.2 Changing start locations 

The outcome of a simulation may be dependent on the start locations of the population. For 

example, two particularly slow individuals may initially be placed in a crucial location creating 

an initial bottleneck situation. This situation may bias the outcome of the simulation. To remove 

this source of potential bias, re-run the simulation several times using the Randomise function 

(or the Swap Locations function). The Randomise function changes the start location of each 

individual, while the Swap Locations function rotates the location of individuals whilst 

maintaining the same occupied nodes.   

 

KEY POINT:  

It is impossible it know exactly where an entire population will start during an evacuation. By 

varying these positions, the sensitivity of the results produced can be established. 
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8.2.3 Varying the Scenario 

As mentioned, it is unlikely that one evacuation scenario will cover all the possible 

contingencies likely to be encountered. It is therefore suggested that a range of scenarios be run 

in which the population characteristics, exit performance, evacuation scenario and fire 

atmosphere are varied. 

 

8.2.3.1 Population variations 

It is advisable to test the sensitivity of the numerical predictions to variations in the key 

population specification parameters. The key parameters that should be checked are the overall 

number of people in the population, starting location, movement rates and response times. In 

simulations involving obstacles that can be traversed by agile evacuees, it may be necessary to 

test the suitability of the agility/obstacle parameter settings.  

 

In situations where the Local Familiarity system or the Occupant Itinerary List is used 

particular care should be taken in the repetition of simulations. In simulations where individuals 

have had their exit knowledge manually defined by the user, their knowledge will not fluctuate 

between simulations. This should be taken into consideration when examining the results. If 

individuals are attributed with itinerary lists, then the impact of this performance upon the rest 

of the population should be examined, i.e. some simulations should be conducted with the 

individuals performing their tasks while others should omit the performance of these tasks.  

 

Where pre-defined procedures have been implemented then cases should be re-run as the delays 

experienced by individuals during the simulation will vary between each run. This may be 

significant depending upon the nature of the scenario. 

 

Finally, simulations involving fire atmospheres (software level C only) require the setting of 

the personal incapacitation dose attribute PID and the respiratory minute volume (see the 

Theory Manual). As described in the Theory Manual, these parameters are dependent on a 

number of personal considerations and the default values used by buildingEXODUS may not 

be appropriate for all applications.  The precise value of these attributes will affect the total 

number of fatalities and when an evacuee becomes incapacitated.  

 

It should be remembered that within a particular scenario a wide variety of people may be 

exposed to the fire hazards with a corresponding wide range of sensitivities to the toxic fire 

hazards.   

 

Within the general population there are a number of sub-populations that require special 

consideration when considering the impact of toxic fire hazards. These notably include the 

elderly – particularly those with cardiovascular complaints; the very young – due to the greater 

volume of air inhaled per minute relative to their body weight; the asthmatic population – within 

the general population some estimates suggest that approximately 5% of adults and 15% of 

children are asthmatic; and sufferers of other lung conditions such as chronic bronchitis [52].  

 

8.2.3.2 Exit variations 

A key parameter that can alter the overall evacuation performance is the exit potential (this will 

only affect the outcome of the simulation if the Potential Map system is used). It is suggested 

that as a first simulation, the exit potential of all external exits be set to identical values (100 is 

the default). This will treat all exits equally, resulting in occupants travelling towards their 

nearest serviceable exit. This type of simulation can represent the base case. Subsequent 
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simulations can be performed with biased potentials making some exits more or less attractive. 

This should reflect the fact that some exits will be more popular than others, as the occupants 

are more familiar with a particular exit. Biased exits could also reflect the fact that staff (fire 

wardens) are directing occupants towards a particular exit. 

 

If the Local Familiarity system is used, the Attractiveness of the exits will influence the overall 

evacuation performance. It is suggested that initially all of the exits are familiar to the occupants 

(i.e. each exit has an Attractiveness of 100%), enabling the occupants to travel to their nearest 

serviceable exit. Subsequent simulations can be performed with different levels of 

Attractiveness making some exits more or less likely to be familiar to the occupant population. 

These changes can be made in conjunction with the Exit Usage, which will also impact upon 

the selection of familiar exits as viable egress alternatives according to the behavioural regime 

used. 

 

In situations where the impact of exit availability (i.e. opening/closing times) is an important 

issue, these parameters should be varied and its importance on the overall evacuation assessed. 

Finally, the size and location of exits are two parameters that can be assessed for their relevant 

importance to evacuation efficiency. 

 

8.2.3.3 Internal Exits 

The introduction of an explicit representation of Internal Exits, enables a degree of flexibility 

of the simulation of movement through internal openings. The user is able to manipulate the 

Flow Rate applied to the Internal Exit, the Potential bias attached, the Availability and the 

Direction of the flow through the exit.  All of these factors may impact upon the movement of 

the population throughout the geometry. If applied, the nature of the Internal Exit should be 

detailed, as well as the basis for their design. Again the influence of these factors can be 

established by varying the attributes of the Internal Exits. 

 

8.2.3.4 Fire Atmospheres (software level C only) 

When specifying fire atmospheres it is preferable to base the spread rates on data generated 

from experimental test fires or mathematical zone/field models, or to import external data files 

directly from the CFAST/SMARTFIRE model. If this type of information is not available, the 

built in functions can be used to specify arbitrary fire growth scenarios. When using these in-

built functions, it is advisable to repeat the simulation several times with varying degrees of fire 

severity. Where possible fire severity should be bracketed between slow and fast fire growth 

rates. 

 

KEY POINT:  

It is important to look at a range of scenarios in order to produce a robust and credible set of 

solutions. 

 

8.3 Interpretation of Results 

The total evacuation time for a simulation, while being a useful statistic, does not convey the 

entire story concerning the simulation. Considerable insight can be gained by viewing the 

simulation as this reveals details concerning congestion zones and bottlenecks. In a number of 

situations the overall evacuation time may not even be of interest to the user.  Furthermore, 

analysis of the numerical and graphical data produced by buildingEXODUS can reveal many 

vital issues that may become lost in a simple statistic such as the total evacuation time. In 
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addition to the standard evacuation statistics produced by buildingEXODUS, other useful 

measures can be derived from this raw data (e.g., the number of fatalities). 

 

8.3.1 Additional Parameters. 

On completion of a buildingEXODUS simulation, a number of (user-) selected parameters can 

be echoed to a data file for later investigation. These include travel distance, cumulative wait 

time, travel time, FIN, etc. These statistics are produced for each individual. It is often useful 

to determine average statistics for the simulation such as average travel distance, average wait 

time, average travel time, average FIN for survivors, etc. 

 

8.3.2 Flow graphs and flow rate graphs 

buildingEXODUS will automatically produce graphs depicting the number of people who have 

evacuated as a function of time for each exit. It is also possible to output data concerning the 

flow rate achieved through each exit. This data can be a very useful aid in understanding the 

outcome of a particular evacuation. Similar data can also be collected from internal exits and 

census regions. This data allows a comprehensive understanding of the performance of both 

structural and procedural aspects of the structure. 

 

8.3.3 Inherent Assumptions in the Toxicity Model (software level C only) 

While the FED models used in buildingEXODUS reflect current accepted practise, these 

models are far from perfect. The equations used in the FED model are based on a number of 

different data sources, including laboratory animal experiments to fire fatality studies. The 

equations used in the FED models are based on regression analysis of this type of data.   

 

As mentioned  in the Theory Manual, the precise FED formulation used can lead to quite 

different predicted outcomes.  A subtler problem concerns the assumptions inherent in these 

models. Implicit in the application of the FED model is the assumption that the work load of 

the exposed individual remains constant throughout the exposure. This is because, with the 

exception of the CO equation, the RMV (Respiratory Minute Volume) does not explicitly appear 

in any of the expressions.  As RMV values may vary from about 10 l/min at rest to in excess of 

50 l/min while involved in heavy work, this is expected to have a pronounced impact on the 

dose inhaled and hence the time to incapacitation.  While it may be valid to assume that the 

effort involved in participating in a life threatening evacuation is the equivalent of light to heavy 

activity, this may not be equivalent to the level of activity used in the derivation of the FED 

regression equations. 

 

Furthermore, the majority of animal experimentation upon which the FED analysis is based has 

been directed toward assessment of incapacitation and lethality, rather than to the assessment 

of evacuation efficiency. In addition, this laboratory experimentation has been based on 

uniformly young and healthy animals [52].  The nature of the actual distribution of human 

responses to the toxic fire gases is not known for certain. Only for CO has some insight been 

gained from blood COHb data as it relates to a large number of fatalities [52]. 

 

A possible deficiency in both heat exposure models (Purser and Speitel) concerns the exclusion 

of the thermal effects due to humid rather than dry air. Recent research suggests that the 

concentration of water vapour in the atmosphere of compartments subjected to large scale fires 

can reach levels of 17 %. The incapacitating effects of air with a high water vapour content are 

more severe than dry air as it reduces heat loss through sweat and delivers more heat to exposed 



Chapter 8 – Interpreting Results 

 

© 2017 University of Greenwich 115 

skin.  Because of the relatively short exposures typically encountered in evacuation situations, 

this effect may not be of great significance.  However, due to its higher heat capacity, inhaled 

hot air with a high water vapour content can cause more severe damage to the respiratory tract 

than dry air at the same temperature, this effect may be of greater significance in evacuation 

scenarios. 

 

Finally, the effect of the irritant fire gases on the escape capabilities of individuals has now 

been included in the toxicity models. These gases include HCL, HF, HBr, SO2, and NO2 

amongst some estimated twenty others [23-26,52].  These gases cause sensory irritation to the 

eyes, nose, throat and lungs ranging from mild irritation to severe pain. As the degree of 

irritancy increases the evacuees escape abilities are degraded.  As with the effects of smoke 

concentration these effects are considered to be proportional to the concentration of exposure 

rather than the accumulated dose. 

 

8.4 Presenting Results 

Evacuation analysis is often presented to a third party for scrutiny as part of the performance-

based design process and as part of other analytical/engineering activities (e.g., procedural 

design, forensic analysis, research, etc.). In the performance-based design process, evacuation 

(egress) analysis is used to provide an estimate of the RSET component – the required safe 

egress time; this is then typically compared against the ASET component – the available safe 

egress time (providing a fire is modelled or the conditions are assumed). This RSET analysis is 

typically achieved through the use of engineering calculations or computational tools, such as 

the buildingEXODUS model. The ASET analysis is performed in a similar manner using 

engineering calculations, zone models (such as CFAST) and/or fire field models (such as 

SMARTFIRE). In this process one group of people perform the analysis, while another group 

judges the approach adopted, the tools used and the results produced. For this judgment to be 

fair, accurate and credible, the third parties need to have a comprehensive and detailed 

understanding of the key elements involved in the analysis – in the assessment of the evacuation 

performance. This understanding (and the information that needs to be presented to promote it) 

is not trivial and should not be taken for granted. Given this, there is the potential for analysis 

to be accepted or rejected on an incomplete, partial, or inaccurate understanding of the subject 

matter, the tools used and the factors that should be considered. To properly assess the analysis, 

it is critical that third parties have as complete a description of the results and methods employed 

as possible. Without a complete description, the results presented may be misunderstood or 

deemed to be less credible than they actually are. 

 

There are a number of different regulatory guides on the information that should be included 

when presenting egress analysis. These come from a range of different application areas (e.g., 

IMO [150], SFPE [151], etc.[152]). These guides have been examined to establish a baseline 

for the information that should be reported when describing the use of an evacuation tool: when 

using buildingEXODUS. This baseline is described below. The order of the sections presented 

is only a suggestion. In addition, sections may well be combined, and other additional sections 

included, according to the nature of the project and the emphasis of the results presented. 

However, if whole subject sections are omitted completely, some explanation from the authors 

is required.  
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1:Nature/Scope of project 

A basic description of the purpose of the project and the subject matter involved. 

2:Participants / Stakeholders/Interested Parties  

The target audience of the results and their influence over the format/content of the results. 

3:Engineer’s/User’s capabilities  

Background of those performing the analysis - contributing to the credibility of the results 

produced and the conclusions drawn. 

4:Goals and Objectives 

A description of the results, conclusions and recommendations to be produced. 

5:Methodology/Tools Employed  

A description of the capabilities/limitations of the tools being employed. 

6:Nature of the Problem  

A description of the specific, real world egress-related issues that are to be examined. 

7:Performance Measures   

A description of the real world parameters that are of particular interest and which can be 

quantified. These measures may be informed by the stakeholders, specified by regulatory 

requirements or derived from other performance criterion. 

8:Design Measures  

A description of the model variables used to represent the real world parameters of interest, 

which should include a discussion of the relationship between real world parameters, the 

quantified performance measures and the design measures in the form of model variables. 

9:Design Scenarios  

A description of the response scenarios to be represented, how these were arrived at, the 

underlying assumptions and what real-world situations the design scenarios represent. 

10:Design Assumptions  

A description of how the design scenarios are implemented within the model; i.e., the 

geometrical, population, procedural, environmental, and behavioural assumptions 

employed within the model and the parameters settings selected to reflect these assumptions. 

11:Simulated Results  

Presentation of the simulated conditions produced during the design scenarios in terms of 

the design measures; i.e., the simulated conditions are described and supported by the 

design measures produced. These may be in the form of numerical, textual, graphical and/or 

animated evidence. 

12:Derived Conclusions  

A translation from the design measures (i.e., the outcome of the design scenarios as 

represented by the simulated results) to the performance measures (i.e., real world 

conditions). This should include a description of the credibility and strength of the 

conclusions drawn. 

13:Recommendations 

Real world implications derived from the performance measures. These recommendations 

should be prioritised according to their credibility of the underlying conclusions and the 

significance of their impact. 

 

 

Two examples are now presented to demonstrate the array of results that can be produced when 

using the buildingEXODUS model, the scenarios that can be examined, the information 

required to describe these scenarios and the manner in which the results can be presented. 
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KEY POINT:  

It is critical to provide a third party with sufficient information to judge the results 

appropriately. If the results are not presented in sufficient details or are not presented in 

context, then a third party may misinterpret the conditions being simulated and the 

consequences of the results produced. 

 

8.5 Results Example(1): Analysis of an Evacuation Performed Using buildingEXODUS 

In this section we will consider the analysis [1] of an evacuation from a hypothetical 

supermarket/restaurant configuration (see Figure 8-2). This represents a general analysis that 

could be performed in response to a number of different engineering questions.  

 

8.5.1 Structure 

The overall dimensions are 50m x 40m, with the restaurant area measuring 20m x 20m. 

Included in the restaurant is a rest-room facility.  The geometry has four external exits, all of 

which are located in the supermarket section.  The only access to the restaurant is via three 

internal entrances from the supermarket floor. 

 

 
Figure 8-2: The hypothetical supermarket/restaurant geometry 

 

The UFR for all the external exits was set using the “user defined” option. Each exit had the 

same range of values that varied from a minimum of 1.11 occupants/m/sec, to a maximum of 

1.43 occupants/m/sec (producing an average value of 1.27 occupants/m/sec).  The internal exits 

were set to free-flow conditions. 

 

The widths of the four exits are, Main exit 4m (maximum flow rate 5.77 occupants/s, minimum 

flow rate 4.44 occupants/s, average flow rate 5.08 occupants/s), Bottom emergency exit 3m 

(maximum flow rate 4.29 occupants/s, minimum flow rate 3.33 occupants/s, average flow rate 

3.81 occupants/s), Top and Right Hand Side (RHS) emergency exit 2m each (maximum flow 

rate 2.86 occupants/s, minimum flow rate 2.22 occupants/s, average flow rate 2.54 occupants/s).  

The refined estimate of the maximum travel distance for this geometry was identified by 



Chapter 8 – Interpreting Results 

 

© 2017 University of Greenwich 118 

buildingEXODUS as 27.5m, the exit used being the Top emergency exit, with the starting point 

located towards the top left side of the supermarket between the wall and the first row of 

shelves. 

 

8.5.2 Population 

In England & Wales, the maximum legal number of occupants in a supermarket is dependent 

on the available floor space.  For the restaurant area, the number of seats available dictates the 

number of occupants.  The supermarket floor has a free area of 1523.5 m2 allowing a maximum 

of 761 occupants (maximum legal density is 2m2/person). The restaurant has 147 seats, thus 

giving a maximum total population (including staff and evacuees) as 908 occupants.  

Simulations were performed using 908 and a smaller population of 508 occupants representing 

a 4m2/person density on the supermarket floor.  
 

Occupants on the shop floor are assumed to be unhindered by shopping trolleys, the assumption 

being that as the goods have not been purchased they will be more readily abandoned.  In these 

simulations, the abandoned trolleys do not feature. Occupants who have completed their pass 

through the tills at the start of the evacuation are given a hindered travel speed to reflect reduced 

travel capability resulting from being encumbered with their purchased items. The security 

procedures in place are assumed not to affect the results produced. 

 

Three population mixes were used, populations A, B and C as outlined in Table 8-1.  Population 

A comprised of people with an instantaneous response time and all had an identical maximum 

travel speed of 1.5 m/s. This is considered to be representative of the resident population.  

 

Table 8-1: Population parameters used in the building simulations 

 (sec)  (m/s)

 

Population B comprised of people with an instantaneous response time but with an arbitrary 

range of travel speeds. The population was divided into three classes, fast movers - with 

maximum travel speeds of between 1.0 and 1.5 m/s, slow movers - with maximum travel speeds 

of between 0.6 and 0.9 m/s and hindered travel speeds of between 0.7 and 1.0 m/s (see Table 

8-2). 
 

Table 8-2: Speed Distributions used in 

populations B and C 

 Table 8-3: Response time 

Distributions used in population  

C 

Category % of popn Speed Range 

(m/s)

 Location Range of Response  

Times (sec)

Fast

Slow

Hindered 5

 

Population C comprised of people with a range of response times and travel speeds. Occupants 

response times varied according to location (see Table 8-3), in the supermarket between 0 and 

60 seconds, in the restaurant between 40 and 90 seconds while those in the rest-rooms between 

90 and 120 seconds.  The travel speeds were distributed in an identical manner to population 

B. In populations B and C, 65% of the occupants were in the fast movers group and where a 
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distribution is indicated, the attribute was allocated by a uniform random process. The 

populations described in Table 8-3 are located in the schematic shown in Figure 8-3. 

 

NOTE:  

Evacuees are assumed not to be in groups; i.e., evacuate as individuals.  
 

 
Figure 8-3: Schematic of initial population distribution. 

 

8.5.3 The Scenarios 

A total of nine scenarios were considered (see Table 8-4).  Scenarios 1 - 6 used 508 or 908 

occupants in each population mix. In these simulations the occupants initially travel towards 

their nearest exit. The remaining scenarios involved 908 occupants. In scenarios 7 and 8 the 

main and bottom exits are deemed to be biased in order to attract more occupants (reflecting 

them being more familiar to the evacuating population); furthermore a 30 second opening delay 

is imposed on the RHS exit in scenario 8 and in scenario 9 the effect of increasing the size of 

the RHS and TOP exits by 1m is examined. 

 

Table 8-4: Scenario description 
SCE Pop 

Pop Size Response Speed Dist 

 

508

1.5

0 0.6-1.5

0-120 0.6-1.5

 

 

908

0 1.5

0 0.6-1.5

0-120 0.6-1.5

0 0.6-1.5

0 0.6-1.5

0 0.6-1.5
 

8.5.4 Results and Discussion 

Figure 8-4 depicts the initial distribution for an instant response scenario with 908 occupants - 

note the random allocation of positions. 
 

 

[0,60] 

[40,90] 

[90,120] 
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Figure 8-4: Example of an initial occupant distribution for a population consisting of 

908 occupants 
 

Figure 8-5 depicts the same simulation some time into the simulation.  It is clear that in 

situations involving an instant response, considerable crowding at the exits occurs from an early 

stage in the evacuation.  Several other points of congestion are also of interest - the internal 

exits from the restaurant and main exit vestibule area, and the entrance to the tills. 
 

 
Figure 8-5: Example queuing after 6 seconds of an instant response scenario involving 

908 occupants 
 

Table 8-5 presents the simulation results in terms of averages and overall evacuation times.  In 

most cases it is essential to consider not simply the raw data presented in this table but also to 

examine flow-rate/evacuation curves. 
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Table 8-5: Result summary for the nine EXODUS simulations 
SCE Pop TET (s) Avg TET (s) Avg Resp (s) Avg CWT (s) 

Avg Dist (m) 

 

The buildingEXODUS estimate for the evacuation time (obtained using a simplistic 

formulation where the maximum path calculation is performed and exit use is assumed to be 

balanced) for scenarios (SCE) 1 and 4, are 55 seconds for the small population and 84 seconds 

for the large population. The manner in which this time was spent by the evacuating population 

(derived from Table 8-5) is shown in Figure 8-6. The underlying differences in the conditions 

produced during these scenarios become more apparent. For instance, the importance of the 

response phase is much more pronounced in Scenarios 3 and 6, while congestion was much 

more prominent in Scenario 4 where people responded immediately and travelled at a uniform 

speed. 
 

 
Figure 8-6: Time spent by the evacuating population in travelling, in congestion or 

responding. 
 

From Table 8-5 we see that buildingEXODUS has exceeded the TET produced by the simplistic 

formulation by 25% for the small population (68 seconds as opposed to 55 seconds) and 55% 

for the large population (133 seconds as opposed to 84 seconds).  The reason for this is quite 

straightforward.  Implicit in the simplistic formulation is the assumption that the building 

occupants are optimally distributed between the exits and that each exit operates at its maximum 

flow capacity, until the building is emptied. 
 

This is unlikely to be the case in reality and it is not the case in the buildingEXODUS 

simulations. In both cases the maximum flow rate for the combined exits (13.25 

occupants/second) is achieved only momentarily (see Figure 8-7).  An examination of the 

evacuation rates for the individual exits (see Figure 8-8) reveals that while the two smaller exits 

attain maximum flow conditions for the majority of their operation the two larger exits (MAIN 

and BOTTOM) peak for only a short period of time. This is probably due to the restricted direct 

access to these exits causing the sporadic arrival of agents.  It is noteworthy that the main exit 
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dried up after 30 seconds for the small population and 60 seconds for the large, suggesting that 

the building occupants are not optimally distributed between the exits. 
 

 
Figure 8-7: Overall flow rates predicted by EXODUS for 508 occupants in (Scenario) 

SCE 1, SCE 2 and SCE 3 

 

From Figure 8-7 it is apparent that while (Scenario) SCE 1 and SCE 2 produce fairly similar 

flow profiles, SCE 3 is quite different.  In SCE 1 and SCE 2 the occupants react immediately 

to the call to evacuate. However, in SCE 1 all occupants have a constant maximum travel speed 

of 1.5 m/s while in SCE 2 they have a distribution of travel speeds.  It is therefore unsurprising 

that SCE 1 was completed in a shorter period of time than SCE 2 as the occupants will arrive 

at the exits sooner on average.  Furthermore, and, as maybe expected due to the influence of 

the response times, the average TET increases from SCE 1 to SCE 3.  

 

  
(a) (b) 

Figure 8-8: Individual exit flow rates for (a) SCE 1 and (b) SCE 4 

 

It is also interesting to note that the average wait time (avg CWT) - the time spent stationary as 

a result of conflicts or queuing - is lower in SCE 2 than SCE 1.  This is indicative of a smaller 

amount of occupant-occupant interaction in SCE 2.  This should come as no surprise, as in SCE 

1 all occupants have identical travel speeds, more occupants will arrive at the exits at about the 

same time. This generates greater crowding and hence more occupant-occupant interactions 

occur than in SCE 2. 
 

The inclusion of a distribution of response times in SCE 3 has an enormous impact on the 

outcome of the simulation. As can be seen in Figure 8-7 the overall evacuation flow rate fails 
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to attain its peak value throughout the simulation.  Examination of the individual exit flow-rates 

for this simulation reveal that maximum flow-rate is never achieved for any exit and the flow-

rate varies wildly (see Figure 8-9).   Again this is an expected result as the staggered start times 

result in staggered arrival times at the various exits.  We also note that the average CWT for 

SCE 3 is less than that found in SCE 1 and SCE 2.  Again this is to be expected as the staggered 

start times result in less chance of conflicts occurring. The extended tail in SCE 3 is due to the 

late start of the occupants in the restaurant and the extremely long response time of the 

individuals in the rest-room.  
 

 
Figure 8-9: Individual exit flow rates for SCE 3 

 

The next three simulations involved repeating the first three scenarios with a higher population 

density (see Figure 8-10).  While the trends for the small and large populations with instant 

response times appear similar, there is a marked difference when response times are included. 
 

In moving to a larger population it is perhaps natural to assume that the evacuation times will 

increase as the population size increases. We note from Table 8-5 that for the instant response 

simulations, the increase in average TET when moving from 508 to 908 occupants is 

approximately 16 seconds in both cases.  However, when examining the case where response 

times are included, the increase on average TET is only 3 seconds.  This unexpected result may 

be explained by close examination of the evacuation dynamics in each of these simulations. 

 

If we examine the average CWT values for the large population we note that they are 

considerably larger than the corresponding small population values.  This is to be expected as 

larger populations will result in greater occupant-occupant interaction and hence more chance 

of conflict.  Furthermore, as the degree of staggering increases (i.e. distributed travel speeds 

and response times), the average CWT decreases as there is less chance of conflict.   
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Figure 8-10: Overall flow rates predicted by EXODUS for 908 occupants in SCE 4, SCE 

5 and SCE 6 
 

Figure 8-10 and Figure 8-11 demonstrate the effects of increasing the occupant density for 

populations B (see Figure 8-11) and C (see Figure 8-12). In the instant response simulations 

(see Figure 8-11), occupants reach the exits quickly and maximum flow conditions are rapidly 

attained at each exit, regardless of the population size.  The time that the exits spend at 

maximum flow is dependent upon the number of occupants available to use each exit, thus 

when a larger population is used the exits can maintain maximum working capacity for longer.  

However, in both the large and small population cases, the population dispersal results in the 

MAIN and BOTTOM exits drying up well before the smaller exits, leaving the smaller exits to 

cope with the crowds. In both these simulations we thus move from an initial situation in which 

the exit capacity is ample to cope with the crowds to a situation where it is not.  The situation 

is considerably worse in the large population case and results in the larger population taking 

longer to exit. 
 

 
Figure 8-11: Overall flow rates predicted by EXODUS when increasing the population 

size from 508 to 908 occupants (population B) 
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When response times are included (see Figure 8-12) the TET and average TET for the larger 

population is only marginally greater than that for the small population. Furthermore, the 

overall flow rates never attain maximal values and the flow rates attained for the large 

population are always larger than those observed for the smaller population.  
 

For the small population the individual exits never attain maximal flow conditions.  This is 

particularly true for the two larger exits that fail to attain even 50% of their flow capacity.  Thus 

in this case we find that there is always an over-supply of exit capacity and that the response 

time dictates the overall evacuation time.  In this situation additional occupants could be added 

to the simulation without causing a large increase in the overall TET. 
 

 
Figure 8-12: Overall flow rates predicted by EXODUS when increasing the population 

size from 508 to 908 occupants (population C) 
 

The situation is very different for the large population. Here we find that the two smaller exits 

attain near maximal flow conditions for a large proportion of the time and the larger two exits 

are in heavy demand though never reach peak capacity (see Figure 8-13).  In this case we find 

that exit capacity is limiting the evacuation performance.  
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Figure 8-13: Individual exit flow rates predicted by EXODUS for SCE 6 (908 occupants, 

population C) 
 

To demonstrate this difference between the two cases, the simulations were repeated with the 

smaller exits reduced from a width of 2m to 1.5m.  This resulted in a small increase in TET and 

average TET for the small population (0.5% and 7% respectively) and a much larger increase 

for the large population (16.9% and 39.5% respectively). 
 

SCE 7 concerned the use of biased exits. This facility is intended to be used in situations where 

occupants may be more familiar with a particular exit route.  By biasing an exit we increase the 

likelihood that occupants will select the biased exit in preference to other, perhaps closer but 

less familiar exits.  In this simulation the MAIN, BOTTOM and the internal restaurant exit by 

the BOTTOM exit were biased in order to attract more occupants. 
 

 
Figure 8-14: Overall flow rates predicted by EXODUS in SCE 7 and SCE 5 
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In SCE 7 we find that the MAIN exit usage has increased from 22% to 39% of the occupants 

and the BOTTOM exit has increased from 22% to 25%.  This has the effect of maintaining 

higher overall flow rates for longer (see Figure 8-14) as the main and bottom exits have a higher 

flow capacity than the smaller exits.  The average travel distance has increased from 21.1m to 

23m reflecting the fact that occupants have not used their nearest exit and the average CWT has 

decreased from 12.1 seconds to 9 seconds, reflecting the fact that there is less congestion at the 

TOP and RHS exits.  Furthermore, as the MAIN and BOTTOM exits are being used more 

effectively and the queues at the TOP and RHS exits have decreased, the TET has decreased 

from 116 seconds to 98 seconds. 
 

In all the evacuation scenarios demonstrated thus far, it has been assumed that all the exits have 

been opened at the start of the evacuation and that all the occupants are aware of the existence 

of the exits.  In the next simulation (SCE 8), an opening delay time is introduced into the 

operation of one of the exits.  Furthermore, the exits in SCE 8 are biased in an identical manner 

to SCE 7.  
 

The particular scenario selected is one in which the opening of the RHS exit is delayed by 30 

seconds and the occupants are not aware of its existence for this period of time.  Hence 

occupants will not move towards this exit during this period.  When the exit becomes available 

it will then attract occupants.  buildingEXODUS is also capable of simulating the situation in 

which while the exit is not operational, queuing will occur by the exit.  This capability is 

intended to simulate the situation where occupants are aware that an exit exists, but there is 

difficulty in opening the exit. 

 

 
Figure 8-15: Overall flow rates predicted by EXODUS in SCE 7 and SCE 8 

 

With the RHS exit delayed we find that the TET for SCE 8 increases from 98 seconds (SCE 7) 

to 112 seconds (see Figure 8-15) and the average distance travelled increases from 23m to 

28.7m.  The increase in travel distance reflects the fact that some occupants have travelled to a 

further exit while others have initially moved away from the RHS exit and then back towards 

it as they became aware that it was functioning.  We also note from Figure 8-15 that the peak 

in the overall flow rate for SCE 8 is maintained for a longer period of time than for SCE 7, but 

that the level achieved is somewhat lower.   
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The final simulation (SCE 9) considers the effect of increasing exit widths and hence overall 

flow capacity.  For this case, the scenario in SCE 5 (908 occupants, distributed travel speeds, 

instant response times) was repeated with the width of the TOP and RHS exits increased from 

2m to 3m. With the exits’ width increased, we find that the TET is reduced from 116 seconds 

in SCE 5 to 90 seconds in SCE 9.  Associated with this is a reduction in the average CWT from 

12.1 to 8.7 seconds.  In SCE 5, the TOP and RHS exits were working at full capacity and were 

the last exits to finish.  It is therefore the capabilities of these exits that are limiting the overall 

flow rate.  This can be improved by either forcing occupants to use the under-utilised MAIN 

and BOTTOM exits, or increasing the flow capacity and hence size of the TOP and RHS exits.  

The latter course of action was taken in SCE 9, reducing the overall evacuation time (see Figure 

8-16). 
 

 
Figure 8-16: Overall flow rates predicted by EXODUS in SCE 5 and SCE 9 

 

8.6 Results Example (2): Examination of Procedural Change Using buildingEXODUS 

A second example is now presented. This example requires the examination of several ‘real-

world’ engineering questions:  

 How long will it take the space to be evacuated given the use of the current tonal alarm? 

 What conditions emerge during this evacuation?  

 How long will it take the space to be evacuated given the use of a voice alarm? 

 Does the introduction of a new notification system improve performance? If so, what is 

the nature of this improvement? 

These questions need to be translated into scenarios simulated within the model. This is 

achieved using the guidance presented earlier in this chapter. 

 

The following description represents the basic information that would need to be provided to 

the client by the engineer in support of their analysis. Excluded from this information is a 

detailed description of the model itself, which can be found in both the Theory Manual and 

User Guide. This description should normally accompany the presentation of any results. 

 

8.6.1 Real World Considerations 

The structure in question is a rectangular single-storey library facility. The university facility 

includes a general reading area, classrooms, computer facilities, and high-density seating. 



Chapter 8 – Interpreting Results 

 

© 2017 University of Greenwich 129 

Concerns have led safety managers to consider implementing a new voice notification system 

supported by staff. Currently, the structure has a tonal alarm with a well-manned, although 

disorganized, staff response. 

 

The structure is relatively compartmentalized, with eight perimeter exits (see Figure 8-17). Four 

of these exits are in routine use: Exits 1, 3, 4 and 6. Of these, Exit 3 is considered to be the main 

exit, with the majority of occupants choosing to also enter via this exit. Exits 2, 5, 7 and 8 are 

only used during emergency egress. The engineers are not able to make structural changes as 

part of this analysis. 

 

 
Figure 8-17: Structure of interest with exit locations marked. 

 

At peak hours, the structure is occupied by 475 individuals who are distributed throughout the 

structure. This population is broadly representative of the general office population including a 

sub-population of those with impaired movement capabilities. The occupancy levels will not 

change as a result of this analysis. 

 

Fortunately, the safety managers observed the performance of the occupants during an 

unannounced drill; specifically, safety managers observed the time taken for the occupant 

population to respond and a representative sample was collected (see Figure 8-18). This 

provided an indicator as to the effectiveness of the current procedure; i.e., how quickly the tonal 

alarm and staff effected an evacuation. It is apparent that the occupant population responded 

within approximately 3 ½ minutes (see dashed line in Figure 8-18). 
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Figure 8-18: Response time data collected from unannounced drill. 

 

It was noted that only Exits 1, 3, 4 and 6 are routinely used. Of these Exit 3 is used most 

frequently to enter the structure. Exit 4 is only accessible from a small room within the building.  

 

Modelling Considerations 

The geometry is constructed from a CAD diagram provided by the client. This is then used to 

bound the nodal network produced using the Node Flood facility. This was then edited to 

include the theatre facility located in the northern section of the structure (see Figure 8-19). 

This facility was introduced after the original diagrams were produced. Therefore the engineer 

was required to modify the nodal mesh produced. 

 

 
Figure 8-19: Dense seating of the theatre area in room adjacent to exit. 

 

The theatre is formed from 30 seats packed into a small room. These seats do not allow free 

passing and have restricted access at the end of each row. This is then taken into account by 

reducing the connectivity of the seats between and within rows, and to the surrounding free 

space. 

 

The perimeter exits were measured as being 1.0m, 1.5m or 2.0m in width once the impact of 

effective width considerations is accounted for. The exit configuration is constant throughout 

this analysis. To be conservative, and in line with regulatory guidance, a flow rate of 1.33 

occ/m/s is assumed through these perimeter exits. The internal exits consist of automatic sliding 

doors that open as individuals approach and then close behind them as they pass. These are 

designed to limit noise throughout the structure, but also aid in mobility access. During the 
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observation of the unannounced drill it was noted that these do not impinge on the free 

movement of the population. Therefore, the internal exits are modelled as open spaces. The 

flow is then limited by the width of the exit, rather than an imposed flow rate. 

 

The population is produced using the Population Panel facility. The default panels are 

employed to represent a general office population. A population of 475 is then distributed 

throughout the space. Once generated, a sub-population of 47 people is manually selected 

(using the Rubber Band Select facility, selected from the Edit menu and Select sub-menu in 

Population Mode) and then their Mobility attributes replaced according to a Mobility range of 

0.4 – 1.0 approximating the data produced by Shields et al.[32]. This is achieved by using the 

Substitute Range facility (from the Edit menu and Substitute sub-menu in Population Mode), 

applied to the selected 47 people. The entire population of 475 is then selected, excluding those 

that are initially located in the seated area. This is achieved by selecting an area; then depressing 

the CTRL key and selecting another area. By doing this, the entire structure excluding the 

seating area can be selected using three overlapping rectangles. This is performed to ensure 

those with mobility restrictions are not initially located in the seated area, as there are access 

limitations to this room. Once completed, the Swap Locations facility is applied (from the Edit 

menu and Relocate sub-menu in Population Mode), in order to distribute those with a mobility 

impairment around the selected areas of the structure. 

 

The size of the population is a constant during this analysis. Three different response time 

distributions are considered: immediate; observed; and expected. An immediate (i.e., zero) 

response is employed in order to bound the analysis and produce the maximum level of 

congestion possible. The observed response time distribution is produced by implementing the 

response times collected from the unannounced drill. The expected response time distribution 

is implemented to reflect the potential benefits to the response time of implementing procedural 

improvements; e.g., guidance on the existence and location of exits. The implementation of 

these three response time distributions is now discussed. 

 

The immediate response time distribution is represented by selecting the Specified Response 

option in Behavioural Options dialogue box in Simulation mode and setting this to zero.  This 

overrides any Response Times associated to members of the population. This is denoted by ‘I’ 

in the scenario description in the results section.  

 

The observed response distribution is represented through the use of the Distribution Curves 

facility (selected from the Tools menu in Population Mode). The frequency distribution of the 

data collected during the drill is simplified and then embedded using the Distribution Editor. 

The curve is broken down into 30 second sections representing key changes to the response 

curve. The implemented response curve can be compared to that representing the original data 

(compare the graph schematic in Figure 8-21 with the dashed line in Figure 8-18).  
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Figure 8-20: Global application of response curves to occupant population. 

 

This distribution is associated to the population panels prior to the generation of the 475 people 

(see Figure 8-21). This is denoted by ‘O’ in the scenario description of the results section. 

 

 
Figure 8-21: Implementation of the response time distribution using the Distribution 

Editor. 

 

No dedicated data was available regarding the expected performance of a voice alarm within 

the structure. Therefore, data had to be sought out from elsewhere and applied. A representative 

data-set was found that described the response of a student population to the implementation of 

a voice alarm. This case (see Gwynne [135]) was deemed sufficiently similar to allow the data 

to be implemented without modification. This data indicated that the population can be expected 

to respond between 20 and 90 seconds to the voice alarm. This data was included by selecting 

the entire population in Population Mode, and using the Substitute Range facility (available 

from the Tools menu and the Substitute sub-menu). This is denoted by ‘E’ in the scenario 

description of the results section. 

 

NOTE:  

Although in reality these scenarios can be conducted and produced in any order, it may be most 

convenient to produce the response curves first and save the file. This can then easily be 

modified to implement the immediate and substituted response times. 
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Three different procedural responses are assumed: use of nearest exit; use according to 

familiarity; use according to procedure. The use of the nearest exit, in this case, approximates 

the design loading of the exits and can be considered an efficient use of the exits available. This 

is implemented using the default Potential Map and Potential attribute settings. All of the exits 

are available during this procedure.  This is denoted by ‘N’ in the scenario description of the 

results section. 

 

Only Exits 1,3,4 and 6 are used when the exits are used according to familiarity. Exit 3 is, in 

reality, used most frequently. Guidance was provided on the expected number of people using 

each exit. The model was then configured to reflect these numbers. This was achieved using 

the Local Familiarity system. The Attractiveness of each of the four exits was modified to 

reflect their use. These values were adjusted as part of an iterative process in order to 

approximate the desired use. Eventually, Exits 3 and 4 were assigned an Attractiveness of 100; 

Exit 1 had an Attractiveness of 30; while Exit 6 had an Attractiveness of 20. Although not 

considered a main exit, Exit 4 could only be accessed by a small number of people who were 

forced to exit through it; therefore, the Attractiveness of 100 is slightly misleading. The other 

exits are not available in this scenario. This is denoted by ‘F’ in the scenario description of the 

results section. 

 

The final exit use scenario is deemed to represent the improvement in exit use produced through 

the information provided by the voice notification system. This was observed from comparable 

scenarios/drills and then employed here [135]. In this case, all of the exits are deemed available. 

However, the use of the exits is deemed to be still influenced by the normal use of the structure, 

even though staff and the alarm system are guiding the population. Therefore, the main exit 

(Exit 3) and the associated small exit (Exit 4) are assumed to be familiar to everyone; Exits 3 

and 4 are deemed to be familiar to 50% of the population; the other exits are deemed to be 

familiar to 20% of the population. In this manner, the information provided is assumed to have 

some effect, but that this effect is imperfect. This scenario is denoted by ‘P’ in the scenario 

description of the results section. 

 

In order to produce representative results, eight simulations were conducted for each of the 

scenarios produced by the response/procedure combinations. These include two relocations 

within the space (using the Randomise feature) and two relocations while maintaining the same 

distribution (using the Swap Location feature). Special care had to be shown when randomising 

those located in the seating area, as this was not considered wheelchair accessible; i.e., that not 

all of the population would, in reality, be able to sit here. Therefore, to ensure that the population 

was ‘reasonably’ distributed, the Swap Seat Location feature was employed (see Figure 8-22). 

 

 
Figure 8-22: Swap Locations on Seats. 

 

The results produced were configured using the Data Output Control feature from the Rulebase 

menu in Simulation Mode.  
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Figure 8-23: Configured Data Output Control dialogue box. 

 

These options were selected in order to provide a general overview of the results produced and 

also some explanation of the underlying causes (see Figure 8-23). 

 

Results Produced 

The results associated with each combination of response/procedure are shown in Table 8-6. 

The scenario names are formed from the response condition [I, O, or E] followed by the 

procedural response [N, F, or P]. The average values are shown for each of the result categories. 

 

Table 8-6:  Master Results. %R, %C and %T is the percentage of time spent 

responding, in congestion and travelling respectively.  

Scenario Avg.Resp 

Time 

(sec) 

Avg 

TET 

(sec) 

Avg 

CWT 

(sec) 

Avg Dist 

(m) 

Avg 

PET 

(sec) 

%R %C %T 

I_N 0 72 10 20 28 0 31 69 

O_N 74 217 1 17 89 78 1 21 

E_N 57 110 1 18 73 76 1 23 

I_F 0 178 33 53 76 0 35 65 

O_F 74 253 11 48 123 59 8 34 

E_F 57 230 24 53 75 50 15 35 

I_P 0 108 11 39 42 0 23 77 

O_P 74 253 1 36 104 68 1 31 

E_P 57 169 4 37 91 64 4 32 

 

The impact of the different factors can be isolated on average across the scenarios in which they 

are active; for instance, when occupants chose to use their nearest exit – I_N, O_N, and E_N. 

This is only an indicator, given the variation in the scenarios examined; however, it does 

provide a usable estimate of the impact of the factors examined. As expected, the scenarios 

involving an immediate response produce the shortest overall evacuation times (ranging from 

72 to 178 seconds), and the highest level of congestion (ranging from 23 to 35% of the 

evacuee’s time). The impact of the two sets of factors (response times and exit use) can be seen 

in Table 8-7 and Table 8-8. It is apparent that the slight improvement of the exit use reduces 

the evacuation times over those produced through familiar use of the exits by 19%. This is due 

both to a reduction in congestion experienced and the distances traversed. This suggests that 
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the encouragement of people to use the exits more efficiently, albeit in an imperfect manner, 

improves the outcome, given the response time distributions examined. 

 

The immediate response of the population is not realistic; however, these scenarios, which are 

completed in approximately two minutes given the various exit uses, produce the highest levels 

of congestion: 18 seconds per person. Therefore, there are consequences for having people all 

respond immediately: increased congestion potentially leading to issues of comfort and safety.  

 

Employing the observed response times produced an average total evacuation time of just over 

four minutes. The evacuation time was reduced to just under three minutes when the expected 

response times were applied: a 29% improvement. This suggests that the reduction of the 

response times associated with the tonal alarm provides some benefit, given the different 

procedures examined. 

 

Table 8-7: Impact of Exit Use 

Factor 

Avg 

TET 

(sec) 

Avg 

CWT 

(sec) 

Avg 

Dist 

(m) 

Avg 

PET 

(sec) 

N 133.0 4.0 18.3 63.3 

F 220.3 22.7 51.3 91.3 

P 176.7 5.3 37.3 79.0 

 

Table 8-8: Impact of Response Times distributions. 

Factor 

Avg 

TET 

(sec) 

Avg 

CWT 

(sec) 

Avg 

Dist 

(m) 

Avg 

PET 

(sec) 

I 119.3 18.0 37.3 48.7 

O 241.0 4.3 33.7 105.3 

E 169.7 9.7 36.0 79.7 

 

Two critical scenarios can be compared. The current situation (i.e., the expected performance 

given the use of the tonal alarm system and current procedure), is represented in Scenario O_F. 

This is based on the assumption that in the current procedure, the occupant population will 

respond according to observed data-set and use the exits according to their familiarity. This 

scenario produces an evacuation time of 253 seconds (4 ¼ minutes). This time is primarily due 

to the time spent by the occupant population responding to the call to evacuate, representing 

nearly 60% of an evacuee’s time. 

 

The predicted improvement is shown in Scenario E_P. Here is assumed that the introduction of 

the voice notification reduces the response time (comparable with observations made 

elsewhere), and produces a slight improvement in the use of the exits available. This produces 

an overall evacuation time of 169 seconds – a 33% improvement on the current situation. There 

is also a slight reduction in the congestion experienced by the evacuating population: down 

from 8% of their time in Scenario O_F, to 4% in Scenario E_P. This is primarily due to the 

more efficient use of the exits. It should also be remembered that in Scenario E_P, the range of 

response times is reduced; therefore, we would normally expect an increase in the congestion 

experienced. This is compensated for by the more efficient use of the exits available. 
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The results produced can be further examined. In Table 8-9 the final exit to clear is identified, 

along with the number of people using it and the design load. The maximum level of congestion 

is produced when occupants move immediately and use their nearest exit, overloading the exit 

capacity and prolonging the overall evacuation time. The introduction of response times, even 

when the nearest exit is used, means that the overall evacuation times are not determined by the 

overloading of an exit. 

 

Where people move according to familiarity or according to the new procedure, the main exit 

is used most frequently and used beyond its design capacity. The reduction in congestion 

produced by improving exit use from the familiar to procedure, demonstrates that the 

evacuation times can be improved by better balancing the use of the exits. For instance, the only 

difference between Scenario E_F and Scenario E_P is that the occupant population used the 

exits in a more balanced manner. This reduced the level of congestion from 15% to 4% of the 

evacuating population’s evacuation time.  

 

Table 8-9: Key Exit Results 

Scenario Exit Used 

Last 

Population 

Load 

Design 

Load 

Comment 

I_N Exit 7 75 52 Elevated congestion. Overloaded exit 

produces evacuation time. 

O_N Exit 3 90 104 Exits not overloaded. Results are instead 

more dependent on the increasing 

response times. 
E_N Exit 6 67 81 

I_F Exit 3 352 104 In both the unmanaged and the managed 

response, the main entrance (Exit 3) is 

used the most frequently. 
O_F Exit 3 354 104 

E_F Exit 3 378 104 

I_P Exit 3 220 104 

O_P Exit 3 230 104 

E_P Exit 3 230 104 

 

The different conditions produced during the scenarios can be more clearly seen in Figure 8-24. 

Through the use of the Population Density contour, the different levels of crowding around the 

exits can be clearly seen. During Scenario I_N the immediate movement of the population 

towards their nearest exit produced congestion at the exits themselves. During Scenario E_P 

the more distributed movement of people to different exits lessened this effect, producing less 

red in the Population Density contour; i.e., fewer instances of 4 persons/m2. 
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Scenario I-N Scenario E-P 

Figure 8-24: Congestion seen through the Population Density contour. 

 

This effect can be clearly demonstrated using the Footfall contour, which graphs the routes used 

to reach an exit. In the contour, red represents 4 occ/m2. The population density represented by 

the contour reduces as the contour becomes more blue. 

 

 
Scenario I_N 

Figure 8-25: Route use demonstrated using the Footfall contour. 

 

The evolution of congestion in the evacuation can also be examined. In Figure 8-26 the time 

spent in congestion is plotted against the arrival time. In Scenario I_N the time spent in 

congestion increased as the evacuation progressed due to the build up of congestion at the final 

exits (see Figure 8-24(a)). In Scenario E_P, the impact of congestion was consistently low 

throughout. 

 

 
 

Scenario I_N Scenario E_P 

Figure 8-26: Evolution of congestion conditions seen through the individual times spent 

in congestion. 

 

It is possible to drill further into the data, examining the experience of a representative 

individual. In Figure 8-27 the cumulative congestion experienced by an individual during 

Scenario I_N is shown. It is apparent that as they travelled to the exit they experienced relatively 

little congestion; i.e., during the first 50 seconds. After this point, the congestion experienced 

rapidly increased as they queued at the overloaded exit. This was produced using the Trace 

Control facility available from the Simulation menu in Simulation mode. The CWT flag was 
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enabled and a ten second interval defined. The data for a representative individual was selected, 

providing an indicator of the evolution of the individual’s CWT every ten seconds as the 

simulation progressed. 

 

 
Figure 8-27: Evolution of congestion for an individual during Scenario I_N. 

 

8.7 Reporting Results 

As part of any buildingEXODUS analysis, it is essential that a report be produced that includes 

– along with the results and recommendations, a record of the values for all initial set-up 

parameters, a justification of the rationale for the scenarios being investigated and detailed 

results along with sensitivity analysis.  If, as part of a simulation or scenario, the default values 

are altered, it is vital that these changes are noted and justified in the documentation supporting 

the results.  Finally, it should be possible for anyone reviewing the analysis to reproduce the 

simulations from the supporting documentation.   

 

buildingEXODUS provides several facilities to help the user report sufficiently comprehensive 

and detailed results.  These include the format of the data file that is produced and the 

askEXODUS tool that allows data from several files to be compiled in order to produce more 

robust and representative analysis. 

 

8.7.1 Data File Format 

The data file produced by buildingEXODUS after the simulation is completed is separated into 

several sections. These are designed specifically to provide guidance on the simulated 

conditions and then present the results at the individual, population, egress component and 

structure level. The data presented (and the presence of the sections) can be manipulated by the 

user. Therefore, the user can include/exclude sections as they see fit. However, by including 

the key background information the user is able to ensure that a broad understanding of the 

simulated conditions (and therefore the underlying assumptions) that were present and which 

contributed to the results produced. The key sections available are as follows 

 
Header Information: when and where the simulation was produced and the geometry file 

(EXO/MTA) used. 

Input Parameters: the Population attributes, Fire Scenario, Toxicity Model and RuleBase 

settings and switches selected – the key scenario parameters. 

Results Summary: the number of people evacuated and the overall evacuation time. 
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Individual Occupant Results: the individual attributes listed in order of arrival to a point of 

safety. The attributes included can be reduced by the user according to their needs or the nature 

of the scenario. For instance, the user may choose to exclude the exposure levels to toxins if 

there is no fire in the scenario. 

Egress component performance:  by default this will include the results by external exits 

(including flow rates generated, time that the exit was in use, number of people that used it, 

etc.); however, this may also include other egress components that can produce results, such as 

internal exits, census points, queues and transit nodes. 

Exit efficiency: the OPS (Optimal Performance Statistic) and MNS (Mean Non-Flow Statistic) 

statistics (described in the User Guide, Chapter 6) are provided.  

Route information: if itineraries are used, then the locations visited as part of this are listed 

Graph data: The data used to produce the graphs presented by buildingEXODUS during the 

simulation can be echoed to the data file. These files can then be reproduced in third-party 

software. 
 

These sections provide an indication of the assumptions made and the key results produced for 

a single simulation.  

 

8.7.2 askEXODUS  

askEXODUS is a separate utility supplied with the buildingEXODUS software. It is a post-

processing tool that analyses buildingEXODUS simulation files. Its purpose is to ease the 

analysis of the simulation files produced by buildingEXODUS making it easier to merge and 

compile the data generated by multiple simulation runs. While the detail included in a 

simulation output file allows a broad understanding of the conditions produced in a single 

simulation to be gained, askEXODUS allows a broad understanding to be gained from multiple 

simulation output files produced by multiple runs of the said scenario. 

 

askEXODUS provides two main methods of extracting data from the simulation output files. 

The first allows the user to select specific attributes to be output from all imported simulation 

files and present them in a tabular form ready for statistical analysis or the generation of graphs 

using third party spread sheet applications. The second method is based on a query system that 

allows the user to define specific criteria that should apply during the data extraction process.  

 

The data that the user is able to extract from the simulation output files relates to the simulation 

performance, the population experiences and the performance of flow controlling or monitoring 

devices.  

 

Further information and details of how askEXODUS can aid in the analysis of numerous 

simulation output files is provided in the askEXODUS User Guide. 

 

8.8 Concluding Comments 

buildingEXODUS is a powerful tool which can be used to assist in evaluating the means of 

evacuation from a structure. It can be used to highlight potential problems with a structure and the 

proposed evacuation procedures. It can also be used to suggest improvements to the structure and 

investigate the effectiveness of the proposed modifications. Due to the variability in human 

behaviour, a single run of the model is unlikely to accurately predict the precise outcome of any 

one single evacuation incident. If used correctly, the model is capable of suggesting the range of 

evacuation performance - from optimal to sub-optimal behaviour - for the structure/population/ 

environment system.   
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As the prediction of evacuation performance is not an exact science, buildingEXODUS should 

only be considered an aid to evaluating the evacuation performance of a structure. It is not 

intended as a replacement of accepted good engineering practice, guidelines and judgement. 

Only those experienced in evacuation analysis should make use of the software and only after 

the user manual has been thoroughly studied. All users should pay particular attention to the 

assumptions specified in the software and ensure that none of the conditions or assumptions are 

violated by their application. 

 

Finally, the correct use of buildingEXODUS relies on good engineering judgement when setting 

the parameters, designing the scenarios and interpreting the results generated. 
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9.1 Tutorial 1: A Square Geometry 

In this tutorial we will demonstrate several key features of buildingEXODUS, namely constructing 

a geometry using the interactive tools, specifying a simple population and running a simulation.  

The geometry is kept simple so that the key features are not lost in needlessly complex details.  

 

The geometry to be modelled is a simple square room which is free of obstructions.  Its dimensions 

are 6m x 6m.  The compartment has a single door of width 1.0m placed at the bottom left corner.  

The room is to be occupied by 30 people of random type. 

 

NOTE: 

The user should be aware that in this tutorial and the following tutorials the results generated may 

be dependent upon a number of factors including the attributes of evacuees, the resolution of 

conflicts, etc.  Therefore the values provided may only demonstrate a single instance from what 

might be a distribution of potential results. 

 

9.1.1 Creating the outline of the compartment 

To construct the initial area of the compartment the user must be in GEOMETRY MODE.  This is 

the default starting mode when creating a new geometry. 

 

The first step in creating the square floor area is to create the nodes defining the compartment in the 

Geometry Window.  This is achieved by using the Node tool to create free-space nodes (selected via 

the Generate sub-menu on the Tools menu [Tools>Generate>Node], see Figure 9-1).  The Node 

tool may also be selected via the Node button ,  on the tool bar.  

 

 
Figure 9-1: Selection of Node on the Generate sub-menu. 

 

NOTE: 

By default the node tool creates Free-Space nodes. 
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As the room has dimensions of 6m x 6m a total of 144 free-space nodes (12 x 12) will be created. 

 

NOTE: 

By default each node is calculated as representing a space of 0.5m x 0.5m. 

 

 

 
(a) 

 
(b) 

 
(c) 

Figure 9-2: Creating a square region measuring 6m x 6m consisting of 12 x 12 nodes 

 

First, ensure that the Physical Distance option is enabled. (Go to the Tools menu and check that 

Physical Dist. has a check mark next to it). If it does, continue with the node creation. If it doesn’t, 

click on it before continuing.  

 

The nodes are created, by dragging out a square region on the model window.  After the desired 

region is selected (Figure 9-2(a)) a dialogue box will appear (Figure 9-2(b)) prompting the user to 

enter the number of nodes to create.  A value of 12 for both the X (number of nodes horizontally) 

and Y (number of nodes vertically) direction should be entered.  The nodes are generated, by 

pressing the PACK button (Figure 9-2 (c)).  Please note that a quicker way of performing this task 

is presented in B.1.3. 

 

9.1.2 Connecting the nodes 

The Free-Space nodes that comprise the internal geometry of the square room must now be 

interconnected.  This is achieved through use of the Auto Connect tools, available on the Tools menu 

(see Figure 9-1). 

 

To connect the nodes the user should select from the Tools menu the Auto Connect option and then 

the All item from the sub-menu [Tools>Auto Connect>All].  Since the Physical Distance option is 

enabled (Physical Dist.), when the nodes are connected, the Horizontal and Vertical arcs should be 

0.5m in length and the diagonal arcs 0.707m in length.  The length of an arc can be checked by 

clicking on it. 

 

Figure 9-3 depicts the result of these actions. 
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(a) 

  
(b) 

Figure 9-3:  (a) The Geometry following the Auto Connect All procedure (b) The dialogue 

boxes for a vertical and a diagonal arc within the connected geometry. 

 

9.1.3 An Alternative Approach 

The task presented in B.1.1 and B.1.2 can be completed in a much quicker fashion in the following 

way. First ensure Physical Distance is enabled [Tools>Physical Dist]. Select the Node tool and drag 

a rectangle as described in B.1.1.  When requested for the number of nodes, supply the same values 

but click the CONX button rather than the PACK button. 

 

9.1.4 Adding an External Exit 

To complete the geometry specification for this simple room we must construct an exit node.  The 

External Exit tool will be used to place the exit in the bottom left corner of the room (available via 

[Tools>Generate>External Exit] or through selecting the  button from the toolbar).  To place 

an exit the user should first click on the External Exit tool and then point to the desired location and 

click.  The External Exit icon should now appear in the Geometry Window in the desired location. 

 

Once the exit is positioned in the desired location, it must be connected to the geometry.  This 

connection will be made manually through the use of the Arc tool, available via 

[Tools>Generate>Arc].  It should be noted that the lengths of any arcs connected to exit points are 

automatically set to zero.  As the exit is 1.0m wide it must be connected to two nodes and hence two 

arcs are required.  Figure 9-4 shows the exit being connected to the rest of the room. 

 

NOTE: 

The width of an External Exit is determined by the number of nodes connected to it.   The width 

calculation is then based on the assumption that each node is wide enough to carry a single person. 

 

NOTE: 
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An alternative method of connecting an External Exit is for the user to select the nodes connected 

to the exit and then the exit itself, by holding down the CTRL key, so that all objects are selected 

simultaneously.  Then select [Tools>Auto Connect>Door] and the exit will automatically be fully 

connected to nodes identified.  

 

NOTE: 

Other External Exit parameters are set in SCENARIO mode. 

 

  

(a) (b) 

Figure 9-4: Connecting the door to the geometry. As the door is 1.0m wide it must be 

connected with two nodes: (a) Connecting to the first node, (b) Connecting to the second 

node 

 

9.1.5 Adding a Population  

To specify a population you must be in POPULATION MODE.  This is done by clicking on the  

button from the toolbar.  POPULATION MODE can only be accessed once an external exit has been 

created and connected. 

 

As the geometry of the room is now completed the next step is to define and include the population.  

buildingEXODUS provides various tools for this purpose but in this case we are not particularly 

interested in the specifics of the population so we will use the random population generation tool.  

To create the population the user should select [Tools>Person>Random Generate] from the menu.  

This creates a dialogue box prompting the user to enter the number of people required (Figure 9-5).  

In this case, 30 people will be generated.  Clicking the OK button generates the population (Figure 

9-6). 

 

 
Figure 9-5: Supplying the number of occupants 
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NOTE: 

As a region was not selected, the random generate sequence is free to generate people anywhere 

within the geometry.  If the user first selects an area of the geometry using the button and 

dragging out a selection box, then the population will only be generated within that selected area. 

 

 
Figure 9-6: Room after 30 people are generated 

 

9.1.6 Changing the door parameters 

To specify door parameters you must be in SCENARIO MODE.  This is done by clicking on the  

button from the toolbar.  SCENARIO MODE can only be accessed once at least one person exists 

within the geometry. 

 

To change the door flow parameters the user should double click on the door icon.  This will bring 

up the DOOR dialogue box.  In this example we will set the flow characteristics to those 

recommended by HMSO with a +/- 10% variation.  The degree of variation required (10%) should 

be entered at the “-%” and “+%” edit boxes (see Figure 9-7).  The door Status is set to Open (default 

value) and the door Active is set to Yes (default value).  This implies the door is available for use 

and will attract all the occupants. 

 

 
Figure 9-7: Modifying flow characteristics in the exit dialogue box 
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9.1.7 Determining the Maximum Travel Distance 

While in SCENARIO Mode, the maximum travel distance for the geometry can be determined.  This 

is achieved by first double clicking on the exit door icon to bring up the DOOR dialogue box (Figure 

9-7).  Then by pressing the MAX P button, buildingEXODUS locates the most remote point within 

the room and highlights the maximum distance path to the exit (Figure 9-8).  A second dialogue 

box, called MAX PATH will also appear.  This box contains an estimation of the maximum travel 

distance (see Figure 9-9).  In this case the first estimate for the maximum travel distance is 7.57m.  

Also, an estimation of the evacuation time is given as approximately 31.7 seconds. 

 

The actual maximum travel distance can be calculated using simple trigonometry.  If we consider a 

right angle triangle in which the hypotenuse is the path of maximum travel distance, the hypotenuse 

would extend from the top left corner to the centre of the door.  Thus if we take the opposite side of 

the triangle to be 6m and the adjacent side to be 5.5m, this produces a maximum travel distance of 

8.14m. 

 

The first estimate for the maximum travel distance can generally be improved if the REFINE button 

is pressed on the MAX PATH dialogue box. 

 

NOTE: 

The Refine command is only available when the boundary view is active. 

 

  
Figure 9-8: Displaying the maximum path Figure 9-9: Displaying an estimate for the 

maximum travel distance and an estimated 

evacuation time 

 

To obtain the refined estimation of the maximum travel distance switch to Boundary View by 

selecting [View>Boundary] from the menu.  Open the Door dialogue box and select MAX P button 

to reveal the MAX PATH dialogue box.  The maximum path is now displayed as a dotted line (Figure 

9-10).  Now select the REFINE command to reveal another dialogue box (Figure 9-11), showing 

the length of the refined travel distance which for this case is 7.96m, producing an error of 2.2%.  

The refined maximum path is also drawn on the geometry, this time as a continuous line (Figure 

9-10).  After this dialogue is closed the maximum travel distance value will be updated with the 

refined Figure 9-12).  Also a new estimation of the evacuation time will be calculated and it will 

update the current estimated evacuation time.  
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Figure 9-10: The Max P function in 

boundary view 

Figure 9-11: The refined maximum path 

calculation 

 

 
Figure 9-12: The updated maximum path and total evacuation time estimations 

 

9.1.8 Running the simulation 

To run the simulation you must be in SIMULATION MODE.  This is done by clicking on the  

button from the toolbar.  Switch the geometry to Boundary View if it is not already enabled. 

 

It is possible to save simulation data to an output file (default is set to Save).  The type of data to 

saved is set via the Data Output Control Dialogue box, opened by selecting [Rulebase>Data Output 

Options] from the menu.  In this example, select the following information for each passenger: Age, 

Agility, Drive, Gender, Patience, Response, Fast walk (Attributes tab), CWT, Distance and PET 

(Variables tab).  Figure 9-13 shows the DATA OUTPUT CONTROL dialogue box with these 

parameters selected. 
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(a) Attributes Tab (b) Variables Tab (c) Hazards Tab 

Figure 9-13: Configuring output data in the Data Output Control dialogue box 

 

This completes the process of setting the parameters required to run a simulation and save the 

resulting data.  The simulation is started by pressing the PLAY button  on the toolbar (see Figure 

9-14).  The passengers will start moving towards the exit and interact with each other.  This 

interaction can be viewed on the screen in the Geometry Window.  Figure 9-14 shows the simulation 

in progress.  You can keep a track of the progress of the evacuation by noting the simulation time 

and number of people out which are displayed on the far right of the toolbar in the Geometry 

Window. 

 

 
Figure 9-14: Simulation paused at 2.1 seconds 

 



Chapter 9 - Tutorial 1 

© 2017 University of Greenwich 151 

9.1.9 Interrogating an Occupant 

During a simulation, it is often necessary to interrogate an occupant.  Occupant interrogation 

involves the examination of the attributes associated with the occupant.  Here we will interrogate an 

occupant to find the path taken to his/her current location.  To interrogate an occupant (or any 

buildingEXODUS object), first click on the Select Person  icon on the Simulation toolbar, then 

open its dialogue box by double-clicking on the object in the Geometry Window.  The Person 

dialogue box is shown in Figure 9-15. 

 

 
Figure 9-15: Dialogue box to interrogate a person 

 

At this point, we can see the occupant being interrogated is a Male aged 26 years.  We can further 

interrogate this occupant to see the Attributes, Gases (level C only) or Path taken.  For this example, 

only the path taken will be examined.  To view the path taken by the occupant, the PATH button 

must be pressed, and the path from the starting location to the current location is shown as a dotted 

line - an example is given in Figure 9-16.  If the occupant has already successfully egressed, the 

path taken to the exit used is shown. 
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Figure 9-16: An occupant's path being interrogated 

 

NOTE: 

It is recommended that the user presses the PAUSE button before attempting to select a person. 

 

NOTE: 

By clicking the ATTRIB button, a complete list of the person's current attributes will be displayed. 

 

9.1.10  Graphs and Tables produced 

The following sub-sections indicate some of the output produced by buildingEXODUS for the 

simulation. 

 

9.1.10.1 The Graphs 

Graphs can be accessed in two ways: either by selecting [View>Display>Graphs] or by double-

clicking one of the graphs (All Exits, Main Graph or Mortuary Graph) individually from the side 

Navigation window.  In this example there are no casualties so the Mortuary Graph will not be 

generated. 

 

Three types of flow graphs are produced for each simulation (see Figure 9-17).  The first type 

entitled All Exits, plots the total number of people out of the geometry as a function of time (see 

Figure 9-17a).  The information is lost from this graph when a simulation is reset.  

 

The second type of graph also represents the total number of people out of the geometry, but this 

time counts only those that used an individual exit, i.e. the number of occupants through the exit as 

a function of time (Figure 9-17b).  One graph is produced for each exit used during a simulation; 

each one is titled with the name of the exit represented.  The information presented in these graphs 

is lost when a simulation is reset. 
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(a) (b) (c) 

Figure 9-17: All Exits, Individual Door and Main Graphs 

 

The third type of graph is entitled Main Graph.  Like the All Exits graph, it plots the total number 

of people out of the geometry as a function of time (Figure 9-17c).  However, unlike the All Exits 

graph, data for the last 5 simulations is kept and is only lost when the graph is reset (by selecting 

the Clear option within the Edit menu and then selecting the Main Graph option within the resulting 

Clear submenu [Edit>Clear>Main Graph]) or the software is closed down.  Its function is to allow 

comparison between simulations. 

 

9.1.10.2 The Summary window 

The Summary Window is a selectable tab of the Data Window, which is positioned below the Main 

buildingEXODUS window.  If the data window isn’t displayed, select [View>Data Window] from 

the menu.  The Summary Window can be viewed by clicking on the Summary tab.  When in 

Geometry, Population or Scenario Modes the information presented is a summary of the geometry, 

doors and population used in the last simulation.  It presents the number of nodes, lines,  occupants, 

zones (used in level C only) the status of each exit and the Undo summary.  When viewed in 

Simulation Mode it just shows the status of each exit. 

 

9.1.11  The Output Window 

The Output Window is a selectable tab of the Data Window.  This window contains all of the 

information requested when setting the Data Output Control dialogue box (Figure 9-13).  By 

clicking on this tab this information is printed to the screen.  The information is displayed in several 

sections, the number of which is dependent upon the complexity of the simulation. 

 

NOTE: 

The user should ensure that the options in the INPUT PARAMETERS dialogue box are enabled (see 

Figure 9-18). This is good practice so the settings that were enabled are shown with the outputted 

data.  This is accessible within the DATA OUTPUT CONTROL dialogue box by clicking the 

PARAMS button. 

 

 
Figure 9-18: The Input Parameters dialogue box 
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For this tutorial case there are no Fire Scenario or Hazard Summary sections.  An example of the 

output seen is shown below.  The first section contains information relating to when the simulation 

was run and the output generated along with the software version and SimSeed used and the users 

licence information.  

 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

           Simulation of T1_2.exo, with 30 People. 

              Started Thu Aug 29 11:53:47 2013  

         Initialisation time 0 (s). Run time 1 (s). 

                 Current Memory Usage 21732K 

           File Generated Thu Aug 29 11:53:48 2013 

                    SimSeed: 1377773627 

               buildingEXODUS  V6.0.0.822  x86 

                          LEVEL: C 

                         1077807400 

                   Expires on: 7 May 2014 

                             -- 

                             -- 

               buildingEXODUS is a product of 

                           G.U.E.L 

                       a subsidiary of 

                 the University of Greenwich 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Simulation Options Default 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

 

The second section contains summary information relating to the population as a whole. 

 
Population Parameter Summary 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Attribute            | Average|     Min|     Max| 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Males                |      17|      17|      17| 

Female               |      13|      13|      13| 

Age                  |   35.03|   20.00|   51.00| 

Agility              |    5.22|    3.10|    7.00| 

Drive                |    7.62|    1.45|   13.70| 

FWalk (m/s)          |    1.14|    0.81|    1.47| 

Walk (m/s)           |    1.03|    0.73|    1.32| 

Crawl (m/s)          |    0.23|    0.16|    0.29| 

Leap (m/s)           |    0.91|    0.65|    1.18| 

Mobility             |    1.00|    1.00|    1.00| 

Patience (s)         | 1000.00| 1000.00| 1000.00| 

Response (s)         |   14.15|    0.00|   29.27| 

Weight (kg)          |   63.38|   50.38|   74.89| 

Height (m)           |    1.67|    1.54|    1.83| 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

 

The third section relates to the option settings applied during this simulation.  If the simulation 

contained a Fire and/or Hazard Scenario then a summary of these settings would appear before the 

Occupant Switches section. 
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Occupant Switches 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Switch               |Value       | 

+++++++++++++++++++++++++++++++++++ 

Local Familiarity    |OFF         | 

All Main Exits       |OFF         | 

Floor Potential Map  |OFF         | 

Local Potential      |ON          | 

Maintain Target Exit |OFF         | 

Maintain Itinerary   |OFF         | 

Transit Node Grouping|OFF         | 

Milling              |OFF         | 

Zone Events          |OFF         | 

Natural Movement     |OFF         | 

Extreme Behaviour    |OFF         | 

Impatient            |OFF         | 

Seat Jumping         |OFF         | 

Wall Proximity       |OFF         | 

Avoid Congestion     |OFF         | 

Social Response      |OFF         | 

Social Movement      |OFF         | 

Stair Spacing        |Staggered   | 

Stair Edge Pref.     |ON          | 

Crawling             |ON          | 

Smoke Stagger        |OFF         | 

Smoke Redirection    |OFF         | 

Smoke Visual Coef.   |        2.00| 

Signage System       |None        | 

Max Sim.             |OFF         | 

+++++++++++++++++++++++++++++++++++ 

 

The fourth section is a summary of the simulation, showing the number of people out, the time of 

the first person out and last person out, along with the overall evacuation time. 

 
Number of People out 30, first out (secs) 3.79   last 36.21  

Final Simulation time 36.21  (s) 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

 

The fifth section is the main section of the Output Window, it contains all the information requested 

in the DATA OUTPUT CONTROL dialogue box for each person. 

 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Exit results table:- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Pos|Gender      |  Age| Agility|   Drive|   FWalk Rt (m/s)|Mobility|Patience|Response|     CWT|Distance|     PET| 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

    1|Male        |   28|    3.88|    6.40|             1.44|    1.00| 1000.00|    2.31|    0.00|    0.00|    3.79| 

    2|Male        |   26|    7.00|   10.43|             0.92|    1.00| 1000.00|    0.55|    0.00|    3.21|    5.50| 

    3|Female      |   31|    4.87|    6.14|             1.05|    1.00| 1000.00|    0.99|    0.00|    3.41|    5.85| 

    4|Female      |   32|    6.13|    5.19|             1.36|    1.00| 1000.00|    0.13|    0.36|    6.74|    6.96| 

    5|Female      |   49|    5.05|    2.71|             1.08|    1.00| 1000.00|    0.00|    0.53|    6.83|    8.38| 

    6|Male        |   32|    6.96|    9.55|             1.00|    1.00| 1000.00|    4.62|    0.00|    2.50|    8.71| 

    7|Male        |   48|    4.54|    6.37|             1.29|    1.00| 1000.00|    4.16|    0.30|    5.41|   10.16| 

    8|Male        |   25|    6.54|   10.16|             1.29|    1.00| 1000.00|    4.04|    0.00|    7.24|   11.15| 

    9|Female      |   25|    5.87|    7.43|             1.23|    1.00| 1000.00|    7.97|    0.88|    2.62|   12.53| 

   10|Female      |   48|    5.28|    4.31|             1.33|    1.00| 1000.00|   10.33|    0.00|    1.21|   12.83| 

   11|Male        |   43|    3.75|   10.49|             1.20|    1.00| 1000.00|    9.83|    0.00|    3.41|   14.30| 

   12|Male        |   48|    5.13|    9.84|             1.02|    1.00| 1000.00|   11.61|    0.00|    1.50|   14.82| 

   13|Female      |   26|    4.42|    8.10|             0.81|    1.00| 1000.00|    9.81|    0.00|    3.91|   16.26| 

   14|Male        |   36|    5.54|   13.70|             1.17|    1.00| 1000.00|   12.07|    0.00|    4.62|   17.46| 

   15|Male        |   27|    3.91|   12.83|             1.14|    1.00| 1000.00|   14.82|    0.00|    2.50|   18.75| 

   16|Male        |   33|    5.06|    8.26|             1.33|    1.00| 1000.00|   15.63|    0.00|    3.21|   19.78| 

   17|Female      |   20|    5.03|    3.94|             1.26|    1.00| 1000.00|   17.77|    0.00|    4.21|   22.75| 

   18|Male        |   30|    3.10|   13.69|             1.22|    1.00| 1000.00|   18.37|    0.00|    4.83|   24.02| 

   19|Male        |   20|    3.38|   11.23|             1.37|    1.00| 1000.00|   20.16|    1.18|    3.62|   25.64| 

   20|Female      |   21|    6.23|    1.45|             0.96|    1.00| 1000.00|   18.16|    0.00|    5.91|   26.04| 

   21|Male        |   48|    4.07|   11.46|             1.47|    1.00| 1000.00|   22.33|    0.47|    4.21|   27.32| 

   22|Female      |   28|    6.40|    4.80|             0.93|    1.00| 1000.00|   21.30|    0.00|    5.04|   28.48| 

   23|Female      |   45|    5.69|    2.53|             0.99|    1.00| 1000.00|   22.35|    1.39|    3.41|   28.91| 

   24|Male        |   32|    3.85|   13.06|             0.97|    1.00| 1000.00|   22.67|    0.52|    5.12|   30.01| 

   25|Female      |   44|    6.74|    3.72|             1.01|    1.00| 1000.00|   24.77|    1.02|    3.00|   30.43| 

   26|Male        |   37|    4.28|    9.41|             0.98|    1.00| 1000.00|   25.05|    0.23|    4.83|   31.82| 

   27|Female      |   51|    6.58|    8.46|             0.83|    1.00| 1000.00|   21.41|    1.51|    6.41|   32.15| 

   28|Male        |   31|    5.69|    5.46|             1.19|    1.00| 1000.00|   24.15|    1.26|    7.83|   33.66| 

   29|Male        |   48|    5.60|    5.55|             1.37|    1.00| 1000.00|   29.27|    0.00|    5.21|   34.80| 

   30|Female      |   39|    5.91|    2.09|             1.03|    1.00| 1000.00|   27.74|    1.20|    6.00|   36.21| 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Avg|            | 35.0|    5.22|    7.62|             1.14|    1.00| 1000.00|   14.15|    0.36|    4.27|   19.98| 
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The sixth section summarises the exit performance for each exit in the geometry.  It lists the number 

of people to use the exit, the time of the first person out through the exit, the time of the last person 

out through the exit and the prescribed unit flow rate for the exit.  Also displayed is the geometry 

OPS value. 

 
Door performances:- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Ext. Exit Door_1          Number Used:   30  First Entry:   3.79 (s) Last :  36.21 (s) Avg PPM :  55.52 

 Flow Time:  32.42 (s) No Flow Time:   0.00 (s) MNS :   0.00 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

OPS = 0.000 

End of Door data 

 

As can be seen from this table the first person exited in 3.79 seconds and the last in 36.21 seconds.  

 

As only one exit is available the OPS value for this simulation was 0. 

 

9.1.12  Randomising occupant’s starting locations 

In the second example simulation, the starting positions of the occupants will be changed randomly. 

To randomise the passengers’ starting locations select [Edit> Relocate>Randomise] from the menu.  

After issuing the command all people will be moved to new positions (Figure 9-19). 

 

 
Figure 9-19: Randomised starting locations 

 

NOTE: 

Each time Randomise is selected a different seed is used resulting in a different starting location. 

The simulation needs to be reset in order to relocate occupants. 

 

As no other variations are to be used in this simulation, press the PLAY button to start the 

evacuation.  While the simulation is running the graphs will be updated and in the end the Output 

Window will be appended with the new output results.  The second run will produce a different 

sequence of results. 

 

NOTE: 

The degree of variation observed in the results is dependent on the nature of the scenario being 

simulated - namely the nature of the geometry, number of people and nature of their attributes. 

 

NOTE: 
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It is possible to change the locations of each individual occupant while maintaining the overall set 

of starting locations. To do this, select the target population and then select Edit>Relocate>Swap 

Locations. 

 

9.1.13  Constructing a population using the Population Panel 

For the third sample simulation the population will be deleted and replaced by a population 

constructed using the population panel.  This is achieved by first moving to POPULATION mode 

using the  or  buttons on the toolbar. 

 

To delete the current population, select [Edit>Delete>Everyone] from the menu.  Once the 

population is deleted a new population can be created using the population panel tool.  To use this 

tool the user should click on PANEL POPULATE button  on the tool bar.  The POPULATION 

EDITOR dialogue box will be displayed (Figure 9-20) containing the default population distribution.  

For the purposes of this demonstration we will accept the default population characteristics and 

generate a population of 50 people.  Ensure that only Free Space nodes are selected (i.e. that all 

other Node Types are deselected) and also that the Global allocation system is selected.  Type 50 in 

the Total Pop. Size text box press the Populate button.  The software will then ask the user to confirm 

creating the defined number of people.  Once confirmed the software will generate 50 people located 

randomly within your selected region (or the entire geometry in the active window if no region was 

selected). 

 

 
Figure 9-20: Generating 50 occupants using the Standard population in the population panel 

editor 

 

NOTE: 

As a specific region was not selected for the population (i.e. since the Selection allocation system 

was not used), the generated people will be placed randomly throughout the entire geometry (i.e. 

globally). 
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NOTE: 

The default number shown in the Total Pop. Size text box represents the maximum number of people 

that could be generated in the selected region (or within the entire geometry if no region is selected). 

 

NOTE: 

The available locations to place the generated people can be further controlled by selecting only 

the node types that the user wants to use. For example, the user can select just Seats in order to 

place occupants only on the available Seat nodes. 

 

9.1.14  Checking the refined estimation of the evacuation time 

Move to SCENARIO MODE and double click on the Door within the geometry to open its dialogue 

box. 

 

After the new population is created we can get an estimation of evacuation time by pressing the 

MAX P button in the Door dialogue box.  The refined estimation of the evacuation time is 

approximately 44 seconds (Figure 9-21). 

 

 
Figure 9-21: Refining the TET and maximum travel distance estimates 

 

9.1.15  Running the Simulation 

Move to SIMULATION MODE. 

 

Now that the population has been set the simulation of the evacuation can start.  Using the previous 

settings, press the PLAY button on the toolbar to start the simulation. 

 

9.1.16  Graphs and Tables produced 

The same series of graphs are displayed for this simulation as were shown in Section 9.1.10.1. 

 

9.1.16.1 The Graphs 

Figure 9-22 depicts the graphs produced for this simulation. 
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Figure 9-22: Graphs produced for 50 occupant simulation 

 

NOTE: 

The Main Graph now displays three curves, two for the first two simulations and one for the third 

simulation. 

 

9.1.17  The Summary Window 

The Summary Window now contains the following: 

 
Door Summary:-----------> 

 door            (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.33 1.33)(X  50)(P  0.00) 

 

9.1.18 The Output Window 

 

The Output Window contains the following information: 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

           Simulation of T1_2.exo, with 50 People. 

              Started Thu Aug 29 11:57:01 2013  

         Initialisation time 0 (s). Run time 0 (s). 

                 Current Memory Usage 23060K 

           File Generated Thu Aug 29 11:57:02 2013 

                    SimSeed: 1377773821 

               buildingEXODUS  V6.0.0.822  x86 

                          LEVEL: C 

                         1077807400 

                   Expires on: 7 May 2014 

                             -- 

                             -- 

               buildingEXODUS is a product of 

                           G.U.E.L 

                       a subsidiary of 

                 the University of Greenwich 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Simulation Options Default 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Population Parameter Summary 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Attribute            | Average|     Min|     Max| 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Males                |      31|      31|      31| 

Female               |      19|      19|      19| 

Age                  |   46.08|   19.00|   79.00| 

Agility              |    4.43|    2.33|    6.98| 

Drive                |    8.06|    1.07|   14.89| 

FWalk (m/s)          |    1.33|    1.20|    1.50| 

Walk (m/s)           |    1.20|    1.08|    1.35| 

Crawl (m/s)          |    0.27|    0.24|    0.30| 

Leap (m/s)           |    1.07|    0.96|    1.20| 

Mobility             |    1.00|    1.00|    1.00| 

Patience (s)         |    2.99|    1.02|    4.84| 

Response (s)         |   15.29|    0.19|   29.69| 

Weight (kg)          |   60.04|   41.10|   89.27| 

Height (m)           |    1.73|    1.51|    2.00| 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Occupant Switches 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Switch               |Value       | 

+++++++++++++++++++++++++++++++++++ 

Local Familiarity    |OFF         | 

All Main Exits       |OFF         | 

Floor Potential Map  |OFF         | 

Local Potential      |ON          | 

Maintain Target Exit |OFF         | 

Maintain Itinerary   |OFF         | 

Transit Node Grouping|OFF         | 

Milling              |OFF         | 

Zone Events          |OFF         | 

Natural Movement     |OFF         | 

Extreme Behaviour    |OFF         | 
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Impatient            |OFF         | 

Seat Jumping         |OFF         | 

Wall Proximity       |OFF         | 

Avoid Congestion     |OFF         | 

Social Response      |OFF         | 

Social Movement      |OFF         | 

Stair Spacing        |Staggered   | 

Stair Edge Pref.     |ON          | 

Crawling             |ON          | 

Smoke Stagger        |OFF         | 

Smoke Redirection    |OFF         | 

Smoke Visual Coef.   |        2.00| 

Signage System       |None        | 

Max Sim.             |OFF         | 

+++++++++++++++++++++++++++++++++++ 

Number of People out 50, first out (secs) 3.40   last 46.09  

Final Simulation time 46.09  (s) 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

 

 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Exit results table:- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Pos|Gender      |  Age|   Drive|   FWalk Rt (m/s)|Patience|Response|     CWT|Distance|     PET| 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

    1|Male        |   56|   11.54|             1.48|    2.80|    0.95|    0.00|    1.21|    3.40| 

    2|Male        |   37|   14.59|             1.29|    3.53|    0.52|    0.00|    3.62|    4.90| 

    3|Male        |   43|    7.79|             1.20|    3.21|    0.19|    0.33|    4.41|    5.75| 

    4|Male        |   35|   10.13|             1.36|    4.84|    3.39|    0.86|    2.00|    7.25| 

    5|Female      |   36|    1.59|             1.34|    3.05|    2.90|    0.00|    4.33|    7.66| 

    6|Female      |   68|    1.68|             1.50|    1.56|    1.92|    0.33|    7.24|    8.75| 

    7|Male        |   38|   10.07|             1.38|    1.62|    3.53|    0.78|    6.04|   10.25| 

    8|Male        |   56|   10.88|             1.20|    3.15|    3.94|    0.17|    5.83|   10.60| 

    9|Male        |   36|   11.97|             1.43|    1.60|    4.83|    1.29|    6.04|   11.92| 

   10|Male        |   20|   12.48|             1.29|    1.93|    6.32|    2.09|    4.41|   13.42| 

   11|Female      |   48|    5.54|             1.23|    3.82|    7.40|    0.67|    5.04|   13.68| 

   12|Female      |   47|    4.40|             1.21|    4.24|    7.41|    1.91|    5.33|   15.25| 

   13|Female      |   51|    6.60|             1.20|    2.63|   12.58|    0.00|    2.00|   15.75| 

   14|Female      |   64|    3.59|             1.37|    4.40|    6.00|    2.99|    8.45|   16.75| 

   15|Male        |   69|   14.89|             1.31|    1.23|    9.04|    1.17|    7.33|   17.35| 

   16|Male        |   27|   13.80|             1.43|    2.33|    0.32|    5.63|   15.57|   18.42| 

   17|Male        |   44|    6.92|             1.44|    3.03|   10.50|    1.63|    7.74|   19.09| 

   18|Male        |   33|    6.21|             1.46|    4.76|   10.64|    3.97|    5.41|   19.92| 

   19|Female      |   68|    8.14|             1.26|    3.33|   14.24|    0.22|    5.83|   20.59| 

   20|Male        |   53|    7.29|             1.39|    2.11|   12.53|    2.35|    6.91|   21.42| 

   21|Male        |   53|    7.48|             1.22|    4.46|   19.85|    0.67|    0.71|   22.67| 

   22|Male        |   44|   10.54|             1.34|    1.57|   13.97|    2.09|    7.24|   23.09| 

   23|Female      |   28|    4.87|             1.25|    1.02|   18.07|    2.92|    2.21|   24.27| 

   24|Female      |   35|    5.84|             1.20|    4.26|   11.17|    8.99|    3.41|   24.59| 

   25|Male        |   54|    5.03|             1.21|    1.50|   15.50|    4.94|    4.71|   25.92| 

   26|Male        |   39|   11.57|             1.25|    2.53|   16.56|    3.87|    6.54|   27.18| 

   27|Male        |   79|   12.26|             1.42|    1.79|   14.51|    6.20|    7.54|   27.59| 

   28|Male        |   76|    8.76|             1.42|    4.46|   20.74|    3.45|    4.33|   28.75| 

   29|Male        |   19|   11.67|             1.34|    1.54|   21.29|    2.66|    5.33|   29.55| 

   30|Male        |   33|    8.58|             1.24|    3.13|   15.99|    6.58|    7.74|   30.42| 

   31|Female      |   36|    3.47|             1.31|    4.36|   15.05|    9.88|    6.04|   31.06| 

   32|Female      |   49|    4.06|             1.32|    3.73|   22.78|    3.85|    4.83|   31.92| 

   33|Male        |   79|   12.49|             1.40|    4.72|   21.97|    4.70|    6.24|   32.75| 

   34|Male        |   49|   12.61|             1.24|    3.62|   22.66|    3.30|    7.45|   33.59| 

   35|Male        |   37|   10.92|             1.43|    1.44|   23.94|    4.69|    5.95|   34.42| 

   36|Male        |   74|    9.28|             1.24|    2.62|   18.38|   11.27|    4.83|   35.09| 

   37|Male        |   63|   11.42|             1.27|    4.02|   27.01|    4.16|    4.04|   35.92| 

   38|Male        |   24|    5.74|             1.48|    4.29|   23.21|    7.78|    6.24|   36.75| 

   39|Female      |   37|    7.26|             1.24|    1.89|   25.78|    5.15|    6.04|   37.42| 

   40|Female      |   27|    8.83|             1.25|    3.01|   27.67|    3.39|    7.04|   38.25| 

   41|Female      |   32|    8.55|             1.48|    3.97|   29.69|    4.44|    5.04|   39.09| 

   42|Female      |   41|    4.51|             1.42|    4.25|   25.98|    9.12|    4.33|   39.75| 

   43|Male        |   36|   10.46|             1.44|    2.35|   29.59|    4.82|    6.74|   40.75| 

   44|Male        |   31|    9.17|             1.21|    2.20|   28.43|    5.16|    7.45|   41.42| 

   45|Female      |   28|    9.41|             1.45|    2.40|   29.31|    6.47|    7.04|   42.25| 

   46|Male        |   26|    5.08|             1.39|    4.69|   27.36|   10.70|    4.83|   43.09| 

   47|Female      |   77|    2.80|             1.30|    2.64|   12.20|   25.99|    5.21|   43.75| 

   48|Male        |   47|    6.06|             1.43|    2.62|   27.73|    9.21|    8.74|   44.59| 

   49|Female      |   46|    1.07|             1.43|    2.84|   28.76|    8.23|    9.66|   45.42| 

   50|Female      |   76|    3.02|             1.26|    2.31|   10.23|   27.55|    8.54|   46.09| 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Avg|            | 46.1|    8.06|             1.33|    2.99|   15.29|    4.77|    5.81|   25.99| 

Door performances :- 
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++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Ext. Exit Door_1          Number Used:   50  First Entry:   3.40 (s) Last :  46.09 (s) Avg PPM :  

70.29 

 Flow Time:  42.68 (s) No Flow Time:   0.00 (s) MNS :   0.00 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.33   1.33 

OPS = 0.000 

End of Door data 

 

As can be seen from this table the first person exited in approximately 3 seconds and the last in 

approximately 46 seconds.  As only one exit is available the OPS for this simulation was 0. 

 

9.1.19  Adding an additional exit 

Move to GEOMETRY Mode. 

 

For the fourth sample simulation the geometry will be modified through the addition of another exit. 

The second exit will have identical characteristics to the first.  The current population defined will 

be used.  The second exit door will be added to top right corner of the square room.  

 

Section 9.1.4 describes how to add an exit door.  Using the same method, add a second exit in the 

location specified, as shown in Figure 9-23.  After placing the exit it should be renamed to “Door_2” 

by double clicking on it to retrieve the Door dialogue box, and entering its new name in the Title 

box. 

 

 
Figure 9-23: Adding a second exit 

 

9.1.20  Changing the door parameters 

Move to SCENARIO MODE. 

 

The Door_2 parameters should be set in a similar fashion as for the original exit, as shown in Section 

9.1.6.  Enter 10 in the “-%” and “+%” edit boxes (see Figure 9-7).   

 

9.1.21  Acquiring the room’s maximum path 

The addition of an exit door will alter the maximum path and the estimated evacuation time.  Using 

the same method described previously, the new maximum path and the new estimated evacuation 

time can be obtained.  

 

As this is a square room, the maximum travel distance will be measured from the corner of the room 

to the door following a path along the wall. 
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For this example the estimated maximum travel distance is 5.0m and the estimated evacuation time 

is estimated at 22.96 seconds (see Figure 9-24).  The actual maximum path is measured from a 

corner of the room to the centre of the door.  As the door is 1.0m wide, this produces an actual 

maximum path of 5.5m.  The refined estimate is 5.44m, producing an error 0.4%. 

 

  
Figure 9-24: Estimates for maximum travel distance and total evacuation time (unrefined, 

left and refined, right) 

 

9.1.22  Running the simulation 

Move to SIMULATION MODE and start the simulation by clicking the PLAY button. 

 

9.1.22.1 Graphs and Tables produced 

The graphs produced by this simulation are displayed below. 

 

 
Figure 9-25: Graphs produced by simulation 

 

NOTE: 

From Figure 9-25, the Main Graph window can be seen to display the curves from the previous 

simulations.  This is particularly useful for comparing the results across scenario types. 
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9.1.22.2 The Summary Window 

The Summary Window contains the following: 

 
Door Summary:-----------> 

 Door_1          (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.33 1.33)(X  21)(P100.00) 

 Door_2          (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.20 1.46)(X  29)(P100.00) 

<-----------------------> 

 

9.1.22.3 The Output Window 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

           Simulation of T1_3.exo, with 50 People. 

              Started Thu Aug 29 11:58:27 2013  

         Initialisation time 0 (s). Run time 1 (s). 

                 Current Memory Usage 23020K 

           File Generated Thu Aug 29 11:58:29 2013 

                    SimSeed: 1377773907 

               buildingEXODUS  V6.0.0.822  x86 

                          LEVEL: C 

                         1077807400 

                   Expires on: 7 May 2014 

                             -- 

                             -- 

               buildingEXODUS is a product of 

                           G.U.E.L 

                       a subsidiary of 

                 the University of Greenwich 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Simulation Options Default 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Population Parameter Summary 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Attribute            | Average|     Min|     Max| 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Males                |      31|      31|      31| 

Female               |      19|      19|      19| 

Age                  |   46.08|   19.00|   79.00| 

Agility              |    4.43|    2.33|    6.98| 

Drive                |    8.06|    1.07|   14.89| 

FWalk (m/s)          |    1.33|    1.20|    1.50| 

Walk (m/s)           |    1.20|    1.08|    1.35| 

Crawl (m/s)          |    0.27|    0.24|    0.30| 

Leap (m/s)           |    1.07|    0.96|    1.20| 

Mobility             |    1.00|    1.00|    1.00| 

Patience (s)         |    2.99|    1.02|    4.84| 

Response (s)         |   15.29|    0.19|   29.69| 

Weight (kg)          |   60.04|   41.10|   89.27| 

Height (m)           |    1.73|    1.51|    2.00| 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Occupant Switches 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Switch               |Value       | 

+++++++++++++++++++++++++++++++++++ 

Local Familiarity    |OFF         | 

All Main Exits       |OFF         | 

Floor Potential Map  |OFF         | 

Local Potential      |ON          | 

Maintain Target Exit |OFF         | 

Maintain Itinerary   |OFF         | 

Transit Node Grouping|OFF         | 

Milling              |OFF         | 

Zone Events          |OFF         | 

Natural Movement     |OFF         | 

Extreme Behaviour    |OFF         | 

Impatient            |OFF         | 

Seat Jumping         |OFF         | 

Wall Proximity       |OFF         | 

Avoid Congestion     |OFF         | 

Social Response      |OFF         | 

Social Movement      |OFF         | 

Stair Spacing        |Staggered   | 

Stair Edge Pref.     |ON          | 
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Crawling             |ON          | 

Smoke Stagger        |OFF         | 

Smoke Redirection    |OFF         | 

Smoke Visual Coef.   |        2.00| 

Signage System       |None        | 

Max Sim.             |OFF         | 

+++++++++++++++++++++++++++++++++++ 

Number of People out 50, first out (secs) 3.40   last 35.53  

Final Simulation time 35.53  (s) 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Exit results table:- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Pos|Gender      |  Age|   Drive|   FWalk Rt (m/s)|Patience|Response|     CWT|Distance|     PET| 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

    1|Male        |   56|   11.54|             1.48|    2.80|    0.95|    0.00|    1.21|    3.40| 

    2|Female      |   68|    1.68|             1.50|    1.56|    1.92|    0.00|    1.21|    4.55| 

    3|Male        |   37|   14.59|             1.29|    3.53|    0.52|    0.00|    3.62|    4.90| 

    4|Male        |   43|    7.79|             1.20|    3.21|    0.19|    0.33|    4.41|    5.75| 

    5|Male        |   27|   13.80|             1.43|    2.33|    0.32|    0.17|    5.71|    5.96| 

    6|Male        |   35|   10.13|             1.36|    4.84|    3.39|    0.86|    2.00|    7.25| 

    7|Female      |   36|    1.59|             1.34|    3.05|    2.90|    0.00|    3.91|    7.35| 

    8|Female      |   64|    3.59|             1.37|    4.40|    6.00|    0.00|    0.50|    8.08| 

    9|Male        |   56|   10.88|             1.20|    3.15|    3.94|    0.00|    5.21|    9.85| 

   10|Male        |   20|   12.48|             1.29|    1.93|    6.32|    0.00|    3.91|   10.95| 

   11|Female      |   48|    5.54|             1.23|    3.82|    7.40|    0.17|    4.41|   12.68| 

   12|Female      |   47|    4.40|             1.21|    4.24|    7.41|    0.00|    4.83|   12.93| 

   13|Male        |   44|    6.92|             1.44|    3.03|   10.50|    0.00|    2.83|   14.14| 

   14|Female      |   35|    5.84|             1.20|    4.26|   11.17|    0.00|    3.62|   15.77| 

   15|Male        |   38|   10.07|             1.38|    1.62|    3.53|    6.59|    5.95|   15.98| 

   16|Female      |   51|    6.60|             1.20|    2.63|   12.58|    0.00|    2.91|   16.51| 

   17|Female      |   76|    3.02|             1.26|    2.31|   10.23|    0.10|    6.21|   16.70| 

   18|Female      |   77|    2.80|             1.30|    2.64|   12.20|    0.13|    4.50|   17.36| 

   19|Male        |   33|    6.21|             1.46|    4.76|   10.64|    2.36|    5.33|   18.23| 

   20|Male        |   53|    7.29|             1.39|    2.11|   12.53|    1.29|    4.04|   18.33| 

   21|Male        |   39|   11.57|             1.25|    2.53|   16.56|    0.30|    1.71|   19.70| 

   22|Male        |   69|   14.89|             1.31|    1.23|    9.04|    5.42|    5.04|   19.91| 

   23|Female      |   28|    4.87|             1.25|    1.02|   18.07|    0.00|    1.41|   20.72| 

   24|Male        |   79|   12.26|             1.42|    1.79|   14.51|    2.12|    4.33|   21.39| 

   25|Female      |   36|    3.47|             1.31|    4.36|   15.05|    1.31|    4.91|   21.68| 

   26|Male        |   53|    7.48|             1.22|    4.46|   19.85|    0.00|    0.71|   22.00| 

   27|Male        |   74|    9.28|             1.24|    2.62|   18.38|    0.00|    3.12|   22.44| 

   28|Male        |   36|   11.97|             1.43|    1.60|    4.83|    9.44|   10.36|   23.08| 

   29|Male        |   54|    5.03|             1.21|    1.50|   15.50|    1.27|    6.12|   23.42| 

   30|Male        |   44|   10.54|             1.34|    1.57|   13.97|    2.83|    7.04|   23.80| 

   31|Male        |   76|    8.76|             1.42|    4.46|   20.74|    0.76|    2.71|   24.92| 

   32|Male        |   33|    8.58|             1.24|    3.13|   15.99|    3.65|    4.62|   25.13| 

   33|Male        |   19|   11.67|             1.34|    1.54|   21.29|    0.00|    3.71|   25.69| 

   34|Female      |   68|    8.14|             1.26|    3.33|   14.24|    5.35|    5.83|   25.72| 

   35|Male        |   79|   12.49|             1.40|    4.72|   21.97|    1.66|    2.91|   27.41| 

   36|Male        |   24|    5.74|             1.48|    4.29|   23.21|    0.66|    3.33|   27.58| 

   37|Female      |   41|    4.51|             1.42|    4.25|   25.98|    0.00|    1.91|   28.93| 

   38|Male        |   37|   10.92|             1.43|    1.44|   23.94|    0.77|    3.91|   29.00| 

   39|Female      |   49|    4.06|             1.32|    3.73|   22.78|    1.17|    4.62|   29.03| 

   40|Male        |   63|   11.42|             1.27|    4.02|   27.01|    0.00|    2.50|   30.55| 

   41|Female      |   37|    7.26|             1.24|    1.89|   25.78|    0.99|    2.71|   30.59| 

   42|Male        |   49|   12.61|             1.24|    3.62|   22.66|    3.57|    3.41|   30.63| 

   43|Male        |   26|    5.08|             1.39|    4.69|   27.36|    0.00|    2.71|   30.87| 

   44|Male        |   47|    6.06|             1.43|    2.62|   27.73|    0.75|    3.21|   32.35| 

   45|Female      |   27|    8.83|             1.25|    3.01|   27.67|    0.00|    4.21|   32.61| 

   46|Female      |   46|    1.07|             1.43|    2.84|   28.76|    0.53|    2.41|   32.80| 

   47|Female      |   28|    9.41|             1.45|    2.40|   29.31|    1.82|    1.71|   33.92| 

   48|Female      |   32|    8.55|             1.48|    3.97|   29.69|    0.00|    4.12|   34.03| 

   49|Male        |   36|   10.46|             1.44|    2.35|   29.59|    0.45|    3.91|   34.42| 

   50|Male        |   31|    9.17|             1.21|    2.20|   28.43|    2.84|    3.21|   35.53| 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Avg|            | 46.1|    8.06|             1.33|    2.99|   15.29|    1.19|    3.77|   20.93| 

Door performances :- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Ext. Exit Door_1          Number Used:   21  First Entry:   3.40 (s) Last :  34.03 (s) Avg PPM :  

41.14 

 Flow Time:  30.63 (s) No Flow Time:   1.19 (s) MNS :   3.89 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.33   1.33 

Ext. Exit Door_2          Number Used:   29  First Entry:   4.55 (s) Last :  35.53 (s) Avg PPM :  

56.16 

 Flow Time:  30.98 (s) No Flow Time:   0.00 (s) MNS :   0.00 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 
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 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

OPS = 0.042 

End of Door data 

 

As can be seen from this table the first occupants out of the geometry exited out of Door_1 at 3.4s 

and Door_2 at 4.55s.  The last person to use Door_1 exited the geometry after 34.03s and the last 

person to use Door_2 exited after 35.53s.  A total of 21 people used Door_1 while 29 people used 

Door_2.  The OPS for this simulation was 0.042, indicating that a quite efficient evacuation took 

place. 

 

NOTE: 

The Exit Usage will fluctuate according to the starting location of the occupants. 
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9.2 Tutorial 2: Two rooms joined with a corridor 

In this tutorial several of buildingEXODUS key features will be demonstrated: namely 

constructing a geometry using the interactive tools, specifying a population, defining a scenario 

and running a simulation.  The geometry is kept simple so that the key features are not lost in 

needlessly complex details.  

 

The geometry to be modelled consists of two square rooms connected via a corridor.  The 

dimensions of the rooms are 10m x 10m and the corridor connecting them is 7.5m x 1.5m.  The 

corridor connects the middle of the adjacent walls.  Each room has a single door measuring 

1.0m in width.  The left room has the door placed in the front left corner while the right room 

has the door placed in the middle of the front wall.  The two rooms are occupied by elderly 

people, of which there are 40 people in the left room and 30 people in the right room.  The 

population is made up of 50% males and 50% females. 

 

9.2.1 Defining the enclosure 

To create and modify the geometry you must be in GEOMETRY MODE. 

 

The first step in creating the geometry is to create the nodes defining the two rooms and corridor 

section.  This is achieved by using the Node tool to create Free-Space nodes by dragging out a 

selection box within the Main Window; by default this window will be called Floor_0. 

 

NOTE: 

By default the Node tool creates Free-Space nodes. 

 

As each room has dimensions of 10m x 10m a total of 400 Free-space nodes (20 x 20) will be 

created for the rooms. As the corridor measures 7.5m x 1.5m, a total of 45 Free-space nodes 

(15 x 3) will be required to define the corridor. 

 

NOTE: 

By default each node represents a point on a grid separated by 0.5m x 0.5m. 

 

Using the Node tool and the drag method the three regions can be quickly created.  For this 

example the user is recommended to create three separate items, two 10m x 10m rooms and the 

7.5m x 1.5m corridor (see Figure 9-26 a-c).  Remember to make sure the Physical Distance 

option is selected [Tools>Physical Dist] and to use the Conx button when entering the number 

of nodes in order to automatically connect up the nodes as they are created. 
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(a) 

 
(b) 

 
(c) 

Figure 9-26: Creating the geometry 

 

Alternatively if the user has created the nodes using the Pack button then the geometry will 

look like Figure 9-27 
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Figure 9-27: Geometry created using Pack button 

 

NOTE: 

Once the nodes representing the two rooms and corridor have been created, remember to turn 

off the Node tool by selecting the  button from the tool bar to avoid the creation of unwanted 

nodes.  If unwanted nodes were created the user can delete these by either selecting 

[Edit>UNDO], dragging a selection box around the unwanted nodes and selecting 

[Edit>Delete>Node] or double click on each node and select the Delete button from the Node 

dialogue box. 

 

If the user dragged out regions to create the nodes representing the two rooms or corridor such 

that the three sections (two rooms and corridor) were not adjacent, they will not be connected 

when using the Auto Connect tool (see Figure 9-28). 

 

 
Figure 9-28: Geometry created with nodes not adjacent 

 

In order to move the nodes so they are adjacent the Object Lock needs to be turned off by 

deselecting [Edit>Object Lock] from the menu or by toggling the   button on the toolbar.  

Select the nodes to be moved and drag them into place.  As the nodes are moved they will 

“Snap” into place unless the user has turned off the Snap function.  This can be toggled by 

clicking the  button on the toolbar or by selecting [Edit>Node Align>Snap]. For this 

example leave Snap mode on.  Once the nodes have been aligned correctly, turn the Object 

Lock on in order to avoid accidently altering the geometry when making further edits. 

 

To complete the connection, select the nodes that need to be joined by arcs and then select 

Tools>Auto Connect>All 
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9.2.2 Connecting the Nodes and “Cleaning” up the Arcs 

Depending on the method used in the previous step, the Free-space nodes that comprise the 

internal geometry may need to be connected.  This is achieved by making sure that the Physical 

Dist setting is on [Tools>Physical Dist], dragging a selection box around all the nodes in the 

geometry and then selecting Tools>Auto Connect>All from the menu (see Figure 9-26c). 

 

If the Physical Dist option is not enabled then buildingEXODUS will use the current default 

arc length. This can be set by double clicking on the   button on the toolbar to open the 

Default Arc dialogue box (see Figure 9-29).  In general this value will be 0.5 unless the user 

needs to connect up nodes that represent two points separated by a distance other than 0.5m 

that is not represented by the physical distance between the nodes. 

 

 
Figure 9-29: Default Arc dialogue box 

 

NOTE: 

buildingEXODUS automatically calculates the length of the diagonal arcs. 

 

It can be seen that four redundant arcs connecting the corner nodes of the corridor to each of 

the side rooms (see Figure 9-30a) have been created.   These arcs should be deleted by double 

clicking on them and then selecting the DELETE button from the Arc dialogue box that appears 

(see Figure 9-30b).  

 

 
(a) 

 
(b) 

Figure 9-30: (a) Redundant arc connections can be removed (b) using the delete option 

in the Arc dialogue box. 
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NOTE: 

Care should be taken when NOT using the Physical Dist setting or using a default arc length 

other than 0.5m.  Checking an arc length is good practice in order to ensure the correct 

distances have been used as is carefully checking no unwanted connections have been created. 

 

9.2.3 Adding Exits 

To complete the geometry specification for this tutorial we must construct the external exits.  

The External Exit tool (available from [Tools>Generate>External Exit]) will be used to place 

the exits in the bottom left corner of Room1 (left) and in the middle of the bottom wall in Room2 

(right). 

 

To place a door the user should first select the External Exit tool from the toolbar and then point 

to the desired location and click.  The door icon should now appear in the Geometry Window 

in the desired location. 

 

Once the door is positioned in the desired location, it must be connected to the geometry.  This 

connection will be made manually through the use of the Arc tool (select Arc icon from 

toolbar).  As the door is 1.0m wide it must be connected to two nodes and hence two arcs are 

required.  Figure 9-31 shows the doors connected to the rooms. 

 

Note that the length of arcs connected to door is automatically set to zero. 

 

NOTE: 

Other door parameters are set in SCENARIO MODE. 

 

 
Figure 9-31: Room geometry complete with external doors. 

 

Now that the nodes defining the geometry have been defined the Boundary mode can be 

switched on [View>Boundary] (see Figure 9-32).  
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Figure 9-32: Geometry of room depicted in Boundary mode. 

 

9.2.4 Adding a population 

To specify a population you must be in POPULATION MODE. 

 

As the geometry is now completed the next step is to define and include the population.  We 

will first create the appropriate population panels, create the required number of people and 

then place them in the appropriate locations. 

 

To create the population the user should click on the POPULATION PANEL button  on the 

tool bar.  This will open the POPULATION EDITOR from which the user can add, delete or 

modify population groups (Panels). Initially the editor will contain the default standard 

population, which for the purposes of this tutorial will have to be deleted and new population 

panels created.  To delete all existing panels the user can click on the CLEAR button. 

 

To create a new population group click on the CREATE button.  This will create a population 

group in the Panels list box named Panel0.  An additional panel is required, this is generated 

by pressing the CREATE button one more time creating a second group called Panel1.  The 

newly created panels are formed with all the attributes assigned default values.  To customise 

the panels click twice on the desired group to bring up the Population Panel dialogue box (see 

Figure 9-33).  

  



Chapter 9 - Tutorial 2 

© 2017 University of Greenwich 173 

 

 
Figure 9-33: The Population Panel dialogue box allows the group characteristics to be 

specified. 

 

We will first modify Panel0.  This group will consist of males aged 65 to 80 years.  The first 

attribute to be modified is the group name.  From the initial Panel0 it should be changed to 

something meaningful such as “Males_65-80”.  This attribute is located at the top left side of 

the dialogue box.  The other attributes are altered according to Table 9-1  

 

Table 9-1: Attributes for group panel Males_65-80 

Attribute Min Max 

Response time (s) 50 120 

Drive  2 7 

Patience (s) 0  4 

Age (yrs) 65 80 

Agility 2 4 

 

Next select the Travel Speeds button and enter a Fast Walk range of 0.3m/s to 0.9m/s.  Click 

Ok to accept changes to the travel speeds and the SAVE button to accept and save all the 

alterations. 

 

The next group Panel1 will consist of females aged 65 to 80 years.  The panel name can be 

changed from Panel1 to Females_65-80 with the remaining attributes changed according to 

Table 9-2. 

 

Table 9-2: Attributes for group panel Females_65-80 

Attribute Min Max 

Response time (s) 50 120 

Drive  2 6 

Patience (s) 0  4 

Age (yrs) 65 80 

Agility 2 3 
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The Travel Speeds should be changed so the Fast Walk speed is 0.3m/s to 0.75m/s and also the 

Gender list box should be changed to indicate Female. 

 

NOTE: 

The attributes have been chosen to represent the attributes of older people in the population. 

The primary attributes affected are response times, which have been increased and travel 

speeds, which have been decreased. 

 

The population distribution for this example consists of 50% males and 50% females.  Enter 

these percentages alongside each panel (see Figure 9-34). 

 

 
Figure 9-34: The Population Editor 

 

As both panels have been created with the desired attributes a population based on these panels 

can now be generated.  However first a region needs to be selected to populate, otherwise it will 

fill all available nodes with people.  Within this example the left room should contain 40 people 

and right room 30.  The regions to populate can be selected while the Population Editor is still 

open, or the region can be selected and then the Population Editor opened.  By default the 

population size to be created will default to all available nodes within the selected region.  

Having selected a region in the left room (Room1), ensure that only Free Space nodes are 

selected (i.e. that all other Node Types are deselected) and also that the Selection allocation 

system is selected.  Enter 40 into the Total Pop. Size field in the Population Editor and click 

Populate.  Click Yes again to confirm the creation of 40 people.  Next select a region within the 

right room (Room2), open the Population Editor and again ensure that only Free Space nodes 

are selected (i.e. that all other Node Types are deselected) and also that the Selection allocation 

system is selected. Enter 30 people in the Total Pop. Size field and click Populate and Yes again 

to confirm. 

 

The population specification is now complete (see Figure 9-35), and we now progress to 

SCENARIO MODE. 
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Figure 9-35: The complete population 

 

9.2.5 Setting the evacuation scenario 

To specify the evacuation scenario (such as door parameters) you must be in SCENARIO 

MODE. 

 

In the first example both doors will be open and available immediately and will remain open 

throughout the simulation.  To set/change the door flow parameters the user should double click 

on each door icon.  This will bring up the DOOR dialogue box for the selected exit.  In this 

example we will set the flow characteristics to that recommended by HMSO with a +/- 10% 

variation.  The degree of variation required (10%) should be entered in the “-%” and “+%” edit 

boxes.  Check the door Status edit box is set to Open (default value) and the door Active edit 

box is set to Yes (default value).  This implies the door is available for use and will attract all 

the occupants. 

 

9.2.6 Determining the Maximum Travel Distance 

While in SCENARIO MODE, the maximum travel distance for the geometry can be determined.  

This is achieved by first double clicking on the exit door icon to bring up the DOOR dialogue 

box.  Then by pressing the MAX P button buildingEXODUS locates the point within the 

geometry that is furthest from any exit and highlights the path to the exit (see Figure 9-36).  The 

Max Path dialogue box will also appear, this displays an estimation for the maximum travel 

distance (see Figure 9-37).  In this case the first estimate for the maximum travel distance is 

13.23m and the estimated evacuation time is given as 70.24 seconds. 

 

NOTE: 

The MAXP function may be selected from either exit. 
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Figure 9-36: Maximum path highlighted. 

 
Figure 9-37: Estimated max 

travel distance and total 

evacuation time 

 

After using the REFINE option these values have changed to 13.61m for the estimated 

maximum travel distance and 71.51 seconds for the estimated evacuation time (see Figure 

9-38). 

 

  
(a) (b) 

Figure 9-38: Refined estimation of max path (a) and travel distance with evacuation 

time (b) 

 

The actual maximum distance can be calculated using simple trigonometry.  By studying 

various paths in the room we note that the correct location has been selected.  If we consider a 

right angle triangle in which the hypotenuse is the path of maximum travel distance, the 

hypotenuse would extend from the top right corner to the centre of the door.  Thus if we take 

the opposite side of the triangle to be 10m and the adjacent side to be 9.5m, this produces a 

maximum travel distance of 13.79m.  Thus the first estimate produces an error of 4.1% in the 

maximum travel distance while the refined estimate produces an error of 1.0%.  

 

NOTE: 

The Refine command is only enabled when the boundary view is active. 

 

9.2.7 Viewing the catchment area of an exit door 

Another function available in the DOOR dialogue box is the MAP function. This enables the 

catchment area of a door to be viewed.  

 

NOTE: 

The catchment area of a door is an indication of the area of influence exerted by the door.  It 

can be changed by altering the door exit potential thereby making it more or less attractive to 

the occupants. 
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To view the catchment area of the exit in Room1 double click on the door icon to open its 

dialogue box, and press the MAP button.  The results of this process are shown in Figure 9-39a.  

This process may also be repeated for the exit in Room2, the corresponding results are shown 

in Figure 9-39b. 

 

 
(a) 

 
(b) 

Figure 9-39: Viewing the catchment area of (a) Door 1 and (b) Door 2 

 

9.2.8 Running the simulation 

To run the simulation you must be in Simulation mode. 

 

Before running a simulation, select the Behaviour Options from the Rulebase menu.  In this 

example we will enable the Extreme Behaviour option from the Behaviour tab within the 

Behavior Options dialogue box. We will also choose to dump to our output file the following 

information for each occupant: Gender, Age, Agility, Drive, Fast wk, Patience, Response time, 

CWT, Distance travelled and PET. All these parameters can be set at the DATA OUTPUT 

CONTROL dialogue box which can be accessed from the Rulebase menu by selecting the Data 

Output option. 

 

This completes the setting of the parameters required to run the simulation. The simulation is 

started by pressing the PLAY button on the toolbar. The occupants will start moving towards 

the exits and interacting with each other. This interaction can be viewed on the screen in the 

Geometry Window (see Figure 9-40). Figure 9-40 shows the simulation in progress. You can 

keep track of the progress of the evacuation by noting the simulation time and number of people 

out which are displayed on the far right of the toolbar in the Geometry Window. 
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Figure 9-40: 93 seconds into the simulation. 

 

9.2.9 Graphs and Tables produced 

The following subsections indicate some of the output produced by buildingEXODUS for the 

simulation. 

 

9.2.9.1 The Graphs 

Three types of flow graphs are produced for each simulation. The first type of graph is placed 

in the DOOR dialogue box, where “door” is the name of the particular exit. It represents the 

total number of people out of the geometry through the particular exit named door as a function 

of time (see Figure 9-41a and Figure 9-41b). One of these windows is produced for each exit 

in the geometry. A new graph is drawn and the old deleted at the start of each simulation. The 

second type of graph is placed in the ALL EXITS window. It represents the total number of 

people out of the geometry through all the available exits as a function of time (see Figure 

9-41c). A new graph is drawn and the old deleted at the start of each simulation. The third type 

of graph is placed in the MAIN GRAPH window. Like the All Exits graph, it represents the total 

number of people out of the geometry through all the available exits as a function of time (see 

Figure 9-41d). However, unlike the All Exits graph the old data is not deleted when the new 

simulation is started. This allows the user to compare the results from one scenario simulation 

with another. 
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(a) (b) 

  
(c) (d) 

Figure 9-41: The graphical information produced for the first simulation for (a) door1, 

(b) door2, (c) All Exits and (d) Main Graph 

 

9.2.9.2 The summary window 

The Summary Window is iconised in the bottom of the Main buildingEXODUS window. By 

double clicking on this icon the following information is printed to the screen: 

 
<Geometry Summary:------> 

 Nodes  : 847 

 Lines  : 12      

 People : 70         

 Zones  : 0          

Door Summary:-----------> 

 Door_1          (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.20 1.46)(X   0)(P100.00) 

 Door_2          (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.20 1.46)(X   0)(P100.00) 

<-----------------------> 

 

The information presented is a summary of the geometry and population used in the last 

simulation. It presents the number of nodes in the simulation, the number of lines in the 

geometry, the number of people in the simulation, the number of zones (used in software level 

C), and the status of each external defined door (open, active, range of flow rates selected, 

number of people to use exit and exit potential) and the Undo summary. 

 

9.2.9.3 The output window 

The Output Window is accessible via the Output tab at the bottom of the Main 

buildingEXODUS Window (see Figure 9-40). This window contains all of the information 

requested when setting the Data Output Control dialogue box. By clicking on this tab this 

information is printed to the screen. The information is displayed in six sections. 

 

In this instance, the first section contains the user licence information (i.e. dongle number and 

software level), a brief summary of the results (i.e. the name of the geometry and number of 

people out) and information detailing the  performance of the simulation, such as the time and 

date that the simulation was started and completed, the total run time and the simulation seed 

used to generate the results. 
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The second section contains summary information relating to the population as a whole. The 

third section relates to the option settings applied during this simulation.  If the simulation 

contained a Fire and/or Hazard Scenario then a summary of these settings would appear before 

the Occupant Switches section.  The fourth section is a summary of the simulation, showing the 

number of people out, the time of the first person out and last person out, along with the overall 

evacuation time.  

 

The fifth section is the main section of the Output Window, it contains all the information 

requested in the Data Output Control dialogue box for each person.  The sixth section 

summarises the exit performance for each exit in the geometry. It lists the number of people to 

use the exit, the time of the first person out through the exit, the time of the last person out 

through the exit and the prescribed unit flow rate for the exit. Also displayed is the geometry 

OPS value. 

 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

           Simulation of T2_2.exo, with 70 People. 

              Started Thu Aug 29 12:01:24 2013  

         Initialisation time 0 (s). Run time 1 (s). 

                 Current Memory Usage 24404K 

           File Generated Thu Aug 29 12:01:26 2013 

                    SimSeed: 1377774084 

               buildingEXODUS  V6.0.0.822  x86 

                          LEVEL: C 

                         1077807400 

                   Expires on: 7 May 2014 

                             -- 

                             -- 

               buildingEXODUS is a product of 

                           G.U.E.L 

                       a subsidiary of 

                 the University of Greenwich 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Simulation Options Default 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Population Parameter Summary 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Attribute            | Average|     Min|     Max| 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Males                |      35|      35|      35| 

Female               |      35|      35|      35| 

Age                  |   72.99|   65.00|   80.00| 

Agility              |    2.67|    2.02|    3.98| 

Drive                |    4.08|    2.16|    6.71| 

FWalk (m/s)          |    0.55|    0.30|    0.90| 

Walk (m/s)           |    0.49|    0.27|    0.81| 

Crawl (m/s)          |    0.11|    0.06|    0.18| 

Leap (m/s)           |    0.44|    0.24|    0.72| 

Mobility             |    1.00|    1.00|    1.00| 

Patience (s)         |    2.07|    0.02|    3.99| 

Response (s)         |   89.51|   50.55|  119.98| 

Weight (kg)          |   63.48|   40.07|   88.94| 

Height (m)           |    1.76|    1.50|    2.00| 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Occupant Switches 

+++++++++++++++++++++++++++++++++++++++++++++++++ 

Switch               |Value       | 

+++++++++++++++++++++++++++++++++++ 

Local Familiarity    |OFF         | 

All Main Exits       |OFF         | 

Floor Potential Map  |OFF         | 

Local Potential      |ON          | 

Maintain Target Exit |OFF         | 

Maintain Itinerary   |OFF         | 

Transit Node Grouping|OFF         | 

Milling              |OFF         | 

Zone Events          |OFF         | 

Natural Movement     |OFF         | 

Extreme Behaviour    |OFF         | 

Impatient            |OFF         | 

Seat Jumping         |OFF         | 

Wall Proximity       |OFF         | 

Avoid Congestion     |OFF         | 

Social Response      |OFF         | 

Social Movement      |OFF         | 

Stair Spacing        |Staggered   | 

Stair Edge Pref.     |ON          | 

Crawling             |ON          | 

Smoke Stagger        |OFF         | 

Smoke Redirection    |OFF         | 

Smoke Visual Coef.   |        2.00| 

Signage System       |None        | 

Max Sim.             |OFF         | 

+++++++++++++++++++++++++++++++++++ 

Number of People out 70, first out (secs) 62.16  last 156.62 

Final Simulation time 156.62 (s) 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 
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++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Exit results table:- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Pos|Gender      |Start Node  |  Age|      Weight (kg)|Mobility|Response|End Node    |     CWT|Distance|     PET|Jumps| 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

    1|Male        |476         |   78|            85.44|    1.00|   52.13|Door_2      |    0.00|    7.16|   62.16|    0| 

    2|Female      |672         |   71|            62.01|    1.00|   50.55|Door_2      |    0.00|    7.91|   63.91|    0| 

    3|Male        |600         |   71|            49.91|    1.00|   55.00|Door_2      |    0.00|    3.91|   67.48|    0| 

    4|Male        |497         |   68|            87.41|    1.00|   58.52|Door_2      |    0.00|    6.95|   68.82|    0| 

    5|Female      |201         |   69|            77.07|    1.00|   54.20|Door_1      |    0.00|    4.62|   69.59|    0| 

    6|Male        |48          |   70|            78.39|    1.00|   65.18|Door_1      |    0.00|    7.21|   76.50|    0| 

    7|Male        |292         |   75|            72.52|    1.00|   53.45|Door_1      |    0.00|    9.16|   78.27|    0| 

    8|Male        |723         |   72|            63.67|    1.00|   69.15|Door_2      |    0.00|    2.62|   78.44|    0| 

    9|Male        |62          |   68|            63.09|    1.00|   76.66|Door_1      |    0.00|    1.00|   79.97|    0| 

   10|Female      |224         |   80|            88.43|    1.00|   53.67|Door_1      |    0.00|   11.07|   80.48|    0| 

   11|Male        |361         |   79|            53.67|    1.00|   58.84|Door_1      |    0.00|    8.62|   82.67|    0| 

   12|Male        |576         |   79|            54.67|    1.00|   74.40|Door_2      |    0.00|    6.12|   84.02|    0| 

   13|Female      |220         |   74|            45.95|    1.00|   76.74|Door_1      |    0.00|    4.91|   85.39|    0| 

   14|Female      |463         |   79|            54.36|    1.00|   77.33|Door_2      |    0.00|    5.33|   86.51|    0| 

   15|Male        |83          |   65|            43.14|    1.00|   75.15|Door_1      |    0.00|   10.12|   88.37|    0| 

   16|Male        |485         |   67|            72.84|    1.00|   82.10|Door_2      |    0.00|    4.41|   90.09|    0| 

   17|Female      |350         |   67|            68.32|    1.00|   69.88|Door_1      |    0.00|   11.07|   91.47|    0| 

   18|Male        |222         |   70|            51.16|    1.00|   86.39|Door_1      |    0.00|    4.50|   93.48|    0| 

   19|Male        |814         |   75|            50.84|    1.00|   67.68|Door_2      |    0.00|    8.16|   93.75|    0| 

   20|Male        |155         |   78|            56.54|    1.00|   82.78|Door_1      |    1.39|    5.83|   94.87|    0| 

   21|Female      |79          |   74|            59.60|    1.00|   87.87|Door_1      |    1.39|    1.91|   95.40|    0| 

   22|Male        |657         |   72|            48.12|    1.00|   83.38|Door_2      |    0.00|    5.00|   95.73|    0| 

   23|Female      |344         |   71|            81.13|    1.00|   58.97|Door_1      |    0.00|   12.90|   97.55|    0| 

   24|Male        |760         |   74|            64.03|    1.00|   86.27|Door_2      |    0.00|    4.83|   97.76|    0| 

   25|Male        |335         |   80|            51.74|    1.00|   79.93|Door_1      |    1.91|    9.66|   99.02|    0| 

   26|Male        |81          |   66|            88.94|    1.00|   92.77|Door_1      |    0.00|    2.12|   99.84|    0| 

   27|Female      |764         |   66|            55.21|    1.00|   92.62|Door_2      |    0.00|    3.12|  100.72|    0| 

   28|Female      |87          |   68|            41.83|    1.00|   87.19|Door_1      |    0.00|    8.12|  101.35|    0| 

   29|Male        |339         |   69|            58.29|    1.00|   86.47|Door_1      |    1.87|   10.04|  101.57|    0| 

   30|Female      |681         |   71|            41.05|    1.00|   93.50|Door_2      |    0.54|    3.41|  101.86|    0| 

   31|Female      |844         |   78|            67.98|    1.00|   88.71|Door_2      |    0.27|    6.12|  102.73|    0| 

   32|Male        |99          |   79|            46.31|    1.00|   95.80|Door_1      |    0.00|    2.12|  103.52|    0| 

   33|Female      |750         |   65|            71.35|    1.00|   82.18|Door_2      |    1.02|   10.54|  104.24|    0| 

   34|Male        |279         |   76|            77.58|    1.00|   91.04|Door_1      |    0.59|    8.36|  104.46|    0| 

   35|Male        |521         |   79|            41.40|    1.00|   91.48|Door_2      |    0.00|    4.24|  105.11|    0| 

   36|Female      |306         |   69|            43.27|    1.00|   69.15|Door_1      |    2.10|   11.78|  105.43|    0| 

   37|Female      |139         |   71|            72.57|    1.00|   94.54|Door_1      |    2.18|    4.04|  106.29|    0| 

   38|Male        |832         |   65|            69.20|    1.00|   93.37|Door_2      |    0.65|    9.86|  106.53|    0| 

   39|Female      |743         |   77|            87.22|    1.00|   99.22|Door_2      |    0.00|    2.83|  107.26|    0| 

   40|Female      |516         |   79|            62.73|    1.00|   90.36|Door_2      |    0.29|    7.04|  107.98|    0| 

   41|Female      |401         |   68|            48.52|    1.00|   74.33|Door_1      |    0.00|   10.04|  109.28|    0| 

   42|Female      |780         |   79|            52.49|    1.00|  100.47|Door_2      |    0.30|    5.24|  109.31|    0| 

   43|Male        |148         |   73|            45.95|    1.00|   91.11|Door_1      |    0.00|    8.45|  109.83|    0| 

   44|Female      |707         |   78|            56.78|    1.00|  106.07|Door_2      |    0.00|    1.71|  109.97|    0| 

   45|Male        |460         |   67|            42.44|    1.00|   99.89|Door_2      |    0.00|    5.95|  111.12|    0| 

   46|Female      |137         |   71|            73.33|    1.00|   99.11|Door_1      |    0.00|    3.54|  112.23|    0| 

   47|Male        |152         |   79|            77.76|    1.00|  103.00|Door_1      |    0.00|    7.45|  113.46|    0| 

   48|Female      |683         |   74|            78.40|    1.00|  109.94|Door_2      |    0.00|    2.21|  114.86|    0| 

   49|Female      |502         |   75|            78.80|    1.00|  101.62|Door_2      |    0.00|    4.54|  115.84|    0| 

   50|Female      |160         |   71|            82.84|    1.00|  104.31|Door_1      |    0.00|    3.41|  116.32|    0| 

   51|Male        |474         |   66|            49.15|    1.00|   99.06|Door_2      |    0.24|    8.86|  117.58|    0| 

   52|Female      |188         |   76|            81.90|    1.00|  101.26|Door_1      |    0.00|    8.95|  117.76|    0| 

   53|Male        |12          |   75|            51.62|    1.00|  108.33|Door_1      |    0.00|    5.00|  118.66|    0| 

   54|Male        |491         |   79|            45.72|    1.00|   94.89|Door_2      |    0.00|    9.45|  119.40|    0| 

   55|Female      |133         |   77|            87.93|    1.00|  109.16|Door_1      |    0.00|    6.24|  119.71|    0| 

   56|Male        |355         |   79|            83.03|    1.00|   99.64|Door_1      |    0.00|    9.45|  123.12|    0| 

   57|Female      |211         |   76|            56.93|    1.00|  105.50|Door_1      |    0.00|    7.66|  125.00|    0| 

   58|Male        |283         |   74|            55.74|    1.00|  109.44|Door_1      |    0.00|   12.19|  127.14|    0| 

   59|Male        |125         |   74|            49.97|    1.00|  105.32|Door_1      |    0.00|    9.74|  128.24|    0| 

   60|Male        |669         |   75|            84.77|    1.00|  111.49|Door_2      |    0.00|    9.21|  128.56|    0| 

   61|Female      |282         |   74|            77.69|    1.00|  117.96|Door_1      |    0.00|    6.71|  128.72|    0| 

   62|Female      |451         |   77|            60.46|    1.00|  109.19|Door_2      |    0.00|    9.86|  129.89|    0| 

   63|Female      |4           |   75|            40.07|    1.00|  112.53|Door_1      |    0.00|    9.00|  130.59|    0| 

   64|Female      |771         |   68|            65.57|    1.00|  118.18|Door_2      |    0.54|    9.24|  134.54|    0| 

   65|Female      |694         |   79|            66.21|    1.00|  117.39|Door_2      |    0.54|    7.12|  134.77|    0| 

   66|Female      |286         |   75|            75.90|    1.00|  103.16|Door_1      |    0.00|   10.69|  135.81|    0| 

   67|Male        |316         |   66|            63.55|    1.00|  118.05|Door_1      |    0.00|    8.24|  138.10|    0| 

   68|Female      |377         |   70|            82.76|    1.00|  112.06|Door_1      |    0.00|   10.45|  138.95|    0| 

   69|Male        |320         |   69|            63.70|    1.00|  118.88|Door_1      |    0.00|    8.54|  140.56|    0| 

   70|Female      |305         |   66|            54.40|    1.00|  119.98|Door_1      |    0.00|   11.40|  156.62|    0| 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Avg|            |            | 73.0|            63.48|    1.00|   89.51|            |    0.23|    6.99|  105.38|  0.0| 

Door performances :- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Ext. Exit Door_1          Number Used:   40  First Entry:  69.59 (s) Last : 156.62 (s) Avg PPM :  27.58 

 Flow Time:  87.03 (s) No Flow Time:  18.93 (s) MNS :  21.75 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

Ext. Exit Door_2          Number Used:   30  First Entry:  62.16 (s) Last : 134.77 (s) Avg PPM :  24.79 

 Flow Time:  72.61 (s) No Flow Time:  18.22 (s) MNS :  25.10 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

OPS = 0.140 

End of Door data 

 

As can be seen from this table the first person exited in 62.16 seconds from Door2 and the last 

in 156.62 seconds from Door1. A total of 30 people used Door2 and 40 people used Door1 

indicating that everyone used the closest exit.  The OPS for this simulation was 0.14 indicating 

a fairly efficient distribution of occupants between exits.  
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It is clear from the output which exit each person used to leave the enclosure as the last node 

has been selected in the Data Output Control dialogue box.  The low values for CWT incurred 

by most of the occupants indicates that very few conflicts and little queuing occurred. 

 

The output graph produced by Door2 (Figure 9-41b) suggests that Door2 dried up momentarily 

at around 70 seconds into the simulation.  The slope in the output graphs produced by Door1 

and Door2 suggest that the flow-rate achieved through these exist are approximately equal.  

However, the change in slope of the Door2 output graph (Figure 9-41a) after approximately 

100 seconds suggests that the flow-rate through Door2 doubled after this time.  

 

TIP: 

In geometries with more than one exit, it is useful to print out the last node option in the Data 

Output Control dialogue box as this will indicate the exit used by each occupant. 

 

9.2.10 Delayed Opening Time for Door2 

In the second example simulation, the opening time of exit Door2 will be altered so that it opens 

NOT at the start of the simulation, but 95 seconds into the evacuation.  To change the opening 

time of an exit, buildingEXODUS must be switched to SCENARIO MODE. 

 

 
Figure 9-42: Setting opening time for Door2 to 95 seconds. 

 

To set the opening time for exit Door2, double click on the Door2 icon to open the Door 

dialogue box and click the Times button. This will bring up the Edit Times dialogue box (Figure 

9-42). In this example the Events time field should contain only a single value; 95, indicating 

that the exit should change its state at 95 seconds into the simulation.  When this value is 

accepted, ensure that the Status field in the Door dialogue box is changed to Closed, indicating 

that the door is initially closed. 

 

NOTE: 

The Active attribute of Door2 is still set to YES. 

 

9.2.11 Running the simulation 

Move to SIMULATION MODE. 

 

Now that the scenario has been set, the simulation can start.  Press the PLAY button on the 

toolbar to start the simulation. 

 

NOTE: 

The identical population and starting locations are used as were used in the last simulation. 
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As Door2 does not open until 95 seconds into the evacuation, a crowd develops around the 

unopened door.  Figure 9-43 depicts the situation a few fractions of a second before the exit is 

due to open.  As can be seen a crowd develops around the exit while other occupants of Room2 

some of the other occupants have only just begun to move due to their long response time.  

While this situation is developing in Room2, 8 people have successfully evacuated through 

Door1.  

 

 
Figure 9-43: Before Door2 opens a crowd develops around it 

 

Figure 9-44 depicts the situation 10 seconds after Door2 has opened. 
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Figure 9-44: After 105 seconds occupants are flowing through both exits 

9.2.12 Graphs and Tables produced 

The same series of graphs and tables are produced for this example as were produced 

previously. 

 

9.2.12.1 The Graphs 

Figure 9-45 depicts the output graphs for this simulation. 
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(a) (b) 

 
(c) (d) 

Figure 9-45: Output graphs produced in example 2 for (a) Door1, (b)Door2, (c) All 

Exits and (d) Main Graph 

 

9.2.12.2 The summary window 

The summary window contains the following information. 

 
Door Summary:-----------> 

 Door_1          (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.20 1.46)(X  40)(P100.00) 

 Door_2          (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.20 1.46)(X  30)(P100.00) Times 

(secs):   95.0 

<-----------------------> 

 

9.2.12.3 The output window 

The Output Window contains the following information. 

 
+++++++++++++++++++++++++++++++++++ 

Number of People out 70, first out (secs) 69.67  last 156.65 

Final Simulation time 156.65 (s) 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Exit results table:- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Pos|Gender      |Start Node  |  Age|      Weight (kg)|Mobility|Response|End Node    |     CWT|Distance|     PET|Jumps| 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

    1|Female      |201         |   69|            77.07|    1.00|   54.20|Door_1      |    0.00|    4.62|   69.67|    0| 

    2|Male        |48          |   70|            78.39|    1.00|   65.18|Door_1      |    0.00|    7.41|   76.65|    0| 

    3|Male        |292         |   75|            72.52|    1.00|   53.45|Door_1      |    0.00|    8.86|   77.47|    0| 

    4|Male        |62          |   68|            63.09|    1.00|   76.66|Door_1      |    0.00|    0.50|   79.24|    0| 

    5|Female      |224         |   80|            88.43|    1.00|   53.67|Door_1      |    0.00|   11.57|   81.42|    0| 

    6|Male        |361         |   79|            53.67|    1.00|   58.84|Door_1      |    0.00|    8.62|   82.80|    0| 

    7|Female      |220         |   74|            45.95|    1.00|   76.74|Door_1      |    0.00|    4.91|   85.23|    0| 

    8|Male        |83          |   65|            43.14|    1.00|   75.15|Door_1      |    0.00|   10.12|   88.21|    0| 

    9|Female      |350         |   67|            68.32|    1.00|   69.88|Door_1      |    0.00|   10.78|   90.87|    0| 

   10|Female      |79          |   74|            59.60|    1.00|   87.87|Door_1      |    0.00|    1.91|   93.94|    0| 

   11|Male        |155         |   78|            56.54|    1.00|   82.78|Door_1      |    0.00|    6.54|   94.50|    0| 

   12|Male        |222         |   70|            51.16|    1.00|   86.39|Door_1      |    0.08|    6.41|   96.19|    0| 

   13|Female      |672         |   71|            62.01|    1.00|   50.55|Door_2      |   32.11|    8.12|   96.53|    0| 
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   14|Male        |476         |   78|            85.44|    1.00|   52.13|Door_2      |   32.85|    8.45|   96.58|    0| 

   15|Male        |81          |   66|            88.94|    1.00|   92.77|Door_1      |    0.00|    1.21|   97.44|    0| 

   16|Male        |576         |   79|            54.67|    1.00|   74.40|Door_2      |   13.27|    6.83|   98.19|    0| 

   17|Male        |600         |   71|            49.91|    1.00|   55.00|Door_2      |   27.67|    5.12|   98.30|    0| 

   18|Male        |335         |   80|            51.74|    1.00|   79.93|Door_1      |    0.00|   10.45|   98.36|    0| 

   19|Male        |485         |   67|            72.84|    1.00|   82.10|Door_2      |    8.70|    5.12|   99.73|    0| 

   20|Male        |339         |   69|            58.29|    1.00|   86.47|Door_1      |    1.98|    8.62|   99.93|    0| 

   21|Female      |463         |   79|            54.36|    1.00|   77.33|Door_2      |   13.58|    5.83|  100.78|    0| 

   22|Female      |344         |   71|            81.13|    1.00|   58.97|Door_1      |    0.62|   13.90|  100.92|    0| 

   23|Male        |657         |   72|            48.12|    1.00|   83.38|Door_2      |    3.30|    6.21|  101.51|    0| 

   24|Female      |87          |   68|            41.83|    1.00|   87.19|Door_1      |    0.00|    8.33|  101.72|    0| 

   25|Male        |497         |   68|            87.41|    1.00|   58.52|Door_2      |   31.29|    8.66|  102.54|    0| 

   26|Female      |750         |   65|            71.35|    1.00|   82.18|Door_2      |    0.55|   10.16|  103.07|    0| 

   27|Male        |99          |   79|            46.31|    1.00|   95.80|Door_1      |    0.00|    2.12|  103.64|    0| 

   28|Male        |279         |   76|            77.58|    1.00|   91.04|Door_1      |    0.51|    7.95|  103.66|    0| 

   29|Male        |723         |   72|            63.67|    1.00|   69.15|Door_2      |   23.17|    3.62|  104.44|    0| 

   30|Female      |681         |   71|            41.05|    1.00|   93.50|Door_2      |    2.15|    4.12|  104.72|    0| 

   31|Female      |139         |   71|            72.57|    1.00|   94.54|Door_1      |    1.22|    3.83|  105.08|    0| 

   32|Female      |306         |   69|            43.27|    1.00|   69.15|Door_1      |    0.88|   12.69|  106.62|    0| 

   33|Male        |760         |   74|            64.03|    1.00|   86.27|Door_2      |    5.78|    6.24|  106.67|    0| 

   34|Male        |521         |   79|            41.40|    1.00|   91.48|Door_2      |    0.63|    4.54|  106.71|    0| 

   35|Male        |832         |   65|            69.20|    1.00|   93.37|Door_2      |    0.87|   11.16|  108.34|    0| 

   36|Male        |814         |   75|            50.84|    1.00|   67.68|Door_2      |    6.84|   10.86|  108.68|    0| 

   37|Female      |401         |   68|            48.52|    1.00|   74.33|Door_1      |    0.00|   10.04|  109.30|    0| 

   38|Male        |148         |   73|            45.95|    1.00|   91.11|Door_1      |    0.00|    8.45|  109.60|    0| 

   39|Female      |707         |   78|            56.78|    1.00|  106.07|Door_2      |    0.67|    1.41|  110.14|    0| 

   40|Female      |844         |   78|            67.98|    1.00|   88.71|Door_2      |    4.86|    7.74|  110.43|    0| 

   41|Female      |764         |   66|            55.21|    1.00|   92.62|Door_2      |    6.23|    5.41|  111.84|    0| 

   42|Male        |152         |   79|            77.76|    1.00|  103.00|Door_1      |    0.00|    6.45|  112.09|    0| 

   43|Female      |137         |   71|            73.33|    1.00|   99.11|Door_1      |    0.00|    3.54|  112.50|    0| 

   44|Male        |460         |   67|            42.44|    1.00|   99.89|Door_2      |    1.48|    5.95|  112.74|    0| 

   45|Female      |780         |   79|            52.49|    1.00|  100.47|Door_2      |    1.34|    7.45|  113.40|    0| 

   46|Female      |516         |   79|            62.73|    1.00|   90.36|Door_2      |    3.91|    8.16|  114.14|    0| 

   47|Female      |683         |   74|            78.40|    1.00|  109.94|Door_2      |    0.19|    2.21|  115.24|    0| 

   48|Female      |502         |   75|            78.80|    1.00|  101.62|Door_2      |    0.47|    4.54|  116.19|    0| 

   49|Female      |160         |   71|            82.84|    1.00|  104.31|Door_1      |    0.00|    3.41|  116.35|    0| 

   50|Male        |474         |   66|            49.15|    1.00|   99.06|Door_2      |    0.13|    8.66|  117.06|    0| 

   51|Female      |188         |   76|            81.90|    1.00|  101.26|Door_1      |    0.00|    8.95|  117.83|    0| 

   52|Male        |12          |   75|            51.62|    1.00|  108.33|Door_1      |    0.00|    5.00|  118.58|    0| 

   53|Female      |743         |   77|            87.22|    1.00|   99.22|Door_2      |    6.88|    4.83|  118.59|    0| 

   54|Male        |491         |   79|            45.72|    1.00|   94.89|Door_2      |    0.00|    9.45|  119.30|    0| 

   55|Female      |133         |   77|            87.93|    1.00|  109.16|Door_1      |    0.00|    6.24|  119.65|    0| 

   56|Male        |355         |   79|            83.03|    1.00|   99.64|Door_1      |    0.00|    9.45|  122.95|    0| 

   57|Female      |211         |   76|            56.93|    1.00|  105.50|Door_1      |    0.00|    7.66|  124.88|    0| 

   58|Male        |283         |   74|            55.74|    1.00|  109.44|Door_1      |    0.00|   12.19|  127.15|    0| 

   59|Male        |669         |   75|            84.77|    1.00|  111.49|Door_2      |    0.00|    9.21|  128.41|    0| 

   60|Male        |125         |   74|            49.97|    1.00|  105.32|Door_1      |    0.00|    9.74|  128.46|    0| 

   61|Female      |282         |   74|            77.69|    1.00|  117.96|Door_1      |    0.00|    6.71|  128.57|    0| 

   62|Female      |451         |   77|            60.46|    1.00|  109.19|Door_2      |    0.00|    9.86|  129.95|    0| 

   63|Female      |4           |   75|            40.07|    1.00|  112.53|Door_1      |    0.00|    9.00|  130.55|    0| 

   64|Female      |694         |   79|            66.21|    1.00|  117.39|Door_2      |    0.00|    6.91|  133.99|    0| 

   65|Female      |286         |   75|            75.90|    1.00|  103.16|Door_1      |    0.00|   10.69|  135.74|    0| 

   66|Female      |771         |   68|            65.57|    1.00|  118.18|Door_2      |    0.00|   10.45|  135.77|    0| 

   67|Female      |377         |   70|            82.76|    1.00|  112.06|Door_1      |    0.00|   10.24|  138.46|    0| 

   68|Male        |320         |   69|            63.70|    1.00|  118.88|Door_1      |    2.08|    7.41|  139.98|    0| 

   69|Male        |316         |   66|            63.55|    1.00|  118.05|Door_1      |    1.30|    8.74|  140.45|    0| 

   70|Female      |305         |   66|            54.40|    1.00|  119.98|Door_1      |    0.00|   11.40|  156.65|    0| 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Avg|            |            | 73.0|            63.48|    1.00|   89.51|            |    3.39|    7.34|  109.25|  0.0| 

Door performances :- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Ext. Exit Door_1          Number Used:   40  First Entry:  69.67 (s) Last : 156.65 (s) Avg PPM :  27.59 

 Flow Time:  86.98 (s) No Flow Time:  19.68 (s) MNS :  22.63 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

Ext. Exit Door_2          Number Used:   30  First Entry:  96.53 (s) Last : 135.77 (s) Avg PPM :  45.87 

 Flow Time:  39.24 (s) No Flow Time:   6.82 (s) MNS :  17.38 (%) Opened:  1 Closed:  0 

 Event Times (Secs) :   95.0 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

OPS = 0.133 

End of Door data 

 

As can be seen from this table the first person exited in 69.67 seconds from Door1 and the last 

in 156.65 seconds from Door1.  A total of 30 people used Door2 and 40 people used Door1 

indicating that everyone used the closest exit.  The OPS for this simulation was 0.133 indicating 

a fairly inefficient distribution of occupants between exits.  

 

The high CWT values incurred by some of the occupants indicates that these occupants were 

involved in queuing at the closed exit.  For the most part the occupants with the largest CWT 

also have the smallest Response Times indicating that they were the first to start moving and 

hence had to wait at the closed exit. 

 

While the output graph for Door1 shows little change compared with the last example, the 

Door2 output graph shows marked differences.  The step initial slope in the Door2 output graph 

indicates a sizeable flow-rate was initially achieved through this exit.  After approximately 120 

seconds the slope decreases to about a third of its original value indicating a marked decrease 
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in the flow-rate.  This is in contrast to what was achieved in the first example where we find a 

comparatively constant slow flow-rate.  The combined effect of long initial response time and 

large initial flow-rate results in this example producing a similar result to the previous example. 

 

TIP: 

It can be extremely useful to select additional graphical output data when configuring the DATA 

OUTPUT CONTROL dialogue box. The Time-Span option will produce flow-rate information 

which can be graphed to reveal the manner in which the flow-rate varies for each exit during 

the simulation. 

 

9.2.13 Opening and Closing an Exit During a Scenario 

For the third example exit Door1 will be closed for the first 85 seconds of the simulation.  After 

this delay it will open only for a period of 10 seconds, i.e. it will close at 95 seconds, preventing 

any further occupants from exiting. Whilst Door1 will exhibit this behaviour, Door2 will 

remain open throughout the simulation. 

 

To alter the event times, return to SCENARIO MODE. 

 

 
Figure 9-46: Setting opening and closing times for Door1. 

 

To set the times for Door1, double click on the Door1 icon to reveal its dialogue box.  Click 

the Times button to reveal the Edit Times dialogue box.  In this example the Event times field 

should be set to "85 95" indicating that the door will change its state at 85 seconds and again at 

95 seconds into the simulation (see Figure 9-46).  Multiple event times can be entered in this 

way by ensuring the values are separated by a space.  Ensure that the initial state of the door is 

Closed.  

 

As Door2 will remain open throughout the simulation, ensure that the Event Times field has 

been cleared and that the initial status is open. 
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9.2.14 Running the simulation 

Move to SIMULATION MODE. 

 

Now that the scenario has been set the simulation of the evacuation can start.  Using the previous 

settings, press the PLAY button on the toolbar to start the simulation. 

 

NOTE: 

The identical population and starting locations are used as were used in the last two 

simulations. 

 

Figure 9-47 depicts the status of the simulation after 84.8 seconds into the evacuation. Door1 

has not opened and a crowd is beginning to form around the exit. A total of 6 people have 

already successfully evacuated through Door2 while a number of people in both rooms have 

not even begun to move due to long response times. 

 

 
Figure 9-47: Status of evacuation prior to the opening of Door1. 

 

Figure 9-48 depicts the status of the evacuation 94.8 seconds into the simulation, fractions of a 

second before Door1 closes again. At this stage 9 people have managed to use Door1. 
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Figure 9-48: Status of evacuation a fraction of a second before Door1 closes again. 

 

 
Figure 9-49: Door1 has closed again and the occupants of Room1 head for Door2 via the 

connecting corridor. 

 

Figure 9-49 depicts the status of the evacuation 121.80 seconds into the simulation.  Door1 has 

closed again and the occupants of Room1 are heading for the Door2 through the connecting 

corridor. 

 

In buildingEXODUS it is possible to interrogate occupants to find for example, their travel 

path.  Using the Edit>Select>People Select from the menu or clicking the  button, double 
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click on a person in the simulation or from the Exit List window at the bottom.  Then click the 

Path button on their corresponding Person dialogue box.  In Figure 9-50 four occupants have 

been interrogated to reveal their respective travel paths.  In this figure, we can see that Occupant 

1 started in Room 2 and simply headed for the exit in that room.  The other three occupants 

started in Room 1 and had different degrees of difficulty in evacuating.  Occupant 2 had not 

started to egress by the time Door1 had closed, and thus headed directly for Door2.  However, 

he faced some difficulty in moving through the congested corridor thus his path can be seen to 

weave through the corridor.  Occupant 3 had a starting location close to Door1 and was forced 

to queue at this door.  Unfortunately, before he could pass through the door, the door was closed 

and no longer available.  This occupant then headed for Door2 requiring him to retrace his first 

few steps.  The final occupant, Occupant 4 successfully egressed through Door1, although the 

initial starting location was further away than that of Occupant 3. 

 

 
Figure 9-50: Interrogating four occupants to reveal their travel path 

 

9.2.15 Graphs and Tables produced 

The same series of graphs and tables are produced for this simulation as for the previous 

simulation. 
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9.2.15.1 The Graphs 

 

  
(a) (b) 

  
(c) (d) 

Figure 9-51: Graphs produced for (a) Door1, (b) Door2, (c) All Exits, and (d) The Main 

Graph 

 

Figure 9-51 depicts the graphs for this simulation. 

 

9.2.15.2 The summary window 

The Summary Window contains the following information.  

 
Door Summary:-----------> 

 Door_1          (Off)  (Inactive)(Unit Flow Rt (occ/m/s) 1.20 1.46)(X  11)(P100.00) Times (secs):   85.0   95.0 

 Door_2          (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.20 1.46)(X  59)(P100.00) 

<-----------------------> 

 

9.2.15.3 The output window 

The Output Window contains the following information. 

 
+++++++++++++++++++++++++++++++++++ 
Number of People out 70, first out (secs) 61.95  last 186.30 

Final Simulation time 186.30 (s) 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Exit results table:- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Pos|Gender      |Start Node  |  Age|      Weight (kg)|Mobility|Response|End Node    |     CWT|Distance|     PET|Jumps| 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

    1|Male        |476         |   78|            85.44|    1.00|   52.13|Door_2      |    0.00|    7.16|   61.95|    0| 

    2|Female      |672         |   71|            62.01|    1.00|   50.55|Door_2      |    0.00|    7.91|   63.99|    0| 

    3|Male        |600         |   71|            49.91|    1.00|   55.00|Door_2      |    0.00|    3.91|   67.45|    0| 

    4|Male        |497         |   68|            87.41|    1.00|   58.52|Door_2      |    0.00|    6.95|   68.90|    0| 

    5|Male        |723         |   72|            63.67|    1.00|   69.15|Door_2      |    0.00|    2.62|   78.45|    0| 

    6|Male        |576         |   79|            54.67|    1.00|   74.40|Door_2      |    0.00|    6.12|   83.87|    0| 

    7|Female      |201         |   69|            77.07|    1.00|   54.20|Door_1      |    9.35|    7.12|   86.29|    0| 

    8|Female      |463         |   79|            54.36|    1.00|   77.33|Door_2      |    0.00|    5.33|   86.29|    0| 

    9|Male        |48          |   70|            78.39|    1.00|   65.18|Door_1      |    9.41|    7.62|   86.43|    0| 
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   10|Female      |224         |   80|            88.43|    1.00|   53.67|Door_1      |    7.89|   11.28|   88.66|    0| 

   11|Male        |361         |   79|            53.67|    1.00|   58.84|Door_1      |    3.99|    9.45|   88.71|    0| 

   12|Male        |485         |   67|            72.84|    1.00|   82.10|Door_2      |    0.00|    4.41|   89.99|    0| 

   13|Female      |220         |   74|            45.95|    1.00|   76.74|Door_1      |    3.94|    5.62|   90.22|    0| 

   14|Male        |292         |   75|            72.52|    1.00|   53.45|Door_1      |   12.01|    9.36|   90.68|    0| 

   15|Male        |83          |   65|            43.14|    1.00|   75.15|Door_1      |    2.86|   10.83|   91.84|    0| 

   16|Female      |350         |   67|            68.32|    1.00|   69.88|Door_1      |    1.03|   11.69|   93.43|    0| 

   17|Male        |62          |   68|            63.09|    1.00|   76.66|Door_1      |   11.92|    1.91|   93.52|    0| 

   18|Male        |155         |   78|            56.54|    1.00|   82.78|Door_1      |    1.88|    5.62|   95.04|    0| 

   19|Female      |79          |   74|            59.60|    1.00|   87.87|Door_1      |    0.00|    2.41|   95.16|    0| 

   20|Male        |814         |   75|            50.84|    1.00|   67.68|Door_2      |    0.00|    8.86|   95.91|    0| 

   21|Male        |657         |   72|            48.12|    1.00|   83.38|Door_2      |    0.00|    5.21|   96.15|    0| 

   22|Male        |760         |   74|            64.03|    1.00|   86.27|Door_2      |    0.00|    4.83|   97.78|    0| 

   23|Female      |764         |   66|            55.21|    1.00|   92.62|Door_2      |    0.00|    3.12|  100.83|    0| 

   24|Female      |681         |   71|            41.05|    1.00|   93.50|Door_2      |    0.51|    3.41|  101.60|    0| 

   25|Female      |750         |   65|            71.35|    1.00|   82.18|Door_2      |    0.51|    9.83|  102.47|    0| 

   26|Female      |844         |   78|            67.98|    1.00|   88.71|Door_2      |    1.04|    6.04|  103.09|    0| 

   27|Male        |521         |   79|            41.40|    1.00|   91.48|Door_2      |    0.00|    4.24|  105.28|    0| 

   28|Male        |832         |   65|            69.20|    1.00|   93.37|Door_2      |    0.00|    9.36|  105.29|    0| 

   29|Female      |516         |   79|            62.73|    1.00|   90.36|Door_2      |    0.00|    6.74|  107.18|    0| 

   30|Female      |743         |   77|            87.22|    1.00|   99.22|Door_2      |    0.00|    2.83|  107.21|    0| 

   31|Female      |780         |   79|            52.49|    1.00|  100.47|Door_2      |    0.00|    5.24|  109.07|    0| 

   32|Female      |707         |   78|            56.78|    1.00|  106.07|Door_2      |    0.00|    1.71|  109.84|    0| 

   33|Male        |460         |   67|            42.44|    1.00|   99.89|Door_2      |    0.00|    5.95|  111.20|    0| 

   34|Female      |683         |   74|            78.40|    1.00|  109.94|Door_2      |    0.00|    2.21|  114.96|    0| 

   35|Female      |502         |   75|            78.80|    1.00|  101.62|Door_2      |    0.00|    4.54|  115.65|    0| 

   36|Male        |474         |   66|            49.15|    1.00|   99.06|Door_2      |    0.00|    9.24|  117.96|    0| 

   37|Male        |491         |   79|            45.72|    1.00|   94.89|Door_2      |    0.00|    9.45|  119.45|    0| 

   38|Male        |279         |   76|            77.58|    1.00|   91.04|Door_2      |    0.00|   24.85|  125.58|    0| 

   39|Male        |339         |   69|            58.29|    1.00|   86.47|Door_2      |    0.00|   34.26|  127.11|    0| 

   40|Male        |669         |   75|            84.77|    1.00|  111.49|Door_2      |    1.24|    9.71|  130.45|    0| 

   41|Male        |222         |   70|            51.16|    1.00|   86.39|Door_2      |    1.30|   32.93|  130.81|    0| 

   42|Female      |451         |   77|            60.46|    1.00|  109.19|Door_2      |    1.86|   10.16|  132.14|    0| 

   43|Male        |152         |   79|            77.76|    1.00|  103.00|Door_2      |    1.01|   22.73|  132.29|    0| 

   44|Female      |694         |   79|            66.21|    1.00|  117.39|Door_2      |    0.00|    6.91|  133.86|    0| 

   45|Female      |771         |   68|            65.57|    1.00|  118.18|Door_2      |    0.00|    9.45|  134.21|    0| 

   46|Female      |188         |   76|            81.90|    1.00|  101.26|Door_2      |    0.00|   20.69|  137.43|    0| 

   47|Female      |87          |   68|            41.83|    1.00|   87.19|Door_2      |    1.50|   31.73|  139.28|    0| 

   48|Male        |355         |   79|            83.03|    1.00|   99.64|Door_2      |    0.00|   17.19|  140.90|    0| 

   49|Male        |283         |   74|            55.74|    1.00|  109.44|Door_2      |    1.17|   22.14|  141.39|    0| 

   50|Male        |335         |   80|            51.74|    1.00|   79.93|Door_2      |    3.63|   35.68|  143.05|    0| 

   51|Female      |133         |   77|            87.93|    1.00|  109.16|Door_2      |    1.78|   24.35|  146.87|    0| 

   52|Male        |148         |   73|            45.95|    1.00|   91.11|Door_2      |    3.75|   25.93|  148.57|    0| 

   53|Female      |282         |   74|            77.69|    1.00|  117.96|Door_2      |    1.58|   21.35|  150.17|    0| 

   54|Female      |139         |   71|            72.57|    1.00|   94.54|Door_2      |    2.51|   25.85|  150.72|    0| 

   55|Female      |211         |   76|            56.93|    1.00|  105.50|Door_2      |    0.00|   20.52|  154.71|    0| 

   56|Male        |125         |   74|            49.97|    1.00|  105.32|Door_2      |    0.59|   23.35|  158.89|    0| 

   57|Male        |12          |   75|            51.62|    1.00|  108.33|Door_2      |    3.85|   26.90|  160.41|    0| 

   58|Female      |377         |   70|            82.76|    1.00|  112.06|Door_2      |    2.00|   18.90|  161.35|    0| 

   59|Male        |316         |   66|            63.55|    1.00|  118.05|Door_2      |    1.51|   18.40|  162.36|    0| 

   60|Female      |286         |   75|            75.90|    1.00|  103.16|Door_2      |    1.31|   19.81|  163.67|    0| 

   61|Female      |306         |   69|            43.27|    1.00|   69.15|Door_2      |    0.22|   35.13|  167.93|    0| 

   62|Male        |81          |   66|            88.94|    1.00|   92.77|Door_2      |    1.77|   29.47|  169.75|    0| 

   63|Male        |99          |   79|            46.31|    1.00|   95.80|Door_2      |    3.34|   23.93|  170.02|    0| 

   64|Female      |4           |   75|            40.07|    1.00|  112.53|Door_2      |    2.33|   29.97|  171.75|    0| 

   65|Female      |344         |   71|            81.13|    1.00|   58.97|Door_2      |    5.03|   38.13|  174.48|    0| 

   66|Male        |320         |   69|            63.70|    1.00|  118.88|Door_2      |    3.09|   22.35|  176.01|    0| 

   67|Female      |401         |   68|            48.52|    1.00|   74.33|Door_2      |    2.38|   30.80|  180.50|    0| 

   68|Female      |137         |   71|            73.33|    1.00|   99.11|Door_2      |    4.31|   24.06|  184.10|    0| 

   69|Female      |160         |   71|            82.84|    1.00|  104.31|Door_2      |    4.96|   24.43|  184.60|    0| 

   70|Female      |305         |   66|            54.40|    1.00|  119.98|Door_2      |    0.00|   21.02|  186.30|    0| 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Avg|            |            | 73.0|            63.48|    1.00|   89.51|            |    1.78|   14.47|  122.76|  0.0| 

Door performances :- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Ext. Exit Door_1          Number Used:   11  First Entry:  86.29 (s) Last :  95.16 (s) Avg PPM :  74.40 

 Flow Time:   8.87 (s) No Flow Time:   0.00 (s) MNS :   0.00 (%) Opened:  1 Closed:  1 

 Event Times (Secs) :   85.0   95.0 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

Ext. Exit Door_2          Number Used:   59  First Entry:  61.95 (s) Last : 186.30 (s) Avg PPM :  28.47 

 Flow Time: 124.35 (s) No Flow Time:  21.35 (s) MNS :  17.17 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

OPS = 0.489 

End of Door data 

 

As can be seen from this output the first person exited in 61.95 seconds from Door2 and the 

last in 186.3 seconds from Door2. A total of 59 people used Door2 and 11 people used Door1 

indicating that 29 people from Room1 travelled to Room2 in order to use Door2.  The OPS for 

this simulation was 0.489 indicating an inefficient distribution of occupants between exits.  

 

The high values for the distance travelled indicates that a number of occupants had to travel to 

an exit that was not their closest exit in order to evacuate from the enclosure.  The exit curves 

for this simulation (see Figure 9-51) suggest that considerable changes in flow-rate occurred at 

various stages through the simulation.  The relatively long evacuation time for this evacuation 

is a result of the extra travel distance some of the occupants incurred. 
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9.2.16 Altering the Exit Potential 

Move to SCENARIO MODE. 

 

For the fourth example the Potential of the Door1 will be increased relative to Door2.  This 

will decrease this exits influence in the geometry.  The exit Potential will arbitrarily be set to 

110 in this example.  To change the exit Potential double click on the Door1 icon to open the 

Door dialogue box.  In the Potential field enter the value 110 and click on the Apply button 

(Figure 9-52).  To view the catchment area of Door1 click on the Map button. 

 

 
Figure 9-52: Change exit potential for Door1. 

 

Figure 9-53 depicts the new extent of the catchment area of Door1. All occupants in the hatched 

area will be attracted to Door1. 

 

 
Figure 9-53: Catchment area of Door1. 

 

The catchment area of Door2 can be found in a similar manner by clicking on the Map button 

in the Door2 dialogue box (Figure 9-54). 

 

NOTE: 

In this scenario both doors should be open and active throughout the simulation.  Therefore 

any event times that still exist in the Edit Times dialogue boxes of each door should be deleted.  

This can be done by double clicking on the Times button of the Door dialogue box and deleting 

the values found in the Event Times field. 
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Figure 9-54: Catchment area of Door2. 

 

NOTE: 

The Potential Assignment capability in Scenario mode [Tools>Potential Assignment] allows 

the user to manipulate the Potential attributes of all of the external exits within the same 

window. This makes for easier manipulation with less likelihood of errors being made. 

 

9.2.17 Running the simulation 

Move to SIMULATION MODE. 

 

 
Figure 9-55: Status of evacuation after 80 seconds. 

 

Now that the scenario has been set the simulation of the evacuation can start. Using the previous 

settings, press the PLAY button on the toolbar to start the simulation. 

 

NOTE: 

The identical population and starting locations are used as were used in the last simulation. 
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Figure 9-55 depicts the status of the simulation after approximately 80 seconds.  Three people 

have used Door1 while five people have used Door2.  Also note that several people are in the 

corridor space heading for Room2.  Figure 9-56 depicts the status of the evacuation after 122.0 

seconds.  At this stage most of the occupants from Room1 have either evacuated through Door1 

or made their way to Room2 and out Door2. 

 

 
Figure 9-56: Status of evacuation after 122.0 seconds 

 

9.2.18 Graphs and Tables produced 

The same series of graphs and tables are produced for this simulation as for the previous 

simulation. 
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9.2.18.1 The Graphs 

Figure 9-57 depicts the graphs for this simulation. 

 

  
(a) (b) 

  
(c) (d) 

Figure 9-57: Output graphs produced for example 4 for, (a) Door1, (b)Door2, (c) 

All Exits and (d) The Main Graph 

 

9.2.19 The summary window 

The Summary Window contains the following information. 

 
Door Summary:-----------> 

 Door_1          (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.20 1.46)(X  25)(P110.00) 

 Door_2          (Open) (Active)  (Unit Flow Rt (occ/m/s) 1.20 1.46)(X  45)(P100.00) 

<-----------------------> 

 

9.2.20 The output window 

 

The Output Window contains the following information. 

 
+++++++++++++++++++++++++++++++++++ 

Number of People out 70, first out (secs) 62.21  last 179.69 

Final Simulation time 179.69 (s) 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Exit results table:- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Pos|Gender      |Start Node  |  Age|      Weight (kg)|Mobility|Response|End Node    |     CWT|Distance|     PET|Jumps| 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

    1|Male        |476         |   78|            85.44|    1.00|   52.13|Door_2      |    0.00|    7.16|   62.21|    0| 

    2|Female      |672         |   71|            62.01|    1.00|   50.55|Door_2      |    0.00|    8.12|   64.35|    0| 

    3|Male        |600         |   71|            49.91|    1.00|   55.00|Door_2      |    0.00|    3.91|   67.56|    0| 

    4|Male        |497         |   68|            87.41|    1.00|   58.52|Door_2      |    0.00|    7.24|   69.43|    0| 

    5|Female      |201         |   69|            77.07|    1.00|   54.20|Door_1      |    0.00|    4.62|   69.62|    0| 

    6|Male        |48          |   70|            78.39|    1.00|   65.18|Door_1      |    0.00|    7.21|   76.47|    0| 

    7|Male        |723         |   72|            63.67|    1.00|   69.15|Door_2      |    0.00|    2.62|   78.53|    0| 

    8|Male        |62          |   68|            63.09|    1.00|   76.66|Door_1      |    0.00|    0.50|   79.20|    0| 
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    9|Male        |576         |   79|            54.67|    1.00|   74.40|Door_2      |    0.00|    6.12|   83.93|    0| 

   10|Female      |220         |   74|            45.95|    1.00|   76.74|Door_1      |    0.00|    4.91|   85.39|    0| 

   11|Female      |463         |   79|            54.36|    1.00|   77.33|Door_2      |    0.00|    5.33|   86.46|    0| 

   12|Male        |83          |   65|            43.14|    1.00|   75.15|Door_1      |    0.00|   10.12|   88.24|    0| 

   13|Male        |485         |   67|            72.84|    1.00|   82.10|Door_2      |    0.00|    4.41|   89.99|    0| 

   14|Male        |155         |   78|            56.54|    1.00|   82.78|Door_1      |    0.00|    5.04|   92.17|    0| 

   15|Male        |814         |   75|            50.84|    1.00|   67.68|Door_2      |    0.00|    8.16|   93.60|    0| 

   16|Female      |79          |   74|            59.60|    1.00|   87.87|Door_1      |    0.00|    1.91|   93.84|    0| 

   17|Male        |222         |   70|            51.16|    1.00|   86.39|Door_1      |    0.00|    5.41|   94.79|    0| 

   18|Male        |657         |   72|            48.12|    1.00|   83.38|Door_2      |    0.00|    5.00|   95.63|    0| 

   19|Male        |81          |   66|            88.94|    1.00|   92.77|Door_1      |    0.00|    1.21|   97.32|    0| 

   20|Male        |760         |   74|            64.03|    1.00|   86.27|Door_2      |    0.00|    4.54|   97.36|    0| 

   21|Male        |292         |   75|            72.52|    1.00|   53.45|Door_2      |    0.00|   17.36|   98.86|    0| 

   22|Female      |764         |   66|            55.21|    1.00|   92.62|Door_2      |    0.00|    3.12|  100.90|    0| 

   23|Female      |87          |   68|            41.83|    1.00|   87.19|Door_1      |    0.00|    8.12|  101.38|    0| 

   24|Female      |681         |   71|            41.05|    1.00|   93.50|Door_2      |    0.60|    3.41|  101.69|    0| 

   25|Female      |750         |   65|            71.35|    1.00|   82.18|Door_2      |    0.60|    9.83|  102.68|    0| 

   26|Male        |279         |   76|            77.58|    1.00|   91.04|Door_1      |    1.68|    6.62|  103.01|    0| 

   27|Female      |139         |   71|            72.57|    1.00|   94.54|Door_1      |    0.00|    3.62|  103.29|    0| 

   28|Female      |224         |   80|            88.43|    1.00|   53.67|Door_2      |    0.69|   21.11|  103.84|    0| 

   29|Female      |350         |   67|            68.32|    1.00|   69.88|Door_2      |    0.69|   18.49|  105.34|    0| 

   30|Female      |844         |   78|            67.98|    1.00|   88.71|Door_2      |    1.85|    6.74|  105.57|    0| 

   31|Male        |99          |   79|            46.31|    1.00|   95.80|Door_1      |    0.00|    3.12|  106.39|    0| 

   32|Male        |832         |   65|            69.20|    1.00|   93.37|Door_2      |    0.36|   10.57|  107.00|    0| 

   33|Female      |743         |   77|            87.22|    1.00|   99.22|Door_2      |    0.00|    2.83|  107.05|    0| 

   34|Female      |516         |   79|            62.73|    1.00|   90.36|Door_2      |    0.13|    7.33|  108.46|    0| 

   35|Female      |780         |   79|            52.49|    1.00|  100.47|Door_2      |    0.14|    4.74|  108.68|    0| 

   36|Male        |148         |   73|            45.95|    1.00|   91.11|Door_1      |    0.00|    8.24|  109.38|    0| 

   37|Female      |707         |   78|            56.78|    1.00|  106.07|Door_2      |    1.30|    1.00|  110.33|    0| 

   38|Male        |521         |   79|            41.40|    1.00|   91.48|Door_2      |    1.46|    5.83|  111.23|    0| 

   39|Male        |460         |   67|            42.44|    1.00|   99.89|Door_2      |    0.18|    6.45|  112.04|    0| 

   40|Female      |137         |   71|            73.33|    1.00|   99.11|Door_1      |    0.00|    3.54|  112.27|    0| 

   41|Male        |361         |   79|            53.67|    1.00|   58.84|Door_2      |    1.78|   19.66|  113.05|    0| 

   42|Male        |152         |   79|            77.76|    1.00|  103.00|Door_1      |    0.00|    7.45|  113.41|    0| 

   43|Male        |339         |   69|            58.29|    1.00|   86.47|Door_2      |    1.52|   21.19|  113.82|    0| 

   44|Male        |335         |   80|            51.74|    1.00|   79.93|Door_2      |    2.29|   18.99|  114.46|    0| 

   45|Female      |683         |   74|            78.40|    1.00|  109.94|Door_2      |    0.35|    2.21|  115.41|    0| 

   46|Female      |160         |   71|            82.84|    1.00|  104.31|Door_1      |    0.00|    3.41|  116.25|    0| 

   47|Female      |502         |   75|            78.80|    1.00|  101.62|Door_2      |    0.83|    4.54|  116.62|    0| 

   48|Male        |474         |   66|            49.15|    1.00|   99.06|Door_2      |    0.84|    8.36|  117.19|    0| 

   49|Female      |188         |   76|            81.90|    1.00|  101.26|Door_1      |    0.00|    8.95|  118.02|    0| 

   50|Male        |12          |   75|            51.62|    1.00|  108.33|Door_1      |    0.00|    5.00|  118.75|    0| 

   51|Female      |344         |   71|            81.13|    1.00|   58.97|Door_2      |    1.22|   20.19|  119.51|    0| 

   52|Male        |491         |   79|            45.72|    1.00|   94.89|Door_2      |    0.00|    9.45|  119.58|    0| 

   53|Female      |133         |   77|            87.93|    1.00|  109.16|Door_1      |    0.00|    6.74|  120.17|    0| 

   54|Female      |306         |   69|            43.27|    1.00|   69.15|Door_2      |    0.69|   18.81|  123.44|    0| 

   55|Female      |211         |   76|            56.93|    1.00|  105.50|Door_1      |    0.00|    7.36|  124.24|    0| 

   56|Male        |125         |   74|            49.97|    1.00|  105.32|Door_1      |    0.00|    9.54|  127.88|    0| 

   57|Male        |669         |   75|            84.77|    1.00|  111.49|Door_2      |    0.00|    9.21|  128.44|    0| 

   58|Female      |282         |   74|            77.69|    1.00|  117.96|Door_1      |    0.00|    6.91|  128.89|    0| 

   59|Female      |451         |   77|            60.46|    1.00|  109.19|Door_2      |    0.00|   10.16|  130.52|    0| 

   60|Female      |4           |   75|            40.07|    1.00|  112.53|Door_1      |    0.00|    9.00|  130.58|    0| 

   61|Female      |771         |   68|            65.57|    1.00|  118.18|Door_2      |    0.58|    9.24|  134.62|    0| 

   62|Female      |401         |   68|            48.52|    1.00|   74.33|Door_2      |    0.52|   17.66|  134.98|    0| 

   63|Female      |694         |   79|            66.21|    1.00|  117.39|Door_2      |    0.58|    8.12|  136.97|    0| 

   64|Male        |355         |   79|            83.03|    1.00|   99.64|Door_2      |    0.00|   15.86|  137.64|    0| 

   65|Male        |320         |   69|            63.70|    1.00|  118.88|Door_1      |    0.00|    7.41|  137.74|    0| 

   66|Male        |283         |   74|            55.74|    1.00|  109.44|Door_2      |    0.41|   20.90|  139.00|    0| 

   67|Female      |377         |   70|            82.76|    1.00|  112.06|Door_2      |    1.16|   16.28|  154.13|    0| 

   68|Male        |316         |   66|            63.55|    1.00|  118.05|Door_2      |    0.00|   16.99|  157.70|    0| 

   69|Female      |286         |   75|            75.90|    1.00|  103.16|Door_2      |    1.16|   19.02|  161.25|    0| 

   70|Female      |305         |   66|            54.40|    1.00|  119.98|Door_2      |    0.00|   18.90|  179.69|    0| 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

  Avg|            |            | 73.0|            63.48|    1.00|   89.51|            |    0.34|    8.76|  109.56|  0.0| 

Door performances :- 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ 

Ext. Exit Door_1          Number Used:   25  First Entry:  69.62 (s) Last : 137.74 (s) Avg PPM :  22.02 

 Flow Time:  68.12 (s) No Flow Time:  13.73 (s) MNS :  20.15 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 

 Type: General  Potential: 110.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

Ext. Exit Door_2          Number Used:   45  First Entry:  62.21 (s) Last : 179.69 (s) Avg PPM :  22.98 

 Flow Time: 117.48 (s) No Flow Time:  40.48 (s) MNS :  34.46 (%) Opened:  0 Closed:  0 

 Event Times (Secs) None 

 Type: General  Potential: 100.00 Attractiveness: 100.00 Unit Flow Rate (occ/m/s):   1.20   1.46 

OPS = 0.233 

End of Door data 

 

As can be seen from this table the first person exited in 62.21 seconds from Door2 and the last 

in 179.69 seconds from Door2.  A total of 45 people used Door2 and 25 people used Door1 

indicating that 15 people from Room1 travelled to Room2 in order to use Door2.  The OPS for 

this simulation was 0.233 indicating an inefficient evacuation, though not as bad as the previous 

example (OPS = 0.489). 

 

As in the last example, the high values for the distance travelled indicates that a number of 

occupants had to travel to an exit that was not their closest exit in order to evacuate from the 

enclosure.  The exit curves for this simulation (see Figure 9-57) suggest that the flow through 

Door2 is somewhat patchy with several gaps formed in the curve.  This indicates that the exit 

was not used continuously once the flow started.  This is probably due to the long response times 

and the slow movement rates of the people.  The curve for Door2 indicates that the evacuation 
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time was somewhat protracted by the last few people to exit from the geometry. By checking 

the output table we note that these occupants travelled a long distances (approx 19m) and were 

thus located in Room1. 
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9.3 Tutorial 3: A two floor geometry 

During this tutorial a two-floor geometry will be created. This will require: 

 

Generating several floors, generating staircases, connecting the floors to the staircases 

and modifying the staircase connection. 

 

9.3.1 Creating the Geometry 

1. Create two 10m x 10m rooms in separate Windows to form a two-floor geometry.  To add 

an additional floor to a geometry once a floor has already been created, move to Geometry 

mode, select Tools from the menu bar and the Floor option from the resulting menu 

[Tools>Floor>Copy].  From this sub-menu select the Copy item.  In order to view both 

windows at the same time, select Window from the menu bar and the Tile item from the 

pull-down menu [Window>Tile]. Place a 1m exit in the bottom left corner of the “ground 

floor”. It is suggested that wherever possible, the staircase should be created in the same 

window as the lower floor feeding the staircase. 

 

2. Create a stairwell in both floors by deleting both the appropriate nodes and the diagonal 

arcs within the corners of each region (see Figure 9-58). 

 

 
Figure 9-58: Creating the stairwell 

 

9.3.2 Generating a Transit Node 

3. Add and connect a single run staircase as illustrated in Figure 9-59.  To create the staircase, 

Click on the Stair Transit Node button  on the toolbar and click at the location of the 

staircase as shown in Figure 9-59. Alternatively, generate a Stair Transit Node by selecting 

[Tools>Generate>Transit Node] while in Geometry mode.  Once the Stair Transit Node 

has been created double click on it to display its corresponding dialogue box. 

 

4. Make sure the Definition Type is set to Component (i.e. as opposed to Sub Component) and 

enter the highlighted values shown below to modify the attributes of the Stair Transit Node 

dialogue box: 

 

Ground Floor Top Floor 
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(If the Sub-Component option was selected in the Definition Type then the user would have 

to enter the following attributes: Lanes, Riser Number, Width, Riser Height, Tread Depth 

and Nosing) 

 

Table 9-3: Stair information. 

Attribute Value 

Properties Tab 

Capacity 26 

Lanes 2 

Riser Number 14 

Width 1.4m 

Height 2.38m 

Length 3.497m 

Riser Height 0.170m 

Tread Depth 0.269m 

Nosing 0m 

Advanced Tab 

Handrail Enabled 

Handrail Size 0.1m 

Effective Width Enabled 

Reduction Width 0.087m 

 

5. When the attributes have been entered and accepted, the transit node should, if possible, be 

positioned as close to its actual location in the geometry as possible; i.e., in the 1.5m x 3.5m 

space previously removed from the ground floor. This will assist in the generation of VR 

animations should the user wish to produce them. 

 

9.3.3 Connecting the Transit Node to the Geometry 

6. Select the three nodes on the ground floor that are to be connected to the transit node itself. 

This can be achieved by holding down the CTRL key and then dragging out the areas around 

both the three nodes and the transit node itself. 

 

7. Select [Tools>Auto Connect> Stairs and Transit Nodes] while in Geometry mode. 

 

8. The model will then attempt to determine the relative position of the transit mode in relation 

to the free-space nodes. The dialogue box shown in Figure 9-59 will then be displayed. This 

represents an attempt to determine whether the transit node and the floor geometry line up 

appropriately. This may not always be the case, depending on how the floor is represented 

(e.g., was it imported from a DXF), or the stair configuration. 

 



Chapter 9 - Tutorial 3 

© 2017 University of Greenwich 202 

 
Figure 9-59: Transit Node Auto Connect. 

 

9. The set of nodes identified to connect to the transit node will either remain the same colour, 

or be highlighted (see Figure 9-59). The text in the dialogue box provided will ask whether 

the highlighted node (shown white in Figure 9-59) is on the left-side of transit node. If the 

highlighted node is correctly described (in this case, it is actually described as being on the 

left of the transit node), then click Yes. If not, click No and the opposite orientation will be 

assumed when the transit node is connected. In effect, the model is attempting to accurately 

orientate the stair structure and the building so that the arc connections represent the path 

that would, in reality, be adopted. 

 

10. The Arc lengths are automatically calculated by the model. However, the user has the option 

to modify these from in the Auto Stair Connector dialogue box (shown in Figure 9-60). 
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Figure 9-60: Modifying the automated arc lengths. 

 

11. The user will then be prompted as to which end of the transit node to connect to the free-

space nodes that were previously selected. In this case, the bottom of the transit node needs 

to be connected, and so No should be selected from the dialogue box (see Figure 9-61). 

 

 
Figure 9-61: Identification of the end of the transit node to be collected. 

 

12. The transit node will now appear connected to the free-space nodes selected on the ground 

floor (see Figure 9-62). 
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Figure 9-62: Connected transit node. 

 

13. The transit node now needs to be connected to the upper floor. The process of connecting 

the transit node to the upper floor is identical to connecting it to the ground floor outlined 

previously (see point 6), except for an additional consideration. Given that the transit node 

is on the ground floor and the free-space nodes are on the upper floor (i.e. in separate 

windows), the user must first ensure that it is possible to highlight all of the necessary nodes 

without needing to manipulate windows, as this will lose the focus causing some of the 

nodes to be deselected. The user should then select both the three nodes to which the top of 

the Stair transit node will be connected (in the upper floor) and the transit node itself (in the 

ground floor), see Figure 9-63. Once again, the selection of multiple nodes can be achieved 

by holding down the CTRL key and either clicking on the desired nodes or alternatively 

dragging out areas around them. 

 

 
Figure 9-63: Organising the windows to ensure pointer focus is maintained. 
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14. Once both the free space nodes and the transit node have been selected, the [Tools>Auto 

Connect>Stairs and Transit Nodes] option should again be selected. This will then lead to 

the same series of questions as before. In this instance, the arcs do need to connect to the 

top transit node, and so the answer to this question should instead be Yes. 

 

15. In this case, a link will be inserted into the geometry representing that the floors (i.e., 

different windows) have been connected (see Figure 9-64). 

 

 
Figure 9-64: Linking the staircase.  

 

9.3.3.1 Populating and Running the Simulation 

16. Place 30 random occupants on the top floor and 20 on the ground floor.  This is achieved 

by moving to Population mode. Select the entire ground floor, and then select 

[Tools>Person>Random Generate]. Enter 20 for the ground floor. Repeat this for the upper 

floor, generating 30 people instead. 

 

17. Move to Simulation mode. Ensure that the population responds immediately by setting a 

Specified Response time of 0.0 seconds in the Behaviour tab of the Behavioural Control 

dialogue box [Rulebase>Behaviour Options]. Run the simulation and note the results 

produced. Assess the impact of starting locations by selecting each of the floors in turn, and 

then selecting [Edit>Relocate>Randomise]. This will alter the location of each person, but 

will ensure that the same number of people is positioned on each floor. 

 

18. Change the staircase behaviour to PACKED and assess the impact of starting locations.  

This is set by selecting [RuleBase->Behaviour Options] in Simulation mode to display the 

Behaviour Control dialogue box, and then setting the Spacing variable within the Behaviour 

tab.  Compare the results produced. 
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9.3.3.2 Creating a dog-leg staircase. 

19. Remove the staircase and replace with a “dog leg” style staircase, as illustrated in Figure 

9-65.  

 

 
Figure 9-65: Single lane “dog leg” style staircase, with 1.5m x 1m landing. (The Transit 

Node has been moved to more clearly demonstrate the connection.) 

 

20. Each flight should contain 7 risers (having a Height of 1.190m) and should have a Width of 

0.7m. Again, use the highlighted values of the following table to populate the Transit Node 

dialogue box. Also, make sure that the first flight should have a Direction of 0 degrees and 

the second a Direction of 180 degrees. The landing between these two flights should be 

1.0m x 1.5m, so a block of six Landing nodes should be added and connect the two flights 

of stairs. The information for these stairs is shown in Table 9-4 

 

Table 9-4: Transit node attributes. 

Attribute Value 

Properties Tab 

Capacity 6 

Lanes 1 

Riser Number 7 

Width 0.7m 

Height 1.190m (i.e. 2.38m/2) 

Length 1.614m 

Riser Height 0.17m 

Riser Depth 0.269m 

Nosing 0m 

Advanced Tab 

Handrail Enabled 

Handrail Size 0.1m 

Effective Width Enabled 

Reduction Width 0.087m 
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21. To create the ‘dog leg’ style stair case, firstly create the first flight of stairs, in the same 

manner as before, then simply Copy and Paste them in order to create the corresponding 

second flight.  This is achieved by first selecting the Stair Transit Node and then selecting 

the Copy option from the Edit menu in Geometry mode [Edit>Copy]. Then select the Paste 

option from the Edit menu to paste a copy of the Stair Transit Node into the geometry 

window [Edit>Paste].  Having generated the second flight of stairs its direction then needs 

to be modified so that it faces in the opposite direction to the first flight.  This is achieved 

by double clicking on the Stair Transit Node to display is corresponding dialogue box, and 

then changing its Direction to 180 degrees. 

 

22. The same procedure should be employed as before in order to connect the transit nodes to 

the geometry. Additional work will be required to connect the stair flights to the landing 

nodes. This is the same process as connecting the original single flight transit node to the 

ground floor, except that the top of the first flight has to be connected to the landing, while 

the bottom of the second flight has to be connected to the landing. The top of the second 

flight has to be connected to the upper floor as before. Given that the landing is three nodes 

wide, it is suggested that the two left hand nodes should be accessible (i.e., connected) to 

the top of the first flight, and the two right hand nodes should be accessible to the bottom 

of the second flight (see Figure 9-66). 

 

 
Figure 9-66: Transit Node flights connected to landing. (The Transit Nodes have been 

separated to more clearly demonstrate the connections to the Landing.) 

 

23. Once connected, the structure should approximate that shown in Figure 9-65. 

 

24. Run simulation and assess the impact of starting locations, as before. 
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9.4 Tutorial 4: Creating a Geometry using a DXF file 

In this tutorial the use of DXF files is demonstrated. A seated area is created using a pre-defined 

CAD DXF file containing information defining the geometry of the enclosure.  Once the DXF 

file is imported into buildingEXODUS, the interactive tools are used to mesh the circulation 

area by generating the grid of interconnecting nodes and complete the specification of the 

geometry. A population of 160 people of random type will also be created, 60 people in the 

seated area and 100 people in the remainder of the geometry. 

 

To begin this tutorial ensure that buildingEXODUS is in GEOMETRY MODE. 

 

9.4.1 Loading the DXF file 

To construct the grid of nodes we will use the Node Flood function.  This works by flooding an 

area with nodes until a boundary is encountered. The purpose of the DXF file is to provide the 

boundary of the enclosure.  Thus before flooding the geometry with nodes, we must import the 

DXF file containing the building layout. 

 

To load a DXF file, select Tools from the menu bar, the Construction sub-menu and the Load 

Boundary item from the pull-down menu [Tools>Construction>Load Boundary].   

buildingEXODUS will now expect to be supplied with the name of a third party geometry file 

via the OPEN dialogue box. By default buildingEXODUS will assume that the file to be read 

in is a DXF file (i.e. *.DXF).  As a result, select the T4.DXF file that defines the geometry to 

be used within this tutorial and then click the OPEN button.  Upon clicking the OPEN button 

all of the relevant information contained within the given DXF file will be loaded and displayed 

within the DXF Import Editor (see Figure 9-67). 

 

 
Figure 9-67: The DXF file as displayed within the DXF Import Editor 
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NOTE:  

To import DXF files into buildingEXODUS the User first needs to install the EXODUS Third Party 

Extras Library. These are available for download from the EXODUS Licensed Users Area on the 

FSEG website (fseg.gre.ac.uk).  

 

NOTE:  

If the User attempts to open a DXF file when the EXODUS Third Party Extras Library is not 

installed they will be warned that the Extras Library is not installed and buildingEXODUS will 

instead then use the previous version DXF importer functionality (i.e. the DXF Import Editor shown 

in Figure 9-67 will not be used). 

 

All of the information contained within the DXF file will be imported, with the exception of 

TEXT,  HATCHING, DIMENSIONS, SPLINE CURVES and any hidden layers.  Similarly, any 

empty layers or those comprising solely of the aforementioned elements will also be omitted. 

Once loaded, the corresponding valid Layers, Blocks, Entities and Colours are then listed within 

the left hand window.  Double clicking on the Layers, Blocks, Entities and Colours items within 

the left hand window will toggle the display of the elements contained within these lists.  Once 

displayed, these elements can then in turn be selected by clicking on them in order to highlight 

them within the overall structure. Any selected elements will be highlighted magenta (i.e. 

selecting a given layer will highlight all the structural information contained within that layer 

as magenta).   Once imported the DXF file should contain 3 layers (i.e. External_walls, 

Internal_walls and Door_sweeps), 3 blocks (DoorSweep1, DoorSweep2 and DoorSweep3), 2 

entities (i.e. LINE and INSERT) and 3 colours (i.e. Red, Yellow and Cyan).  The effect of 

automatically stripping out redundant elements and layers can be seen by comparing the 

resulting imported geometry (see Figure 9-67) with the original DXF file as displayed within 

AutoCAD (see Figure 9-68). 

 

 
Figure 9-68: The DXF file as displayed within AutoCAD 

 

http://fseg.gre.ac.uk/
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Only those lines defining the structure itself or the obstacles within it (i.e. the overall circulation 

space) are required for the purposes of evacuation modelling. Any line imported from the DXF 

file will be treated as a wall (and hence an obstacle). Any lines therefore not representing 

walls/obstacles should therefore be removed prior to importing into buildingEXODUS.  As a 

result, it is first necessary to remove the lines representing the door sweeps.  To achieve this the 

user can delete each of the 3 blocks by clicking on each in turn and then pressing the DELETE 

button on the keyboard. Alternatively the layer on which all 3 blocks are present (i.e. 

Door_sweeps) can be selected and then deleted.  Having deleted these elements the geometry 

should comprise merely the external (red) and internal (yellow) walls. 

 

The user is next required to define the corresponding units of the DXF file via the Units list box 

located at the bottom of the DXF Import Editor. Since in this instance the units of the file are 

in metres, select the Metres option.  Once this is complete the user can finally import the 

geometry as displayed within the DXF Import Editor into buildingEXODUS by clicking the 

OK button. 

 

When the DXF file is successfully imported into buildingEXODUS, use the Zoom Reset 

function to allow the entire geometry to be viewed - select View from the menu bar, the Zoom 

sub-menu and then the Reset item from the pull-down menu [View>Zoom>Reset].   

 

Depicted in Figure 9-69 is the outline of the geometry to be used in this tutorial. 

 

 
Figure 9-69: The DXF outline of the lecture room example 

 

9.4.2 Using The Node Flood Function 

Once the geometry has been read in, the next step is to define the grid of nodes filling the 

interior of the structure. This is done using the Node Flood function. The Node Flood function 

requires a closed boundary into which to place the nodes. If a closed boundary has not been 

generated by the DXF file, the Node Flood function will not be able to stop generating nodes.  

Thus, if a closed boundary has not been generated it is necessary to manually close the geometry 

using the interactive tools provided.  This principle is illustrated in Figure 9-70.  A portion of a 
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DXF outline is shown, with an open boundary.  This boundary is closed by placing Free-space 

nodes across the open boundary. 

 

 
Figure 9-70: Closing a boundary 

 

NOTE: 

Only external open boundaries must be closed.  Internal compartments will only require 

boundary closing if they are NOT to be included in the buildingEXODUS description of the 

entire enclosure. 

 

Before proceeding, ensure that the Snap option is switched on.  Select Edit from the menu bar, 

the Node Align sub-menu and the Snap item from the pull-down menu [Edit>Node 

Align>Snap]. 

 

In the current example, only one external boundary requires closing.  First enlarge the area in 

question using the Zoom function.  To close the boundary place one Free-space node at the top 

of the open portion, and replicate the node five times in the downward direction by using the 

Replicate function [Edit>Replicate>Down].  Figure 9-71 shows this area of the boundary after 

the nodes have been placed. 

 

NOTE: 

The user may wish to use a nodal type other than Free-Space when closing the gaps in the DXF 

file. This will assist in identifying the unwanted nodes once the geometry has been flooded. 

Alternatively the user may instead draw a Line across the offending gap. The function for 

drawing a line can be accessed through the Generate sub-menu on the Tools menu 

[Tools>Generate>Line]. 
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(a) (b) 

Figure 9-71: Closing the external boundary in the lecture hall with (a) Nodes and (b) 

using the Line function 

 

Now the boundary has been closed the Node Flood function may be utilised.  To operate this 

function, select Tools from the menu bar, the Construction sub-menu and the Node Flood item 

from the pull-down menu [Tools>Construction>Node Flood].  Now, when the mouse is 

clicked, buildingEXODUS will attempt to flood an area with free-space nodes. Before operating 

the Node Flood function, ensure that the whole area to be filled with nodes can be seen in the 

window by using the Zoom Reset function [View>Zoom>Reset].  Ensuring that the whole 

geometry is visible prior to node flooding means that the user is able to detect if the Node Flood 

leaks out through small gaps in the boundary into the outer area, thereby enabling them to 

immediately stop the operation.  If node leakage does occur the user should first delete all the 

nodes generated as a result of the Node Flood function, before then sealing the gap and then 

starting the node flood operation again. 

 

 
Figure 9-72: Geometry after Node Flood function performed 
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NOTE: 

Be very careful where you click the mouse button as clicking will start the Node Flood process. 

 

The Node Flood function attempts to place a mesh of nodes within the confines of the geometry 

defined by the DXF file. Each node represents a physical space of 0.5m x 0.5m (default size). 

In some geometries small discrepancies are inevitable as it is not possible to place a 0.5m square 

node in a space smaller than 0.5m. Due to their small size, these discrepancies are generally 

insignificant. Furthermore, as they generally occur along walls they are not expected to have a 

major impact on occupant flow dynamics. 

 

The small discrepancies in the spacing of the nodes can however be rectified by using the 

Smooth function.  To use this, first select all of the nodes and then select the Node Align option 

in the Edit menu, before then selecting the Smooth option within the resulting submenu 

[Edit>Node Align> Smooth]. 

 

Once the Node Flood has been completed the nodes originally placed along the opening in order 

to close the boundary can be deleted by double clicking each in turn, and clicking the DELETE 

button on each of the dialogue boxes appearing.  The geometry should now resemble that shown 

in Figure 9-72. 

 

NOTE: 

If the user had blocked off the gaps in the geometry using the Line function, then the resultant 

line should be removed. The user must first enable the selectability of the Line object by 

accessing the Gra. Ctrl Options dialogue box via the Display sub-menu off of the View menu 

[View/Display/ Gra. Ctrl Options]. 

 

9.4.3 Creating the Seat Rows 

Once the specification of the mesh is completed it is necessary to add the interior details. In this 

example the lecture hall (interior room) will consist of 10 rows of 12 seats. In addition eight 

benches of five seats will be distributed through the larger exterior space. 

 

NOTE: 

It is possible to place the seat rows into the geometry before using the Node Flood function.  

However, judging the correct spacing for the seat rows would be difficult using this technique.  

By substituting free space nodes with seat nodes after the Node Flood, the correct spacing for 

the grid will be used as it has already been calculated. 

 

The seat rows will be placed into the geometry by substituting free-space nodes. The last row 

(nearest to the back wall of the enclosure) will start 1m from the back wall, and 2m from both 

the left and right walls.  A row of free-space nodes will be left between each row of seats, 

indicating a large aisle between seat rows. 

 

Before proceeding, it is important to note that seats in buildingEXODUS have a direction.  The 

front of a seat is indicated by a small black rectangle as shown in Figure 9-73, and by default 

the front of the seat is at 90o, i.e. facing to the right.  The seat shown in Figure 9-73 is facing 

180o as indicated by the direction arrows also shown in Figure 9-73. 
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Figure 9-73: Seat direction Figure 9-74: Substituting Node Attributes 

 

To start placing the seat rows, the free-space nodes to be substituted must first be selected.  This 

is accomplished by clicking on each in turn whilst holding the CTRL key on the keyboard.  In 

this fashion, a group of nodes is selected.  It is possible to select all the free-space nodes to be 

substituted in one go, however it is suggested that each seat row is done in turn. 

 

Once selected, the nodes are substituted by selecting Edit from the menu bar, and the Substitute 

item from the pull-down menu.  From the Substitute sub-menu, select the Nodes option 

[Edit>Substitute>Nodes].  This presents the Node Substitution dialogue box.  In this dialogue 

box, the Node Type should be changed to Seat, and the Direction to 180o, as shown in Figure 

9-74. 

 

This process should be repeated for each seat row.  At this stage the room with the seats should 

resemble Figure 9-75. 

 

It should be noted that the obstacle values attached to the back of seats should be altered to a 

higher value to reflect that it is harder to climb over seats.  To change the obstacle value of the 

affected arcs each should be double-clicked to retrieve its’ dialogue box.  The obstacle value in 

the dialogue box must then be altered.  To alter many arcs in this manner is a time consuming 

process.  It can be easier and quicker to delete all the arcs in the seat region, by selecting the 

region and then choosing the Delete sub-menu item from the Edit menu and then the Arc 

[Edit>Delete>Arc>All].  The arcs can then be reconnected in each direction separately and in 

smaller regions, for example all the vertical (and diagonal) arcs in a Free-Space-Seat 

combination.  In this way, only a few modifications of the default arc are required.  Note that it 

is important to maintain all the arc lengths.  The setting of Obstacle values should be done in 

conjunction with the setting of the Agility attributes for the occupants. Suggested Obstacle 

values for each link are illustrated in Figure 9-76. 
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Figure 9-75: Room with seat rows 

completed 

Figure 9-76: Arc lengths and obstacle 

values 

 

Now the seat rows have been defined, the next step is to create the benches.  To complete this 

operation, the same technique is used.  Figure B.4.9 shows where the benches should be located.  

Remember during the substitution process to alter the direction of the seats correctly. 

 

 
Figure 9-77: Location of extra benches 

 

NOTE: 

The Seat node in buildingEXODUS is intended to represent a seat and the space available to 

stand in front of the seat, thus occupants can walk along seat rows.  For this reason, it is unusual 

to require free-space nodes in front of seats, indeed this should only be the case when a wide 

aisle exists between the seat rows. 
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NOTE: 

The Seat node in buildingEXODUS has an additional impact. It also allows the user to focus 

the Randomisation of people prior to the simulation beginning. The user can choose to 

Randomise only those occupants initially located on Seat nodes, using the Randomise on Seats 

functionality in Population or Simulation modes [Edit>Relocate>Randomise on Seats].  

 

9.4.4 Adding an Exit Node 

At this stage, the entire enclosure should be mapped with nodes and all that is required is the 

addition of exits, both internal and external.  For this example, a single external exit will be 

added at the location of the open boundary.   

 

The exit is 1.9m in width suggesting that it can accommodate up to four lanes, i.e. the exit 

requires four arcs.  Click the External Exit tool on the toolbar and place an exit near to the open 

boundary.  Modify the exit name if required. Now connect the exit to the free-space nodes just 

inside the open boundary by using the arc tool and dragging arcs between the exit and the Free-

Space nodes.  Figure 9-78 shows the exit area after this process has been completed. 

 

Before proceeding, switch on the boundary view by selecting View from the menu bar, and the 

Boundary item from the pull-down menu [View>Boundary].  If the entire geometry cannot be 

seen in the window, perform a Zoom Reset on the window [View>Zoom>Reset].  The complete 

geometry should now resemble that shown in Figure 9-79. 

 

 

 

 
Figure 9-78: Connectivity at exit Figure 9-79 The complete enclosure 

 

9.4.5 Adding a Population in Sections 

Switch to POPULATION MODE.  We will now populate the enclosure using the Random 

Generate function [Tools>Person>Random Generate].  First select the seating area in the 

lecture room and generate 60 people.  Repeat this procedure, placing 50 more people in the 

rounded part of the geometry, and a further 50 in the rest of the geometry. 
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Now the population procedure is complete, move buildingEXODUS into SCENARIO MODE 

so that some Scenario parameters may be modified. 

 

9.4.6 Modifying Exit Parameters 

In Scenario mode set the exit’s unit flow rate to comply with British Regulations allowing a 

10% variation. Double click the exit to retrieve its dialogue box as shown in Figure 9-81.  

Modify the Unit Flow Rate list-box as indicated in Figure 9-81, to show HMSO.  This will 

change the Unit Flow Rate parameter to 1.33 occupants/metre width/second.  To introduce a 

10% variation, change the +% box to 10 and the -% box to 10.  The dialogue box will then 

show the actual range, as indicated in Figure 9-81. 

 

While in SCENARIO MODE the maximum travel distance for the enclosure can be estimated 

using the MAXP button on the DOOR dialogue box. An estimate of the evacuation time for the 

geometry is also determined using this function. 

 

 

 

Figure 9-80: Randomly generated 

occupants within the enclosure 

Figure 9-81: Setting exit capabilities in the 

Door dialogue box 

 

9.4.7 Running the Simulation 

To run the simulation, move to SIMULATION MODE. Before running a simulation, select the 

behaviour model [Rulebase>Behaviour Options] and set the required parameters in the 

appropriate dialogue boxes. These can be set in the same manner as in previous tutorials. Once 

set this completes the setting of the parameters required to run the simulation. The simulation 

is started by pressing the PLAY button on the toolbar. The evacuees will start moving towards 

the exit and interacting with each other. This interaction can be viewed on the screen in the 

Geometry Window. 

 

Once the simulations have been completed, the user should return to Geometry mode to 

generate Boundary nodes. Although this will not necessarily have a large impact on the results 

produced it will affect the routes adopted by the evacuees. The Boundary nodes can be 
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automatically generated by selecting the Generate option within the Auto Boundary Nodes sub-

menu, as shown in Figure 9-82 [Tools>Generate>Auto Boundary Nodes>Generate]. 

 

 
Figure 9-82: Automatically generating Boundary Nodes. 

 

The user should note that the Boundary nodes will not overwrite the Seat nodes that had 

previously been generated (see Figure 9-83 (a)). Once the simulation is re-run the evacuees can 

be observed maintaining a distance from the walls of the structure (see Figure 9-83(b)). 

 

 

 

 

 

(a) (b) 

Figure 9-83: (a) Generation of Boundary nodes (b) Evacuees avoiding Boundary nodes. 
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9.5 Tutorial 5: Creating Internal Compartments and Defining Obstacles. 

In this tutorial we will demonstrate the manual construction of internal compartments and the 

definition of insurmountable/surmountable obstacles. Also demonstrated will be the use of 

Internal Exits to control the potential map - and hence the flow behaviour of people - within the 

internal compartment.  Figure 9-84 depicts the basic layout of the enclosure. 

 

 
Figure 9-84: Geometry to be constructed 

 

9.5.1 Constructing the Geometry 

Before starting the tutorial, ensure that Geometry mode has been selected and no other 

geometries are defined.  The complete enclosure is a simple 10m x 10m square room, i.e. 20 

nodes x 20 nodes.  Select the Node tool and draw a large bounding box as demonstrated in 

Tutorial 1.  Into the dialogue box that appears, type the values for both X and Y directions (20 

in each case) and click the PACK button.   

 

This will create a grid representing the complete enclosure.  By using the [Tools>Auto 

Connect>All] tool, connect the grid using the default values, i.e. 0.5m in the horizontal and 

vertical directions, and 0.707m for the diagonal arcs. 

 

We now need to create the internal room.  The only barrier between the internal room and the 

main enclosure is the presence of a wall.  A wall is represented by an absence of connecting 

arcs, thus preventing occupants from traversing the nodes either side.  In this case, the simplest 

method to achieve this goal is to remove the relevant arcs.  Using the [View>Zoom> In] tool, 

magnify the bottom left hand corner of the enclosure so that 10 nodes can clearly be seen in 

both directions.  Figure 9-85 indicates how the geometry should now look. 

 



Chapter 9 – Tutorial 5 

 

© 2017 University of Greenwich 222 

 
Figure 9-85: Zoomed in portion of geometry 

 

At this point, the correct arcs must be removed in order to model the internal room.  Using the 

select tool, select the eighth and ninth rows of nodes (from the bottom) using a bounding box. 

Each row should contain eight nodes. Once selected, delete the arcs connecting these two rows 

by selecting [Edit>Delete>Arc>Vertical].  This will delete the vertical arcs connecting the 

selected nodes.  Repeat to remove the diagonal arcs (i.e. [Edit>Delete>Arc>Diagonal]). The 

geometry should now resemble Figure 9-86. 

 

This process should be repeated, but this time, in the vertical direction. Select the eighth and 

ninth columns (from the left edge of the enclosure), each column should contain eight nodes.  

Delete the horizontal and diagonal arcs.  The geometry should now resemble Figure 9-87.  Note 

that two extraneous diagonal arcs in the top-right corner of the internal room also require 

deletion.  Delete these arcs by double-clicking each in turn and clicking the DELETE button on 

each dialogue box. 

 

In essence, the definition of the internal room is now complete, however, any occupants placed 

inside this compartment do not have any route to the main enclosure, thus we must create the 

internal exits.  The internal exit on the top wall of the internal room will measure 1m in width 

and will be placed 2m from the left wall.  From this definition, we deduce that two Internal Exit 

node pairs are required across the width of the internal opening.  This is achieved by selecting 

the nodes representing the internal exit (by dragging out an area around the nodes), selecting 

the Tools menu and then Internal Exit from the Generate sub-menu [Tools>Generate>Internal 

Exit]. These nodes will then form a single Internal Exit. 

 

NOTE: 

You need to reconnect the arcs across each Internal Exit. This can be done by making sure the 

four nodes defining the Internal Exit are selected and by using the Auto Connect/All tools i.e. 

[Tools>Auto Connect>All]. 

 

Create an identical Internal Exit on the right wall of the compartment, this exit should be placed 

2m from the bottom wall (see Figure 9-88).  
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Figure 9-86: Top wall of internal room Figure 9-87: Side wall of internal room 

 

 
Figure 9-88: Position of Internal Exits 

 

NOTE: 

Internal Exits may be fully connected. 

 

When the arcs have been added, switch to Boundary view [View>Boundary] to examine the 

connectivity around the internal room.  Figure 9-90 shows the geometry in this view, note how 

the walls are portrayed. 

 

NOTE: 

You may have to regenerate the boundary lines to update the walls with your new connectivity. 

To do this you must select the [Tools>Generate>Regen. Boundary Lines] option. 

 

NOTE: 

The user will also have to open the Display Control dialogue box and select the Internal Drs 

option in order to view their location in Boundary mode (see Figure 9-89).  
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Figure 9-89: To see the location of the internal exit on screen in boundary mode, the 

user should select the option highlighted above. 

 

At this stage, the main exit should be added.  The exit should measure 2m in width and be 

placed in the top right hand corner of the geometry.  To place the exit, use the Zoom Reset 

function to view the complete geometry [View>Zoom>Reset], and turn off the Boundary view 

[View>Boundary].  The exit can then be placed in the correct location and connected with arcs 

of length 0.0m.  After this procedure is complete, switch on the Boundary view and advance to 

POPULATION mode.  Figure 9-91 illustrates the geometry at this stage.  

 

  
Figure 9-90: Geometry in boundary view Figure 9-91: The complete geometry 

 

Now the basic geometry has been specified, a number of different scenarios will be examined. 

 

9.5.2 Example 1: Conducting a Simulation Without Local Potentials 

Once the geometry has been specified we must populate the enclosure. If we are not concerned 

where occupants will be placed we can generate a population quite quickly using the Random 

Generate function. However, in this example we will identify three specific population zones 

that we will populate with a certain number of people. For the purposes of this example we will 

generate a random population.  Using the select tool, draw a bounding box around the internal 

room and using the [Tools>Person>Random Generate] function, generate 30 people. 
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To populate the rest of the enclosure is slightly more difficult, due to the shape but can be done 

by making multiple selections. Draw a rectangle around the top part and then holding down the 

CTRL key, draw a rectangle around the lower right part. Now again using the Random Generate 

function add a further 50 people.  The enclosure should now resemble Figure 9-92. 

 

Note that the population density throughout the enclosure is uneven. This may reflect the 

particular usage of this structure.  

 

Now move to Scenario mode and identify the catchment area of the main exit.  This is achieved 

by opening the exit’s dialogue box (by double clicking the exit) and clicking the MAP button.  

If the Local Potentials option is enabled the catchment area encompasses only the outer 

enclosure, excluding the internal room, as shown in Figure 9-93. 

 

  
Figure 9-92: 80 people in the enclosure Figure 9-93: The reduced catchment area 

of main exit (Local Potential enabled) 

 

Now move to Simulation mode. 

 

By default, EXODUS assumes that when an Internal Exit is defined, a local potential map is 

required.  This option can be switched off overriding any local potentials defined.  For the first 

simulation to be conducted, switch this option off by de-selecting the Local Potential option 

from the Route tab in the Behaviour Options dialogue box [RuleBase>Behaviour Options]. The 

effect of doing this on the catchment area of the exit can be seen in Figure B.11. 
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Figure 9-94: The catchment area of the main exit (Local Potential disabled) 

 

Now start the simulation and carefully view the movement within the internal room. Note how 

more of the occupants in this case use the internal exit on the right wall of the internal room.  

In such an enclosure, this kind of behaviour would be unlikely: some occupants would have 

used the other internal exit.  To model this using the global potential map only is impossible in 

this case, thus we must use a localised potential map to overcome this problem. 

 

9.5.3 Example 2: Conducting A Simulation With Local Potentials 

For the second example we will use the same population as defined in example 1 and define a 

set of local potentials for the internal exits. 

 

Move back into Scenario mode and retrieve the dialogue box for each of the two internal exits.  

Modify the Potential attribute in each case to 150.0.  (For these figures to have any impact upon 

the simulation, the Local Potential flag should be enabled). When this task is completed, use 

the MAP function to view the catchment area of the exit point.  Note that in this case the internal 

room is not included, as a potential has been placed on each of the internal exits and this 

potential is allowed to affect the potential map through the Local Potential option being enabled 

(see Figure 9-93).   

 

Now move into SIMULATION mode and enable the Local Potential option in Behaviour 

Options dialogue box from the Rulebase menu [Rulebase>Behaviour Options].  We now have 

a localised potential map inside the internal room, and each of the internal exits has been equally 

biased.  Execute the simulation as before, again noting the flow behaviour inside the 

compartment.  Note how we now have a more even distribution of people using each of the 

internal exits. This is because the attractiveness of the exits are now established locally, rather 

than being dependent upon their proximity to the nearest external exit. 

 

When the simulation has finished, move back into SCENARIO mode and alter the Potential on 

the eastern internal exit to 150 (maintaining the potential of the northern Internal Exit to 100.0).  

Move to SIMULATION mode and start the simulation.  This time, note how all the occupants 

use the top internal exit to egress out of the compartment.  This is due to the heavy biasing of 

the right internal exit to make it extremely unattractive. 
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9.5.4 Example 3: Adding Insurmountable Obstacles 

In this example we will add a selection of insurmountable obstacles to the geometry.  These are 

objects that people have to walk around rather than climb over, for example a table.  Such 

obstacles can cause problems to evacuating occupants as they are forced to take evasive action 

to avoid them.  In buildingEXODUS these obstacles are simply modelled as white-space i.e. 

with no nodes.  For the purposes of this tutorial, we shall create eight 1m x 1m tables (similar 

to restaurant tables), simply by deleting the relevant nodes. 

 

Before proceeding, move to Population mode and delete all the people by selecting 

[Edit>Delete>Everyone].  Now move back into GEOMETRY mode to place the tables.  If the 

Boundary view is switched on then remove this option in order to see the connected grid. 

 

As the tables measure 1m x 1m, this means each table occupies the space of 4 nodes, thus for 

each table, 4 nodes must be deleted.  To create each table, highlight the four nodes to be 

removed by using the Select tool and the CTRL key on the keyboard and select the Delete Nodes 

item from the Edit menu [Edit>Delete>Node].  After the nodes have been deleted, the diagonal 

arcs in each corner of the table must also be deleted.  The easiest method to complete this task 

is to retrieve the dialogue box for each arc, and press the DELETE button on each.  Add the 

eight tables to the geometry, matching the positions with those shown in Figure 9-95. 

 

  
Figure 9-95: Geometry with tables Figure 9-96: Travel path of single occupant 

 

Now advance to POPULATION mode and place one default person just above the internal 

enclosure, so that the occupant will interact with the obstacles en route to the Exit node.  Now 

advance to SIMULATION mode and switch on the Boundary view [View>Boundary].  Play the 

simulation.  When complete, take a note of the Total Evacuation Time (TET) and display the 

path of the occupant as shown in Figure 9-96. 

 

Note from Figure 9-96 how the person weaves between the tables en route to the exit point.  In 

this case, although the person had to dodge around the tables, the travel speed used was still the 

fast walk speed.  In reality, this kind of weaving would force a person to slow down.  This is 

modelled through the use of Boundary nodes placed around each obstacle. 
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9.5.5 Example 4: Adding a Halo of Boundary Nodes 

In this example we will add a halo of Boundary nodes around each of the tables. This is achieved 

by the user selecting the [Tools>Generate>Auto Boundary Nodes> Generate] function. This 

will then automatically position Boundary nodes on the periphery of the structure and around 

the ‘tables’. 

 

When the Boundary nodes have been generated, the geometry should resemble Figure 9-97. 

 

 
Figure 9-97: Table with a halo of Boundary nodes 

 

Now switch on the Boundary view and move to POPULATION mode.  We are going to reduce 

the Walk Speed attribute of the occupant to ensure the effect of the Boundary nodes is clear. 

 

Using the Person Select tool, open the dialogue box for the occupant and click the ATTRIB 

button to gain access to the travel speed attributes.  Now modify the Walk Rt attribute to 0.5.  

The person now has a walk speed of 0.5m/s.  Now move into SIMULATION mode and run the 

simulation.  Note how the person slows down in the regions containing the Boundary nodes.  

When the simulation has finished, again note the TET and travel path of the person. 

 

NOTE: 

The user is able to manipulate the graphical appearance of the nodes, using the Display Control 

dialogue box [View>Display>Gra Ctrl Options]. 

 

We note that the TET has now increased and that small deviations in the travel path can be seen.  

Both effects are due to the Boundary nodes. 

 

In order to see how the Boundary nodes may affect a large population, move to POPULATION 

mode and remove the current occupant.  Now populate the enclosure in the manner described 

in Section 9.5.2 (i.e. populate the internal enclosure with 20 people).  Advance to SCENARIO 

mode and ensure that both the Internal Exits have identical potentials, i.e. they are equally 

biased.  Now move to Simulation mode and execute a simulation.  Note again how the paths of 

the people weave considerably between the tables. 
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Figure 9-98: Path taken by occupants of internal room. 

 

In Figure 9-98 the path of the population has been overlaid on top of the original starting 

locations of all the people.  This further reveals the degree of manoeuvring required in order to 

egress in this case. 

 

9.5.6 Example 5: Using a Combination of Obstacle Types 

In the next part of this tutorial will consider obstacles that are surmountable.  To model these, 

we use the Obstacle attribute on the arcs.  As an example consider a small pile of debris.  Some 

people would be able to run straight over such a pile, whereas others would be forced to 

circumvent the pile.  In buildingEXODUS the ability to move over such obstacles is dependent 

on the relative sizes of the obstacle values and the agility of the people. For example, if the pile 

of debris has an obstacle value of 5, only occupants with an Agility of 5 or over will be able to 

go over the pile.  It should be noted that this facility must be used with caution, as it may be 

possible to trap certain occupants. 

 

For the purposes of this tutorial, we will increase the obstacle values of the arcs surrounding 

one node only, and demonstrate that only those with sufficient agility values can go over the 

obstacle. 

 

 
Figure 9-99: Node to contain obstruction 
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Now move into GEOMETRY mode and double-click all the arcs connected to the node 

containing the obstruction as indicated in Figure 9-99.  For each Arc dialogue box, modify the 

Obstacle attribute to 5 and click the OK button. 

 

Now move to POPULATION mode, delete the entire population and select the internal room.  

This time, we will populate the room using the Population Panel Editor (PPE).  Press the 

PANLE POPULATE icon on the toolbar to retrieve the PPE dialogue box (i.e. ).  Click the 

CLEAR button to remove the current panels, and create two new panels by clicking the CREATE 

button twice.  For PANEL0 keep the default values for each of the attributes except for the 

following: 

 Change Gender to Male, 

 Change Agility to range from 3 to 7, and 

 Change the Age to range from 20 to 20 

 

Repeat this process for PANEL1, but  

 Change the Gender attribute to Female,  

 Change Agility to range from 1 to 4 and  

 Change the Age to range from 20 to 20. 

 

Next, set each panel so that it represents 50% of the overall population. In the PPE ensure that 

only Free Space nodes are selected (i.e. that all other Node Types are deselected) and also that 

the Selection allocation system is selected.  Type 20 in the Total Pop. Size text box press the 

Populate button.  Then click Yes to confirm the generation of the 20 people (i.e. 10 from each 

panel). 20 occupants should now be generated inside the internal room.  Note that all the males 

are the same colour and all the females are the same colour. 

 

 
(a) (b) 

Figure 9-100: Paths taken by two people around an obstacle 

 

Move to SIMULATION mode and de-select the Local Potential option within the Route tab of 

the Behaviour Control dialogue box [Rulebase>Behaviour Options].  Now start the simulation 

and note the route taken to the exit by each of the occupants.  You should notice that some of 

the males go over the obstacle and some do not, and no females traverse the obstruction at all.  

Use the path facility to see the path taken by some occupants more clearly.  In Figure 9-100, 

the path taken by two people is shown, (a) a male who traversed the obstruction and (b) a female 

who avoided the obstruction. 

 

It should be noted that modifying arc obstacle values in this way does not cause the Potential 

Map to modify in any way and thus some people may become trapped if used incorrectly.  

Furthermore, this technique can be used to model insurmountable objects by placing obstacle 

values higher than any Agility values.  However, it is better to delete the affected nodes or arcs 

completely as this ensures the Potential Map is constructed in the correct manner i.e. going 

around the obstacle. 
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TIP: 

It should be remembered that an arc with an elevated obstacle value that connects Free-Space 

nodes will not obstruct people but will instead reduce the person's travel speed. 

 

9.5.7 Example 6: Using Obstacle Zones 

In the final part of this tutorial a simplified method of altering the Obstacle values for a group 

of arcs via the use of Obstacle Zones will be outlined. This method will also provide the ability 

to alter Obstacle values dynamically throughout the simulation, as opposed to them merely 

remaining static at predefined values. The ability to dynamically alter the Obstacle values of 

arcs in this manner is intended to enable the reduction in passenger travel speeds resulting from 

deteriorating conditions (i.e. flooding) to be modelled. 

 

Before proceeding, move to GEOMETRY mode and ensure that all of the arc Obstacle values 

modified previously in example 5 are set back to their default values (i.e. Obstacle value = 0.0).  

 

We are now in a position to define the physical region or zone representing the required 

obstacle. Within this example we will first attempt to replicate the obstruction simulated within 

example 5 via the manual modification of arc Obstacle values. Move to SCENARIO mode and 

select the Zone option from within the Tools menu, and then the Edit Zone option from within 

the resulting submenu [Tools>Zone>Edit Zone]. Once selected, the Zone Editor will then be 

displayed. Next select the Obstacle option from within the Zone Type list box and then use the 

select tool to draw a boundary box around the node assumed to contain an obstruction within 

example 5 (see Figure 9-99). When this node (and only this node) has been selected then click 

the CREATE button within the Zone Editor. Once clicked EXODUS will then create a new 

Obstacle Zone comprising each of the currently selected nodes. This Obstacle Zone will be 

added to the Zone list within the left hand side of the Zone Editor and will by default be called 

Obstacle_Zone_1. To ensure that the created Obstacle Zone corresponds to the correct physical 

region (i.e. group of nodes), select the zone by clicking its corresponding panel within the Zone 

list and then click the SHOW button. The geometry should now resemble that shown in Figure 

9-101. 
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Figure 9-101: The Zone Editor showing the 1 node included within “Obstacle_Zone_1”. 

 

Having defined the Obstacle Zone itself, the next thing to do is to define the Obstacle values 

that each of the connecting arcs are required to adopt. The definition of arc Obstacle values is 

achieved by specifying a series of Obstacle Zone Events, with each event comprising both an 

Obstacle value and its corresponding trigger time. To define the Obstacle Zone Events for a 

given zone, first select the zone within the Zone list in the manner outlined previously and then 

click the ATTRIBUTES button to display that zones corresponding Obstacle Zone Event 

dialogue box. Within the Obstacle Zone Event dialogue box the time and its corresponding arc 

Obstacle value are entered in pairs in the time(s)+obstacle list. For example, the 

time(s)+obstacle list “2.30 3.40 5.00 4.00” means that 2.30 seconds into the simulation the arcs 

directly connected to nodes within the given zone will adopt an Obstacle value of 3.40, and that 

at 5.00 seconds into the simulation these connecting arcs will then in turn adopt an Obstacle 

value of 4.00 etc.  

 

We will now try and replicate the same conditions achieved manually in example 5. This will 

therefore require all the arcs connected directly to nodes within the defined zone to adopt an 

Obstacle value of 5.0 from the start of the simulation (i.e. time=0.0 seconds).  Enter the values 

0.00 and 5.00 into the time(s)+obstacle list, ensuring that the numbers are separated by either 

a space or a comma. No linear interpolation will be used within this example, therefore users 

should ensure that the Interpolate checkbox remains unchecked. The dialogue box should now 

resemble that shown in Figure 9-102. 

 

 
Figure 9-102: The Obstacle Zone Event dialogue box with a single zone event. 

 

Once both the event time and Obstacle value have been entered, verify the changes made by 

clicking the OK button. Then close down the Obstacle Zone Editor and move to SIMULATION 
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mode. Once in SIMULATION mode, enable the Zone Events option in the Behaviour tab of the 

BEHAVIOUR CONTROL dialogue box (RuleBase>Behaviour Options). Also, ensure that the 

Local Potential option is once again deselected within the Route tab. Bring up the Arc dialogue 

box of one of the arcs directly connected to the node assumed to contain the obstruction, and 

then start the simulation. As soon as the simulation starts you should notice that the Obstacle 

value of the connecting arc immediately jumps from its default value of 0.0 to the user-defined 

value of 5.0. This change will also result in the colour of the arcs similarly changing from their 

default Black to Cyan (see Figure 9-103). 

 

 
Figure 9-103: The Arc dialogue box showing the modified Obstacle value. 

 

Once run, you should notice the routes taken to the exit by each of the occupants should be 

identical to those generated previously within example 5. Once again, some of the males go 

over the obstacle, while some do not. This is due to the fact that the Agility within the male 

population ranged from 3 to 7. In contrast, no females should traverse the obstacle at all, since 

the Agility within the female population ranged from 1 to 4. As with the manual modification 

of arc Obstacle values discussed previously in example 5, the modification of Obstacle values 

via the definition of Obstacle Zones does not change the potential map in any way. 

Insurmountable objects can once again be modelled via the definition of Obstacle values higher 

than any Agility values. However, users wishing to model insurmountable objects are advised 

to instead delete the affected nodes/arcs completely, since this ensures that the potential map is 

constructed in the correct manner (i.e. goes around the obstacle). 

 

We will now attempt to expand the use of Obstacle Zones to define arc Obstacle values that 

dynamically change with time. Move to SCENARIO mode and once again open the Zone Editor 

in the manner detailed previously. Once again, set the Zone Type to Obstacle and then select 

the Obstacle Zone comprising the single obstruction node (i.e. Obstacle_Zone_1) by clicking 

its corresponding panel within the Zone list. Once selected, then click the ATTRIBUTES button 

to display that zones corresponding Obstacle Zone Event dialogue box. Within this example, 

we will assume that the Obstacle values of the connecting arcs initially start at 1.0 (i.e. the 

minimum Agility value assigned to females within this population) and increase linearly with 

time, before reaching a maximum value of 7.0 (i.e. the maximum Agility value assigned to 

males within this population) 30 seconds into the simulation. Enter the values “0.00 1.00 30.0 

7.0” into the time(s)+obstacle list, once again ensuring that the numbers are separated by either 

a space or a comma. Next, enable linear interpolation by ensuring that the Interpolate checkbox 

is selected. The dialogue box should now resemble that shown in Figure 9-104. 
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Figure 9-104: The Obstacle Zone Event dialogue box with multiple zone events. 

 

Once complete, verify the changes made by clicking the OK button and then return to 

SIMULATION mode. Bring up the Arc dialogue box of one of the arcs directly connected to the 

node assumed to contain the obstruction, and then start the simulation. Once again, as soon as 

the simulation starts you should notice that the Obstacle value of the connecting arcs 

immediately increase from their default value of 0.0. However, where previously the Obstacle 

values merely increased to a static value (i.e. 5.0), within this example the values can be seen 

to increase linearly with time throughout the simulation until reaching their maximum value of 

7.0 30 seconds into the simulation. The variation in the Obstacle value of the arcs also results 

in occupants adopting slightly different routes to the exit point than those adopted previously. 

In some cases, individuals with Agility values below 5.0 (i.e. both males and females), who had 

previously been unable to travel across the obstacle, instead find themselves able to traverse the 

obstacle. These individuals typically responded early in the simulation, and hence reached the 

obstacle before its corresponding Obstacle values had sufficiently increased enough to become 

impassable. Conversely, males with Agility values exceeding 5.0, who had previously been able 

to traverse the obstacle, in some cases found themselves unable to do so. In these cases, the 

individuals typically responded late in the simulation, and hence only reached the obstacle after 

its corresponding Obstacle values had exceeded their designated Agility. 
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9.6 Tutorial 6: Defining and Using User-Defined Fire Hazards  

This tutorial will demonstrate the principles in defining fire hazards created within the 

buildingEXODUS model. Fire hazards created using the CFAST model are examined in 

Tutorial 8. It should be noted that all values used for fire hazards in this tutorial are for 

demonstration purposes only, and are not intended to represent real fire hazard values.  This 

tutorial only relates to users with software level C. 

 

Fire hazards in buildingEXODUS are defined in a three-step process.  Firstly the Zones 

(physical area) over which the fire hazards will spread are defined.  Secondly, the fire hazards 

are defined, and finally the zones and hazards are linked together.  In this tutorial, three main 

examples will be considered.  Example 1 will be based upon a simple square room with a single 

zone encompassing the whole room.  In example 2, a more complex geometry involving two 

rooms and a corridor will be used, requiring the use of three zones.  In the final example, the 

concept of using fire hazards in a time dependent manner will be demonstrated. 

 

9.6.1 Example 1: A Simple Room With One Zone 

For example 1, we will need to create a simple room measuring 10m x 10m, i.e. 20 nodes by 

20 nodes.  Create this room using the method described in tutorial 1 using the Auto Connect 

tools to connect the grid, i.e. [Tools>Auto Connect>All].  When this task is complete, create a 

1m wide exit (i.e. connected to two Free-Space nodes), located in the bottom right corner of 

the geometry.  

 

Now advance to POPULATION MODE and populate the room with 20 individuals using the 

Random Generate function [Tools>Person>Random Generate].  Switch on the Boundary view 

to hide the nodes and arcs [View>Boundary].  At this stage the enclosure should resemble 

Figure 9-105. 

 

 
Figure 9-105: Simple 10m x 10m room with 20 individuals 

 

Now move into SCENARIO MODE.  We are now in a position to create the zone for the fire 

hazards. 

 

In example 1, only the smoke fire hazard will be considered.  However, the methods described 

may be equally applied to the other fire hazards.  We will define a smoke level function that 

linearly increases with respect to time. The smoke concentration in the upper layer will increase 



Chapter 9 – Tutorial 6 

 

© 2017 University of Greenwich 238 

from 0.1 /m to 0.6 /m in 30 seconds.  The smoke concentration in the lower level will increase 

from 0 /m to 0.5 /m in the same time period.  This specification is represented in Figure 9-106, 

which depicts a graph of smoke concentration over time for the first 40 seconds. Again it should 

be noted that such a spread is not intended to represent reality. 

 

 
Figure 9-106: Linear increase in smoke concentration. 

 

We are now in a position to define the zone.  Using the select tool, draw a bounding box around 

the whole enclosure, but do not include the external exit.  Now click the Add Zone button  

on the tool bar.  This will now highlight all the nodes within the zone and present the ADD 

ZONE dialogue box, as shown in Figure 9-107. Into this dialogue box, we only wish to modify 

the name of the zone, say to myzone.  Change this as indicated in Figure 9-107 and click the 

OK button. 

 

 
Figure 9-107: Defining a zone 

 

Now we can define the hazards to be used.  However, we must first decide the coefficients used 

to define the smoke spread function.  We note from the Theory Manual that the spread function 

is defined using a simple polynomial comprising a gradient and a power.  In this case, we need 
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only a linear increase, i.e. the power = 1.0.  The gradient can be calculated from the fact that 

we wish to increase the upper level from 0.1 /m to 0.6 /m in 30 seconds.  This yields a gradient 

of 0.02 [i.e. (0.6 - 0.1)/30 to two decimal places].  Click the HAZARD EDITOR button   to 

open the Hazard Editor dialogue box.  Now click the CREATE button in order to create a new 

fire hazard, entitled HAZ1.  Now click the UPPER button to modify the coefficients for the 

upper values.  Type the values for the Smoke coefficients as shown in Figure 9-108. 

 

NOTE:  

The values that appear in the dialogue box may be rounded. 

 

 
Figure 9-108: Zone dialogue box with appropriate parameters for the Smoke hazard 

 

Repeat this procedure for the LOWER hazard values, keeping the smoke coefficients identical, 

except for the starting value, which should be zero. 

 

Now click the SCENARIO EDITOR button on the toolbar so that the zone and hazard may be 

linked.  Now click the CREATE button to create a new scenario component.  You will now have 

to change the zone to MYZONE and the hazard to HAZ1.  To complete the former of these 

tasks, click the zone marked NONE (the button on the left side of the component).  Another 

dialogue box will appear showing the list of zones, in this case just MYZONE.  Click MYZONE 

to highlight it, and then the OK button.  The zone in the scenario component will now read 

MYZONE.  Now change the hazard definition to HAZ1, by clicking the remaining button 

marked “NONE” to retrieve the list of HAZARDS.  Now highlight HAZ1 by clicking it once, 

and then click the OK button.   

 

We now need to specify the time over which the HAZ1 will be active on MYZONE.  For the 

purposes of this tutorial, type the value 1000 in the end time to ensure that the hazard will be 

active through the whole simulation.  The Scenario Editor should now resemble that shown in 

Figure 9-109. 
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Figure 9-109: The Scenario Editor dialogue box 

 

NOTE: 

The Interpolate All checkbox need only be considered when importing CFAST or SMARTFIRE 

data files. 

 

Now move into SIMULATION MODE.  The first simulation to be conducted will be a base case 

for comparison purposes and so will NOT include the smoke hazards. Start the simulation by 

clicking the PLAY button and note the simulation time.  You should find the TET is in the region 

of 30 - 40 seconds.  Now reset the simulation and open the Hazard Options dialogue box via 

the Rulebase menu [Rulebase>Hazard Options], and enable the Hazard Model.  

 

Play the simulation and again note the TET.  This time, the evacuation should be quicker than 

the previous one, despite the presence of smoke!  The reason for this lies in the Response Time 

attribute of the people.  In the first simulation the individuals simply waited until their response 

time had elapsed before evacuating.  When smoke is present however, an override may cut short 

the response time.  The default value for the smoke related override is 0.1 /m.  Thus in this case, 

all the people reacted immediately as the smoke level started at 0.1 /m.   

 

If we examine the Main Graph produced for each of these simulations they are clearly different 

although the final TET in each case is similar (see Figure 9-110).  

 



Chapter 9 – Tutorial 6 

 

© 2017 University of Greenwich 241 

 
Figure 9-110: Evacuation curves for the first two simulations 

 

Figure 9-110 reveals that in the first simulation, the response times had a considerable impact, 

slowing the overall evacuation.  Furthermore, in the simulation with smoke, the rate of egress 

was considerably higher.  This is an expected result as more people were at the exits at an earlier 

time.  This point can be further illustrated by increasing the threshold level that overrides the 

response time for the smoke hazard. For this demonstration, we will increase the smoke override 

to 0.5 /m.  Any individuals not responding by this stage will be forced to crawl for the whole 

of their egress.  To modify the smoke override threshold, re-set the simulation and select the 

Hazard Options item from the Rulebase menu [Rulebase>Hazard Options].  This presents a 

dialogue box configuring the hazard and smoke models.  Modify the dialogue box options to 

match those shown in Figure 9-111 (i.e. set the smoke response override to 0.5 /m). 

 

 
Figure 9-111: Hazard Control dialogue box 

 

NOTE: 
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Person heights have no impact upon hazards generated within buildingEXODUS. They only 

become a factor when CFAST data files are used to describe the hazard. 
 

Now re-run the simulation.  Note that this time the simulation takes considerably longer.  This 

is due the individuals being slowed considerably by the high smoke levels.  Examination of the 

evacuation graphs in this case, reveals that the last simulation initially follows the first but after 

approximately seven seconds it starts to diverge due to the effect of the smoke decreasing the 

travel speed of the remaining individuals. 

 

 
Figure 9-112: Evacuation curve from all three simulations 

 

Before progressing to the next example, reset the simulation and start it again.  Pause the 

simulation after a few seconds and interrogate an individual to reveal the Person dialogue box.  

Click the GASES button and resume the simulation.  Note how the current smoke level to which 

the individual is exposed is displayed (see Figure 9-113). 

 

 
Figure 9-113: Person Gases dialogue box 

 

9.6.2 Example 2: Using Multiple Zones 

For example 2 we need to expand the current geometry.  First, move to POPULATION MODE 

and delete all the people. Next, move to GEOMETRY MODE and following the procedure 

described in Tutorial 2, construct another 10m x 10m room and join it to the current room with 

a 1m wide, 3m long corridor. Your geometry should resemble that shown in Figure 9-114.  
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Figure 9-114: Outline of new geometry 

 

Place 50 individuals in each room using the random generate function [Tools>Person>Random 

Generate], and progress to Scenario mode. 

 

In the manner described in example 1, highlight the room on the left and click the ADD ZONE 

button, and name the zone LEFTROOM.  Repeat this process, creating two further zones 

entitled CORRIDOR and RIGHTROOM.  Now click the EDIT ZONE button to retrieve the 

ZONE EDITOR dialogue box.  Click the MYZONE button and then the REMOVE button to 

delete the zone created in example 1.  At this stage, the ZONE EDITOR dialogue box should 

resemble Figure 9-115. 

 

 
Figure 9-115: The Zone Editor dialogue box 

 

We now need to create two further hazard definitions, HAZ2 and HAZ3.  Close the Zone Editor 

dialogue box by clicking the OK button, and open the Hazard Editor by clicking its button  

on the toolbar.  Now click the CREATE button twice to create the two new hazard definitions.  

Modify the values of the smoke hazard in the UPPER and LOWER dialogue boxes for both 

HAZ2 and HAZ3 using the table below for the coefficients. 
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Table 9-1 : Smoke hazard coeficients for example 2 

Hazard Height Starting Value Gradient Power 

HAZ2 UPPER 0.05 0.017 1.0 

HAZ2 LOWER 0.00 0.017 1.0 

HAZ3 UPPER 0.05 0.015 1.0 

HAZ3 LOWER 0.00 0.015 1.0 

 

Following the procedure demonstrated in example 1, link the hazards to the zones so that the 

Scenario Editor resembles Figure 9-116. 

 

 
Figure 9-116: The Scenario Editor For Example 2 

 

NOTE: 

The behaviour relating to staggering in smoke or redirection in response to the existence of a 

smoke barrier is not enabled. 

 

Before moving into SIMULATION MODE, we will retrieve the GASES dialogue box for three 

nodes, one from each zone, so as to monitor the progress of the smoke levels.  In Boundary 

view the simplest way to achieve this is to use the Display / Nodes function.  To do this, first 

select a region encompassing the corridor and at least one row of nodes into each room; then 

select the Display item from the View menu and then Nodes from the sub-menu 

[View>Display>Nodes].  This should reveal the nodes in the selected region. The geometry 

should now resemble Figure 9-117. 
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Figure 9-117: Using the Node Display function 

 

Now move into SIMULATION MODE and double-click one node from each zone to retrieve 

their respective dialogue boxes, and click the GASES button on each.  Move the dialogue boxes 

around to tidy the view.  Ensure that the options set for this simulation are the same as for the 

third simulation in the previous example (i.e. smoke override set at 0.5 /m and hazard model 

switched on).  Now select [Edit>Clear>Main Graph] to clear all the previous evacuation 

graphs and then start the simulation.  Note how the smoke levels change as the simulation 

progresses, Figure 9-118, displays an example.   

 

Repeat the simulation two times, adjusting the parameters as described in the previous example 

(i.e. case 1: no smoke, case 2: smoke override set to 0.1 /m, case 3: smoke override set to 0.5/m). 

After the simulations have completed, examine the Main Graph.  An example is shown in 

Figure 9-119.  Note that in this instance, the case with no smoke produces a much faster rate of 

egress.  This is because in this case, the Response time attribute of the individuals is not as 

important as the exit becomes quickly over-subscribed.  It is also important to note again the 

difference between the override levels.  The case where a “quick” response applies i.e. override 

at 0.1 /m, produces a quicker evacuation.  This suggests that it is important in this kind of 

scenario to ensure individuals react quickly. 

 

 
Figure 9-118: Simulation in progress 

 



Chapter 9 – Tutorial 6 

 

© 2017 University of Greenwich 246 

 
Figure 9-119: Graphs from three zone simulations 

 

9.6.3 Example 3: Using Multiple Time Zones 

In the previous two examples the hazards were active throughout the simulation. This approach 

works well if one equation is sufficient to define the hazard spread over the complete time 

period.  However, in some cases this may be insufficient as the spread rate may change over 

time. This possibility is catered for through the ability to define multiple hazards and attaching 

them to zones over different time periods.  

 

In this example we will continue to use the geometry defined in the previous example.  Move 

buildingEXODUS into SCENARIO MODE and click the HAZARD EDITOR button to retrieve 

the Hazard Editor dialogue box.  We are now in a position to create the new hazards.  We will 

require five new hazard definitions, two will be used for the LEFTROOM and CORRIDOR, 

and the remaining hazard will be used in the RIGHTROOM.  Remove all the currently created 

hazards by clicking the CLEAR button.  Now click the CREATE button five times to create 

FIVE new hazards.  Using the tables below, define the individual hazards, using the name 

indicated in each case.  Note that only the starting values are to be varied between the UPPER 

and LOWER heights and that the oxygen concentration has a decreasing gradient. 

 

NOTE: 

It should be noted that the values that eventually appear in the dialogue boxes may be rounded. 

 

Hazard Name: “LEFT0-30” 

 

Table 9-2: Hazard information for LEFTROOM from 0 - 30 seconds 
Hazard Lower Value Upper Value Gradient Power 

Temperature 20 30 3.67 1  

HCN 0 5 1 1 

CO 0 1000 100 1 

CO2 0 1 0.067 1 

O2 21 20 -0.067 1 

Smoke 0 0.05 0.005 1 

Start Time 0.0  

End Time 30.0 

 

Hazard Name: “LEFT30-1000” 
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Table 9-3: Hazard information for LEFTROOM from 30 to 1000 seconds 
Hazard Lower Value Upper Value Gradient Power 

Temperature 130 140 8.67 1  

HCN 30 35 0.5 1 

CO 3000 4000 200.0 1 

CO2 2.0 3.0 0.133 1 

O2 19.0 18.0 -0.133 1 

Smoke 0.15 0.20 0.01 1 

Start Time 30.0  

End Time 1000 

 

Hazard Name: “CORR0-30” 

 

Table 9-4: Hazard information for CORRIDOR from 0 - 30 seconds. 
Hazard Lower Value Upper Value Gradient Power 

Temperature 20 25 2.5 1  

HCN 0 1 0.10 1 

CO 0 500 12.5 1 

CO2 0 0.5 0.031 1 

O2 21.0 20.5 -0.031 1 

Smoke 0 0.05 0.00125 1 

Start Time 0.0  

End Time 30.0 

 

Hazard Name: “CORR30-1000” 

 

Table 9-5: Hazard information for CORRIDOR from 30 - 1000 seconds. 
Hazard Lower Value Upper Value Gradient Power 

Temperature 95 100 0.28 2  

HCN 4 5 0.0375 2 

CO 500 1000 12.5 2 

CO2 1.25 1.75 0.00563 2 

O2 19.75 19.25 -0.00563 2 

Smoke 0.05 0.1 0.00063 2 

Start Time 30.0  

End Time 1000 

 

 

Hazard Name: “RIGHT0-1000” 

 

Table 9-6: Hazard information for RIGHTROOM from 0 - 1000 seconds. 
Hazard Lower Value Upper Value Gradient Power 

Temperature 20 25 0.0833 2  

HCN 0 1 0.0039 2 

CO 0 500 1.25 2 

CO2 0 0.5 0.0007 2 

O2 21 20.5 -0.0007 2 

Smoke 0 0.05 0.00007 2 

Start Time 0.0  

End Time 1000 
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It should be stressed at this point that the curves generated from the above data are purely 

hypothetical and do not contain any data describing the development of the irritant gases or the 

level of radiative flux.  The values have been chosen to demonstrate how to obtain various 

trends for the hazards.  The following graphs represent each hazard over the first 60 seconds of 

a simulation at the upper height.  The notes for each graph explain the trends. 

 

Figure 9-120a demonstrates three trends.  In zone 1 (LEFTROOM) the temperature initially 

increases linearly for 30 seconds.  After 30 seconds, the temperature continues to increase 

linearly but at a faster rate.  The temperature in zone 2 (CORRIDOR) has a similar profile for 

the first 30 seconds, but then increases according to a time-squared function.  In the third zone 

(RIGHTROOM), a time-squared function is used to increase the temperature for the entire 

period.  Note that for a certain period (approximately 30 - 55 seconds) the temperature in zone 

3 actually exceeds that in zone 2 - in reality if the fire were in zone 1 this would be an unlikely 

scenario. 
 

In Figure 9-120b the HCN concentrations for zones 2 and 3 follow the same profile as the 

temperatures.  In zone 1 however, the rate of increase actually slows at 30 seconds.  In real 

fires, after a certain period, this kind of trend is common. 
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(a) (b) 

  
(c) (d) 

  
(e) (f) 

Figure 9-120: Upper height hazard trends for each zone, (a) temperature (C), (b) HCN (ppm), 

(c) CO (ppm), (d) carbon-dioxide (%), (e) oxygen (%) and (f) smoke (l/m) 

 

Figure 9-120c shows the graphs for carbon monoxide.  Again, similar profiles are used as for 

the temperature, but in this case, a high value was used for the coefficient in the time squared 

function after 30s in zone 2 - note the rapid rate of increase.  This demonstrates that powers of 

2 and above should be used with care. 

 

Figure 9-120d and Figure 9-120e demonstrate the graphs for carbon dioxide and oxygen 

concentrations respectively.  Note that the trends are exactly opposite - this should always be 

the case for these two gases as their respective values should always sum to 21%. 

 

The final graph shown (Figure 9-120f) shows the values for the smoke concentration.  Again a 

similar trend is used as for temperature. 
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Now the hazards have been defined, the Scenario Editor must be used to link them to the zones 

over the required time periods.  Click the OK button to close the Hazard Editor dialogue box, 

then click the SCENARIO EDITOR button on the toolbar.  Now configure the dialogue box so 

that it resembles Figure 9-121.  When completed, click the OK button and move 

buildingEXODUS into SIMULATION MODE. 

 

 
Figure 9-121: Scenario Editor for Example 3 

 

Once again, clear the Main Graph window [Edit>Clear>Main Graph] and then enable the 

Hazard Model by selecting the Hazard Options item from the Rulebase menu and then checking 

the Enabled check box.  Ensure that the smoke override level is set at 0.5 /m and start the 

simulation. 

 

When complete you should notice that some individuals have become incapacitated.  When this 

happens, a mortuary icon appears in a similar fashion to that for an external exit.  The 

individuals “inside” the mortuary can be interrogated like any other individual. An example is 

shown in Figure 9-122.  Note that for the individual shown, the cause of incapacitation was the 

FIH level - the Gases dialogue box shows that this has reached a level greater than 1.0.  This 

fact can be ascertained immediately from the icons next to the mortuary.  Each expired 

individual has a symbol inside the icon, either “H” or “T”.  “T” indicates the individual was 

incapacitated due to temperature exposure and “H” indicates the incapacitation was caused by 

the toxic nature of the hazardous gases.  It is likely that for the fire hazard scenario defined that 

all the individuals that expired were incapacitated due to excessive levels of temperature.   
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Figure 9-122: Interrogating a fatality Figure 9-123: Starting and ending locations of 

fatalities 

 

The mortuary icon itself can also be interrogated in the same manner as an exit.  For example, 

the starting and ending location of all the fatalities can be displayed.  An example is shown in 

Figure 9-123.  By selecting an arc which is connected to a node on which a fatality occurred 

you will note that the obstacle value of the arc has increased. This reflects the fact that the body 

of the incapacitated person remains in the geometry creating an obstacle for the other 

individuals to negotiate. 

 

Now modify the toxicity models by selecting the Hazard Options item from the Rulebase menu 

[Rulebase>Hazard Options].  Modify the options so that the Speitel heat equation is used in 

place of the Purser heat equation.  Now re-run the simulation.  You should notice at the end of 

the simulation that fewer fatalities have occurred (see the Theory Manual for explanation). 

 

9.6.4 Example 4: Using Experimental Fire Hazard Data. 

In some cases it may be possible to use experimental fire data or fire data generated from 

mathematical fire models. In this example we will make use of experimental data generated for 

a room fire [24]. The test conditions are intended to represent a fire in a well-ventilated room 

with an open doorway. The fire was generated in a polystyrene chair with polyurethane 

cushions. Fire data was reported for a five-minute period with concentrations and temperature 

being logged every minute. Smoke concentrations and the physical dimensions of the room are 

not reported in the original publication [24]. 

 

The scenario to be modelled consists of an elderly man (70 years old) sleeping in the room of 

ignition. The room measures 10m x 10m with a 1m wide exit. The man will be given a long 

response time (180 seconds) to signify that he is originally asleep and a slow movement rate 

(0.6 m/s). The temperature response override will be set at 100oC. 

 

9.6.4.1 Defining the Fire Zone. 

Start a new file by clicking the New button and create the same room as described in example 

1 (i.e. a square room 10m by 10m).  Place the exit again in the bottom right hand corner of the 

geometry, link with arcs and move to Population mode.  In this case we are going to use one 

evacuee only and follow his progress.  Click the DEFAULT PERSON button and place a single 

evacuee in the top left corner of the geometry.  Double click the individual to retrieve his 

dialogue box and modify his attributes so that his age is 70 years, his response time is 180 

seconds, and finally his fast walk and walk speeds are 0.6m/s and 0.4m/s respectively.  Now 

move to Scenario mode so that the atmosphere may be defined. 
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Table 9-7 displays the experimental data [24]. Tables 6.7 to 6.11 displays the fire data in the 

required hazard format (note only the upper and lower values are assumed to be the same).  In 

this case the values provided for each of the hazards are time-snaps after each minute.  From 

this data we can interpolate using a simple linear function for each hazard.  As the data supplied 

covers five minutes, five hazard definitions are required to operate on a single zone covering 

the entire geometry.  Note however, that the value for POWER is not included, this should take 

the value 1.0 in all cases.  To construct this fire in buildingEXODUS, first create the zone as 

described in Example 1, and then follow the same steps as in Example 3, to utilise the data 

shown in the tables below. 

 

Table 9-7: Experimental fire data [24]. 
Time (min)  1 2 3 4 5 

CO    ppm 0 0 500 2000 3500 

HCN ppm 0 0 0 75 125 

CO2   % 0 0 1.5 3.5 6 

O2     % 20.9 20.9 19 17.5 15 

Temp C 20 65 125 220 405 

 

Table 9-8: Hazard data for 0-180 seconds 

Hazard 
0-60s 60-120s 120-180s 

Start Value Gradient Start Value Gradient Start Value Gradient 

Temperature (C) 20 0 20 0.75 65 1.0 

HCN ppm 0 0 0 0 0 0 

CO  ppm 0 0 0 0 0 8.333 

CO2  % 0 0 0 0 0 0.025 

O2  % 21 0 21 0 21 -0.025 

 

Table 9-9: Hazard data for 180-300 seconds 

Hazard 
180-240s 240-300s 

Start Value Gradient Start Value Gradient 

Temperature (C) 125 1.583 220 3.083 

HCN ppm 0 1.25 75 0.833 

CO  ppm 500 25.0 2000 25.0 

CO2  % 1.5 0.0333 3.5 0.0417 

O2  % 19.5 -0.0333 17.5 -0.0417 

 

When the hazards have been defined, open the SCENARIO EDITOR dialogue box as described 

in the previous examples, and link the zone to the fire hazards, using the times described in the 

table captions (see Figure 9-124). 
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Figure 9-124: Example Scenario Editor dialogue box for Example 4 

 

Now move to SIMULATION MODE and enable the Hazard Model from within the Hazard 

Options dialogue box [Rulebase>Hazard Options]. In this example, also ensure that the 

Temperature response override is set to 100oC. You should notice that the individual does not 

respond for some time - until the temperature reaches 100 degrees.  Interrogate the individual 

to reveal his GASES dialogue box and carefully track the individual through the simulation. 

 

Table 9-10: Values in Gases dialogue box at different stages during simulation 
 Simulation Time (s) 

Attribute 120 130 140 150 160 170 Final 

FIN 0.010 0.010 0.012 0.013 0.017 0.023 0.03 

FIH 0.009 0.015 0.024 0.034 0.050 0.068 0.088 

FICO2  0.004 0.005 0.005 0.005 0.006 0.007 0.007 

PID (%) 30 30 30 30 30 30 30 

RMV (l/m) 8.5 8.5 8.5 8.5 50 50 25.0 

VCO2 0.992 1.054 1.122 1.195 1.270 1.348 1.415 

Temp (deg C) 65.0 75.0 85.0 94.833 104.833 115.000 - 

CO (ppm) 0.0 83.33 166.6 248.601 331.931 416.650 - 

CO2 (%) 0.0 0.250 0.50 0.746 0.996 1.250 - 

HCN (ppm) 0.0 0.0 0.0 0.0 0.0 0.0 - 

O2 (%) 21.0 20.68 20.36 20.045 19.725 19.4 - 
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9.7 Tutorial 7: Demonstration of Miscellaneous Features 

In this tutorial examples are outlined to demonstrate the capabilities of a number of features not 

covered in previous tutorials.  While these tutorials will not examine all aspects of the 

functionality of the new features, they provide a useful introduction into their use and their 

capabilities. The design of these tutorials has been based on the assumption that the user has 

progressed through the previous tutorials concerning the fundamental buildingEXODUS 

functionality. These tutorials will therefore only briefly address the more basic aspects of the 

model and will concentrate upon the use of the advanced features. 

 

It is acknowledged that the nature and shape of the geometries included here are relatively 

arbitrary. However, this tutorial is designed to demonstrate some of the buildingEXODUS 

features rather than representing a realistic scenario. 

 

9.7.1 Example 1.: Use of Census Regions  

This tutorial is intended to demonstrate the use of the Census Region and demonstrate the types 

of data that can be produced. 

 

For this example two rooms, each of 7.5m x 7.5m need to be created. These rooms are then 

centrally connected by a 1.5m opening. This effectively positions a connecting opening between 

the two rooms. A single exit should be centrally positioned on the eastern wall of the structure 

(Figure 9-125). This external exit is then positioned horizontally in line with the internal opening 

and is attributed with free-flow conditions. 

 

 
Figure 9-125: The geometry including Census Region. 

 

The Census Region should be positioned on the eastern side of the internal opening (see Figure 

9-125). This is achieved by identifying the three constituent nodes and then generating the Census 

Region [Tools>Generate>Census Region]. The Census Region is therefore positioned on the 

internal opening to record the number of evacuees evacuating through the opening. 

 

Once completed a population of 200 people should be placed in the west room (see Figure 9-125), 

using the Random Generate function in Population mode [Tools>Person>Random Generate].  

In this example the nature of the evacuee population is of no particular interest and so a random 

population will suffice. These individuals should however respond instantly. No hazards are 

involved in this simulation. 
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(a) (b) (c) 

Figure 9-126: Three methods to examine the graph generated by the Census Region. 

 

Once the simulation is run the user will notice that the evacuees progress quickly towards the 

single exit point.  In addition to the graphical windows normally generated, an additional 

Census_1 window can also be produced (see Figure 9-127). This can be achieved in a number of 

ways: selecting the Graphs, from the Display sub-menu on the View menu 

[View>Display>Graphs] (see Figure 9-126 (a)); right-clicking on the Census region and then 

selecting the Graph option from the pop-up menu that appears (see Figure 9-126 (b)); or if the 

Navigation Window is displayed, then the Census Regions within the geometry can be accessed 

through expanding the Floors tree until the Census Regions branch is visible (see Figure 9-126 

(c)). 

 

 
Figure 9-127: The graphs generated by the Census Region and the External Exit. 

 

This graph represents the number of individuals that pass the Census Region and the time that 

this event takes place. This data allows additional analysis of the arrival times of evacuees at the 

exit and the user-specified area within the geometry. This subsequently allows analysis of the 

progression of individuals during the simulation and the possible influences upon this 

progression. In this instance the close proximity of the Census Region to the exit demonstrates 

only a 5-10 second time lag in the evacuee arrival times (see Figure 9-127). The similarity of the 

two curves generated reflects the similarities between the two ‘exits point’ (i.e. the exits have the 

same width and flow conditions). Therefore the internal and external openings exert a similar 

impact over the course of the simulation. 
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Figure 9-128: Data concerning the performance of the Census Region and the external exit 

(door_1). 

 

In addition to the additional graphical data, the user is also supplied with data concerning the flow 

times and arrival times of the evacuating individuals (see Figure 9-128).  

 

NOTE: 

The addition of a Census Region has no impact upon the behaviour of the simulated evacuees. Its 

use is therefore restricted to the gathering of information concerning a specific location within 

the geometry. 

 

To exaggerate the differences in the results produced, the evacuee population should be randomly 

distributed between the two rooms, using the Randomise function available in Population and 

Simulation mode [Edit>Relocate>Randomise]. The differences in the results produced for the 

Census Region and the External Exit should then be more pronounced due to the changes in the 

evacuee locations. The user might also adjust the width of the external exit and/or adjust the flow 

rate assigned to it to allow comparison between the results produced by the internal opening 

(represented by the Census Region) and the external exit. 

 

9.7.2 Example 2: Use of Census Regions and the Population Density Contour  

In Example 2, a more complex geometry is used to examine the impact of the population density 

upon the efficiency of the evacuation and the use of Census Regions in examining this impact. 

Two 8m x 9m rooms are generated and are connected by a 1.5m wide corridor, as shown in Figure 

9-129. This corridor leads directly to an exit point 1m wide (i.e. connected to two nodes), located 

centrally. A Census Region is positioned at the connecting opening of each room (see Figure 

9-129) to record the number of individuals evacuating through the opening. They are both located 

on the southern side of the connecting internal openings. 

 

Two populations are randomly generated [Tools>Person>Random Generate]. Fifty individuals 

are located in the west room, while 280 are located in the east room. All of the evacuees respond 

instantly. No hazards are involved in this simulation. 
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Figure 9-129: Diagram of the geometry used in Example 2. 

 

A significant difference in the results produced by the Census Regions can be observed reflecting 

the differences in the conditions around the internal openings. These differences are evident in 

the number of evacuees using each internal opening, the time of the last evacuee out and the flow 

rates produced due to the differences in the size of the populations and the subsequent population 

densities (see Figure 9-130 and Figure 9-131). 

 

 
(a) (b) (c) 

Figure 9-130: Evacuee arrivals at the two Census Regions and the exit. 

 

From Figure 9-130 (a) it is clear that the evacuee population evacuating from the west room 

cleared the room after approximately 18 seconds, while the population in the east room continued 

evacuating until over 140 seconds (see Figure 9-130(b)). This is confirmed by examining the data 

output in Figure 9-131. This might suggest to the user that a more uniform distribution of evacuees 

throughout the structure may considerably reduce the overall evacuation time of nearly 165 

seconds (see Figure 9-130(c) and Figure 9-131). This type of detailed information based around 

the evacuee activity at specific locations in the geometry would not have been possible without 

the use of the Census Region. 

 

 
Figure 9-131: Data output from Example 2 
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To better comprehend the differences in the conditions around the two internal openings, the 

Population Density Contour feature can be utilised. This is available from the View menu and the 

Contour sub-menu in Simulation mode [View>Contour>Pop. Density]. 

 

Once the Population Density Contour has been enabled, the differences in the densities that are 

achieved around the two internal openings become apparent (see Figure 9-132). The population 

densities around the left internal opening can clearly be seen to be diminishing, with large areas 

of the geometry empty and only small areas of the geometry being fully occupied (depicted as 

red). In contrast, the solid dark area (displayed red on the screen) around the right hand opening 

depicts the relatively static, high-density population. This therefore demonstrates the ability of 

buildingEXODUS not only to produce quantitative results (in terms of evacuation times), but that 

it can also be used for qualitative analysis of the evacuee behaviour and the subsequent conditions 

that the evacuees experienced during the evacuation.  

 

 
Figure 9-132: The appearance of the conditions as depicted by the Population Density 

Contour. 

 

It should be remembered that the population density is measured according to nodal connectivity. 

Therefore in areas depicted as red, the nodes are fully occupied. When the nodes are connected 

according to physical distance, these fully occupied areas approximate 4 individuals per metre2, 

the recommended maximum achievable level of occupation within buildingEXODUS.  

 

As an additional exercise, the user may wish to randomise the location of the individual 

population between the two rooms, to examine the impact upon the individual behaviour around 

the internal openings and the overall evacuation times. 

 

9.7.3 Example 3: Use of the Census Line 

Another, more flexible, method allowing the user to collect results from locations within the 

geometry is the Census Line. Firstly, the user should re-open the geometry used in Example 1 and 

delete the Census Region located within it. To generate the Census Line across the adjoining 

corridor, the user should enable the Census Line option via the Tools menu and the Generate sub-

menu [Tools>Generate>Census Line] (see Figure 9-133). 
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Figure 9-133: Generating the Census Line. 

 

Once this has been completed the user should drag a Census Line across the opening within the 

left-hand internal room. The attributes associated with the Census Line can be accessed (see 

Figure 9-134), assuming that Census Lines are deemed to be Displayed and Selectable in the 

Display Control dialogue box [View>Display>Gra. Ctrl Options]. 

 

 
Figure 9-134: The attributes associated with the Census Line 

 

Once the simulation is run and the results are examined, it becomes apparent that the results 

produced are the same as those produced using the Census Regions (see Figure 9-135), 

demonstrating the consistency between the two methods. This method allows the user greater 

confidence in the nature of the results produced and is more intuitive. 

 

 
Figure 9-135: Results produced using the Census Line 

 

Again the introduction of the Census Line will have no impact upon the behaviour of the evacuees 

and therefore upon the results produced. 
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In the next tutorial several examples are provided to demonstrate the increased sophistication in 

the occupant behaviour that is provided through the use of the Local Familiarity system. This 

system is compared with the original Potential Map system and is also used in conjunction with 

the Target Exit system to demonstrate the overall flexibility of the system. 

 

9.7.4 Example 4: Use of Local Familiarity  

In this tutorial numerous changes to the Rulebase will have to be made to allow access to the 

various navigational systems. This tutorial is designed to demonstrate the increased flexibility of 

the Local Familiarity system making use of the individual Occupant Exit Knowledge. 

 

A 15m x 15m geometry is constructed with four exits located at the corners of the geometry each 

with HMSO flow rate restrictions (see Figure 9-136). The geometry has three 5m x 5m sub-

compartments possibly representing internal offices (see Figure 9-136). One of the exits, located 

in the north-eastern corner of the geometry is a frequently used, main exit. This exit is attributed 

with an Attractiveness of 100% so that all of the occupants will be aware of the existence of this 

exit. The other three exits are defined as emergency exits. These exits are attributed with an 

Attractiveness of 50, so that the occupants have only a 50% probability of being familiar with 

these exits. These exits will not normally be used (i.e. when the Normal behavioural regime is 

used) due to their emergency status. 

 

 
Figure 9-136: The geometry used in tutorial 4 with associated probability of the 

occupant’s exit awareness 

 

Five sub-populations are generated to reflect the different forms of behaviour that might be 

expected in this type of structure. Population 1 is located in the north-western sub-compartment. 

These occupants have had their Exit Knowledge manually engineered (in Population mode) so 

that the occupants are familiar with their nearest Emergency Exit (e_1) and the Main Exit (m_1) 

(see Figure 9-137).  

 

 
Figure 9-137: Attributed exit awareness of an occupant in Population 1. 

 

This is intended to represent a group of office workers who are familiar with their particular office 

and the main foyer of the structure (see Figure 9-136). Similar sub-populations are located in 
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south-west and south-east rooms of the geometry with similarly guaranteed understandings of the 

geometry (Population 2 is aware of exits e_2 and m_1 and is located in the south-west room, 

while Population 3 is aware of exit e_3 and m_1 and is located in the south-east room). Population 

4 is made up of 10 randomly positioned occupants, located in the main area of the structure outside 

of the three sub compartments (see Figure 9-136). These occupants have not been attributed with 

an Exit Knowledge specifically, but instead have exits attributed to them by the model, according 

to the Attractiveness of the individual exits and therefore have a more varied understanding of the 

potential egress routes. This is performed automatically prior to the commencement of each 

simulation.  

 

As the main exit (m_1) has an Attractiveness of 100, the occupants whose familiarity is dependent 

upon probability will always be familiar with this exit. As the three emergency exits each have 

an Attractiveness of 50, occupant familiarity with them is not guaranteed. Population 4 might 

represent occupants who are infrequent users of the structure and therefore use the main entrance 

to enter the building, but otherwise have a less predictable understanding of the enclosure. 

 

Finally, Population 5 is also located in the main area of the geometry, outside of the sub-rooms 

(see Figure 9-136). These are attributed with a Target Exit, forcing them to follow a specific path 

during the simulation. In this instance the four occupants are aware of exit e_2. This might be 

used to simulate members of staff who have to follow a pre-determined path irrespective of the 

conditions that they face.  

 

All of the occupant populations respond instantly. No Hazards are involved in this simulation 

 

 
Figure 9-138: The output when using the NORMAL regime 

 

Initially the Normal behavioural regime is used. The Local Familiarity check box should be 

enabled on the Route tab of the Behaviour Control dialogue box. When this is used all of the 

occupants except those with Target Exits (Population 5) will head towards the main exit (in the 

north-eastern corner of the geometry). This is because all of the occupants are familiar with the 

main exit (m_1) and given that the Normal regime is selected (i.e. the default position, when the 

Extreme regime is not selected), occupants prefer to move towards exits in constant use (i.e. main 

exits) rather than moving towards an emergency exit, even if the emergency exit is closer. Those 

occupants in Population 5 who have Target Exits head towards their specified target (emergency 

exit e_2) irrespective of the behavioural regime used. (If an occupant is specified with a target 

exit, it will override any other form of goal that may be attributed to the occupant. This can be 

determined by examining the exit usage from the output window (see Figure 9-138). This data 

demonstrates the manner in which the Local Familiarity system operates on a number of levels 

catering for manually imposed exit lists, automatically generated exit lists and their interaction 
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with Target Exits; 25 occupants head towards the main exit (m_1) with only the four members of 

Population 5 heading towards emergency exit e_2. 

 

NOTE: 

The Attractiveness of an exit should represent the likelihood of an occupant being aware of an 

exit and then using the exit during an evacuation. 

 

If the Extreme behavioural regime is used the occupants that are situated in the sub-compartments 

then move towards their nearest exit irrespective of the exit’s usage. In this case, the nearest exits 

are the emergency exits e_1, e_2 and e_3. The occupants that are specified as having Target Exits 

(Population 5) still move towards this exit (e_2). The imposition of a Target Exit supersedes any 

attempt at representing the occupants understanding of the geometry or the altering the 

behavioural regime. 

 

The exits used by the other occupants situated in the main area of the compartment (Population 

4) will be dependent upon their knowledge of the exits (i.e. their Occupant Exit Knowledge) as 

well as their initial location. Given that the Extreme regime has been used, the occupants move 

towards their nearest exit irrespective of the exit usage. Therefore, in this instance, emergency 

exits are used far more frequently than in the previous example (see Figure 9-139). This 

demonstrates the important interaction between the regime used during the simulation and the 

propensity of the simulated evacuees to use emergency exits. It should be noted that the adoption 

of emergency exits will vary between simulations according to the exact exit awareness of the 

occupant population. 

 

 
Figure 9-139: During Extreme behaviour the emergency exits are used far more frequently 

 

This tutorial is particularly useful as it demonstrates numerous features including: 

 The ability for Local Familiarity and Target Exits to interact 

 The different methods that can be used to attribute exit familiarity 

 The impact upon exit usage of the behavioural regime used. 

 

To demonstrate another form of behavioural interaction, Population 5 is deleted and replaced by 

a new population (Population 6) who have been attributed with a list of tasks. This is achieved by 

first creating an itinerary using the Itinerary Editor in Population mode [Tools>Itinerary 

Window], and the EDIT ITINERARY dialogue box (see Figure 9-140) launched by double-

clicking on the highlighted task button on the ITINERARY EDITOR. This should have 

previously been created using the CREATE button on the ITINERARY SELECTION dialogue 

box. 
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(a)  (b) 

Figure 9-140: Creation of an Itinerary 

 

The user is free to choose the nodal location added to the itinerary list. The locations used in the 

creation of this example are outlined in Figure 9-141.  

 

 
Figure 9-141: The approximate location of the nodal locations and the order in which they 

are visited. 

 

Once the itinerary has been created, it has to be attached to a Population Panel. Initially, a new 

panel must be created (using the CREATE button on the POPULATION PANEL dialogue box). 

By double-clicking the button generated for the new population panel and then the ADVANCED 

button, the ADVANCED dialogue box becomes available. From here the ITINERARY dialogue 

box is accessible where the previously defined Itinerary (i.e. Itin_1) can be inserted.  

 

NOTE: 

If the user wishes to place occupants at a specific location then this area should be selected prior 

to the generation of the occupant population. 

 

Once these have been allotted, the simulation can then be run in both Normal and Extreme mode. 

This again will demonstrate the manner in which occupants with different itineraries and different 

levels of familiarity interact during the simulation. 

 

TIP:  

The user may wish to allow elements of the population, who are specified as performing a task, 

to have the possibility not to perform these tasks, i.e. that these occupants / staff are not entirely 

reliable. This can be achieved by the provision of dummy tasks that include no nodal locations 

(see Chapter 4 and the User Guide, Chapter 3).  

 

Populations 1-4 behave in an identical manner to the previous example. Population 6 however 

complete their tasks prior to their evacuation, visiting the nodal locations in the order of their 
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appearance in the EDIT ITINERARY TASK dialogue box. Although this behaviour is 

deterministic, the delay experienced at each location will be randomly distributed between the 

boundaries provided by the user (see Figure 9-140(b)). Again, the choice of the exit for the 

members of Population 6 will be dependent on their awareness, the behavioural regime employed 

and the location of their final task. 

 

NOTE: 

In this instance, the occupants do not have the opportunity to ‘lose’ their tasks through becoming 

impatient or interacting with a deteriorating environment. The user is encouraged to experiment 

with these possibilities. 

 

Once the simulation is complete, the user can save the simulation so that it may be replayed using 

the virtual reality interface (available with Levels B and C). This can only be achieved once the 

simulation is complete. The user should not Reset or perform any other action prior to saving the 

simulation for the virtual reality interface. Once the simulation is complete the user should select 

the VR Save option on the Simulation menu [Simulation>VR Save]. This then generates the VR 

FLOOR CONTROL dialogue box. In this instance, as the geometry consisted of one floor, the 

SAVE button should be pressed, which generates the SAVE AS dialogue box. Once the user has 

completed this task the .VRS and .VRG files produced can then be loaded into the virtual reality 

interface (i.e. vrEXODUS) and viewed. 

 

 
Figure 9-142: Virtual reality views of Example 4 produced using vrEXODUS. 

 

9.7.5 Example 5: Smoke Stagger (Jin’s Inefficient Movement)  

In the next example, a relatively simple geometry is used to examine the introduction of evacuee 

staggering through a smoke-filled environment. The evacuees are provided with no alternative 

routes other than to move through the smoke-filled environment. 

 

A 7.5m x 9.5m room is connected to a 10m x 2.5m corridor (see Figure 9-143). A single exit 

point (connected via a single arc) is positioned at the eastern end of the geometry and has a free 

flow rate attributed to it (i.e. 999 occ/m/s). Twenty people are generated using the Population 

Panel and are positioned in the room at the western end of the geometry (see Figure 9-143). These 

evacuees respond between 0-30 seconds. 

 

The smoke-filled zone encompasses the entire corridor (10m x 2.5m). The evacuees are therefore 

forced to interact with the smoke that blocks the route to their exit point. The simulations should 

be repeated, changing the extinction coefficient between runs, within a range of 0.1/m to 0.6/m 

(the level remaining constant during each simulation). This will enable the impact of the 

extinction coefficient to be examined in context with a number of different extinction coefficient 
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levels. In all of these examples the Crawling option is enabled within the Environment tab of the 

Behaviour Control dialogue box [Rulebase>Behaviour Options]. 

 

 
Figure 9-143: Geometry and hazard used in this example. The smoke is demonstrated 

using the Smoke Contour function 

 

Initially the Smoke Staggering function is disabled. It should be remembered that the Hazard 

Model should be enabled in the HAZARD CONTROL dialogue box [Rulebase>Hazard Options]. 

Prior to the commencement of the simulation under these conditions, although the evacuee 

mobility is reduced in response to the smoke levels, subsequently reducing the evacuee’s travel 

speed, the evacuees are still able to navigate efficiently irrespective of the extent of the extinction 

coefficient (see Figure 9-144).  

 

 
Figure 9-144: Path of an evacuee navigating without staggering function. 

 

Deviations may occur in some of the evacuee’s movement. However, this is caused by the 

evacuees attempting to overtake slower moving evacuees rather than any inefficient movement 

brought on by the environmental conditions. 

 

Next, the Smoke Stagger function is enabled. This is achieved by selecting the Smoke Stagger 

check box on the Environment tab of the BEHAVIOUR CONTROL dialogue box 

[Rulebase>Behaviour Options] (see Figure 9-145).  
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Figure 9-145: Selecting the Smoke Stagger function. 

 

Again, several features become apparent during these simulations. Inefficient movement is 

evident during the evacuee movement. This manifests itself in an inability on the evacuee’s part 

to determine the optimum nodal selection. This becomes more apparent the greater the extinction 

coefficient up to an extinction coefficient of 0.5/m. As the smoke becomes thicker and visibility 

levels decrease, the evacuees are not able to move directly towards their exit point, but instead 

stagger around their ideal path. As the conditions worsen, so the staggering becomes more 

exaggerated (see Figure 9-146).  

 

Occasionally staggering evacuees meander across the geometry and eventually reach the edge of 

the corridor. Once this occurs they favour nodes that are deemed to be at the edge of the geometry, 

through having a reduced connectivity, and attempt to remain in contact with the boundary of the 

geometry (see Figure 9-146). This simulates the evacuee’s feeling their way along the wall of the 

geometry in an attempt to aid their way-finding in the difficult circumstances. 

 

 
Figure 9-146: The type of evacuee movement that is evident once the Smoke Stagger is 

enabled. 

 

Once the extinction coefficient passes 0.5/m, the evacuees are deemed to be crawling. Under these 

conditions the evacuees do not stagger, but are instead forced to move at a further reduced rate 

(defined by their individually assigned Crawl Rate). 
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Figure 9-147: Impact upon the evacuation times of the staggering behaviour 

 

The impact upon the evacuation times generated through the introduction of the staggering 

behaviour will be dependent upon the scenario and the geometry. In this instance a moderate 

increase in the evacuation times is evident, at elevated extinction coefficients (0.3-0.5/m) through 

the introduction of inefficient movement (see Figure 9-147). This difference disappears once the 

evacuees begin to crawl as the staggering behaviour has no impact upon the evacuee once the 

conditions force them to crawl.  

 

The behaviour of the evacuees is better explained when put in context, using the Smoke Contour 

function [View>Contour>Smoke] (see Figure 9-148). The behaviour can be seen to alter once the 

evacuees interact with the smoke-filled environment whilst having no impact prior to this 

interaction. The ability to locate evacuee behaviour in context with their surroundings is important 

for two reasons. Firstly, the inefficient movement is not entirely random, but is instead an 

involuntary response to the deteriorating conditions. Secondly, the behaviour in question is only 

activated under appropriate conditions. 

 

 
Figure 9-148: Selecting the Smoke Contour 

 

NOTE: 

The user may wish to use the Zone Contour version of the smoke contour as it provides a smoother 

animation. This is accessible from the Zone Contour sub-menu from the View menu [View>Zone 

Contour>Smoke]. This method of displaying the smoke is slightly more computationally 

intensive. 
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In the next section the introduction of a more sophisticated interaction with the environment is 

analysed. This is done in conjunction with a variety of environmental conditions and with 

different methods of representing occupant familiarity. 

 

9.7.6 Example 6: Smoke Redirection 

In this example, a relatively complex geometry is produced to demonstrate the significant impact 

that the geometry can have on the outcome of occupant redirection in response to a smoke-filled 

environment. The geometry is approximately 400m2 and has four exits that are positioned as 

shown in Figure 9-149. Initially all four of the exits are in constant use (this will only have an 

impact upon the use of the Local Familiarity system) and are equally biased.  

 

 
Figure 9-149 Geometry for example 6 

 

A smoke hazard is positioned in the eastern, ‘vertical’ corridor (see Figure 9-150). Any movement 

towards either of the two exits at the eastern side of the geometry will therefore require the 

occupants moving through this smoke-filled area. 

 

 
Figure 9-150: The location of the smoke hazard, depicted using the Smoke Contour 

facility 
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The hazard consists of smoke-filled environment with a smoke coefficient of either 0.5/m or 

1.0/m. Both of these hazards should be provided, allowing the user to compare the level of 

redirection in relation to the different extinction coefficients of the smoke hazard. These 

extinction coefficients are constant throughout the simulation. The scenario starts at zero seconds 

and continues for 100 seconds (i.e. it is guaranteed throughout the entire simulation). 

 

Twenty occupants are located at the eastern end of the main ‘horizontal’ corridor, but are not 

initially located in a smoke-filled area (see Figure 9-149). These occupants are generated using 

the Random Generate facility (i.e. [Tools>Person>Random Generate]) and are provided with an 

instant response time. (Alternatively the Specified Response option can be selected in the 

Behaviour tab of the Behaviour Control dialogue box). 

 

Initially, the simulation is run with no smoke redirection and with the use of the potential map 

system. All of the exits are familiar to the occupant and appear equally attractive. It should be 

remembered that the Hazard Model must be enabled for the environment to affect the occupant. 

This is achieved via the Hazard Options dialogue box [Rulebase>Hazard Options]. The 0.5/m 

smoke hazard is initially examined, followed by the 1.0/m environment.  

 

 
Figure 9-151: Usage of Door_3. 

 

In these scenarios, none of the occupants redirect, even once the smoke coefficient is increased. 

Due to the occupants initial location all of the occupants move towards the top-right hand exit 

(Door_3). Therefore the direction of occupant movement is oblivious to the surrounding 

conditions. This therefore forces them to move through the smoke filled environment irrespective 

of the extinction coefficient. This level of exit usage is visible from examining the graph 

representing the number of occupants out through Door_3. From Figure 9-151 it is apparent that 

the entire population used Door_3. 

 

Next, the ability to redirect according to smoke is enabled by enabling the Redirection option 

within the Behaviour tab of the Behaviour Control dialogue box. In this instance the Average of 

the Wood and Bryan data (i.e. Average) is selected as the data-set representing the level of 

redirection. The Smoke Stagger option is also enabled, as is recommended in Chapter 5, the User 

Guide, Chapter 5 and the Theory Manual (see Figure 9-153(a)).  
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Figure 9-152: The route adopted by a redirecting occupant 

 

A number of occupants can be seen to redirect away from the hazard. This can be clearly seen 

from Figure 9-152 and Figure 9-153(b). Usually between 0-4 occupants, i.e. 0-20% of the 

population redirected, when the extinction coefficient of 0.5/m) redirect towards the same exit 

(Door_2). This exit was selected as it provided the nearest alternative to their present target that 

did not entail the occupants moving through the smoke barrier (i.e. the exit in the south-east corner 

was not a viable alternative). 

 

  
(a) (b) 

 
(c) 

Figure 9-153: (a) Redirection Settings. (b) Use of Door_2 with an extinction coefficient of 

05/m. (c) Use of Door_2 with an extinction coefficient of 1.0/m.. 

 

Once the extinction coefficient is raised to 1.0/m the only difference observed in the results is that 

the number of occupants that choose to redirect increased (varying between 0-7 occupants 

redirecting i.e. 0-35% of the population, see Figure 9-153(c)). Again, all of the occupants 

redirected towards Door_2. As expected, the more severe the environmental conditions caused 

an increase in the average number of occupants redirecting. 
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(a) (b) 

Figure 9-154: The occupant redirection once local familiarity is introduced is split 

between Door_1 (a) and Door_2 (b). 

 

In the next scenarios the Local Familiarity system is implemented so that the exit usage is 

dependent upon occupant exit knowledge. To maximise the impact of this introduction the two 

exits placed on the western side of the geometry are deemed to have a 50% probability of the 

occupants being aware of them (i.e. they both have an Attractiveness of 50). This is achieved by 

editing the DOOR dialogue box whilst in SCENARIO mode. The exits on the eastern side of the 

geometry have an Attractiveness of 100 and are therefore familiar to all of the occupants.  

 

 
Figure 9-155: The User-defined data-set. 

 

Once the Local Familiarity system is used two major changes appear in the results produced. 

Firstly, the number of occupants redirecting is reduced. This is because there is the possibility 

that an occupant is not aware of alternative routes, which would then prevent redirection. 

Secondly, as the occupant awareness differs within the population, a number of the occupants 

will only be aware of the exit located in the north-western corner of the geometry, Door_1. 

Therefore, in some of the simulations the redirecting occupants will split between Door_1 and 

Door_2 (see Figure 9-154 and Figure 9-156). 
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Figure 9-156: Occupants redirecting towards different exits due to discrepancies in 

familiarity. 

 

NOTE: 

Once the occupant has encountered a smoke barrier and has decided to redirect, it is assumed 

that the nearest familiar exit will be chosen, irrespective of their use. The exit choice under these 

circumstances is no longer dependent upon the behavioural regime. This is because once the 

occupant has encountered smoke, the occupant is assumed to be motivated to move towards their 

nearest familiar exit. 

 

Finally, the User-Defined function is examined to determine the impact of the smoke redirection 

data-set used upon the behaviour of the occupants. The user should then supply the data-set shown 

in Figure 9-155. The data provided by the user significantly increases the likelihood that the 

occupant population will redirect in comparison to the Average data set (i.e. the average of the 

Bryan and Wood data-sets). This becomes apparent during the simulation with the number of 

occupants redirecting increasing in all of the scenarios examined. It should be noted that this 

cannot be guaranteed during individual runs of the simulation as the behaviour varies between 

runs. However, the average number of occupants choosing to redirect will increase over a period 

of time. 

 

The user is encouraged to experiment with this feature to determine the sensitivity of the model 

to the redirective data-set. 

 

As already seen in Figure 9-150, the movement of the occupants when faced by a smoke-filled 

environment can be better understood when viewed in conjunction with the Smoke Contour 

function (see Figure 9-148). This allows the redirective behaviour of the occupants to be placed 

in context with the severity and location of the worsening environmental conditions. 

 

In the next tutorial the method of defining Internal Exits is examined. The impact of the potential 

biasing is investigated as well as attributing flow rates and the imposition of restrictions on the 

availability of the exit. 
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9.7.7 Example 7: Designing a geometry with two internal exits and the impact of potential 

biasing 

The geometry consists of a large room (15m x 10m) with two connecting corridors (each of 5m 

x 5m), as shown in Figure 9-157. Each corridor ends in a single 2m exit. Both of these exits have 

no restriction placed on the attainable flow rate (i.e. they both have free-flow conditions attached 

to them). 

 

 
Figure 9-157: Geometry used in this example. The nodes of the internal exits are denoted 

by the red squares. 

 

NOTE: 

Internal Exit width calculations are lane-based. 

 

At the connection between the two corridors and the main room, a 2m internal exit is created. The 

nodes that are immediately located either side of the internal opening are selected as being part 

of the internal exit, as outlined in the Theory Manual and User Guide, Chapter 6. These are 

initially unbiased. The northern internal exit (In_Door1) has an HMSO flow rate restriction 

applied to it, while the southern internal exit has no restriction imposed.  

 

NOTE: 

The user should make sure that the Local Potential switch is enabled on the Route tab of the 

Behaviour Control dialogue box, while in Simulation mode [Rulebase>Behaviour Options]. 

 

Two hundred occupants are randomly positioned in the main room (see Figure 9-157). These are 

created using the Population Panel facility. Once created they are all attributed with zero response 

times, enabling a better comparison concerning the internal exit conditions. 

 

No hazard is used during this simulation. 

 

It should be apparent to the user that the simulation conditions during this example, may have 

been represented by manipulating the external exit. However, this may have had different 

qualitative and quantitative influences over the results. For instance, the exact location of the 

congestion would have been at the external exit rather than being somewhere inside the structure, 

which might have influenced the dynamics of the conflict resolution. 

 

When the simulation is run, there should be a relatively even distribution of occupants between 

both the internal and external exits (as each internal exit leads directly to a separate external exit). 
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As no biasing has so far been applied, the exit usage will be entirely dependent upon the starting 

location of the occupants and the subsequent distance to the respective exits. As the occupants 

have been randomly positioned, there should be a general agreement between the internal (and 

therefore, in this case, external) exit usage. However, given that a flow rate restriction has been 

applied to the northern internal exit, the usage times and the flow rates generated will be 

substantially different (see Figure 9-158). 

 

  
(a) Northern internal exit (b) Southern internal exit 

 

 

 

 (c) Output Data   

Figure 9-158: The cumulative arrival of occupants when no biasing is applied to the 

internal exits. From comparing the results in (a) and (b) it is apparent that the numbers of 

occupants using the internal exits are similar although the time it took them to progress is 

significantly different. 

 

In an attempt to balance out the usage times of the internal exits (and therefore reduce the overall 

evacuation times) the user should bias the northern internal exit, making it less desirable. This 

should be done incrementally (in units of one), to establish the sensitivity of the scenario to 

altering the attractiveness of the internal exits. The Potential Assignment Manager available in 

Scenario mode via [Tools>Potential Assignment] (see Figure 9-159), should make this process a 

little easier to manage. 
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Figure 9-159: Potential Assignment Manager. 

 

When there is a difference of three between the potential of the internal exits (the northern internal 

exit having a potential of 103 and the southern internal exit having 100), a significant change in 

both the use and the flow times of the internal exits should be apparent. As more occupants use 

the internal exit with no flow restriction placed upon it, so the overall evacuation time is reduced 

(see Figure 9-160). Indeed it was found that by adjusting the exit usage in this manner, it was 

possible to achieve a reduction of 20% in the overall evacuation times.  

 

  
(a) Northern internal exit (b) Southern internal exit 

 

 

 

 (c) Output Data   

Figure 9-160: The cumulative arrival of occupants when biasing is applied to the internal 

exits. From comparing the results in (a) and (b) it is apparent that the numbers of 

occupants using the internal exits are significantly different. Therefore the time it takes 

them to progress has converged, reducing the overall evacuation time. 
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The user is encouraged to experiment with the maximum advantage that can be achieved through 

balancing the exit usage in this fashion, as well altering the flow rates of the internal exits. 

 

The redundancy within the system can be demonstrated in another fashion. By maintaining the 

biasing at +3, the southern internal exit should then be attributed with a closing/ opening times 

attributed to it, forcing it to be unavailable for a period of time (see Figure 9-161). If, for instance, 

the southern internal exit is made unavailable for 5 seconds during the evacuation, the impact of 

a structural/procedural blockage at this free flowing exit can be ascertained by the user. 

 

 
Figure 9-161: Closing times attributed to the southern exit. 

 

From Figure 9-162 a number of interesting consequences can be seen from the imposition of a 

delay period. Firstly, in Figure 9-162(b) a plateau in the arrival times of the occupants can be seen 

reflecting the unavailability of the exit. The fact that this plateau exists for almost exactly 5 

seconds reflects the fact that the exit was still attractive and that an occupant population formed 

around the opening prior to its availability. 
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(a) Northern internal exit (b) Southern internal exit 

 

 

 

 (c) Output Data   

Figure 9-162: The results produced when the Southern Internal exit is not available for 5 

seconds. 

 

Secondly, and most importantly, the overall evacuation time is not significantly altered. This 

would seem to suggest that the balance in the exit usage could be further improved, allowing more 

occupants to be directed towards the southern exit, reducing the overall evacuation times. The 

user is left to explore such factors. 

 

The following tutorial is designed to examine the use of the Analysis tool available via 

[View>Display>Analysis Options] in Simulation mode. This enables the user to control the 

appearance of the occupant population given that they have performed behavioural actions or find 

themselves in specific environmental conditions. 

 

9.7.8  Example 8: Use of the Behavioural Analysis Tool  

A single 1m exit is centrally positioned at the eastern end of a geometry that measures 20m by 

5m (see Figure 9-163). The exit is attributed with the HMSO flow rate. This exit is initially closed 

only opening after 45 seconds at which stage the occupants are able to evacuate. This causes 

congestion around the exit, forcing the occupants to queue and experience a cumulative wait time. 
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Figure 9-163: The geometry used in Example 8. 

 

TIP: 

The Analysis Tool is easier to use when people are depicted as Blocks rather than Person Shapes 

within the simulation [View>Shape>Block]. 

 

No hazard is included in this simulation. The behavioural regime is set to EXTREME during this 

example. This enables the user to determine the impact of the conditions (in this case congestion) 

upon the behavioural regime implemented by the occupants by using the Analysis tool (see Figure 

9-164). 

 

 
Figure 9-164: The Analysis Tool 

 

The population consists of 100 occupants, generated using the Random Generate function and 

distributed throughout the left half of the geometry. The occupants have a response time of 0 

seconds, which can be attributed using the Substitute facility [Edit>Substitute>People]. Initially 

the occupants have a Patience of a 1000. This is later altered to a Patience level of 1. This enables 

the user to examine the propensity of occupants to turn Extreme given their Patience levels.  

 

NOTE: 

The occupant will become extreme once the cumulative time spent queuing exceeds the occupant’s 

Patience level. 

 

Once the geometry and the population have been created, the user should enable the Analysis tool, 

relating to the adoption of Extreme behaviour. This is available from the Display sub-menu, from 

the View menu in Simulation mode [View>Display>Analysis Options] (see Figure 9-164). 
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(a) 

 
(b) 

Figure 9-165: Occupants involved in congestion around the exit, (a) with a patience 

level of 1000 and (b)with a Patience level of 1 causing a number of them to become 

Extreme, denoted by their darker (red) colour. (In this case, Black Shape has been 

enabled for demonstration purposes). 

 

Once the occupants have a Patience of 1000, even with the additional delays caused by the 

delayed opening of the exit, it is apparent that none of the delays are for a significant enough 

amount of time to cause the occupant’s to resort to Extreme behaviour (see Figure 9-165(a)). This 

can be seen from the uniform nature of the occupant’s appearance.  

 

If the occupant Patience is reduced to 1, then as a number of occupants accrue a Cumulative Wait 

Time greater than one second (i.e. greater than their Patience), numerous occupants momentarily 

become Extreme (see Figure 9-165(b)), allowing the occupants more freedom in their movement. 

This is clear from examining the non-uniform nature of the occupant’s appearance, denoting the 

use of different behavioural regimes according to the local conditions. 

 

The user is encouraged to vary the occupant’s Patience level, including using the Impatient flag 

on the Behaviour tab of the Behaviour Control dialogue box [Rulebase>Behaviour Options], 

causing more Extreme behaviour to be exhibited. This tool has been designed to provide the user 

with a better understanding of the occupant experience during a simulation. 

 

The use of the Analysis tool is further examined in tutorial B7.9. 

 

9.7.9 Example 9: Analysis of the Occupant Intake of Toxic Gases 

A single 1m exit is centrally positioned at the eastern end of a geometry that measures 20m by 

5m (see Figure 9-163). The exit is attributed with an HMSO flow rate. 

 

The population consists of 100 occupants. These are generated using the Population Panel facility 

(the default panels). These occupants will have a response time ranging between 0-30 seconds 

and are located in the western half of the geometry.  
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(a) (b) 

Figure 9-166: (a) The highlighted nodes indicates the area covered by the hazard. (b) The 

FIN settings within the Analysis tool 

 

A hazard is positioned in the last 5m of the geometry, covering 25m2 of floor-space (see Figure 

9-166(a)). This hazard is made up of single factor (HCN) that is increasing linearly, as described 

by the function 

 

𝐻𝐶𝑁 = 5.0𝑡 
 

where t is the time in seconds (therefore the initial value is zero, the gradient is 5.0 and the power 

is 1.0). The HCN concentration at the beginning of the simulation is set to 0 ppm. This hazard is 

active between 0 and 1000 seconds. The Analysis tool should then be enabled, as shown in Figure 

9-166(b), [View>Display>Analysis Options]. The FIN value of 0.5 used in this example is 

arbitrary, although might be taken to represent the maximum acceptable level of occupant 

exposure to Narcotic gases to the user. The user is required to enable the Hazard model by 

selecting the Hazard Options on the RuleBase menu and checking the relevant check box in the 

Hazard Control dialogue box.  

 

Once the simulation is run, with the Analysis tool enabled, the conditions in which the occupants 

find themselves becomes apparent to the user during the simulation, enabling the user to better 

understand the context of the occupant behaviour. Those occupants that respond relatively quickly 

will be exposed to a lower level of toxicity and subsequently have a lower FIN level, as the 

environment has not had time to develop. Therefore the occupant’s final FIN level is below 0.5 

and the Analysis tool will not alter the occupant’s appearance. The occupants who respond later 

are not only faced with a worsening environment, but are also more likely to be caught in 

congestion around the exit. As the conditions worsen, so the delayed occupants have a FIN level 

of greater than 0.5. This is demonstrated by the occupant colour being altered by the Analysis 

tool, to yellow (see Figure 9-167(a)). A number of these occupants, with FIN levels > 0.5, are 

still able to evacuate, as indicated by the yellow occupants in the exit list (see Figure 9-167(c)). 

However, a significant number of occupants were overcome by the conditions.  

 

If the Analysis tool is disabled, information concerning the exact nature of the occupant condition 

is not immediately (visually) available. It is also not immediately apparent that several occupants 

survived the evacuation but still exceeded the FIN level specified (see Figure 9-166(b)). The use 

of the Analysis has no affect upon the behaviour of the occupants or the calculations made by the 

buildingEXODUS model. However, it does clarify the impact of the environment upon the 
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occupant and can also provide a more immediate explanation to the behaviour of occupants, 

without requiring detailed user analysis. 

 

  
(a) Simulation appearance with Analysis enabled (b) Simulation appearance with Analysis disabled 

  
(c) Exit list with Analysis enabled. (d) Exit list with Analysis disabled. 

Figure 9-167: The results produced during the simulations (a and b) and in the form of exit lists 

(c and d). Block shape is enabled in this display to simplify the graphical appearance. 

 

In the next tutorial the effectiveness of the automatic generation of Boundary nodes is examined 

in conjunction with a complex DXF file. 

 

9.7.10  Example 10: Use of the automatic generation of boundary nodes in a complex 

geometry. 

In this example a complex DXF file is loaded into the geometry, flooded with nodes and then has 

a layer of Boundary nodes automatically generated. The complex geometry represents a single 

floor of a three-storey building. Initially, the DXF file is loaded into the geometry using the Load 

DXF facility available from the Construction sub-menu via the Tools menu in Geometry mode 

[Tools>Construction>Load DXF]. Once this has been loaded in the user will have to reset the 

Zoom level so as to be able to see the entire geometry (see Figure 9-168).  

 

 
Figure 9-168: the raw DXF of the geometry used in Example 10 is viewed 

 

Once the DXF file has been loaded in to the buildingEXODUS model, it requires flooding with 

nodes. Due to the complexity of the geometry, two procedures are recommended. Firstly, given 

the large number of gaps in the geometry boundary, instead of generating single nodes to plug 

the gaps, blocks of nodes should be generated by the user. This enables more than one gap at a 

time to be plugged and also guards against the nodal mesh leaking out beyond the required area. 

Secondly, it is suggested that Seat nodes are used in this process rather than Free-Space nodes 

(see Figure 9-169). This is because the excess nodes will be easier to identify, once the surplus 

‘plug’ nodes are to be deleted. For this example, a single free-flow 3.5m exit is then centrally 

connected to the main eastern aperture. 
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Figure 9-169: The gaps that are evident in the DXF  file are blocked using seat nodes, 

simplifying their removal. 

 

If desired, the user may also use the Line function to block up the gaps in the DXF file, although 

in this instance, due to the nature of the geometry, it does not present a huge advantage over the 

method described previously (see Figure 9-170). 

 

 
Figure 9-170: The use of Lines to fill in the gaps around the edge of the geometry. 

 

Once the geometry has been generated, the Boundary nodes can then be automatically generated. 

Normally, this would be a tiresome task, especially in such a complex geometry. This can now 

be achieved using the Generate function, which can be selected in Geometry mode 

[Tools>Generate>Auto. Boundary Nodes>Generate]. Once this is enabled, Boundary nodes are 

added to the geometry, around the edge of the geometry, around obstacles and along wall surfaces 

(see Figure 9-171). It should be noted that this change will not be immediately apparent when in 

Boundary mode; i.e. when the differences in the nodal types are not visible. 

 

 
Figure 9-171: The appearance of the geometry once the Boundary nodes have been added. 
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A population of 500 occupants is generated situated throughout the geometry (see Figure 9-171). 

These are generated using the Population Panel facility (using the default occupant population) 

and react between 0-30 seconds. Once the geometry is populated the simulation can then be run. 

 

For ease of viewing the user may wish to turn off the Boundary nodes so that they do not appear 

on the screen during the simulation. This can be achieved via the Display Control dialogue box 

[View>Display>Gra. Ctrl Options]. This may enable a more detailed analysis of the occupant’s 

behaviour. 

 

The user should run the simulation and compare the results with those produced when the 

Boundary nodes are removed. This can be achieved either by selecting the entire geometry and 

then substituting all of the nodes with Free-Space nodes, or whilst in Geometry mode, the user 

can select the Remove option from the Tools>Generate>Auto Boundary Nodes menu system 

[Tools>Generate>Auto Boundary Nodes>Remove]. 

 

  
(a) Boundary nodes applied. (b)Boundary nodes removed. 

Figure 9-172: A snapshot of the occupant behaviour. 

 

The overall evacuation times produced will be approximately 2 minutes. Although this figure will 

fluctuate according to the localised resolution of conflicts, the introduction of Boundary nodes 

should not cause a significant difference in the results produced, due to the relatively low-density 

nature of the population. However, the user will notice a difference in the behaviour of the 

occupants in relation to the structure, with the occupant’s having a greater tendency to stay away 

from the periphery of the structure, unless forced to do otherwise (see Figure 9-172). 

 

9.7.11  Example 11: Use of the Option Libraries 

This tutorial is designed to demonstrate the use of the behavioural Options Libraries to reduce 

the user workload when constructing simulations. In this tutorial the simulations examined are 

intended to represent Evacuation and Drill Conditions. The user should make use of the *.EXO 

file provided for Example 6, if required. 

 

A hazard is located in the same position as the one used in Example 6, covering the north-south 

corridor (see Figure 9-173). This hazard consists of an elevated smoke level with an extinction 

coefficient of 1.0/m. 
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Figure 9-173: Description of geometry used. The location of the hazard is depicted by the 

grey area. 

 

The Population Panel is used to generate 20 occupants that are positioned in the eastern 10m of 

the corridor travelling in the east-west direction. These occupants respond instantly.  

 

The two eastern exits are given an Attractiveness of 100, while the two western exits each have 

an Attractiveness of 50. This represents the fact that the occupant population is not guaranteed 

familiarity with the western exits. These figures will only have an impact if the Local Familiarity 

option is used. In this tutorial this will always be the case.  
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(a) (b) 

 
 

(c) (d) 

Figure 9-174: (a) The Hazard Control dialogue box after the Drill option library has been 

selected, and (b, c and d) The Occupant Control dialogue box after the Drill option library 

has been selected.  

 

Initially, the simulation will be set up to represent an evacuation drill. This can be achieved 

through the selection of the Drill option library (see Figure 9-174 and Figure 9-175(a)). Even 

though a hazard has been generated, this will be ignored by the population (as well as by the 

model) if the Drill option is used, since when this is the case the Hazard model is disabled. The 

Drill option is enabled by first selecting Option Libraries from the Rulebase menu 

[Rulebase>Option Libraries] and then selecting Drill on the list box on the Options Library 

dialogue box (see Figure 9-175(a) and (b)). 

 



Chapter 9 - Tutorial 7 

 

© 2017 University of Greenwich 287 

 

  
(a) (b) (c) 

Figure 9-175: (a) Selecting the Option Libraries option from the Rulebase menu. (b) 

Selecting the Drill library. (c) Selecting the Evacuation library. 

 

Once the simulation is run it is apparent that there is no interaction between the occupants and 

the hazard defined previously. This becomes more evident if one of the occupants is interrogated 

whilst evacuating through the area deemed to be within the hazard. In effect, as the Hazard model 

has been disabled, the occupants evacuate as if there was no hazard present. 

 

The user therefore has a means by which to vary the environmental conditions without having to 

save numerous buildingEXODUS files. 

 

Next, the Evacuation Option Library is used to represent the conditions and behaviours that might 

be expected during an actual evacuation (see Figure 9-175(c) and Figure 9-176). The selection of 

this library enables the use of the Hazard model and will allow the population to interact with the 

environment in both a physical and psychological manner (through the Smoke Redirection option 

being enabled, see Figure 9-176). 
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(a) (b) 

  
(c) (d) 

Figure 9-176: (a) The Hazard Control dialogue box after the Evacuation option library has 

been selected, and (b, c and d) The Behaviour Control dialogue box after the Evacuation 

option library has been selected.  

 

During the simulation it becomes apparent that the selection of a different option library can 

radically alter the outcome of the simulation. In this instance, occupants can be seen to both 

physically interact with the smoke (see Figure 9-177(a)) and to consider the environment in their 

decision-making process and adapt their behaviour accordingly (see Figure 9-177(b)). 
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(a) (b) 

Figure 9-177: (a) Occupant physical interaction with the environment. The occupant's 

interaction with smoke. (b) Example paths of occupants when the Evacuation library has 

been selected. The occupants have interacted with the smoke filled corridor and have 

redirected towards two other alternative exits. 

 

It should be remembered that the library settings are only suggestions that form the basis of the 

expected behavioural settings rather than describing them completely. The user should not expect 

to necessarily be able to run simulations without adapting the behavioural options at all. For 

instance, the user may be aware of a special circumstance that prevents occupant redirection in 

relation to smoke. In this case the user might still select the Evacuation Option library but may 

then edit the initial settings, disabling the Smoke Redirection option. The model will automatically 

detect that the user has altered the behavioural options and will allow them to save the new 

settings. This can be seen from examining the Option Library dialogue box where the User-

Defined library is visible (rather than the Evacuation option, which would have been the case 

prior to the manipulation of the behavioural settings). This can then be saved as a user-defined 

library by clicking the Save button on the Option Library dialogue box as shown in Figure 9-178. 

This will allow the user to save the options in a personalised library and in the location of their 

choice. 

 

 
Figure 9-178: The generation of a user-defined library. 

 

This library may then be loaded into the buildingEXODUS model for later use replicating the 

conditions of the previous scenarios.  
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When the model is run using the new user-defined option library, the occupants will still be 

affected by the presence of the smoke, although will not be able to redirect away from it, but will 

instead move through it. Differences therefore exist between the results produced by this library 

and the Evacuation library (where the occupants were able to redirect) and the Drill library (where 

the Hazard model was disabled). 

 

The user is encouraged to experiment with this facility and to generate User-Defined option 

libraries for future use. These should be tested to determine whether the options selected generate 

the desired results. 

 

9.7.12  Example 12: Use of Source nodes and Redirection nodes 

In this tutorial the use of Source nodes and Redirection nodes are examined. These will be used 

to generate and control the movement of the population during the simulation. In addition a means 

by which to end the simulation prior to the entire population reaching an exit, whilst still 

generating the final output data, is demonstrated. The geometry should be created as shown in 

Figure 9-179. 

 

 
Figure 9-179: Geometry used in this example. 

 

Whilst still in Geometry mode, the user should double-click on the bottom-left hand node and 

select the Source option from the Node Type combo box (see Figure 9-180). Whilst this dialogue 

box is open, move to Population mode and enter the values below into the appropriate boxes: 

Gen. Start 0.0 

Gen End. 10 

Interval  2.0 

 

These values control the amount of time that the Source node will be generating individuals and 

at what intervals they will be generated. This is the simplest method of generating individuals 

using the Source node. 
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Figure 9-180: Source selection 

 

The user should then move to Simulation mode (it should be apparent that the user will not have 

to supply a population before proceeding) and run the simulation. A stream of five individuals 

will be generated, all of whom will head directly towards the exit (see Figure 9-181(a)).  

 

  
(a) (b) 

Figure 9-181: (a) Simulation with Source Node (b) With decreased time interval of 1 sec. 

 

The user should then move back to Population mode and alter the attributes of the Source node 

to those below: 

Gen. Start 0.0 

Gen End. 20 

Interval  2.0 

 

When the simulation is then re-run, the number of individuals generated will increase to 10 (see 

Figure 9-181 (b)). 

 

Once the simulation is complete the user should move to Scenario mode to manipulate the Source 

node using the more complex and flexible tools available in this mode. By double-clicking on the 

Source mode and then on the Adv button, the user will have access to the Source Node Control 

dialogue box. Once this is available, the user should Append a scenario to the Source node. No 

population or itinerary will be assigned at this stage, but instead the information is provided as 

shown in Figure 9-182, working with the dummy panels already existing. 
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Figure 9-182: The use of dummy panels. 

 

NOTE: 

In this instance the rate at which the population is generated is required, rather than the time 

interval between their generation, as was the case before. This is because the simplified method, 

accessible in Geometry mode, was only intended to allow them to make quick calculations and 

test the geometry, whereas serious use of this functionality was always anticipated to be based 

around using the more complex system outlined here, with the ability to re-use itineraries and 

previously generated populations. 

 

The user should then return to Simulation mode and execute the simulation. The results produced 

will differ between runs, due to the range of values provided, but will approximately fall between 

the two scenarios already examined. 

 

Whilst still in Simulation mode the user should then click on the Simulation Control option on the 

Simulation menu. This will then allow the user to artificially end the simulation at any desired 

point. The user should then click on Enable Max Sim Time [Simulation>Simulation Control], and 

supply a value of 20 (see Figure 9-183(a)) into the Max Sim Time(s) text box. 

 

 
(a) (b) 

Figure 9-183: (a) The Enter Max Sim. Time dialogue box (b) the results produced by 

artificially ending the simulation 

 

Once the simulation has been run, it will become apparent that not all of the individuals will have 

reached the exit before the simulation has ended (at 20 seconds) and therefore remain inside. This 

becomes more apparent when examining the output generated (see Figure 9-183(b)). Once this 

simulation is complete the user should disable the Max Sim. Time option by unchecking the 

Enable Max Sim Time checkbox in the Simulation Control dialogue box [Simulation>Simulation 

Control]. 

 

In the next section, the user will create panel populations and itineraries and associate them with 

the Source node therefore exerting a greater degree of control over its performance. The user 

should move back to Population mode and click on Panel Populations via the Tools menu to 

display the Pop Selection dialogue box (see Figure 9-184(a)). A new population of 100 

individuals should then be defined by entering the value 100 into the Pop Size text box. Having 
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done this, the population from which the 100 individuals will be generated then needs to be 

defined. This is achieved by clicking the Create button, producing a panel representing the given 

population (i.e. Pop_1, see Figure 9-184(a)). Once produced, this panel can then be double clicked 

to display the Population Editor. The Population Editor in turn displays all the sub-populations 

assigned to the current population (i.e. Pop_1), and the percentage of the overall population that 

they represent. Within the Population Editor define the population as a single sub-population by 

again clicking the Create button to produce a default sub-population Panel0. The user should 

supply 100 in the text box determining the percentage of the population being produced from the 

panel (see Figure 9-184(b)).  The panel produced (i.e. Panel0) should then be double-clicked to 

provide access to the Population Panel Editor displaying the range of values for each attribute 

within the given sub-population (see Figure 9-184(c)). 

 

 

 

 

(a) (b) (c) 

Figure 9-184: (a) Population generated (b) Assigning the percentage to the population 

panel. (c) Determining the attributes of a constituent population panel 

 

The next task to complete is to assign itineraries to the Source node. These itineraries are 

generated in the standard manner. In this instance the individual itineraries are Created, the new 

panel is then accessed through double-clicking it, and then locations are associated with the new 

itinerary through the use of the Auto Insert function. They are produced through accessing 

Itinerary Window off of the Tools menu whilst in Population Mode [Tools>Itinerary Window]. 

The two task locations highlighted in Figure 9-185(a) form two separate itineraries, in this case 

labelled top_centre and bottom_right.  

 

 

 
(a) (b) 

Figure 9-185: (a) Task locations (b) Scenarios being assigned to the Source node. 

 

Both the population and the itineraries now have to be associated with the Source node. Move to 

Scenario mode and double-click on the Source node. Once the Node dialogue box is visible, click 

on the Adv button which provides access to the Source Node Control dialogue box. A scenario 

should be Appended, which initially has no population or itineraries attached (if the same 
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geometry has been continuously worked on then one may already exist). Double-click on the Pop 

panel and the user will then be able to add the panel population previously created. Similarly, the 

user can add the two itineraries previously created, each of which should be given a fifty percent 

chance of being visited (see Figure 9-185(b)). The panels that appear in the Source Node Control 

dialogue box will now bear the name of the panels provided (see Figure 9-186). 

 

 
Figure 9-186: The complete scenario in the Source Node Control dialogue box. 

 

The user should then move to Simulation mode. Individuals will be generated by the Source node, 

who will then either move to one or the other of the two itineraries in roughly equal measures, 

before exiting (see Figure 9-187(a)).  

 

  

(a) (b) 

Figure 9-187: (a) Individuals being sent to the two itinerary locations (b) The geometry 

including the Source node, the Redirection node and the single individual in the top hand 

corner. 

 

In this tutorial we will also be demonstrating the interaction between Source nodes and 

Redirection nodes. It should be remembered that Redirection nodes should only influence the 

behaviour of the evacuees if they have included in their itinerary that they visit the Redirection 

node.  

 

In this instance the user is required to identify the node at the top centre of the geometry visited 

as part of the specified itinerary and then position a Redirection node here. This Redirection node 

will then have an additional task associated with it. To assist in locating the nodal location, the 

user should access the itineraries associated with the Source node (double-clicking on the Set 

panel in the Source Node Control dialogue box whilst in Scenario mode), select the appropriate 

panel (labelled top_centre) and then press the Show button, which will outline the nodal location 

associated with this task. Once this has been identified the user should move back to Geometry 

mode, click on this node and select Redirection from the Node Type attribute menu. 

 

The next task for the user is to associate an itinerary with the Redirection node. This is done in 

exactly the same manner as with the Source node. Therefore the user should move to Population 

mode, create an itinerary (sending individuals to the top left corner of the geometry). Once 
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complete the user should move to Scenario mode and then associate this with the Redirection 

node; clicking on the Adv button to gain access to the Itinerary Selection dialogue box and then 

adding the desired itinerary. 

 

To demonstrate the interaction between individuals with the Redirection node, an individual 

should be generated and located towards the top left hand corner of the geometry who has no 

itineraries associated with him. In order to demonstrate the point the path of the individual should 

cross the Redirection node. The final geometry should appear as shown in Figure 9-187(b). 

 

 
 

(a) (b) 

Figure 9-188: (a) The result of clicking the Locat button on the exit dialogue box – the 

paths and starting locations of those using the exit are generated. (b) Individual ignoring 

the Redirection as the node does not appear in his itinerary 

 

Once the simulation is run, individuals will be generated by the Source node as before with 

approximately half of them being sent to the bottom right of the geometry or to the top centre of 

the geometry. Those that move towards to the top centre of the geometry interact with the 

Redirection node when they fall within its range and are subsequently redirected towards the top 

left hand corner of the geometry (see Figure 9-188(a)). The individual initially located at the top 

left hand corner of the geometry is forced to interact with the Redirection node due to the path 

that he has to adopt, but ignores it entirely moving instead directly towards the exit (see Figure 

9-188(b)). 
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9.8 Tutorial 8: Loading and Using CFAST Fire Hazards 

This tutorial will demonstrate the principles in defining fire scenarios involving CFAST 

hazards.  It should be noted that all the values contained within the CFAST hazards/data 

files in this tutorial are for demonstration purposes only, and are not intended to 

represent real fire hazard values. This tutorial only relates to users with software level 

C. 

 

Fire scenarios that use CFAST hazards are defined within buildingEXODUS via a three 

step process.  Firstly the zones (physical area) over which the fire hazards will spread 

are defined.  Secondly, the CFAST hazards are loaded, and finally the zones and 

CFAST hazards are linked together.  In this tutorial, two main examples will be 

considered.  Example 1 will be based on a geometry consisting of seven rectangular 

rooms and an inter-connecting corridor.  Example 2 will extend the geometry outlined 

in Example 1.  The corridor will be subdivided into four separate areas in an attempt to 

make the flow of heat, smoke and toxic gases more realistic.  The temperature 

distribution, smoke and toxic gas concentrations throughout the geometry will then be 

observed, as will its effect upon the enclosed population. 

 

9.8.1  Example 1 – Eight Rooms 

 

For example 1, we will consider the geometry shown below 

 

 
Figure 9-189: Example 1 room geometry 

 

The geometry consists of seven rectangular rooms and an inter-connecting corridor, or 

room 8 as shown.  All internal doors are assumed to have a width of 1m, while the 

external door is assumed to have a width of 1.5m.  Create this geometry within 

buildingEXODUS using the method described in Tutorial 1. 

 

Now advance to POPULATION MODE and populate the geometry with 20 evacuees 

using the Random Generate function [Tools>Person>Random Generate].  Switch on 

the Boundary view to hide the nodes and arcs [View>Boundary].  At this stage the 

geometry should resemble Figure 9-190 
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Figure 9-190: Eight rooms and 20 evacuees 

 

Now move into the SCENARIO MODE.  We are now in a position to define the zones 

for the fire hazards.  In this example each zone will correspond to a different room.  

Start by using the select tool to draw a boundary box around the area defined as ROOM1 

in Figure 9-189.  When selected, click the ADD ZONE button on the tool bar .  This 

will now highlight all the nodes within the zone and present the ZONE INFO dialogue 

box as shown in Figure 9-191. 

 

 
Figure 9-191: Defining Zone1. 

 

Although it is possible to modify the name of each zone, in this instance it will be 

simpler if we leave them unchanged.  Click the OK button to create the zone.  Repeat 

this process for the remaining seven rooms, in each case ensuring that the numbering 

of the zones is consistent with the numbering of the rooms as defined in Figure 9-189.  

(i.e. the physical area represented by ZONEX is equal to the physical area represented 

by ROOMX, where X=1 to 8).  When complete we should have eight zones defined, 

where ZONE1 corresponds to ROOM1, ZONE2 corresponds to ROOM2 etc.  To check 

this is the case, click the EDIT ZONE button  on the tool bar to display the ZONE 

EDITOR dialogue box.  At this stage the ZONE EDITOR dialogue box should resemble 

Figure 9-192. 
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Figure 9-192: Eight defined zones. 

 

To ensure that each zone corresponds to the correct room (i.e. group of nodes), click 

each zone button in turn followed by the SHOW button.  Although mistakes are unlikely 

to have occurred in this example due to the comparatively small number of rooms used, 

and their rectangular nature, it is always worth checking.  Geometries involving large 

numbers of irregular shaped rooms are particularly prone to mistakes and should 

therefore always be checked. 

 

In certain circumstances nodes may be present in positions that make their inclusion to 

a particular room (i.e. zone) ambiguous.  Nodes occupying spaces between doorways 

are neither in one room or another, and as such occupy a sort of “no man’s land”.  In 

instances where this occurs the user must decide for themselves which of the two zones 

the nodes should be assigned to.  Failure to assign the nodes to either zone will result 

in a “safe” area being established (i.e. an area where no hazards are present).  The 

inclusion of these safe areas will negatively affect the realism of the simulation, and 

should therefore be avoided at all times.  

 

NOTE:  

The presence of “safe” areas resulting from a failure to assign nodes to zones may 

potentially have an important impact upon re-directive behaviour. 

 

Once all the zones have been correctly defined we can set about loading the CFAST 

hazards that we intend to use. In order to load CFAST version 6 predictions relating to 

the flow of heat, smoke and toxic gases through rooms buildingEXODUS first requires 

the data to converted. When CFAST is run it generates an ASCII output file (*.OUT) 

summarising the environmental conditions within each sub-volume/compartment at 

each time step. These output files typically contain information about all aspects of any 

given CFAST simulation (including those aspects not relevant to buildingEXODUS) in 

a text based format designed to be read by people, as opposed to computers. An example 

of the .OUT file generated for the 8 compartment structure shown previously in Figure 

9-189 can be found in the file “exodus8.out” provided. To overcome the un-optimised 
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format and excess simulation information that these output files (.OUT) contain it is 

therefore first necessary to convert the relevant hazard data into corresponding 

optimised data files in the existing SMARTFIRE file format (.DAT). 

 

To convert CFAST .OUT files to SMARTFIRE .DAT files a conversion utility called 

CFAST2SMF is provided. This can be found within the buildingEXODUS sub-menu 

within the Windows Start menu. To demonstrate how this utility works we will set 

about converting the CFAST output file “exodus8.out”. First, run the CFAST2SMF 

utility. Once run the user will be confronted with both a console, used to display 

information to the user, and an OPEN FILE dialogue box through which the user can 

identify the CFAST data output file (.OUT) to be converted. Locate the “exodus8.out” 

file within the OPEN FILE dialogue box and then click the OPEN button to confirm 

the selection (see Figure 9-193). 

 

 
Figure 9-193: Locating the CFAST output file (*.out) within the CFAST2SMF 

utility. 

 

Having identified the CFAST data output file, the file and its complete pathname will 

then be output to the corresponding console. In addition, the user will then be provided 

with a SAVE AS FILE dialogue box, through which they can specify both the name 

and location of the SMARTFIRE data file (.DAT) into which the CFAST hazard data 

will be converted (see Figure 9-194). Users are free to locate and name the 

SMARTFIRE .DAT file as they wish. However, a SMARTFIRE .DAT file previously 

converted from the .OUT file “exodus8.out” is provided (i.e. “exodus8.dat”), so users 

should be aware not to overwrite this.  
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Figure 9-194: Defining the location and name of the SMARTFIRE .DAT file. 

 

Once the user has specified both the name and location of the SMARTFIRE data file 

data conversion will then be performed.  Upon successful completion of the data 

conversion procedure, the conversion utility CFAST2SMF will then simply require the 

user to press any key in order to close.  Once converted into a SMARTFIRE data file, 

the hazard data originally generated using CFAST can then be loaded into 

buildingEXODUS. 

 

To demonstrate this we will now load in the .DAT file “exodus8.dat” previously 

converted from the CFAST output file “exodus8.out”. The file “exodus8.dat” (and 

hence the file “exodus8.out” from which it was converted) contains predictions of 

temperature, radiative fluxes, smoke and toxic gases within each of the eight rooms 

outlined in Figure 9-189 at 100-second intervals for a 1200 second (i.e. 20 minute) 

duration.  The source of the fire is defined as being the centre of Room 1.  Once again 

it is important to note that all the values contained within both “exodus8.out” and 

“exodus8.dat” are for demonstration purposes only, and are not intended to represent 

real fire hazard values. 

 

Click the HAZARD button  on the tool bar to retrieve the HAZARD EDITOR 

dialogue box, and click the IMPORT HAZARD FILE button.  buildingEXODUS will 

now expect to be supplied with the name of the data file (*.DAT) via the OPEN 

dialogue box (see Figure 9-195). 
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Figure 9-195: The Open dialogue box showing the SMARTFIRE file 

“exodus8.dat” 

 

Locate the file “exodus8.dat” and click the OPEN button.  buildingEXODUS will now 

automatically create one hazard for every sub-volume/compartment contained within 

the selected hazard data file.  Since “exodus8.dat” was generated from a data file 

defining the same geometry as shown previously (see Figure 9-189) therefore eight 

hazards are created (i.e. 8 rooms).  The HAZARD EDITOR dialogue box should now 

resemble that shown in Figure 9-196. 

 

 
Figure 9-196: The eight hazards loaded from the file exodus8.dat. 
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By default hazards loaded from data files are named Sub-volumeX, as opposed to HazX 

for conventional user defined hazards (see Tutorial 6).  It should also be noted that since 

loaded hazards obtain their data from data files rather than from user defined functions 

(as is the case with user defined hazards), both their UPPER and LOWER buttons are 

disabled.  Clicking one of the Sub-volume buttons will retrieve the HAZARD INFO 

dialogue box (see Figure 9-197).  The HAZARD INFO dialogue box is used to change 

both the name of an individual hazard, and to assign a description to it.  By default, the 

description of all loaded hazards contains text detailing the path and filename of the file 

from which it was loaded, and the sub-volume/compartment number to which the 

hazard relates. In addition, in this instance the description also states that the data was 

loaded from a SMARTFIRE data file, even though the hazard data itself originated from 

CFAST. Although it is possible to modify the name of each hazard, in this instance they 

will be left unchanged. 

 

 
Figure 9-197: HAZARD INFO dialogue box. 

 

Once both the zones and hazards have been defined/loaded it is possible to link them 

(i.e. define which hazard is to be active over which zone).  Click the SCENARIO button 

 on the tool bar to display the SCENARIO EDITOR dialogue box.  Now click the 

CREATE button to create a new scenario component.  It is now necessary to assign each 

hazard to its corresponding zone.  Start by assigning the hazard Sub-volume1 to Zone1.  

To set the zone click the zone marked None (i.e. the button on the left side of the 

component).  Another dialogue box will appear showing the list of eight zones created 

previously.  Click Zone1 to highlight it, and then click the OK button.  The zone in the 

scenario component will now read Zone1.  Now change the hazard definition to Sub-

volume1. Click the hazard marked None to retrieve the list of eight hazards loaded 

previously.  Highlight Sub-volume1 by clicking it once, and then click the OK button 

to finalise your selection. 

 

It should be noted, that as soon as a loaded hazard (in this case Sub-volume1) is assigned 

to the scenario component, the Start and End Time Edit boxes that had previously been 

present are replaced by a DETAILS button.  Click the DETAILS button to retrieve the 

DATA FILE SCENARIO dialogue box (see Figure 9-198).  Loaded hazards require 

additional information to specify the file options required by the user.  The specification 

of this information is achieved via the DATA FILE SCENARIO dialogue box. 
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Figure 9-198: DATA FILE SCENARIO dialogue box. 

 

In this example we wish to use all the data contained within the specified data file from 

the start of the simulation so the default values will be accepted.  Click OK to close the 

dialogue box. 

 

Complete the remaining seven scenario components by assigning Sub-volume2 to 

Zone2, Sub-volume3 to Zone3 etc. in the same manner as defined above. Alternatively, 

rather than manually assign each hazard to each zone the user can instead simply click 

the AUTO LINK button.   The SCENARIO EDITOR should now resemble that shown 

in Figure 9-199. 

 

 
Figure 9-199: Eight scenario components linking zones and hazards 

 

It is important to remember that in this example Sub-volumeX was assigned to ZoneX 

(where X=1 to 8) because the labelling of the rooms within buildingEXODUS (i.e. 

numbering of the zones) and the CFAST geometry which generated the output file 

“exodus8.out” were consistent.   
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NOTE: 

When using loaded hazards, ensuring consistency between the physical regions 

represented by a given zone and the hazard linked to it, is entirely the responsibility of 

the user.  buildingEXODUS carries out no consistency checking.  Failure to ensure 

consistency will result in unrealistic environment conditions within the geometry that 

will negatively affect the validity of the simulation. 

 

Now move into SIMULATION MODE.  To activate the hazard model select the Hazard 

Options item from the Rulebase menu to display the HAZARD CONTROL dialogue box 

shown in Figure 9-200 [Rulebase>Hazard Options].  Click the Enabled check box in 

the Hazard Model sub-section.  The HAZARD CONTROL dialogue box should now 

resemble that shown in Figure 9-200.  Click OK to register your change. 

 

 

Figure 9-200: HAZARD CONTROL dialogue box. 

 

Start the simulation by clicking the PLAY button and note the simulation time.  You 

should find the TET is in the region of 57 seconds.  Since the time taken to evacuate 

the geometry is small we cannot accurately assess the movement of heat, smoke and 

toxic gases through the building, or similarly its effect on the enclosed population.  To 

overcome this we will artificially delay the evacuation of one of the evacuees by 

altering their response settings. 

 

Open the HAZARD CONTROL dialogue box (shown in Figure 9-200) in the manner 

detailed above.  It can be seen that the default values for the smoke and temperature 

response overrides are 0.1 /m and 50.0oC respectively, and that the Rad Heat Flux 

response override (which determines whether the individual responds to the levels of 

radiative flux) is also enabled.  When the Hazard Model is enabled, the presence of 

heat, radiative fluxes, smoke and toxic gases may cause an override to cut short the 

response time of the evacuees.  Since we do not want this to occur we will set the 
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override values to values that they are unlikely to ever achieve, thereby forcing all the 

evacuees to wait until their response times have elapsed before evacuating.  Change the 

values of both response overrides (i.e. Smoke and Temp) to 999, uncheck the Rad Heat 

Flux response override check box and click OK.  All the evacuees within the geometry 

will now wait until their corresponding individual response time has elapsed before 

starting to evacuate, irrespective of their immediate environment (i.e. heat, radiative 

fluxes, smoke and toxic gases). 

 

Now move to POPULATION MODE.  We will now set the Response Time of one of 

the evacuees artificially high to ensure that they remain throughout the duration of the 

hazard scenarios.  Identify one of the evacuees (preferably not in the corridor or the 

room where the fire is present i.e. not room 1 or 8), and retrieve their corresponding 

EDIT PERSON dialogue box (see Figure 9-201) in the manner detailed in Tutorial 3.  

By default the existing Response Time should be between 0 and 30 seconds.  Since all 

the hazards loaded in this example are defined for a 1200 second duration we will now 

set our evacuee response time to 1200 seconds.  The EDIT PERSON dialogue box 

should now resemble Figure 9-201.  Click OK to accept your change. 

 

 
Figure 9-201: Individual evacuee attributes. 

 

Now move to SIMULATION MODE.  Retrieve the GASES dialogue box for one node 

in each of the top rooms (i.e. rooms 1, 2  and 3) as well as the corridor (room 8).  The 

screen should now resemble Figure 9-202.  Now re-run the simulation.  Nineteen of the 

evacuees will start to evacuate the building within the first 30 seconds of the simulation, 

while the evacuee with the modified response time will remain static.  The environment 

data associated with each node (and zone) will update every CFAST time increment.  

Since the CFAST hazards used within this example were from a data file that contained 

environment data at 100 second intervals for a 1200 second duration, the environment 

variables (and hence the GASES dialogue box that displays them) will therefore be 

updated every 100 seconds (i.e. at 0 s, 1 min 40s, 3 min 20s, 5 min 0 s etc.).  The 

simulation will continue to run until the disabled evacuee is overcome by heat, smoke 

or toxic gases and becomes incapacitated. 
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Figure 9-202: Variation in environment variable values between rooms. 

 

For the intervening time between CFAST time increments the environment variables 

remain fixed.  In comparison to a real fire scenario this is unrealistic.  To overcome this 

we will employ linear interpolation on the environment data between CFAST time 

increments.  Move to the SCENARIO MODE and open the SCENARIO EDITOR 

dialogue box by clicking the SCENARIO button  on the toolbar (see Figure 9-199). 

Click the Interpolate All checkbox and return to SIMULATION MODE.  Re-run the 

simulation.  You will now notice that the environment variables are updated in real 

time.  The updating of environment variables within each zone will also affect the levels 

of heat, smoke and toxic gases that the enclosed population are exposed to.  As a result 

the time taken for the disabled evacuee to become incapacitated will in this instance be 

reduced. 

 

When using CFAST generated hazards it is important to note their fundamental 

difference from existing user-defined hazards.  Although both user defined and CFAST 

hazards operate at both upper and lower layers, the concept of layers within these 

hazards differ.  When using user defined hazards, evacuees are exposed to the upper 

layer while they are standing and the lower layer when they assume the crawling 

position.  However when using CFAST hazards this is not the case due to the variation 

in layer depth with time. 
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(a) (b) (c) 

Figure 9-203: The effect of CFAST’s descending smoke layer on the enclosed 

population 

 

NOTE: 

The height information relating to the height of the boundary between the upper and 

lower layers within each compartment is NOT lost as a result of converting the original 

CFAST data into the SMARTFIRE file format. Consequently this information is still 

present within the resulting .DAT file and will hence will still affect the population 

exposed to those hazards. 

 

The variation in the height of the boundary between the two layers during the simulation 

can be observed via the Height value in the GASES dialogue box.  The Upper values 

relate to the values of heat, smoke and toxic gases in the upper layer. Similarly the 

Lower values relate to the values of heat, smoke and toxic gases in the lower layer.  At 

the start of the simulation the Height value within each of the four GASES dialogue 

boxes should read 2.7 metres.  This is because the height of each room within the 

geometry was defined as being 2.7 metres high within the CFAST geometry which 

generated the output file “exodus8.out”.  Since the start of the simulation corresponds 

to the start of the fire, the upper layer within each room is initially assumed to have a 

zero volume and hence the height of the boundary between the upper and lower layers 

will equal the height of the individual room. Since at the outset of the simulation the 

lower layer occupies the majority of the room, both standing and crawling occupants 

will be exposed to the same environments, namely the environment corresponding to 

the lower layer (see Figure 9-203(a)).  This will continue to be true, until the height of 

the boundary between the upper and lower layer descends below the default evacuee 

standing height of 1.7 metres.  At this point the standing occupants will be exposed to 

the heat, smoke and toxic gases within the upper layer, while the crawling occupants 

continue to be exposed to the heat, smoke and toxic gases within the lower layer (see 

Figure 9-203(b)).  Similarly, the descent of the smoke layer beneath the default evacuee 

crawling height of 1 metre will result in both standing and crawling occupants being 

exposed to the heat, smoke and toxic gas within the upper layer (see Figure 9-203(c)). 

 

The variation in the height of the boundary between the upper and lower layer will 

similarly affect the evacuees.  However evacuees are capable of responding to their 

immediate environment and change stances (i.e. stand/crawl) accordingly.  Peoples 

ability to alter their stance is dependent upon the status of the Crawling parameter 

within the Environment tab of the BEHAVIOUR CONTROL dialogue box.  To open the 

BEHAVIOUR CONTROL dialogue box select Behaviour Options from the Rulebase 

menu [Rulebase>Behaviour Options].  If Crawling is enabled then evacuees will 

remain standing until the smoke coefficient that they are exposed to exceeds 0.5/m, 

where upon they will assume the crawling stance.  If crawling is disabled then evacuees 
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will remain standing at all times irrespective of their environment.  By default Crawling 

is enabled. 

 

By analysing the values of the environment variables displayed within the GASES 

dialogue boxes it is possible to visualise the flow of heat, smoke and toxic gases through 

the geometry.  To aid visualisation of the temperature and smoke distribution through 

the geometry buildingEXODUS provides temperature and smoke hazard contours.  To 

activate the smoke contour select the Zone Contour item from the View menu, and then 

select Smoke from the resulting sub-menu [View>Zone Contour>Smoke].  Now re-run 

the simulation.  You will now note that the rooms are coloured according to the density 

of the smoke present within them at the default evacuee standing height level (i.e. 1.7 

metres).  Rooms that are coloured white indicate low smoke density, while rooms that 

are coloured black indicate high smoke density.  To easily aid in the visual identification 

of the smoke density associated with a particular colour a contour scale has also been 

provided.  To activate the contour scale select the Key item from the Help menu, and 

select the Contours item from the resulting sub-menu [Help>Key>Contours]. This will 

display the CONTOURS SCALES dialogue box shown in Figure 9-204.  

 

NOTE:  

The smoke and temperature contours cannot be run simultaneously. 

 

 
Figure 9-204: CONTOURS SCALES dialogue box. 

 

The contour scales for population density, smoke and temperature have all been 

supplied.  To activate the temperature contour select the Zone Contour item from the 

View menu in the same way as for smoke contours, and then select Temperature from 

the resulting sub-menu [View>Zone Contour>Temperature].  Now re-run the 

simulation.  You will now notice that the rooms are coloured using the red scale (as 

opposed to the grey scale for smoke) in accordance with the temperatures outlined in 

Figure 9-204. 

 

9.8.2 Example 2 – Eleven Rooms 

In Example 1 each zone within buildingEXODUS corresponded to one entire room 

within the building that we were attempting to model.  Similarly, each sub-

volume/compartment within CFAST (as defined within the data file “exodus8.out”) 

corresponded to one entire room within the structure.  However due the manner in 

which CFAST works, this is not always the best way to divide up a geometry.  To 

explain this consider example 1 (see Figure 9-189).  CFAST assumes that each layer is 

internally uniform, and that the height of the boundary between the upper and lower 
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layers is the same at every point within a given room.  Hence heat, smoke and toxic 

gases entering through a door/vent on one side of a room will instantly have an effect 

on the environment on the opposite side of the room.  There is assumed to be no delay 

for the hot gas layer to move along the ceiling to the far end of the room.  For long 

rooms this is unrealistic.   

 

The inter-connecting corridor (i.e. room 8) in example 1 is a prime example of this.  To 

demonstrate the user should re-set the simulation.  Turn the smoke contours on in the 

manner discussed previously.  The simulation should then be re-run. The user will 

notice that the end of the corridor furthest from the fire has exactly the same 

environmental conditions as the end of the corridor closet to the fire (see Figure 9-205).  

The modelling of the corridor in this way also has important implications regarding the 

rooms that are connected to it.  Since room 5 and room 7 are the same size, and since 

they are both connected to the corridor, both will exhibit identical environment 

conditions.  However, room 7 is further from the source of the fire than room 5, and as 

such would in real life exhibit less severe environmental conditions. 

 

 
Figure 9-205: Smoke contours within example 1. 

 

When using zone models such as CFAST, this problem is often overcome by sub-

dividing the inter-connecting corridor (i.e. room 8) into separate areas, essentially 

constructing small room partitions or down stands.  In this example we will insert three 

partitions, essentially creating four sub-volumes/compartments (see Figure 9-206).  By 

modelling the corridor as four distinct areas we will ensure that the movement of the 

smoke within the structure (and hence the density of the smoke) will more closely 

resemble reality.   

 

NOTE:  

Within CFAST it is also possible to define Compartments as corridors to overcome this 

problem, see CFAST user manual. 

 

The population of 20 evacuees should be left in place, with one of them still having an 

extended 1200 second response time. 
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Figure 9-206: Example 2 room geometry 

 

Rather than creating the geometry for example 2 from the beginning, simply modify 

the geometry in example 1.  Start by modifying the zones.  Move to SCENARIO MODE 

and click the EDIT ZONE button  on the toolbar to retrieve the ZONE EDITOR 

dialogue box shown in Figure 9-192.  At this stage the ZONE EDITOR dialogue box 

should still contain the eight zones created previously.  Since we now wish to define 

the corridor as four separate zones we will first delete the zone defining the corridor as 

one zone (i.e. zone 8).  Click on Zone8 to select it and then click the REMOVE button.  

The zone should now be deleted, leaving the remaining seven zones unaffected.  Now 

close the ZONE EDITOR dialogue box by clicking the OK button. 

 

We will now define the four new zones within the corridor.  Use the select tool to draw 

a boundary box around the area defined as ROOM8 in Figure 9-206.  When selected, 

click the ADD ZONE button  on the toolbar.  This will highlight all the nodes within 

the zone and present the ZONE INFO dialogue box.  The name for the zone should now 

read Zone8.  Click the OK button to create the zone.  Repeat the process for the three 

remaining zones (i.e. zones 9-11), in each case ensuring that the numbering of the zones 

is consistent with the numbering of the areas as defined in Figure 9-206. 

 

Once all the zones have been defined the next step is to load the new CFAST hazards 

that we intend to use.  Since the CFAST hazards used in example 1 related to the 

previous geometry they are no longer applicable.  A new CFAST data file will have to 

be generated using a data file that defines the geometry defined in Figure 9-206.  The 

CFAST data file containing predictions of the spread of heat, smoke and toxic gases 

within the 11 room structure outlined in Figure 9-206 has been provided and is called 

“exodus11.out”.  It contains predictions of temperature, radiative flux, smoke and toxic 

gas concentrations within each of the eleven rooms/areas outlined in Figure 9-206 at 

100-second intervals for a 1200-second duration. Users are free to convert the CFAST 

output file “exodus11.out” into a SMARTFIRE data file (.DAT) using the 

CFAST2SMF utility in the manner outlined previously. However, as in example 1 a 

pre-converted data file is again provided (i.e. “exodus11.dat”).  
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Start by deleting the existing hazards loaded from “exodus8.dat” in example 1.  Click 

the HAZARD button  on the toolbar to open the HAZARD EDITOR dialogue box.  

The HAZARD EDITOR dialogue box should still resemble Figure 9-196, with eight 

hazards still defined.  Click the CLEAR button.  The hazards should now have been 

deleted.  We will now load the CFAST hazards from the updated data file 

“exodus11.dat”.  Click the IMPORT HAZARD FILE button and then locate and load 

the file “exodus11.dat”.  Eleven hazards should now be automatically created (i.e. one 

for each room/area within the structure).  Once complete click OK to close the HAZARD 

EDITOR dialogue box. 

 

Next click the SCENARIO button  on the toolbar to open the SCENARIO EDITOR 

dialogue box.  Eight scenario components should still be present.  Since the hazards 

assigned to the eight scenario components in example 1 have been deleted, each 

scenario component should now have no hazard assigned to it.  Similarly since the 

original Zone8 was also deleted, the eighth scenario component should also have no 

zone assigned to it.  Assign Sub-volumeX to ZoneX (where X = 1 to 11) in the same 

manner as for example 1.  You should now have eleven scenario components, as 

opposed to the eight that were present in example 1.  Ensure that the smoke contours 

are on [View>Zone Contour>Smoke] and re-run the simulation.   

 

 
Figure 9-207: Smoke contours with example 2. 

 

You will now notice that the density of smoke within the structure is more realistic (see 

Figure 9-207).  The end of the corridor furthest from the fire now has less smoke density 

than the end nearest the fire.  The effect on the rooms connected to the corridor is also 

noticeable.  Rooms 5 and 7 that previously exhibited identical environmental conditions 

during example 1, now exhibit different environmental conditions.  The difference 

between the two simulations is purely down to how the progression of smoke in the 

corridor was modelled in CFAST. 
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9.9 Tutorial 9: Signage Interaction, Route and Exit Adoption and Adaptive 

Response to Exit Congestion 

 

9.9.1 Creating the Geometry 

This tutorial examines the feature within EXODUS that allows occupants to interact 

with signs and a signage system. This interaction can allow the occupants to adapt the 

exit used as a response to exit congestion, adopt new routes in the geometry, reach 

previously unknown locations and evacuate via previously unknown exits. 

 

NOTE:  

The Visibility Catchment Areas (VCA) discussed during this tutorial can be shown in 

vrEXODUS ( see the vrEXODUS manual for further details). 

 

The user should first generate the 13.5m x 13m geometry shown in Figure 9-208(a), 

paying particular attention to the connectivity of the exits (i.e. the doors located in the 

south of the structure being 0.5m wide while the northern exit is 2m wide).  A sign 

should be placed at the location of each exit and it should be associated with that exit. 

This process will now be described. 

 

 
 

(a) (b) 

Figure 9-208: (a) The dimensions of the geometry. (b) The location and size of 

the sub-populations 

 

NOTE:  

Before generating the Sign object the user will first have to double-click on the  

button and then check the two boxes associated with the Sign attribute (i.e. Display and 

Selectable). 

 

9.9.2 Creating the Signs 

Select Generate from the Tools menu, and Sign from the Generate sub-menu 

[Tools>Generate>Sign].  Click on the geometry window to place the sign object and 

while holding the left mouse button down drag out the desired length of the sign - both 

the size and location can be adjusted once the sign has been created. 
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NOTE:  

Given that the Sign may have to be moved by the user, it might be useful to deselect 

both the Edit->Object Lock  and Edit->Node Align->Snap .  The user should 

however revert to Edit->Object Lock when this process is complete to ensure that 

inadvertent changes are not made. 

 

When placing Sign objects the user should make sure that the sign tip (i.e., the base of 

T shape formed by the sign) resides on the node from where the VCA of the sign will 

expand (i.e., typically this will be one of the nodes to which the exit is connected).  If 

not, the user can drag and move a sign to adjust the position (see Figure 9-209).   

 

 
(a) (b) 

Figure 9-209: (a) Sign generated, with the sign tip highlighted. (b) Sign moved so 

that it is appropriately in contact with a node. 

 

Repeat this action for each of the three exits; i.e., generate and position a Sign at the 

exit location that is in contact with a node connected to the exit in the manner shown in 

Figure 9-209.  In this instance, the default values for the sign will be used. The Width 

of the Sign has no impact upon the results produced in terms of the size of the calculated 

VCA. 

 

To associate a sign with an exit, double click on the sign object to display its 

corresponding Sign dialogue box, click on the Information tab, then click on the Target 

attribute and select from the drop down list the appropriate exit (i.e. the exit that is 

indicated by the sign, see Figure 9-210). 
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Figure 9-210: Associating a sign with an exit. 

 

Move to Population Mode and populate the structure as specified in Figure 9-208b (i.e. 

total population size 123 people). Use the Random Block population function to 

complete this step, available from the Tools menu via the Person sub-menu 

[Tools>Person>Random Block]. 

 

The user should then move to Scenario Mode where the visibility zones will be 

generated. This is achieved by first opening the Zone Editor dialogue box by clicking 

the button  and then selecting Visibility Signs from the Zone Type list box (see 

Figure 9-211a). The Visibility Zones can then be generated by simply clicking the Calc 

Viz. Signs button (see Figure 9-211b), with each of the Visibility Zones associated with 

a sign appearing as a separate panel.  

 

  
(a) (b) 

Figure 9-211: (a) Displaying visibility zones, and (b) Generating visibility zones  
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Once generated the zones can be viewed by first selecting the zone in question from the 

Zones list and then by clicking on either the Show button (which shows the area covered 

by the zone in terms of nodes, see Figure 9-212(a)) or the Show Polys button (which 

shows the area covered by the zone in terms of polygons, see Figure 9-212 (b)). 

 

  
(a) (b) 

Figure 9-212: Displaying visibility zone associated with door_3 via a) Nodes, and 

b) Polygons 

 

By double-clicking on the panels associated with each of the signs, it is possible to 

determine the floor area from which each of the signs is visible.  In this case the VCA 

of the sign associated with Door_3 is approximately 72m2, the other two signs have a 

VCA of approximately 45m2. The VCAs represent the areas from where the signs can 

be seen. 

 

The total area from which each sign is visible can also be displayed by first selecting 

the zone in question from the Zones list, clicking on the Show button to display the area 

in terms of nodes, and then clicking the Area button.  Upon clicking this button a 

dialogue box will be displayed showing not only the total floor area from which the of 

the sign is visible, but also the percentage of the entire geometry that the given area 

represents (see Figure 9-213). 

 

 
Figure 9-213: Displaying area data related to the visibility zone associated with 

door_3 
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EXODUS also provides the ability to view the VCA’s of multiple signs simultaneously. 

To achieve this the user should first ensure that no zones are currently being displayed 

in terms of nodes (see Figure 9-212).  The Merged checkbox within the Zone Editor 

dialogue box should then be selected (see Figure 9-211). Once selected zones can then 

be selected in the conventional manner and their corresponding VCA’s displayed by 

clicking the Show button. While the Merged checkbox is selected each zone will be 

displayed in addition to (as opposed to instead of) the previous zones. Hence the VCA’s 

of multiple zones can be displayed simultaneously.  In this manner, selecting and 

showing each sign in turn will display the total area within the structure from which 

signs are visible (see Figure 9-214(a)). 

 

 

 

 

 

 

 

 

(a) (b) 

Figure 9-214: (a) Displaying area the visibility zones associated with door_1, 

door_2 and door_3 simultaneously, and b) the data corresponding to the 

combined area 

 

While displaying multiple zones simultaneously data relating to the combined area can 

also be generated by simply clicking on the Area button (see Figure 9-214(b)). 

 

A detailed summary of the VCA of each sign and the total area on each floor from 

which signs are visible can also be displayed via the VCA Summary function. To utilise 

this function, close the Zone Editor dialogue box and select the VCA Summary option 

from the View menu. Once selected a complete summary of areas covered by the signs 

will then be automatically added to the Output tab of the Data Window (see Figure 

9-215). 

 

 
Figure 9-215: The VCA Summary 
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NOTE: 

To display the Data Window select the Interface option from the View menu, and ensure 

that the Data Window option in the resulting submenu is selected. 

 

9.9.3 Adaptive Behaviour in Relation to Congestion 

 

NOTE: 

The scenario examined in this section will demonstrate the ability of the occupants to 

redirect to an alternative exit as they observe high levels of congestion in the vicinity 

of the exit they are trying to use. 

 

The first scenario examined will not involve the evacuees being able to redirect in 

response to congestion levels around the exits. Move to Simulation Mode, ensuring that 

all of the evacuees respond immediately (setting the Specified Response to 0.0 seconds 

on the Behaviour tab of the Behavioural Options dialogue box), and that the Local 

Familiarity system is enabled within the Route tab, and then start the simulation.  It is 

immediately apparent that the evacuees move directly to the nearest exit (see Figure 

9-216a) and that the exit usage therefore reflects the fact that the populations were 

initially located in close proximity to the three exits (see Figure 9-216b). 

 

   
(a) (b) 

Figure 9-216: (a) The evacuees utilising the nearest exit (b) the exit usage 

 

To allow the occupants to avoid the congestion in front of the exits and redirect to more 

favourable exits, the user should enable the Avoid Congestion checkbox on the 

Behaviour tab of the Behaviour Control dialogue box [Rulebase>Behaviour Options] 

(see Figure 9-217). The simulation should be re-run.  
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Figure 9-217: Selection of ‘Avoid Congestion’ in the Behavioural Options 

dialogue box. 

 

The evacuees’ behaviour will appear more complex due to the movement between the 

exits.  This is due to them assessing the information available to them (i.e. the level of 

congestion around the exits that are visible) and then determining whether it is 

appropriate for them to change their route (see Figure 9-218a and Figure 9-218b). 

 

  
(a) (b) 

 

Figure 9-218: (a) Evacuees redirecting (b) The paths adopted during redirection. 

 

NOTE:  

It should be remembered that the majority of those redirecting will be doing so on a 

rational basis (i.e. based on decision to reduce their evacuation time) whilst others will 

redirect based on a determination to avoid their current congestion, whilst not being 

aware of the conditions around the exit to which they are travelling. 
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9.9.4 Adding an Obstacle and Enabling Signage Driven Behaviour  

 

NOTE: 

The scenario examined in this section will demonstrate the ability of the occupants to 

follow instructions from signs that the occupants happen to observe as they evacuate 

and as a result to redirect to a previously unknown exit. The Signage Driven Behaviour 

will be utilised.  

 

The user should create an obstacle that will obstruct the view of the sign at Door_3.  To 

do this the user should move to Geometry mode select and delete the nodes from the 

area shown in Figure 9-219 [Edit>Delete>Node] and delete the four arcs that will 

remain connecting the nodes across the corners. The user should then regenerate all the 

boundary lines so that the deleted area is reflected on the geometry’s outline. This can 

be achieved by selecting [Tools>Generate>Regen. Boundary Lines] from the menu.  

 

 
Figure 9-219: The location of the obstacle. 

 

The lines representing the new obstacle should be given a height of 2.2m. This can be 

achieved by first selecting the lines and then changing their Height attribute. In order 

to select the lines the user should double-click on the  button on the toolbar to open 

the Display Control dialogue box and then ensure that both checkboxes related to the 

Line attribute (i.e. Display and Selectable) are enabled. 

 

Once all four lines have been selected the user should select [Edit>Substitute>Lines] 

from the menu and enter a value of 2.2 into the Height textbox, thereby indicating that 

each of the lines has an effective height of 2.2m. The user should then return to Scenario 

Mode, where the existing visibility zones should be deleted and then regenerated in the 

manner described previously.  The impact that the obstacle height has upon the 

Visibility Catchment Area (VCA) of sign 3 is shown in Figure 9-220. 
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VCA size = 42.68 m2 

Figure 9-220: Visibility catchment area generated with a line height of 2.2m.  

 

Door_2 should be deactivated so that no occupants use it and therefore will not 

influence the simulation. This is done in Scenario Mode by double clicking on Door_2 

to display its corresponding Door dialogue box and then modifying the door’s 

properties by setting the Active attribute to NO and Status to Off. The occupants around 

Door_3 should be deleted (in Population Mode) and its Attractiveness should be set to 

0 (Scenario Mode, door properties).  This will mean that none of the occupants start 

with knowledge of exit Door_3.  In addition, the population around Door_1 should also 

be deleted. The population around Door_1 and Door_3 is deleted so that the effect of 

signage is more evident. 

 

Move to Simulation Mode to run the simulation. Within the Behaviour Control dialogue 

box enable Local Familiarity (Route tab), set the Signage System to Predictive (Signage 

tab) and set Specified Response to 0.0 (Behaviour tab). These options are available from 

the Rulebase menu and then the Behavioural Options item.   

 

Observe how the occupants originating from the vicinity of Door_2 move towards 

Door_1. Verify that some of these agents will upon passing by the obstacle will see the 

sign above exit Door_3 and will redirect towards Door_3. The occupants who see the 

exit sign choose to evacuate from the structure via Door_3 as it is much closer than 

Door_1 (see Figure 9-221). To re-cap: the Local Familiarity switch enables people to 

move according to their internal list of exits with which they are familiar. Enabling 

Signage Visibility allows the agents to receive information from the signage system and 

also update their internal list of exits. 
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(a) (b) 

Figure 9-221: (a) initial locations of those who used Door_1 (b) initial locations of 

those who used Door_2 

 

9.9.5 Enabling Occupant Driven Behaviour 

 

NOTE: 

The scenario examined in this section will demonstrate the ability of the occupants to 

use signage to find a location they want to visit. The Occupant Driven Behaviour will 

be utilised.  

 

A new sign will be created that will provide information for two separate locations in 

the geometry. These two locations will be on the right hand side of the obstruction 

created in the previous step. 

 

The user should go to Geometry Mode and add a sign in the top right hand side corner 

of the structure making sure its “tip” resides on top of a node. See Figure 9-222(a) for 

the approximately location where to place the sign. 

 

Once the sign has been properly positioned the user should go to Scenario Mode and 

make the new sign point to two nodes located on the top and bottom right hand side of 

the obstruction as shown in the Figure 9-222(a). This can be achieved by double 

clicking on the sign to display its corresponding Sign dialogue box and adding two 

separate target/direction entries in the Occupant Driven Behaviour section as shown in 

Figure 9-222(b). Make sure that both Target and Direction point to the same node. 

(This is necessary only for 0 and 1st order signs, see the Theory Manual). To achieve 

this enable Auto Insert and then click on the top right node to the obstruction (Free 

Space node 196 in Figure 9-222). This will be the first target. To add the direction, click 

the None button that will appear next to the target and then click again on the same node 

as the target. Now the first entry in the Occupant Driven Behaviour section should 

contain two buttons with the same node number (i.e. FS196).  
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Follow the same steps for the second target but first click on the white space below the 

first target on the Sign dialog box and then on the bottom right node to the obstruction. 

Select again the None button that will appear next to the second target and click again 

on the second target node. Now the Sign dialog box should contain two entries as shown 

in Figure 9-222. Note that the actual naming of the target/destination nodes (FS196 and 

FS201 as shown here) will most probably not match the naming of the nodes in the 

user’s geometry but this will not affect the results.  

 

 
(a) (b) 

Figure 9-222: Allocation of targets to Occupant Driven Behaviour  

 

Once the sign has been setup the VCA coverage will have to be calculated. To generate 

the VCA of the new sign click on the Tools menu then Zone item and then the Edit Zone 

item. Change the Zone Type to Visibility Signs and click on Calc. Viz Signs. This will 

generate the VCA of Sign 4 (see Figure 9-223).  
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Figure 9-223: VCA of sign 4 

 

Now that the sign has been setup it is necessary in order to demonstrate its effect to 

assign at least one occupant to use it.  

 

The user should move to Population Mode and pick up from the block of people the 

top right hand side person (circled occupant in Figure 9-224). Double click on this 

person and change their colour to Red to enable them to be more easily tracked within 

the simulation. Click the Has Tasks tick box and then click the O.I.L. (Occupant 

Itinerary List) button in order to assign this person four itineraries as shown in Figure 

9-224. Make sure Auto Insert is enabled and that you create the itineraries in the order 

indicated in the diagram. Note that points 2 and 4 correspond to the same nodes 

specified as targets in the new sign (i.e. Sign 4). The locations of nodes 1 and 3 should 

approximate the locations shown in Figure 9-224. These represent the initial direction 

the individual will have to travel in order to receive information from the signage 

system.  
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Figure 9-224: Structure of occupant itinerary 

 

The itineraries will initially appear in the Itinerary window as shown in Figure 9-225: 

 

 
Figure 9-225: Occupant itineraries 

 

These itineraries will have to be modified to comply with the requirements of the 

signage system. Change the Task type for itineraries 1 and 3 by manipulating the drop-

down boxes to Find Via Signage (see Figure 9-226). Next modify the delay times for 

itineraries 2 and 4 and assign a minimum value of 10 seconds and a maximum value of 

20 seconds (see Figure 9-226). 
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Figure 9-226: Modified itinerary list displaying the 4 tasks that the person will 

have to complete 

 

This setup includes four itineraries corresponding to the two targets that the selected 

occupant wants to visit. More specifically:  

 

1. Itinerary 1 represents the initial direction of travel for the first target, its task is 

to “Find Via Signage” the target indicated by Itinerary 2. In effect, the occupant 

is seeking informing from a sign visible from FS363, that leads them to FS196 

(Itinerary 2) 

2. Itinerary 2 represents the first target that the occupant wants to visit. The 

occupant will remain in that location for 10 to 20 seconds 

3. Itinerary 3 represents the initial direction of travel for the second target, its task 

is to “Find Via Signage” the target indicated by Itinerary 4. In effect, the 

occupant is seeking informing from a sign visible from FS249, that leads them 

to FS201 (Itinerary 4) 

4. Itinerary 4 is the second target that the occupant wants to visit. The occupant 

will remain in that location for 10 to 20 seconds 

 

The user can view the itinerary list (set of tasks) by clicking on the Label button, the 

graph that will appear should look similar to the one shown on Figure 9-224. 

 

With both sign and occupant properly setup the user can go to Simulation Mode and 

run the simulation. First, open the Behaviour Control dialogue box 

[Rulebase>Behaviour Options] and on the Route tab make sure that the Local 

Familiarity flag is enabled. Also, make sure that in the Signage tab the Predictive option 

is enabled. It is advisable to slow down the simulation in order to better observe the 

behaviours exhibited during the simulation. This can be achieved by selecting from the 

Simulation menu the Speed Control option and enabling the relevant check box.  

 

When the simulation is run all the occupants with the exception of the person assigned 

the itineraries will move towards Door_1, those who observe Door_3 will redirect and 

use it as it is more advantageous and will reduce the time to complete their evacuation. 

The person with the itineraries will progress towards location 1 where upon observing 

the sign will receive information regarding their first target and will progress towards 

point 2. Once at point 2, this person will wait there for a duration of between 10 to 20 

seconds. Once this time has elapsed the occupant will head towards point 3 to acquire 

information regarding their second target. Upon observing the sign again this person 

will head towards location 4 where they will remain for 10 to 20 seconds. Once both 
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sets of itineraries are completed this person will head towards the familiar Door_1, if 

the person observes Door_3 he/she will use it. An example path that this occupant 

followed is shown in Figure 9-227. 

 

 
Figure 9-227: Path taken by the individual who utilises signage to reach locations 

they wish to visit 
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9.10 Tutorial 10: Milling and Social Response 

In this tutorial the Social Response and Milling functionality will be demonstrated in a 

simple two room geometry connected by a single corridor. This is formed from two 

rooms both measuring 5m x 4m and connected by a 1m x 1m corridor (see Figure 

9-228). A single 1m exit should then be connected to the middle of the eastern room as 

shown (see Figure 9-228). 

 

 
Figure 9-228: The geometry used in this tutorial. 

 

Once the geometry has been constructed, the geometry should be randomly populated 

as shown in Figure 9-229(a) and supplied with response times (as shown in Figure 

9-229 (b)). 

 

  
(a) (b) 

Figure 9-229: The location of the population. 

 

The user should then move to Simulation mode and run the simulation. It will become 

apparent that the evacuees located in the western room are blocked (somewhat 

artificially) by the stationary individuals located within the corridor, due to their 

extended response times (see Figure 9-230).  

 

 
Figure 9-230: The progress of the evacuees blocked by stationary individuals. 

 

This becomes more clearly apparent from examining the arrival times of the evacuees 

at the exit (see Figure 9-231). Given the fact that vast majority of the evacuees had zero 

response times, it would be anticipated that they should start arriving at the exit within 

a matter of seconds of the simulation commencing. However, this is not the case (see 

Figure 9-231) and is entirely due to the delay caused by the blockage in the corridor. 
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Figure 9-231: Delayed arrival of evacuees in the western room. 

 

The user should now enable the Milling checkbox on the Behaviour tab of the 

Behaviour Control dialogue box [Rulebase>Behaviour Options] (see Figure 9-232). 

 

 
Figure 9-232: Milling enabled on the Behaviour Control dialogue box. 

 

Once the simulation is re-run, the two individuals blocking the corridor can be seen to 

occasionally move from their initial location, without consistently moving towards the 

exit, representing pre-evacuation behaviour. This then enables the evacuees 

approaching from the western room to pass (albeit occasionally) and gain access to the 

exit (see Figure 9-233). 

 



Chapter 9 - Tutorial 10 

 

©2017 University of Greenwich 330 

 
Figure 9-233: The individuals blocking the corridor ‘mill’ out of the way of the 

oncoming evacuees. 

 

The second part of this tutorial requires the user to return to Population mode. Whilst 

here, the user should generate two additional individuals positioned centrally in the 

eastern room. In addition modifications should be made to the population attributes as 

shown in Figure 9-234. This modifies the response times and the social Gene applied 

to members of the population. 

 

 
Figure 9-234: New population and attributes.  

 

The user should now move to Simulation mode and start the simulation. Given that the 

Milling option is still enabled, the population in the western room will be able to pass 

through the corridor, circumnavigating the two individuals in the eastern room who 

have extended response times (see Figure 9-235(a)). 
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(a) (b) 

Figure 9-235: (a) Two evacuees with extended response times are left behind. (b) 

Uneven arrival of evacuees.  

 

The arrival times of the evacuees confirm this behaviour with a relatively consistent 

arrival of the first group of evacuees, a 20 second period of time with no evacuees and 

then the arrival of the final two evacuees (see Figure 9-235(b)).  

 

The user should then return to Population mode in order make clear the impact of the 

new behaviours in the next part of the tutorial. The three individuals that are deemed to 

be related (i.e. that share a common gene) should be coloured red. This is achieved by 

selecting the three individuals (using the CTRL key and the mouse) and then 

Substituting the colour of the individuals as Red [Edit>Substitute>People]. This 

process should then be repeated (using a combination of the CTRL key and dragging 

out an area) to colour the rest of the individuals in the western room as Green and the 

two individuals in the corridor as Dark Blue. This should enable the behavioural 

dynamics evident during this simulation to be more clearly observed. The user should 

then return to Simulation mode, open the Behaviour Control dialogue box and enable 

the Social Response checkbox within the Behaviour tab. Both this and the Milling 

checkbox should now be enabled. 

 

Initially when this simulation is now run it appears as though there are no differences 

from the previous scenario. However, in some of the cases (where the individuals who 

share a gene pass each other sufficiently closely), the two individuals initially located 

in the eastern room are influenced (have their response times reduced) and move off 

before the response time that was initially associated to them. On some of the runs those 

deemed to be socially related interact causing the two individuals with extended 

response times to move off earlier than they might otherwise have done. Note from 

Figure 9-236, that the individual who appears Dark Blue and is identified by the box – 

also has an extended response time (being initially located in the corridor) but is not 

related (i.e. does not share a Gene with a value greater than zero with a moving 

individual) and therefore is not informed. 

 

NOTE: 

It may be easier to see the colours of the people, and hence the various groupings to 

which they belong by displaying people as Blocks as opposed to via a Person Shape. 

This can be assigned in Simulation mode via [View>Shape>Block]. 
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Figure 9-236: The related individuals can be seen to be within the range of 

influence and to all be moving towards the exit. 

 

The impact that this behaviour has had upon the arrival of the evacuees is apparent from 

Figure 9-237 where there is no obvious step in the curve describing the arrival of the 

evacuees. 

 

 
Figure 9-237: Graph demonstrating the relatively even arrival of evacuees at the 

exit. 

 

To demonstrate the other aspects of the social response algorithm, the user is required 

to return to Population mode, delete the population and replace them with two 

individuals, located centrally in the eastern room. These two individuals will have 

attributes as specified in Figure 9-238.  For this a second exit should be added to the 

geometry as shown in Figure 9-238. 

 

 
Figure 9-238: Initial conditions of the tutorial involving social response. 
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The familiarity of the individuals should be specified using the Local Familiarity 

system (accessible from the Fam button from the Person dialogue box in Population 

mode). Once this has been completed the user should move back to Simulation mode. 

 

 
(a)

 
(b) 

Figure 9-239:(a) Differences in the exit awareness cause the individuals to use 

different exits (b) Once the individuals are attributed with the same exits, or 

when the Local Familiarity switch is disabled, they both move towards the same 

exit. 

 

Once the simulation is run, it will be apparent that the two individuals use the exits 

according to their knowledge and then on the proximity of the exit (see Figure 

9-239(a)), rather than solely being based on the proximity of an exit (see Figure 

9-239(b)). 
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9.11 Tutorial 11: Determining the proportion of the population to use each exit 

This tutorial describes how the user is able to use the model to approximate the ideal 

numbers of evacuees that should use each exit in order to optimise the overall 

evacuation time (note: not the evacuation time of each individual evacuee). 

 

Firstly, the user should generate a geometry 25m x 5m with three exits, as shown in 

Figure 9-240. It should be noted that the size of the exits are intentionally unequal, with 

the centrally located exit being twice the size (i.e. 2m) of the other two exits (i.e. 1m). 

The same flow rate should be applied to each of the exits; in this case the HMSO flow 

rate should be applied. 

 

 
Figure 9-240: The geometry used in this tutorial. 

 

Once the user has completed the geometry they should move to Population mode. Three 

sub populations of 50 individuals should be generated around each of the exits (see 

Figure 9-241). This can be achieved by selecting an area around each exit 

(approximately 5m x 5m should suffice) and then use the Random Generate function 

to produce 50 individuals within each area [Tools>Person>Random Generate]. 

Alternatively, this geometry can simply be loaded from T11_1.EXO. 

 

 
Figure 9-241: Location of individuals around the three exits 

 

Once complete the user should move to Simulation mode. The user should then open 

the Behaviour Control dialogue box [Rulebase>Behaviour Options], and within the 

Behaviour tab enable a Specified Response of 0.0 seconds, thereby forcing the entire 

population to react instantly. It will be apparent during the simulation that the three 

exits do not finish at the same time with the outer exits finishing after approximately 

42-45 seconds while the central exit finishes after approximately half of this time (see 

Figure 9-242).  
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Figure 9-242: The uneven capacity of the three exits becomes apparent. 

 

The user should now move to Scenario mode where the Optimum Exit Stat should be 

selected from the View menu [View>Optimum Exit Stat]. This will generate the Opt 

Exit Usage dialogue box, which provides information relating to the number of 

evacuees that should use each exit given the calculated capacity of each exit.  

 

NOTE: 

This calculation does not take into consideration any attribute of an individual evacuee. 

 

 
Figure 9-243: The information provided by the Opt Exit Usage dialogue box. 

 

It is apparent from Figure 9-243 that to gain a more even completion time for the three 

exits, the proportion of people using each of the exits should be altered.  

 

NOTE: 

In reality this might entail altering the procedures within a structure. 

 

To accomplish this, the user should move to Population mode where 13 of each of the 

eastern and western sub-populations should be selected and be attributed with a target 

exit of the central exit (see Figure 9-244). The exit usage should then approximate that 

suggested by the Optimum Exit Stat. Alternatively, this geometry can simply be loaded 

from T11_2.EXO. 
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Figure 9-244: Adjusting exit usage. 

 

The user should then move to Simulation Mode and open the Behaviour Control 

dialogue box, where a Specified Response of 0 seconds should still be applied within 

the Behaviour tab. In addition, the Maintain Target Exit option should also be enabled 

within the Route tab to force the evacuees to maintain their target exits during egress. 

 

Once the simulation is run, the evacuees attributed with Target exits peel off to the 

central exit (see Figure 9-245(a)), where they join the congestion already evident 

around the exit (see Figure 9-245(b)). 

 

 
(a) 

 
(b) 

Figure 9-245: (a) Individuals attributed with target exits peel off towards the 

central exit.(b) These evacuees join the existing congestion and the exits are now 

used as desired. 

 

The simulation times generated reflect this with all three exits finishing within a much 

smaller time interval (see below).  
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However, the values provided by the Optimum Exit statistic becomes increasingly 

invalid the greater the variation in the experiences of the evacuees (e.g. the congestion 

experienced, the distances covered, the response times attributed, etc.). To demonstrate 

this, the user should re-open the first tutorial saved (i.e. T11_1.EXO). The user should 

move to Population mode, select [Edit>Substitute>Range] and provide a response time 

distribution of 0-60 seconds. On returning to Simulation mode the user should ensure 

that the Specified Response time checkbox has been disabled. Once this simulation has 

started, it becomes apparent that the congestion evident in the previous simulations does 

not build up to the same extent as before, with the conditions produced not being 

entirely dependent upon the simultaneous arrival of evacuees at exits (see Figure 

9-246). 

 

 
Figure 9-246: Response time distribution causing evacuees to arrival at the exits 

in a far wider time interval. 

 

In this case, even though the number of people using each exit is unequal, the final 

evacuation times produced at each exit are approximately the same (see below). 

 

 
 

This is entirely due to the fact that the response times of the population now dominate 

the evacuation times generated, rather than simply the conditions experienced at the 

exits. 
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The user should now open the second file generated (i.e. T11_2.EXO) and generate the 

range of Response times within the population as was the case in the previous example 

(i.e. 0-60 seconds). The user should then move to Simulation mode, open the Behaviour 

Control dialogue box and enable the Maintain Target Exit option within the Route tab, 

and then run the simulation. 

 

Even though it will be apparent that the exit usage has been corrected as indicated by 

the Optimum Exit usage statistics, the evacuation times generated at each exit are 

approximately the same as those generated in the previous case (see below). 

 

 
 

This case has been designed to demonstrate the fact that the information provided by 

the Optimum Exit statistic is only really valid in very simple situations where the 

conditions experienced by the evacuees are fairly uniform and dependent upon the 

conditions at the exits. 
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9.12 Tutorial 12: Direction Nodes 

In this tutorial the Direction node functionality will be demonstrated in a simple two 

room geometry connected by a two 1m corridors. This is formed from two rooms both 

measuring 8m x 5m and connected by two 1m x 1m corridors (see Figure 9-247). Two 

1m exits should then be connected as shown. 

 

 
Figure 9-247: The geometry used in this tutorial. 

 

The nodes connecting the two rooms should be selected. They should then be 

Substituted as Direction nodes [Edit>Substitute>Nodes]. This will enable the 

movement of the evacuees across the nodes to be controlled, limiting the direction of 

travel. 

 

Once the Direction nodes have been generated their Node Dir. attribute should be 

adjusted to reflect the direction that we require the individuals to move in. Initially we 

require the upper connection to be configured to allow movement from east to west 

while the bottom connection allows movement from west to east. The nodal directions 

are controlled using angular notation (see Figure 9-248). The angles denote the 

direction of approach that the Direction node will allow. Therefore a Direction node 

with a Node Dir. of 90 will allow evacuees to use it from the east. 
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Figure 9-248: Angular notation used in Direction nodes. 

 

To generate the behaviour that we require in this tutorial the top set of Direction nodes 

should have a Node Dir of 90 and the bottom set of nodes should have a Node Dir of 

270 (see Figure 9-249). As with changing the Type of the nodes, defining the direction 

through which people can negotiate the Direction nodes is achieved by first selecting 

each group of nodes and then Substituting the required Node Dir. 

[Edit>Substitute>Nodes]. 

 

 
Figure 9-249: Setting Node Dir for the two sets of Direction nodes. 

 

Once the geometry is created the user should move to Population mode. Two sub-

populations should be generated using the Random Generate function 

[Tools>Person>Random Generate], as shown in Figure 9-250, with 20 evacuees in 

each room.  
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The evacuees then need to have Target exits defined to force them to use the connecting 

corridor. Therefore, in this example all of the evacuees in the west room should be 

forced to use Door_2 and all of the evacuees in the east room should be forced to use 

Door_1. This is achieved by selecting each room in turn and Substituting the required 

Target exit to the people within it [Edit>Substitute>People]. 

 

 
Figure 9-250: Location of evacuees within the geometry. 

 

The user should then move to Simulation mode, open the Behaviour Control dialogue 

box [Rulebase>Behaviour Options] and select Local Familiarity (Route tab) and 

provide a Specified Response time of 0 seconds (Behaviour tab). Once the simulation 

is run it will become immediately apparent that the evacuees do not necessarily adopt 

the shortest path but instead are forced to use the structure according the limitations 

imposed by the Direction nodes (see Figure 9-251). 

 

 
Figure 9-251: Evacuees having their movement restricted by the imposition of 

Direction nodes. 

 

This can be more clearly seen from examining the paths adopted by the evacuees. This 

can be displayed by clicking on each of the exits to display their corresponding dialogue 
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boxes and then clicking on the Locat button, which displays all of the paths adopted by 

the evacuees using that exit (see Figure 9-252 and Figure 9-253). 

 

 
Figure 9-252: Paths adopted by evacuees using Door_1. 

 
Figure 9-253: Paths adopted by evacuees using Door_2. 

 

The user should then return to Geometry mode and reverse the Node Dir associated 

with the Direction nodes, so that the top set of Direction nodes have a Node Dir of 270 

and the bottom set have a Node Dir of 90. The user should then return to Simulation 

mode and run the simulation with the same behaviour settings as defined previously. It 

will be immediately apparent that the evacuees are forced to adopt different paths due 

to the change in the usage of the connecting corridors (see Figure 9-254 and Figure 

9-255). 
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Figure 9-254: The revised paths adopted by evacuees using Door_1. 

 

 
Figure 9-255: The revised paths adopted by evacuees using Door_2. 

 

It should be noted that the implementation of Direction nodes will influence the paths 

adopted by evacuees irrespective of the navigation system employed (i.e. whether Local 

Familiarity or the Potential Map system is used). This can be demonstrated by moving 

back into Geometry mode and deleting Door_2. The user should then move to 

Population mode and substitute the Nearest door option into all of the evacuees’ Target 

attribute [Edit>Substitute>People]. The user should then move to Simulation mode and 

it will be immediately apparent that the Direction nodes still influence the movement 

of the evacuees in an identical manner to that evident before (see Figure 9-256).  
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Figure 9-256: The modified movement of evacuees is apparent. 
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9.13 Tutorial 13: Generating Queues and Response Curves 

 

9.13.1 Single Queue / Single Server 

In this tutorial the new Queue/Server functionality will be demonstrated in a simple one 

room geometry that measures 15m x 15m. A single 0.5m exit is located in the top-right 

hand corner of the room (see Figure 9-257).  

 

 
Figure 9-257: The geometry used in this tutorial. 

 

A server needs to be located 5m from the bottom right hand corner of the geometry. To 

do this, go to Scenario Mode and open the Queue Window from the Tools Menu 

[Tools>Queue Window]. The user then needs to Create a new Queue. Upon clicking 

the Create button a new Queue panel will appear within the Queues list. This panel 

should be selected by single clicking on its corresponding panel. When selected, the 

name of the panel (i.e. Queue_1) will appear in quotation marks (see Figure 9-258).  

 

 
Figure 9-258: The Queue Selection dialogue box 

 

The user then needs to associate a Server and Route to this Queue. To associate a Server 

to a Queue click on the Servers button while the panel is selected. This will open up the 

Servers dialogue box (see Figure 9-259(a)). The Auto Insert box should be enabled, and 

then the node 5m from the bottom right hand corner selected. Upon clicking at the given 

location a new Server will be created and its corresponding panel added to the Server 



Chapter 9 - Tutorial 13 

 

©2017 University of Greenwich 348 

list (i.e. Server_1). A minimum and maximum delay of 10 and 20 seconds should be 

associated with this server. 

 

 

 
(a) (b) 

Figure 9-259: (a) Server Creation; (b) Location of the server. 

 

NOTE: 

It may be useful during this tutorial to toggle the display of Servers on and off. This can 

be achieved via the Display Control dialogue box [View>Display>Gra.Ctrl Options] 

in any mode and selecting Queues to be Displayed. 

 

The server has now been created. The user should return to the Queue Window (i.e. by 

clicking OK within the Server dialogue box to confirm the changes made), select the 

Queue_1 panel again, and click the Route button to display the Route dialogue box (see 

Figure 9-260).  

 

Routes determine the approach taken by occupants as they approach the queue. In this 

instance, the route required is quite convoluted, requiring occupants to arch around 

before reaching the server. To achieve this, the user needs to select Auto Insert and then 

manually select the desired nodes. These are located 2.5m to the left of the server (select 

this first); 2.5m above the last node; 2.5m to the left of the last node; and then 2.5m 

below the last node. This configuration is shown in Figure 9-260 where the Label button 

has been clicked. 

 

 
Figure 9-260: Location of the server route. 

 

The user then needs to create the necessary itinerary for the queue to be recognised and 

used. Firstly, the user needs to be in Population Mode and the Itinerary Window 
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selected from the Tools menu [Tools>Itinerary Window]. A new itinerary needs to be 

Created (i.e. Itin_1, see Figure 9-261(a)) and then the subsequent panel double-clicked 

to edit the itinerary. The Auto Insert option should be enabled and then any node within 

the geometry selected – the location of the node will be overridden anyway. By default 

any new task created is defined as a Delay task. Change this by selecting Queue from 

the Task drop-down menu. The associated node icon next to this should then be double-

clicked bringing up the list of Queues that can be associated with this Itinerary task. In 

this case, only one Queue has been created (i.e. Queue_1) so this should be selected 

(see Figure 9-261(b)). Figure 9-261(c) shows the Itinerary dialogue box after the task 

has been defined as a Queue.  The Queue has now been defined. 

 

  
(a) (b) 

 
(c) 

Figure 9-261: (a) Creating the itinerary, (b) Queue Selection and (c) Defining the 

itinerary. 

 

In addition to using a Queue, the population is also assumed to respond according to a 

Response Curve as opposed to a simple range. Move to Population Mode and access 

the Distribution Curves option from the Tools menu [Tools>Distribution Curves]. A 

new response distribution needs to be Created (i.e. Resp_1, see Figure 9-262(a)). In 

this case, a normal distribution is required to represent the Response Curve, with the 

nature of the curve described as shown in Figure 9-262(b). 
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(a) (b) 

Figure 9-262: Distribution Editor for the Response Curve. 

 

It is now possible to generate the Population. Go to Population Mode. The user should 

select the 2.5m x 2.5m in the top left hand corner of the geometry – this is where the 

population will initially be located. Once selected, the Panel Populate icon should be 

clicked gaining access to the Pop Setup dialogue box. The Adv. Global Options button 

provides access to the controls for associating Response Curves and Itineraries to this 

population. The Response Curve generated earlier (i.e. Resp_1) can be associated by 

selecting it from the Response Curve drop down box, while the Itinerary (i.e. Itin_1) 

can be added by clicking on the Itinerary button, clicking on the Add button in the 

Itinerary Selection dialogue box, and then selecting the itinerary panel from the list 

shown (see Figure 9-263). 

 

 
Figure 9-263: Associating the Response Curve and the Itinerary to the 

Population. 

 

Once the Advanced Global Panel dialogue box has been closed, a population of 25 

should then be generated in the top right hand corner. 
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The user should move to Simulation Mode to run the simulation. In this instance, it may 

be useful to shuttle the simulation forward given the simplicity of the scenario being 

examined. To ensure that the itineraries are not lost when queuing, the Maintain 

Itinerary option should be selected within the Route tab of the Behaviour Control 

dialogue box [Rulebase>Behaviour Options]. 

 

The user will notice that the population respond according to the stated Response Curve 

attributes, with most them responding between 23 and 27 seconds, as expected (see 

Figure 9-264(a)). The population then moves towards the server. Once the server is 

occupied, the population then realises that it needs to queue and follows the route 

associated with the server (see Figure 9-264(b)). Each person experiences a delay of 

between 10 and 20 seconds when using the server, as specified. Once this delay has 

been served, the person then moves off to the exit (see Figure 9-264(c)). 

 

  
 

(a) (b) (c) 

Figure 9-264: Progression of the simulation. 

 

9.13.2 Single Queue / Multiple Servers 

The same geometry is used as in the previous example. The user should ensure that the 

Queues/Servers visible (via the Gra. Ctrl dialogue box) and then return to Scenario 

Mode and select the Queue Window option from the Tools menu [Tools>Queue 

Window]. Select the Queue_1 panel and then click on the Servers button to gain access 

to the Servers dialogue box. Enable the Auto Insert flag and then define two additional 

servers (i.e. Server_2 and Server_3) by selecting two nodes: the first 2 nodes (i.e. 1m) 

above the original server, and the other four nodes (i.e. 2m) above it (see Figure 9-265). 

 

 
Figure 9-265: Location of three servers. 

 

The performance of these servers can then be configured with the delay characteristics 

defined in the associated Min/Max boxes (see Figure 9-266). 
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Figure 9-266: Configuration of three servers. 

 

Return to Simulation Mode and ensure that the Maintain Itinerary option is again 

enabled. Once the simulation is run, it is apparent that the occupants make use of all 

three servers, selecting the first that becomes available. This selection is made 

irrespective of the delay associated with the service time of a server, and is therefore 

more suited to those occasions (e.g., checkout tills), where the differences in 

performance are relatively small. 

 

9.13.3 Source Nodes / Redirection Nodes / Single Queue / Multiple Servers/ 

Selection Criteria 

The same geometry is used as in the previous example. In this example, occupants will 

be generated dynamically using Source Nodes, and will be redirected between three 

separate queues using a Redirection Node. 

 

Firstly, the user should delete all current queues, servers and itineraries. Once 

completed, the user should go to Scenario mode, open the Queue Window and Create 

three new Queues. The panels will appear in the dialogue box (i.e. Queue_1, Queue_2 

and Queue_3). Each of these Queues should have a single Server associated with them. 

These should be located in the same positions as in the previous tutorial (see Figure 

9-265) and provided with the delay characteristics shown in Figure 9-267. 
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Queue 1 Server 

 

 
Queue 2 Server 

 

 
Queue 3 Server 

Figure 9-267: Configuration of server delay characteristics. 

 

Each of these Queues should have an equivalent Route associated with it. This should 

start 4m from the Server and finish 1m from it, as shown in Figure 9-268. 

 

 
Figure 9-268: Configuration of the server routes. 

 

The user should then go to Geometry Mode and create a Redirection Node and a Source 

Node. These should be located approximately as shown in Figure 9-269 with the 

Redirection node located in the bottom left corner and the Source node located in the 

top right corner of the geometry. 
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Figure 9-269: Location of Source node (top left) and Redirection node (bottom 

right). 

 

A number of itineraries now need to be created.  A queue itinerary needs to be created 

for each of the Queues in the geometry (i.e. three). This requires the generation of an 

itinerary, the selection of Queue from the task drop down box and then the association 

of the Queue with the itinerary, as before. An additional (standard/delay) Itinerary is 

required. This needs to point to the Redirection Node location. In the example below, 

this Itinerary is titled Red (see Figure 9-270). 

 

 
Figure 9-270: Creation of four itineraries. 

 

The user should move to Scenario Mode to define the characteristics of the Source and 

Redirection nodes. The default population can be assumed for the Source node; 

however, the Red itinerary needs to be associated with this population in order for them 

to be informed by the Redirection node. The Source node should be double-clicked, 

and then the Adv button clicked. This will open the Source Node Control dialogue box. 

The Append button creates a Source Scenario – a population / itinerary / performance 

setting. The itinerary panel should be double-clicked and the Red itinerary selected. The 

characteristics can then be configured as shown in Figure 9-271. 
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Figure 9-271: Source Node characteristics. 

 

The Redirection Node then has to be similarly configured. The Redirection Node should 

be double-clicked opening the Node dialogue box. The Range setting should be changed 

to 1m (see Figure 9-272(a)). The Adv button should then be clicked to gain access to 

the Itinerary Selection dialogue box. The three previously created itineraries associated 

with the Queues should then be Added (clicking the Add button and then selecting the 

appropriate itineraries). The model will assume, by default that the Probability option 

is to be employed, and calculate the probability of an occupant randomly selecting one 

of these itineraries (i.e., using one of the queues). This should initially be used. 

 

 

 

(a) (b) 

Figure 9-272: Source Node characteristics. 

 

The scenario can then be run in Simulation mode. It is apparent that occupants select 

(randomly in this case) between the servers, follow the associated route, and then use 

one of the three servers (see Figure 9-273). 
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Figure 9-273: Use of the three queues. 

 

The manner in which the occupants choose between the queues is determined by the 

options selected in the Redirection node (via the Allocation pull down box). The user 

is encouraged to explore these options to investigate their impact on the results 

produced. 
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9.14 Tutorial 14: Advanced Itineraries  

 

9.14.1 A Small Number of People Following an Itinerary in a Complex Space 

A geometry has been prepared for this tutorial (called T14_1.EXO) enabling the user 

to quickly examine the itinerary functionality. Load this EXO into the model using the 

standard approach. A relatively complex space will appear (see Figure 9-274). This 

space has already been meshed and exits attached. The EXO file is therefore ready to 

be populated. 

 

Move to Population Mode and generate a population of 20 people 

[Tools>Person>Random Generate] located in the main atrium area as shown in the red 

box in Figure 9-274. 

 

 
Figure 9-274: Initial location of 20 people. 

 

Once the population has been created the next step is to produce a simple itinerary. To 

do this, open the Itinerary Window by selecting the Itinerary Window from the Tools 

menu in Population Mode [Tools>Itinerary Window]. Within the Itinerary Window 

click the Create button to produce a new itinerary panel (i.e. “Itin_1”, see Figure 

9-275). Double-click on this panel to gain access to the associated Edit Itinerary 

dialogue box. Check the Auto Insert box at the top of the dialogue box, thereby allowing 

Users to manually select the nodal location associated with the task. Once the Auto 

Insert box is checked, click somewhere inside the room located on the southern wall of 

the structure (as indicated by the red square in Figure 9-275). 
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Figure 9-275: Location of task. 

 

Upon clicking on a node a new task will automatically be generated within the Edit 

Itinerary dialogue box, which requires those following this itinerary to move to that 

specific nodal location (see Figure 9-275). By default, all new tasks created will be set 

to the basic Delay task type – requiring those following the itinerary to move to the 

location and wait there for a period of time. In this case, the delay encountered at the 

location should be between 5 and 10 seconds, hence the User must enter the values 5 

and 10 into the Min and Max fields respectively (see Figure 9-275). Once this has been 

completed, click the OK button. 

 

You now have to associate this itinerary (i.e. “Itin_1”) with the population of 20 people. 

Click on the Person Select icon  on the menu-bar, and then select the entire 

population by dragging out a selection box around the population (i.e. approximating 

the red box shown in Figure 9-274). Once the box has been dragged out and surrounds 

the entire population, display the Person Substitution dialogue box by selecting the 

Substitute option within the Edit menu in Population Mode, and then selecting People 

from the resulting sub-menu [Edit>Substitute>People]. Within the Person Substitution 

dialogue box first check the Has Tasks check box (this will initially be marked NULL). 

This enables the selected population to be assigned itineraries. Having selected the Has 

Tasks check box, click the O.I.L. button to display the Edit Itinerary dialogue box. 

Within the Edit Itinerary dialogue box click the Import button. This allows existing 

itineraries to be imported into and hence assigned to the target population. The previous 

itinerary that has just been defined (i.e. “Itin_1”) will appear as a panel in the 

subsequent Itinerary Selection dialogue box. Single-click on this panel to select it 

within the list (quotation marks will appear around the panel name, see Figure 9-276) 

and then click the OK button. 
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Figure 9-276: Importing the Itinerary. 

 

The task associated with the itinerary will now appear in the Edit Itinerary dialogue 

box, indicating that it has been successfully imported. Click the OK button on the Edit 

Itinerary dialogue box and then the OK button on the Person Substitution dialogue box. 

Click on random members of the population to ensure that they have been assigned the 

previously created itinerary (see Figure 9-277). 

 

 
Figure 9-277: Individual that has successfully had an itinerary substituted. 

 

Once complete, move to Simulation Mode and open the Behaviour Options dialogue 

box [Rulebase>Behaviour Options]. Click the Behaviour tab and then check the 

Specified Response Time box. Then set the corresponding Time value to 0 seconds, 

thereby forcing the population to move off simultaneously at the start of the simulation. 

Also ensure that the Maintain Itinerary option is deselected within the Route tab. Click 

the OK button to confirm the changes made and close the Behaviour Options dialogue 

box and then start the simulation. It may be prudent to step through the simulation using 

the Step button  rather than simply playing it in the conventional manner, since the 

simulation will proceed very quickly. Alternatively the User can slow the simulation 

down by enabling the Speed Control function [Simulation>Speed Control]. 

 

Once the simulation commences, the population will be seen to head off towards the 

location at the southern boundary as specified in the itinerary (i.e. “Itin_1”). However, 

as a result of the population moving off simultaneously, some congestion is produced. 

Occasionally, this congestion may be severe enough for people to become impatient 

(i.e., get caught in congestion for a time longer than their Patience attribute). These 

individuals will then abandon their itinerary and instead move towards an exit (see 
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Figure 9-278). The simulation may have to be run several times for this phenomenon 

to be observed. 

 

 
Figure 9-278: The path of an individual initially following their itinerary, getting 

caught in congestion, and then abandoning itinerary and moving to an exit. 

 

In some situations it may be desirable to capture this behaviour. However, if the impact 

of a population following a particular procedure was being tested, then individuals 

deviating from the procedure may introduce noise into the results produced. To force 

the population to follow their assigned itineraries, move to Simulation Mode and open 

the Behaviour Options dialogue box [Rulebase>Behaviour Options], select the Route 

tab and then enable the Maintain Itinerary option. This will force the population to 

follow their itineraries irrespective of the congestion experienced. Click the OK button 

to confirm the changes made within the Behaviour Options dialogue box and then re-

run the simulation to ensure that this is the case. 

 

9.14.2 A Small Number of People Following an Itinerary in a Complex Space 

Surrounded by the General Population 

In some cases, the user may wish to explore the interaction between a small group of 

people following a specific procedure, while the general population is evacuating as 

normal (e.g., to their nearest exit). 

 

Move to Population Mode. Click on the Panel Populate button . Ensure that only 

Free Space nodes are selected (i.e. that all other Node Types are deselected) and also 

that the Global allocation system is selected. Enter a value of 100 into the Total Pop. 

Size text box and then click the Populate button. Then click Yes in the resulting dialogue 

box to confirm the generation of the population. A population of 100 will be generated 

throughout the geometry (in addition to the 20 individuals created previously in Section 

9.14.1). Alternatively, the User can merely load the file T14_2.EXO. Next, move to 

Simulation Mode and run the simulation.  

 

The newly generated general population will move towards their nearest exit, since they 

have NOT been assigned itineraries. While this movement is taking place, the original 

population of 20 still move towards their designated target (i.e. within the southern 
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room) prior to evacuating. In this instance, the population of 20 encounters some 

additional congestion as they interact with the evacuating population. However, since 

the Maintain Itinerary option is still selected, they do not abandon their itinerary due to 

them becoming impatient.  

 

9.14.3 A Small Number of People Following an Itinerary with Delay and Delay Zone 

Tasks 

In this example, the difference between the default Delay and the Delay Zone tasks will 

be explored. A simple rectangular geometry (28m x 16m) has already been created with 

a population of 50 people (open T14_3.EXO). This population has an itinerary 

associated with it that requires them to visit a location in the southeast corner of the 

geometry and delay between 10 and 20 seconds before evacuating. Move to Simulation 

Mode, open the Behaviour Control dialogue box [Rulebase>Behaviour Options] and 

select the Maintain Itinerary option within the Route tab. In addition, select the 

Specified Response option and set the corresponding Time value to 0 seconds 

(Behaviour tab). After running this simulation you will notice that: 

1. The population has to visit the specific location (i.e. node) associated with the 

task prior encountering their delay time and then evacuating, and  

2. It takes between 13 and 15 minutes to complete the simulation.  

 

This leads to significant congestion and a prolonged overall evacuation time. In reality, 

there may be situations where evacuees need to visit a specific location prior to 

evacuating (e.g., operating a machine). However, there may also be situations where 

evacuees merely need to go to a certain area to perform an action/receive orders etc. 

prior to evacuating. In this case, the Delay function (which requires individuals to visit 

a specific nodal location) may not be appropriate.  

 

For the next part of this tutorial, a Compartment zone needs to be created to be used in 

conjunction with the Delay Zone task. Return to Scenario Mode and click on the Edit 

Zone icon  on the menu bar to display the Zone Editor dialogue box, and then select 

Compartment from the Zone Type drop down box (see Figure 9-279(a)). Once selected, 

click the Create button to produce a new zone panel (i.e. “Compartment_Zone_1”). 

Next, select the new zone panel by single-clicking on it so that the name of the zone 

panel appears in quotation marks. Leaving the Zone Editor dialogue box in place, return 

to the geometry and drag out an area covering (approximately) the south-eastern corner 

of the geometry (see in Figure 9-279(b)). Once selected, click the Add Nodes button to 

form the compartment (i.e. to associate the selected nodes within the zone 

Compartment_Zone_1). Having done this confirm that the selected nodes have been 

correctly assigned to the compartment zone (i.e. Compartment_Zone_1) by clicking 

either the SHOW or SHOW POLYS buttons. 
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(a) (b) 

Figure 9-279: (a) Selection of the compartment Zone Type; (b) Area of 

compartment zone. 

 

With zone related tasks Users are required to define not only a target nodal location, 

but also a corresponding Compartment zone. With these types of tasks, individuals will 

initially attempt to reach the defined nodal location corresponding to the task in the 

same manner as the solely nodal based tasks (i.e. Delay, Wait, Way Point etc.).  

However, in contrast to nodal based tasks, individuals are deemed to have reached their 

designated target if:  

1. They reach the defined nodal target associated with the task, OR 

2. They are within the tasks corresponding Compartment zone and they 

experience any congestion (i.e. they are forced to endure any waiting as a 

result of interaction with other individuals). 

 

In this manner, individuals may not actually reach the defined nodal target of the task, 

but instead may stop short within the corresponding Compartment zone if other 

individuals force them to wait. 

 

Where the target (i.e. nodal location) of a zone related task falls within a Compartment 

zone, that Compartment zone will be automatically associated with the task. To 

examine the effect of a Delay Zone task on the population and its corresponding 

differences to the previous Delay task, it is first necessary to change the type of task 

assigned to the population. 

 

Return to Population Mode and select the entire population. Open the Person 

Substitution dialogue box by selecting the Substitute option within the Edit menu, and 

then selecting the People option within the resulting sub-menu 

[Edit>Substitute>People]. Click on the Has Tasks check box on the Person 

Substitution dialogue box (this will initially be marked NULL). Once clicked, it will 

convert to Has Tasks. Click on it again so that it is deselected. A warning will be 

provided requiring that the User confirms that the itineraries are to be removed. This 

will clear the population of their itineraries. Click the OK button to confirm the removal. 

Having done this, close the Person Substitution by clicking the OK button. 
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Figure 9-280: Changing the default Delay to a Delay Zone task for an existing 

itinerary. 

 

Open the Itinerary Window dialogue box by selecting the Itinerary Window option 

within the Tools menu [Tools>Itinerary Window], and then double-click on the original 

itinerary panel (i.e. “Itin_1”) to open the Edit Itinerary dialogue box. In the pull down 

box under the Task heading for this itinerary, the existing task will be identified as 

Delay. Click on this pull down box and select Delay Zone instead (see Figure 9-280). 

Note that in order to clearly see the list of tasks available within the drop down list the 

user may need to resize the Edit Itinerary dialogue box. The Delay Zone functionality 

makes use of a compartment zone. As stated previously, the Delay Zone functionality 

allows the itinerary task to be commenced once an individual arrives within the 

Compartment. They will try and reach the target nodal destination but, if it is occupied 

or they encounter congestion, will get as close as possible within the associated 

Compartment zone. Once they are stationary, and within the compartment, their task 

can commence. 

 

The user is able to confirm the association between the task location and the 

compartment. This is useful when a node falls within two or more Compartment zones; 

i.e. when the nodal location could be associated with more than one Compartment zone. 

To do this, keep the Edit Itinerary window open and click on the node panel within the 

Edit Itinerary dialogue box (shown as FS 1661 in Figure 9-280). This will bring up the 

Zone Selection dialogue box displaying the list of available Compartment zones 

corresponding to the defined nodal location. In this example, there is only one 

Compartment zone (i.e. Compartment_Zone_1) and so the selection is a moot point.  

 

Ensure that the Min and Max time to be spent achieving the Delay Zone task are 10 and 

20 seconds respectively and then click the OK buttons on both the Edit Itinerary and 

Itinerary Selection dialogue boxes. The User now has to associate the new itinerary 

with the population. This can be achieved in the same way as before – go to Population 

Mode, select the population, select [Edit>Substitute>People] to display the Person 

Substitute dialogue box, enable the Has Tasks check box, and then click the O.I.L. 

button and Import the only currently defined itinerary from the Itinerary Selection 

dialogue box (i.e. “Itin_1”). Alternatively the User can merely open the file 

T14_4.EXO. 
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a) Delay b) Delay Zone 

Figure 9-281: Grouping differences between Delay and Delay zone functionality. 

 

Once this is complete move to Simulation Mode and re-run the simulation (ensuring 

once again that the Maintain Itinerary and a Specified Response Time of 0 seconds are 

defined within the Behaviour Control dialogue box). Two things will immediately be 

apparent:  

1. Once the target location is occupied people can fulfil their itinerary obligation when 

they fall within a range of their target (i.e., within the associated Compartment 

zone), rather than occupying it (see Figure 9-281(b));  

2. As a consequence, the simulation is completed in approximately two minutes. 

 

9.14.4 A Small Number of People Following an Itinerary with a Wait Task 

Within this section the functionality of the Wait task is examined. Instead of requiring 

the population to delay for a period of time, the Wait task instead requires the population 

to delay until a time specified by the User. Return to Population Mode and select the 

entire population. Open the Person Substitute dialogue box by selecting the Substitute 

option from the Edit menu, and then selecting the People option from the resulting sub-

menu [Edit>Substitute>People]. Click on the Has Tasks check box (this will initially 

be marked NULL). Once clicked, it will convert to Has Tasks. Click on it again so that 

it is disabled. A warning will be provided requiring that the User confirms that the 

itineraries are to be removed. This will clear the population of their current itineraries. 

Click the OK button to confirm their removal. 

 

Open the Itinerary Window dialogue box by selecting the Itinerary Window option 

within the Tools menu [Tools>Itinerary Window] and double-click on the original 

itinerary panel (i.e. “Itin_1”). In the pull down box under the Task heading for this 

existing itinerary, the task will be identified as Delay Zone. Click on this pull down box 

and select the Wait task. In addition, the User should also provide a value of 45 seconds 

for the Time attribute and a Range value of 10 metres (see Figure 9-282). This indicates 

that people will be required to get within 10 metres of the designated nodal target, and 

that they will wait until 45 seconds into the simulation before moving away from that 

the location. Once complete, click the OK buttons on both the Edit Itinerary and 

Itinerary Selection dialogue boxes.  
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Figure 9-282: Defining a Wait task. 

 

NOTE: 

The Wait task does not make use of a Compartment zone. It instead allows the User to 

specify a Range within which occupants will mill around prior to leaving. 

 

The User now has to associate the new itinerary with the population. This can be 

achieved in the same way as before – go to Population Mode, select the population, 

select Substitute>People from the Edit menu [Edit>Substitute>People], enable the Has 

Tasks check box, and then click on the O.I.L. button and Import the only current 

itinerary (i.e. “Itin_1”) from the Itinerary Selection dialogue box. Double-click on one 

of the people in the geometry to display their corresponding Person dialogue, and then 

view their assigned itinerary by clicking the O.I.L button to ensure that the itinerary has 

been correctly updated. Alternatively, the User can merely open the file T14_5.EXO. 

 

Return to Simulation mode, open the Behavioural Options dialogue box 

[Rulebase>Behaviour Options] and ensure that Maintain Itinerary and Specified 

Response flags are still enabled. The simulation can then be run. 

 

  

(a) (b) 

 
(c) 

Figure 9-283: (a) Occupants heading towards the task location; (b) occupants 

bunching at the location; (c) occupants moving after the specified 45 seconds. 

 

When the simulation is run the individuals should initially head towards the specified 

nodal target of the task in the normal manner (see Figure 9-283(a)). In this instance, 

individuals attempt to reach the defined nodal target (i.e. FS 1661), however if they 
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encounter congestion within the defined Range of the defined target then they are 

deemed as having reached their target. At this point they will stop until the simulation 

time exceeds that defined within the Time attribute of the Wait task (i.e. in this instance 

45 seconds, see Figure 9-283(b)). Figure 9-283(c) shows the population of individuals 

moving away from the nodal location towards their nearest available exit approximately 

48 seconds into the simulation having successfully completed their Wait task.  

 

9.14.5 Forming a Group 

In this example, the ability of individuals to form groups is examined. Return to 

Population Mode and delete the entire population by selecting the Delete option from 

the Edit menu, and then selecting the Everyone option from the resulting sub-menu 

[Edit>Delete>Everyone].  

 

Open the Itinerary Window dialogue box (by selecting the Itinerary Window option 

within the Tools menu [Tools>Itinerary Window] and then double-click on the original 

itinerary panel (i.e. “Itin_1”). In the pull down box under the Task heading for this 

existing itinerary, the task will be identified as Wait. Click on this pull down box and 

select the Form Group task. In addition, the User should also provide a value of 1 for 

the Group ID attribute and a Size value of 4 (see Figure 9-284). These attribute values 

indicate that a group of 4 people is required to be formed and that the four members of 

that group will be assigned as “Group 1” (i.e. that the Gene attributes of the group 

members will be assigned to the value 1). Once complete, click the OK buttons on both 

the Edit Itinerary and Itinerary Selection dialogue boxes to confirm the changes made.  

 

 
Figure 9-284: Defining a Form Group Task. 

 

The User now has to generate a new population to replace the one previously deleted. 

Click on the Generate Person button  on the tool bar, and generate four default 

people by clicking at the approximate locations shown in Figure 9-285. 

 

 
Figure 9-285: The initial locations of the four default people. 

 



Chapter 9 - Tutorial 14 

 

©2017 University of Greenwich 367 

The User now has to associate the new itinerary (containing the Form Group task) with 

the four newly generated individuals. This can be achieved in the same way as outlined 

previously. Move to Population Mode and select the population. Open the Person 

Substitute dialogue box by selecting the Substitute option from the Edit menu, and then 

selecting the People option form the resulting sub-menu [Edit> Substitute>People]. 

Enable the Has Tasks check box (this should initially be set as NULL), then click on 

the O.I.L. button and again Import the only current itinerary (i.e. “Itin_1”) from the 

Itinerary Selection dialogue box. Double-click on one of the people in the geometry to 

display their corresponding Person dialogue, and then view their assigned itinerary by 

clicking the O.I.L button to ensure that the itinerary has been correctly updated (see 

Figure 9-286). Alternatively, the User can merely open the file T14_6.EXO. 

 

 
Figure 9-286: The itinerary assigned to each of the four individuals. 

 

Return to Simulation Mode. Open the Behavioural Options dialogue box 

[Rulebase>Behaviour Options] and ensure that the Maintain Itinerary and Specified 

Response flags are still enabled. The simulation can then be run.  

 

When the simulation is run the individuals should again initially head towards the 

specified nodal target of the task in the normal manner. With Form Group tasks, 

individuals again attempt to reach the defined nodal target (i.e. FS 1661). However, if 

they encounter congestion within 2 metres of this target then the target is deemed as 

having been reached.  

 

Upon reaching their designated target, individuals will then wait until the number of 

people defined within the Size attribute of the Form Group task (i.e. in this case 4) 

arrive. It is important to note, that it is not merely sufficient for any four people to arrive 

at the given location. In each instance, only those with Form Group tasks with the same 

defined Group ID will be counted.  Once the pre-determined number of people 

matching the required criteria have arrived the group is then formed. The Gene attribute 

of each individual within the group is then updated to the corresponding Group ID value 

defined within the Form Group task (i.e. in this instance 1).  This can be observed by 

double clicking on a person within the simulation to display their corresponding Person 

dialogue box and then clicking the Attrib button (see Figure 9-287). The updating of 

the Gene attribute with the Group ID value in this manner will effectively overwrite the 

existing Gene value assigned to each member of the group. By default, the Gene value 

assigned to default people is assumed to be 0 (i.e. undefined), meaning that they are 

initially defined as not being members of a group. At this point, the Form Group task 
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is deemed complete, and hence individuals will move off. Since in this instance no 

further tasks are defined, individuals will all head off as a group towards their nearest 

exit (see Figure 9-287). Since these four individuals are part of a group they will attempt 

to stay together en route to the exit. Consequently, individuals will (if necessary) check 

their speed to ensure that they do not get too far ahead of other members of the group. 

 

 
Figure 9-287: The formed group heading towards their nearest exit (Gene 

attribute set to 1). 

 

9.14.6 Forming a Group With a Leader 

In this example, the assigning of a leader to a given group and the leaders affect on the 

group will be examined. The leader of a given group has the ability to control both the 

locations visited by the group and the actions performed by its members. To 

demonstrate this functionality, we will assign one of the existing four individuals as the 

leader of the group. Within this example, we will assume that that the individual 

initially located in the top left hand corner of the geometry will be the leader of the 

group (see Figure 9-285). However, it is important to note that similar results should be 

observed irrespective of which one of the four people were assigned leadership 

responsibility. 

 

Return to Population Mode and double click on the person in the top left hand corner 

of the geometry to display their corresponding Person dialogue box. Change the colour 

of this person to make identification of the leader easier during the simulation. To do 

this, click on the Colour drop down list and select the Red option. It is important to 

note, that changing the colour of the individual in this manner in no way affects their 

actions/capabilities. As stated previously, this is merely to aid in their identification 

during the simulation.  

 

Having changed the colour of the person, click on the Attrib button to display their 

corresponding attributes. Within this dialogue box, click on the Leader Flag drop down 

list and select the Yes option (see Figure 9-288), and then click the OK button to confirm 

the change. This individual has now been assigned as a leader, and as such will now 

have the ability to control the actions of any groups (and hence the individuals within 

those groups) of which he himself is a member. 
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Figure 9-288: Defining an individual as a group leader. 

 

To demonstrate the leader’s ability to control the actions of other members of the group, 

we will assign an additional task within his itinerary. This task will be added after the 

group has been formed (i.e. after the existing Form Group task), and hence will 

correspond to a task to be performed when the individual is actually leading the group. 

Within the Person dialogue box of the newly assigned leader click the O.I.L button to 

display his corresponding itinerary. Initially the itinerary of this individual should 

consist of only one task, namely the Form Group task assigned to all four people within 

the previous section (see Section 9.14.5). Click the Auto Insert check box in the top 

right hand corner of the dialogue box, and then click within the geometry window in 

the approximate location indicated by the green square shown in Figure 9-289. 

 

 
Figure 9-289: The approximate location of the Wait task (shown in green) in 

addition to the four people within the geometry (leader shown in red). 

 

This should result in a new task being added to the leader’s itinerary after the existing 

Form Group task. By default this new task will be a Delay task. Click on the Task type 

drop down list and select the Wait option to convert the new task to a Wait task. In 

addition, set the corresponding Range value to 3 metres and the Time value to 90 

seconds (see Figure 9-290).  As explained previously within Section 9.14.4, this task 

effectively means that the leader of the group is required to head towards the specified 

nodal location of this task (i.e. somewhere within the green square shown in Figure 

9-289) and will stop either upon reaching it, or within 3 metres of it should congestion 

be experienced. Upon reaching this location this individual will then wait until the 
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simulation time exceeds 90 seconds before moving off. Alternatively, the User can 

merely open the file T14_7.EXO. 

 

 
Figure 9-290: Assigning an additional Wait task to the leader 

 

Return to Simulation Mode. Open the Behavioural Options dialogue box 

[Rulebase>Behaviour Options] and once again ensure that both the Maintain Itinerary 

and Specified Response flags are still enabled. The simulation can then be run.  

 

When the simulation is run the individuals should again initially head towards the 

specified nodal target of the Form Group task (i.e. FS 1661) in the same manner 

observed previously within Section 9.14.5. Once they reach this location (or get to 

within 2 metres of it and experience congestion) they again stop and wait for the 

remaining members of the group to arrive. As soon as the specified number of people 

with a Form Group task with the same defined Group ID value (i.e. 1) arrive, the group 

is again formed and the Gene attributes of each of the group members is again updated 

to the corresponding Group ID value of the Form Group task (see Figure 9-291(a)).  

 

  
(a) (b) 

 
(c) 

Figure 9-291: (a) The group initially being formed, (b) the group performing the 

Wait task, and (c) the group heading off towards their nearest exit. 
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As this point, the Form Group task is deemed complete and the newly formed group is 

free to head off. However, in contrast to the example shown previously in Section 

9.14.5, the group do not head off towards their nearest exit, but instead head off towards 

the location of the Wait task (i.e. FS 210). It is important to note that all members of 

the group head off towards the location of the Wait task, even though the Wait task 

itself was only ever assigned to the leader. This is because it is assumed that the leader 

of the group has effectively ordered the other members of the group to follow him to 

the Wait task he was assigned (i.e. shared the task assigned to him with the other 

members of the group). This is achieved by automatically adding the Wait task within 

the leader’s itinerary to the itineraries of each of the other members of the group. It is 

important to note that the addition of the Wait task to the other members of the group 

is done when the group is formed (i.e. during the simulation). It is NOT simply assigned 

to the other group members at the start of the simulation. This can be observed by 

displaying the itinerary of another member of the group (i.e. not the leader) both at the 

start of the simulation (see Figure 9-292(a)), and after the group has been formed (see 

Figure 9-292(b)).  

 

 
(a) 

 
(b) 

Figure 9-292: (a) The itinerary of a member of the group (i.e. non leader) at the 

start of the simulation, and (b) the itinerary of the same group member after the 

group has been formed. 

 

Once again, since these four individuals are part of a group they will attempt to stay 

together en route to the location of the Wait task. Consequently, individuals will (if 

necessary) check their speed to ensure that they do not get too far ahead of other 

members of the group. Upon reaching the nodal location of the Wait task (i.e. FS 210), 

or getting to within the defined Range of it (i.e. 3 metres) and experiencing congestion, 

each individual will stop (see Figure 9-291(b)). The group will wait at this location until 

the simulation time exceeds the Time specified within the Wait task initially assigned 

to the leader (i.e. 90 seconds). Once this condition is met, the Wait task is deemed 
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complete, and hence the group will move off. Since in this instance no further tasks are 

defined, individuals will all head off as a group towards their nearest exit (see Figure 

9-291(c)). Once again, since these four individuals are still part of a group they will 

attempt to stay together en route to the exit.  

 

9.14.7 Leaving a Group 

In this example, the action of a leader leaving the group to perform additional tasks will 

be examined. To demonstrate this functionality we will extend the example previously 

outlined within Section 9.14.6. 

 

Return to Population Mode and double click on the designated group leader within the 

top left hand corner of the geometry to display their corresponding Person dialogue 

box. Within the Person dialogue box click the O.I.L button to again display this 

individuals corresponding itinerary. Initially the itinerary of this individual should 

consist of two tasks, namely the Form Group task initially assigned to all four people 

within Section 9.14.5, and the Wait task assigned only to the leader within Section 

9.14.6 (see Figure 9-293). Click the Auto Insert check box in the top right hand corner 

of the dialogue box, and then click anywhere within the geometry window. 

 

 
Figure 9-293: The existing itinerary of the group leader. 

 

Clicking within the geometry window should again result in a new Delay task being 

added to the leader’s itinerary after the two existing itinerary tasks (i.e. after the Wait 

task). The reason for clicking anywhere within the geometry window rather than at a 

specific location is because we initially want to create a new Leave Group task. Leave 

Group tasks, unlike the other tasks outlined previously, do not relate to a specific 

location. Consequently, the location at which the User clicks, and hence the 

corresponding nodal location of the task, is not used when performing the task itself. 

Hence, it is irrelevant which location is clicked in order to generate the task. To change 

the type of the newly created task click on its corresponding Task type drop down list 

and select the Leave Group option. The new Leave Group task is now complete since 

this type of task requires no additional parameters to be defined. 

 

Having successfully added the Leave Group task to the leader’s itinerary, we will now 

assign the leader an additional task. Click again within the geometry window, this time 

in the approximate location indicated by the green square shown in Figure 9-294. This 

will again result in a new Delay task being added to the leader’s itinerary after the 

existing itinerary tasks (this time after the newly added Leave Group task).  In this 

instance, we want the leader of the group to go to a specific location (indicated by the 

green square) and stay there for a fixed period of time. This can be achieved by using a 
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conventional Delay task, as outlined previously within Section 9.14.1. As a result, leave 

the type of the newly created task set at its default Delay setting and set the Min and 

Max values to 30 and 60 seconds respectively (thereby forcing the individual to wait at 

the defined location for a time randomly assigned between 30 and 60 seconds in 

accordance with a random uniform distribution).  
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Figure 9-294: The approximate location of the Delay task (shown in green). 

 

The itinerary of the group leader should now resemble that shown below in Figure 

9-295. 

 

 
Figure 9-295: The group leaders itinerary after the addition of Leave Group and 

Delay tasks. 

 

In addition, we will also assume that rather than merely going to the specific nodal 

location of the Delay task, that the individual will instead only be required to get within 

a defined distance of it should congestion be experienced, and that they will also mill 

around within this defined distance while performing their Delay task. To achieve this, 

double click on the Delay tasks corresponding Node button (i.e. FS 451 within Figure 

9-295) to display the Milling Range dialogue box (see Figure 9-296). Define a value of 

2 metres within the Milling Range dialogue box and then click OK to confirm the 

change. Once complete, click the OK buttons on both the Itinerary and Person dialogue 

boxes. Alternatively, the User can merely open the file T14_8.EXO. 

 

 
Figure 9-296: The milling range dialogue box associated with a Delay task. 
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Return to Simulation Mode. Open the Behavioural Options dialogue box 

[Rulebase>Behaviour Options] and once again ensure that both the Maintain Itinerary 

and Specified Response flags are still enabled. The simulation can then be run.  

 

When the simulation is run the individuals should all initially head towards the target 

of the Form Group task (i.e. FS 1661), before again forming a group and collectively 

moving off towards the location of the Wait task (i.e. FS 210) in the same manner as 

outlined previously within Section 9.14.6. In addition, the group will again wait at the 

location of the Wait task until the simulation time exceeds the Wait tasks corresponding 

Time value (i.e. 90 seconds).  

 

However, upon completion of the Wait task the group do not all collectively head off 

towards their nearest exit in contrast to the example shown previously in Section 9.14.6. 

Instead, the existing leader and the three other members of the group effectively part 

company. Upon completion of the Wait task the leader leaves the group (by virtue of 

the Leave Group task assigned to him), and instead heads off to perform his additional 

Delay task. In contrast, the three remaining members of the group again head off 

towards their nearest exit (see Figure 9-297(a)). It is important to note that these three 

individuals are still part of a group at this point (i.e. the group has not been completely 

disbanded merely because of the departure of its leader). Consequently, they will still 

attempt to stay together en route to the exit, and will (if necessary) check their speed to 

ensure that they do not get too far ahead of other members of the group. The existing 

group leader will perform his allocated Delay task (i.e. wait at the specified location for 

a time randomly determined between the Min and Max values of the Delay task) before 

also heading off towards the nearest available exit (see Figure 9-297(b)). 

 

  
(a) (b) 

Figure 9-297: (a) the group and their previous leader heading off to different 

locations, (b) the previous leader heading towards the exit upon completion of his 

Delay task. 

 

It is important to note that while the Wait task assigned to the leader was shared with 

the other members of the group (i.e. it was added to their itineraries thereby forcing 

them to carry out the task too), the Leave Group task was not. Leave Group tasks are 

not shared with group members and are assumed to relate only to the individual to 

whom they are initially assigned. Within this example, since the leader leaves the group 

after completion of the Wait task, all subsequent tasks are also not shared with the 

group. Consequently, the Delay task also assigned to the leader is not shared with the 

members of the group, since by the time this task is carried out the leader has left the 

group and hence has no further control over the actions of its members. Displaying the 

itinerary of a member of the group other than the leader after the group has been initially 
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formed will clearly show that that neither the Leave Group or Delay tasks have been 

shared with the existing group members. Consequently, the itinerary of all group 

members (excluding the leader) should resemble that shown previously in Figure 

9-292(b). 

 

9.14.8 All Leaving a Group 

In this example, the action of a leader effectively disbanding the group will be 

examined. To demonstrate this functionality we will extend the example previously 

outlined within Section 9.14.7. 

 

Return to Population Mode and double click on the designated group leader within the 

top left hand corner of the geometry to display their corresponding Person dialogue 

box. Within the Person dialogue box click the O.I.L button to again display this 

individuals corresponding itinerary. Initially the itinerary of this individual should 

resemble that shown previously in Figure 9-295. As such, it should consist of four tasks, 

namely Form Group, Wait, Leave Group and Delay tasks. 

 

Within the previous example (see Section 9.14.7), the leader effectively left the group 

by virtue of the Leave Group assigned to him. However, since Leave Group tasks are 

not shared with other group members, this resulted in only the leader leaving the group. 

Consequently, the three other group members remained within the group and stayed 

together en route to the nearest exit. Within this example, we will examine the effect of 

the leader instead disbanding the group entirely (i.e. as opposed to merely leaving it 

himself). To achieve this open the leaders Itinerary dialogue box and change the type 

of the existing Leave Group task by clicking on its corresponding Task type drop down 

list and selecting the All Leave Group option. The new All Leave Group task is now 

complete since this type of task requires no additional parameters to be defined. The 

itinerary of the leader should now resemble that shown in Figure 9-298. Alternatively, 

the User can merely open the file T14_9.EXO. 

 

 
Figure 9-298: Changing the Leave Group task within the leader’s itinerary to an 

All Leave Group task. 
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Return to Simulation Mode. Open the Behavioural Options dialogue box 

[Rulebase>Behaviour Options] and once again ensure that both the Maintain Itinerary 

and Specified Response flags are still enabled. The simulation can then be run.  

 

When the simulation is run, it should initially be very difficult to see any discernable 

difference in the behaviours of the people with those shown previously in Section 

9.14.7.  The four individuals again move to the designated location and form a group 

before moving off together to the corresponding Wait location. The leader then leaves 

the group while the remaining three individuals head off towards the nearest exit. 

However, in contrast to the previous example, upon completion of the Wait task it is 

not only the leader that leaves the group but everybody (i.e. all four people). This can 

be seen by examining the itinerary of an individual (i.e. not the leader) after the group 

has been formed (see Figure 9-299). In this case, the All Leave Group task initially 

assigned only to the leader (like the Wait task) is shared with all other members of the 

group. Consequently, upon completion of the Wait task the group is completely 

disbanded (i.e. all members leave the group). Hence, when the three individuals head 

off towards their nearest exit they are (in contrast to the example shown previously in 

Section 9.14.7) not actually a group. As a result, they are not compelled to stay together 

en route to the exit, and are not required to check their speed to ensure that they do not 

get too far away from one another. It is important to note that the reason that this may 

not be immediately apparent within the simulation is because in this example all group 

members were assumed to be default people. Consequently, all group members were 

assumed to have a Fast Walk travel speed of 1.5m/s, and hence there is little opportunity 

for people to separate as a result of differences in their individual travel speeds. 

 

 
Figure 9-299: The All Leave Group task shared with a group member (i.e. non 

leader). 

 

To better demonstrate the differences between the Leave Group and All Leave Group 

tasks we will give one of the non leader members of the group a reduced travel speed. 

Return to Population Mode and double click on the individual within the bottom left 

hand corner of the geometry to display their corresponding Person dialogue box. 

Change the colour of this person to make identification of them easier during the 

simulation. To do this, click on the Colour drop down list and select the Yellow option. 

Once again, it is important to note, that changing the colour of the individual in this 

manner in no way affects their actions/capabilities. As stated previously, this is merely 

to aid in their identification during the simulation.  

 

Having changed the colour of the person, click on the Attrib button to display their 

corresponding attributes. Within this dialogue box, set their Fast travel speed to 0.5 m/s 
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(i.e. in contrast to the default setting of 1.5m/s). Having done this, click the OK buttons 

within both the Itinerary and Person dialogue boxes. Alternatively, the User can merely 

open the file T14_10.EXO. 

 

Return to Simulation Mode and then re-run the simulation and observe the results. Then 

load the Leave Group example shown previously in Section 9.14.7 (i.e. T14_8.EXO) 

and make the same changes (i.e. change the colour and reduce the Fast Walk travel 

speed of the same individual). Then re-run this example and compare the results 

between the Leave Group and All Leave Group scenarios. 

 

When the two scenarios containing a person of reduced travel speed are run the 

differences between them become immediately apparent. As stated previously, within 

the Leave Group example only the leader leaves the group. As a result, the remaining 

three people still constitute a group and hence head towards their nearest exit together. 

Since one of the members of the group has a reduced travel speed, this means that the 

other two members of the group are forced to check their travel speed to ensure that the 

group stays together (see Figure 9-300(a)). 

 

In contrast, within the All Leave Group example all individuals are assumed to leave 

the group upon completion of the Wait task. As a result, the three individuals who head 

directly towards the exit are no longer considered part of a group, and hence there is no 

affiliation between them. Consequently, the faster individuals are no longer required to 

check their speed in order to stay with the slower individual (see Figure 9-300(b)). 

 

  
(a) (b) 

Figure 9-300: (a) the three individuals within the Leave Group example (i.e. still 

a group), (b) the three individuals within the All Leave Group example (i.e. are 

not a group and hence are not compelled to stay together) 

 

9.14.9 Collecting and Dropping Off a Person  

In this example, the collection of individuals and their escort to a designated location 

via the Collect Person and Drop Off Person tasks will be examined. To demonstrate 

this functionality we will use the geometry T14_11.EXO generated previously (see 

Figure 9-301). 
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Figure 9-301: The geometry showing the location of the staff member, the four 

individuals to be collected and the location to which they are to be escorted (i.e. 

the drop off point). 

 

Within this example a staff member has been initially located within the bottom left 

hand corner of the structure (see Figure 9-301). The staff member has been coloured 

red to enable them to be easily identified throughout the simulation, and has also been 

assigned a response time of 0 seconds (i.e. instant response). In contrast, four occupants 

have been placed within the four rooms located at the top of the structure (i.e. one 

occupant within each room). These occupants have been assigned response times of 

300 seconds (i.e. they will not respond until 5 minutes into the simulation).  All 

individuals (i.e. the four occupants and the staff member) have also been assigned a 

Gene value of 2. 

 

Return to Population Mode and double click on the staff member within the bottom left 

hand corner of the geometry to display their corresponding Person dialogue box. Within 

the Person dialogue box click the Attrib button to again display this individuals 

corresponding attributes. Within this dialogue box assign the staff member as being a 

leader by setting their corresponding Leader Flag to Yes (see Figure 9-302). Once the 

Leader Flag has been set the change should be confirmed by clicking the OK button. 
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Figure 9-302: Assigning the staff member as being a Leader. 

 

Having assigned the staff member as being a leader the User is then required to define 

their corresponding itinerary. To achieve this first select the Has Tasks check box 

within the staff members Person dialogue box and then click the O.I.L. button to display 

the staff member’s corresponding Itinerary dialogue box.  By default no tasks have 

been defined for the staff member, hence the Itinerary dialogue box should initially be 

empty.  First select the node (and only the node) occupied by the individual within the 

top left most room, and then click the Append button. Upon clicking this task a default 

Delay task will automatically be added to the Itinerary dialogue box with the selected 

nodes corresponding location (i.e. FS103, see Figure 9-303). 

 

 
Figure 9-303: A default delay task added at the location occupied by the first 

individual (i.e. FS103) 

 

Next, click on the Delay task type for the newly created task to display the list of 

available task types and then select the Collect Person option. Upon changing the type 

of the given task the attributes that the User is required to define will automatically 

change.  Hence the Min and Max delay times that the User was required to define for 

the Delay task will be replaced by both Gene and Size attributes.  Within this task define 

both the Gene and Size values as being 2. These values indicate that the staff member 

is required to collect a person with a Gene value of 2 at the specified nodal location (i.e. 

FS103), and that the Collect Person task is deemed to be complete when two people 

are present (i.e. when the person to be collected and one other person are present).  The 

Itinerary dialogue box should now resemble that shown in Figure 9-304. 

 

 
Figure 9-304: The Itinerary dialogue box of the staff member showing the 

defined Collect Person task. 
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Having fully defined the Collect Person task we will now set about defining the location 

to which the collected individual will be escorted. Within EXODUS this is achieved 

via the Drop Off Person task.  To define the drop off point first select a single node 

within its approximate location as indicated within Figure 9-301.  Once selected then 

click the Append button within the staff members corresponding Itinerary dialogue box.  

Clicking the Append button will once again add a default Delay task corresponding to 

the selected nodal location.  As with the previous task, click the newly created Delay 

tasks type to display the list of available task types, and then select the Drop Off Person 

option.  Once again, upon changing the type of the given task the attributes that the 

User is required to define will automatically change.  Since the Drop Off Person task 

does not require any additional attributes other than the nodal location to be defined the 

Min and Max delay times that the User was required to define for the Delay task will 

instead be replaced by Not Used and the corresponding cells greyed out and disabled.  

The Itinerary dialogue box should now resemble that shown in Figure 9-305. 

 

 
Figure 9-305: The Itinerary dialogue box of the staff member showing both the 

defined Collect Person and Drop Off Person tasks. 

 

We have now defined the collection and drop off of a single individual (i.e. the agent 

initially located in the top left most room).  Continue by defining the collection and 

drop off of the remaining three occupants in the same manner outlined previously.  In 

each case the Collect Person task should be assigned Gene and Size values of 2.  Once 

complete the Itinerary of the staff member should comprise 8 tasks (i.e. four pairs of 

Collect Person and Drop Off Person tasks).  The Itinerary dialogue box should now 

resemble that shown in Figure 9-306. 
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Figure 9-306: The Itinerary dialogue box of the staff member showing the 

Collect Person and Drop Off Person tasks for each of the four occupants within 

the top rooms. 

 

To further ensure that the Collect Person and Drop Off Person tasks have correctly 

defined the User can click on the Label button within the staff members Itinerary 

dialogue box (see Figure 9-307). 

 

 
Figure 9-307: The defined Collect Person and Drop Off Person tasks as 

displayed via the Label function. 

 

Having done this, click the OK buttons within both the Itinerary and Person dialogue 

boxes. Alternatively, the User can merely open the file T14_12.EXO. 

 

Return to Simulation Mode and then run the simulation and observe the results.  When 

the simulation is run the staff member will initially head towards the individual located 

in the top left most room. Upon reaching this individual (i.e. getting to within 1m of 

them) the individual is deemed to have been collected by the staff member. 

Consequently the individual will both respond and have their itinerary updated 

accordingly.  When an individual is collected all of the tasks within the Leader’s 

itinerary from the current Collect Person task up to and including the next Drop Off 

Person task will automatically be added to their itinerary.  However the Drop Off 

Person task within the Leader’s itinerary will instead be converted to a conventional 

Delay task within the collected individuals itinerary (i.e. by default the collected 

individual will merely be required to go to the location defined by the Drop Off Person 

task and encounter a delay of 0 seconds).  Since in this case there were no tasks defined 

for the leader between collecting the individual and dropping them off, this means that 

in each case the collected individuals itineraries will be updated with a single Delay 

task corresponding to the defined drop off location.  This can be observed by clicking 

on a collected individual en route to their designated drop off point and displaying their 

corresponding Itinerary dialogue box (see Figure 9-308). 
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Figure 9-308: The Itinerary dialogue box of a collected individual showing their 

updated Itinerary. 

 

Having collected the individual at the defined location the leader and the collected 

individual will then head off towards the next task within the leaders itinerary (i.e. the 

drop off location).  During the journey to this location both the leader and the collected 

individual will move as a group.  Consequently each member of the group will attempt 

to stay together and will adapt their speed accordingly. Having reached the designated 

drop off point (as defined by the Drop Off Person task) the collected individual will 

then be left by the leader. Hence, the collected individual will either undertake any 

remaining tasks within their itinerary, or (as in this case) simply evacuate via the 

Potential Map to the nearest available exit.  Similarly the leader will also then set about 

undertaking the next task within their itinerary, namely the collection and drop off of 

the next occupant.  This process will continue until all four agents have been 

successfully collected and dropped off (i.e. when all the tasks within the leaders 

itinerary have been successfully completed), where upon the leader will simply 

evacuate via the Potential Map to the nearest available exit. 

 

9.14.10 A Coordinated Delay  

In this example, two individuals will be assigned a Coordinated Delay task to simulate 

them undertaking an action which requires both of them present and takes a defined 

period of time to complete.  This can be used to represent the time taken by staff to 

undertake collaborative actions such as preparing a vulnerable/mobility impaired 

individual for evacuation in either emergency or non-emergency conditions. 
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To demonstrate this, first create a conventional rectangular geometry (the exact 

dimensions are not important) and place a single 0.5m wide exit (i.e. connected via a 

single arc) in the extreme top left hand corner.  Next add two individuals at the 

approximate locations shown in Figure 9-309.  Person 1 should initially be located in 

the extreme bottom left hand corner of the geometry and have a response time of 30 

seconds, while Person 2 should be located further along the bottom edge of the structure 

and have a response time of 0 seconds (i.e. instant response). 

 

 
Figure 9-309: A Simple rectangular geometry with two individuals 

 

Once the population has been created the next step is to produce a simple itinerary 

comprising a Coordinated Delay task. To do this, open the Itinerary Window by 

selecting the Itinerary Window from the Tools menu in Population Mode 

[Tools>Itinerary Window].  If any existing itineraries exist within the Itinerary window 

first delete them by simply clicking the Clear button.  Within the Itinerary Window 

click the Create button to produce a new itinerary panel (i.e. “Itin_1”). Double-click on 

this panel to gain access to the associated Edit Itinerary dialogue box. Check the Auto 

Insert box at the top of the dialogue box, thereby allowing Users to manually select the 

nodal location associated with the task. Once the Auto Insert box is checked, click the 

node in the extreme top right hand corner of the geometry. 

 

Upon clicking this task a default Delay task will automatically be added to the Itinerary 

dialogue box with the selected nodes corresponding location.  Next, click on the Delay 

task type for the newly created task to display the list of available task types and then 

select the Coordinated Delay option.  Next, define the time taken by both agents to 

jointly complete the task by setting both the Min and Max delays to 10 seconds.  Finally 

double click on the tasks corresponding Node button.  This will display a dialogue box 

enabling the User to define Group Size (i.e. the number of agents jointly required to 

undertake the task, see Figure 9-310).  Within this dialogue box enter a Group Size of 

2 and then click the OK button to confirm the value. 
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Figure 9-310: Defining a Coordinated Delay task. 

 

You now have to associate this itinerary (i.e. “Itin_1”) with the two agents. Click on 

the Person Select icon  on the menu-bar, and then select the two individuals by 

dragging out a selection box around them. Once the box has been dragged out and 

surrounds both agents, display the Person Substitution dialogue box by selecting the 

Substitute option within the Edit menu in Population Mode, and then selecting People 

from the resulting sub-menu [Edit>Substitute>People]. Within the Person Substitution 

dialogue box first check the Has Tasks check box (this will initially be marked NULL). 

This enables the selected population to be assigned itineraries. Having selected the Has 

Tasks check box, click the O.I.L. button to display the Edit Itinerary dialogue box. 

Within the Edit Itinerary dialogue box click the Import button. This allows existing 

itineraries to be imported into and hence assigned to the target population. The previous 

itinerary that has just been defined (i.e. “Itin_1”) will appear as a panel in the 

subsequent Itinerary Selection dialogue box. Single-click on this panel to select it 

within the list (quotation marks will appear around the panel name) and then click the 

OK button. 

 

 
Figure 9-311: Substituting the defined Itinerary to the two agents. 

 

The task associated with the itinerary will now appear in the Edit Itinerary dialogue 

box, indicating that it has been successfully imported (see Figure 9-311). Click the OK 

button on the Edit Itinerary dialogue box and then the OK button on the Person 

Substitution dialogue box. Click on both individuals to ensure that they have been 

assigned the previously created itinerary. 

 

Return to Simulation Mode and then run the simulation and observe the results.  As 

soon as the simulation starts Person 2 will immediately head off towards the defined 

location of Coordinated Delay task by virtue of his instant response time.  The 

immediate response on Person 2 means that this individual reaches the location of the 

Coordinated Delay task after only approximately 10 seconds (i.e. long before Person 1 

responds at 30 seconds).  Upon reaching the target location Person 2 will wait for the 

remaining member of the group to arrive.  When Person 1 does finally arrive the defined 

delay (simulating the time by both agents to complete a joint task) will commence. At 

this point both agents will experience the same delay (randomly calculated between the 

Min and Max delay times, i.e. 10 seconds) before deeming the task complete and hence 

simultaneously heading off to their complete the next task within their respective 
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itineraries (or as in this case simply evacuating via the Potential Map to the nearest 

available exit). 

 

It is important to note that the delay imposed upon the agents does not commence until 

the required number of group members are present. Hence, even though Person 2 

reached the location a long time before Person 1 he did not commence the defined delay 

until Person 1 had arrived.  This concept is very different to the imposition of delays 

on individuals via the Delay task, where each agent experiences their delay irrespective 

of the presence/absence of others. 
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9.15 Tutorial 15: Trace Control Function and Advanced Data Collection 

 

9.15.1 Tutorial 15(a): The Trace Control Function 

This first part of this tutorial is intended to demonstrate the use of the Trace Control 

facility and its ability to output specific attributes for selected individuals throughout 

the simulation. This provides the ability to observe the attributes for each of the selected 

individuals as they evolve during their evacuation (as opposed to merely viewing their 

values at the end of the simulation), thereby giving the user a greater understanding of 

the conditions each evacuee encountered. To demonstrate the Trace Control facility a 

number of manually defined fire hazards will be applied to specific areas within 

geometries in order to view their effect upon the enclosed population. The use of 

manually defined fire hazards has been outlined previously in tutorial 6 (and described 

in the User Guide, Chapter 5). Users who have not worked their way through tutorial 6 

are therefore strongly encouraged to do so prior to undertaking this tutorial. 

 

9.15.1.1 Outputting Attribute Data At Fixed Intervals For A Single Person 

We will first attempt to demonstrate the use of the Trace Control facility by utilising a 

geometry defined previously within example 4 of Tutorial 6. Rather than generate this 

entire geometry and its associated fire hazards from scratch, users should simply load 

the file entitled ‘T6_4.exo’. This simple square geometry measures 10m x 10m (i.e. 20 

nodes by 20 nodes) and includes a single External Exit placed in the bottom right hand 

corner. In addition, the geometry also includes five manually defined fire hazards, each 

comprising definitions for Temperature (oC), HCN (ppm), CO (ppm), CO2 (%) and O2 

(%). The five hazards are then applied in a time dependant manner to a single zone 

encompassing the entire geometry. The geometry also comprises a single default 

person, placed in the corner furthest from the available External Exit (i.e. in the top left 

hand corner of the geometry). This individual also has a modified age (70 yrs), fast 

walk and walk speeds (0.6m/s and 0.4m/s respectively) and response time (180 

seconds). 

 

To demonstrate the use of Trace Control facility, let us consider the exposure 

experiences of an individual within a typical simulation. Enable the Hazard Model 

within the Hazard Control dialogue box [Rulebase>Hazard Options] and then ensure 

that the Temperature Response Override is set at 100oC. Once complete, run the 

simulation and then open the individuals Gases dialogue box by clicking the GASES 

button within their corresponding Person dialogue box. The Gases dialogue box should 

resemble that shown in Figure 9-312. 

  



Chapter 9 - Tutorial 15 

 

©2017 University of Greenwich 388 

 

 
Figure 9-312: The GASES dialogue box of the individual after the simulation has 

been completed. 

 

In Figure 9-312 it can be seen that the individual’s exposure to Temperature (i.e. 

convected heat) during the simulation was reflected in both FIH and FIHc values of 

0.113. Exposure to HCN throughout the simulation similarly resulted in the individual 

experiencing a FIHCN value of 0.013, while exposure to CO and CO2 resulted in FICO 

and FICO2 values of 0.011 and 0.00717 respectively. In each case, the overall exposure 

of the individual to the various hazards was similarly reflected within their 

corresponding attributes. However, these attribute values merely represent the sum total 

of the individuals experiences throughout the entire simulation, and as such, give no 

real insight into the conditions that they were exposed to at given times during their 

egress. For instance, knowing that an individual endured an FIHc value of 0.113 

obviously tells us that they were exposed to excess temperatures at some point during 

their egress, but it does not reveal how (i.e. when and where) those excess temperatures 

were experienced. For example, was the individual exposed to a constant temperature 

throughout the entire simulation? Did the temperature he was exposed to linearly 

increase with time? Was the individual only exposed to very extreme temperatures for 

a brief period of time and ambient temperatures for the rest of the simulation? If so, at 

what time were those extreme temperatures experienced? Simply by viewing a single 

attribute value, such as those displayed for each individual within their corresponding 

Gases dialogue box (and also included within simulation files .SIM), gives no real 

insight into the often evolving conditions individuals were exposed to. 

 

The Trace Control facility was developed to address this issue. Individuals of interest 

must first be selected, in order to output the exposure their experiences of during a given 

simulation. To demonstrate how individuals are selected to be traced, we will first set 

about selecting the person initially located within the top left hand corner of the 

geometry (i.e. the only person currently within the structure).  

 

NOTE:  

The pop-up menus will be used in this example to demonstrate this functionality. The 

same outcomes can also be achieved using the traditional menus at the top of the screen 

in Simulation mode [Rulebase>Trace Control]. This is described in the User Guide, 

Chapter 6. These methods are examined in later examples. 

 

Right-click on the individual and then select the Person option from within their 

corresponding pop-up menu. Once selected, a second pop-up menu will then be 

displayed showing the Trace option (see Figure 9-313(a)). The Trace option is used 

both to display and toggle the trace status of the currently selected individual. Since in 
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this case the currently selected individual has not been previously added to the Trace 

Control facility the corresponding Trace option will therefore be unchecked. To add 

the person to the Trace Control facility, simply select the Trace option within the 

Person sub-menu. Upon selection, the individuals change in Trace status will be 

registered and the pop-up menu will instantly disappear. To verify that the person has 

been successfully added to the Trace Control facility, right click on the person, and 

once again select the Person option within their corresponding pop-up menu. If the 

individual has been successfully added to the Trace Control facility, this will be 

reflected in the Trace option being checked (see Figure 9-313(b)). 

 

 

 

(a) (b) 

Figure 9-313: Controlling the Trace status of individuals via their corresponding 

pop-up menu. 

 

Having successfully added the individual to the Trace Control facility the user must set 

about defining the format of the data to be output for each selected individual 

throughout the simulation (i.e. specifying the attributes that are required, when the data 

is output, where it is output to etc.). Within EXODUS, defining the format of this data 

is achieved via the Trace Output Control dialogue box which can be accessed by 

selecting the Trace Control option within the Rulebase menu [Rulebase>Trace 

Control] (see Figure 9-314). The names of the individuals added to the Tracer function 

are displayed within the Trace Control List shown in the top right hand corner of the 

dialogue box. Since in this instance only one person was previously added to the Tracer 

function, this list should therefore comprise a single name (i.e. Person_1 see Figure 

9-314). The addition of a person to the Trace Control facility also results in it becoming 

automatically enabled, which is apparent by the selection of the Enable option within 

the Trace Output Control dialogue box.  

 

 
Figure 9-314: The Trace Output Control dialogue box. 
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NOTE:  

The user is able to add and remove people from the Trace functionality through the use 

of the buttons Add Sel. and Remove within the Trace Output Control dialogue box. 

 

Modify the settings within the Trace Output Control dialogue box so that they match 

those shown within Figure 9-315(a). Once complete, click the Current Toxicity button 

and further modify the settings of the hazard attributes to match those shown within 

Figure 9-315(b). Ensure that the Movement option is deselected (this is addressed in the 

next example) and that the Interval remains set at the default 10 seconds. In this manner, 

data will be output for the selected individuals at regular 10 second intervals (i.e. at 0, 

10, 20, 30 seconds etc.), as opposed to being output merely every time they move. In 

addition, the user should also click the Filename button and specify where they want 

the trace data file to be saved (i.e. the drive and directory).  

 

  

(a) (b) 

Figure 9-315: The settings used within the Trace Output Control dialogue box. 

 

NOTE: 

Users wishing to plot the evolving experiences of selected individuals against time must 

ensure that time is output within the corresponding trace data file, and hence that the 

Sim. Time attribute is selected within the Trace Output Control dialogue box. 

 

Having defined the format of the trace output data, confirm the modifications made by 

clicking the OK button to close the Trace Output Control dialogue box and then run the 

simulation. Upon completion of the simulation a message will inform the user that 

EXODUS has ‘Generated trace file trace.out’. Acknowledge the message by simply 

clicking the OK button, and then open the file ‘trace.out’ from the location specified 

previously. If undertaken correctly the data within the file should resemble that shown 

below. 
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Here it can be seen that each of the attributes previously selected by the user (i.e. Sim 

Time, Distance, FIH, Temperature etc.) have all been output at regular 10 second 

intervals as requested. This is evident not only by looking at the values output within 

the Sim Time attribute, but also by the comment “Output per every 10.00 seconds” 

within the file header. Within this example, each group of attributes output correspond 

to the experiences of a single person, namely Person_1. This is indicated within the 

data file by virtue of the fact that the ID for each group of data values is equal to 1, 

which in turn corresponds to Person_1 within the file header. Copying and plotting this 

trace data into a spreadsheet program enables graphs to be generated for each of the 

selected attributes against time (i.e. Sim Time). Figure 9-316 below shows a graph 

plotting the temperatures experienced by Person_1 against time. Here it can clearly be 

seen that Person_1 was only exposed to ambient temperatures (i.e. 20oC) for the first 

minute of the simulation. For the next minute, the temperature the individual was 

exposed to then increased linearly with time (i.e. increasing at 7.5oC every 10 seconds), 

before slightly increasing its rate of linear increase for the remainder of the simulation 

(i.e. increasing at 10oC every 10 seconds). 

 

 
Figure 9-316: A plot of the temperatures experienced by Person_1 throughout 

the simulation. 

 

The ability to collect and analyse data in the manner outlined above can therefore be 

seen to provide a greater understanding of the experiences of selected individuals and 

hence of the evacuation as a whole. While previously, the user only had the attribute 
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values reflecting each individuals sum total of experiences with which to evaluate their 

overall evacuation, the use of the Trace Control facility has enabled regular snap shots 

into the exposures endured by selected individuals. 

 

Within this example, attribute data for a selected individual was output at regular user 

defined intervals (i.e. every 10 seconds). Within the next example, we will instead look 

at outputting data every time selected individuals move within the geometry (i.e. every 

time they move from one node to another). 

 

9.15.1.2 Outputting Attribute Data Every Time A Given Individual Moves 

Reset the simulation and then select the Movement option within the Trace Output 

Control dialogue box. Upon selecting the Movement option, the user should notice that 

the Interval value will become greyed out (i.e. disabled), and hence unable to be 

modified (see Figure 9-317). 

 

 
Figure 9-317: The Trace Output Control dialogue box with the Movement option 

enabled. 

 

Ensure that all the other settings remain unchanged from those outlined previously in 

example 1, and confirm the change made to the Movement attribute by clicking the OK 

button. Once complete, re-run the simulation.  

 

Upon completion of the simulation a message will once again inform the user that 

EXODUS has ‘Generated trace file trace.out’. It is important to note, that since the 

Overwrite option was enabled within the Trace Output Control dialogue box, the new 

trace data file will have over-written the trace data generated previously within example 

1. Open the file ‘trace.out’ containing the new trace data from the location specified 

previously. If undertaken correctly the new data within the file should resemble that 

shown below. 
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Here it can be seen that each of the attributes previously selected by the user have (in 

contrast to example 1) been output every time the selected individual moved. This is 

evident not only by looking at the values output within the Sim Time attribute which 

appear to show no regular time increment, but also by the comment “Output per nodal 

event change” within the file header. Although as stated, data is output every time an 

individual moves, additional data is also output for each selected individual both at the 

start of the simulation and when they either expire or exit the structure. Once again, 

within this example, each group of attributes output correspond to the experiences of a 

single person, namely Person_1. As outlined in example 1, copying and plotting this 

trace data into a spreadsheet program enables graphs to be generated for each of the 

selected attributes against time (i.e. Sim Time).  

 

Since within this example data was only output for each selected individual a) at the 

start and end of their evacuation and b) every time they moved, large periods of 

inactivity during the simulation on the part of selected individuals will obviously result 

in no data being output for them. This is clearly evident within the attribute data 

displayed previously within the file trace.out. Here it can clearly be seen that the first 

group of attribute data was output at the very start of the simulation (i.e. Sim Time=0.0 

seconds), while the second group of attribute data was not output until the individual 

commenced his evacuation (i.e. Sim Time=155.17 seconds). As a result, the exact 

exposure experiences of the selected individual within that interim time period remains 

unknown. Figure 9-318 below shows a graph once again plotting the temperatures 

experienced by Person_1 against time. Here it can be seen that the enabling of the 

Movement option within the Trace Output Control dialogue box has resulted in a less 

clear idea of the given individuals exposure to temperature. While previously within 

example 1 it was clearly shown that the individual was exposed to only ambient 

temperatures (i.e. 20oC) for the first 60 seconds of the simulation, within this example 

that is no longer apparent. In contrast however, once the individual has commenced 

their evacuation the frequency of the data gathered dramatically increases in 

comparison the previous method of outputting data at regular fixed time intervals. This 

increase in the quantity of data gathered during the individual’s movement, conversely 

gives the user a greater understanding of the conditions faced within that time period.  
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Figure 9-318: A plot of the temperatures experienced by Person_1 throughout 

the simulation. 

 

Users wishing to observe the exposure experiences of individuals within simulations 

are advised to exhibit extreme care in deciding the exact method of data collection to 

be used. Users should consider the length of time individuals within the simulation are 

likely to be immobile, the frequency of exposure data required for analysis and hence 

where appropriate the size of the Interval to be used. 

 

Within the first two examples attribute data was output for a single selected individual. 

Within the next example we will instead look at outputting data for multiple selected 

individuals. 

 

9.15.1.3 Outputting Attribute Data For Multiple People 

Move to Population mode and delete all the existing people within the geometry by 

first selecting Delete within the Edit menu, and then selecting the Everyone option from 

within the resulting sub-menu [Edit>Delete>Everyone]. Once the existing population 

has been successfully deleted, randomly generate 100 new individuals throughout the 

entire geometry [Tools>Person>Random Generate] and assign them all response times 

of 180 seconds using the Substitute function [Edit>Substitute>People]. Return to 

Simulation mode and then draw a boundary box around the two individuals located 

closest to the top left hand corner of the geometry (see Figure 9-319). 
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Figure 9-319:  The geometry containing 100 randomly generated individuals. 

 

Next, open the Trace Output Control dialogue box and click the Add Sel. button. Upon 

clicking the Add Sel. button the names of the two individuals located within the 

boundary box will automatically be added to the Trace Control List (see Figure 9-320). 

This alternative method of adding selected individuals to the Trace Control facility 

enables groups of people to be added en masse thereby removing the need for the user 

to go around to each person in turn adding them via their corresponding pop-up menus. 

Ensure that all of the existing settings within the Trace Output Control dialogue box 

remain the same as those outlined within example 2. 

 

 
Figure 9-320:  The Trace Output Control dialogue box with two individuals 

selected to be traced. 

 

Confirm the changes made by clicking the OK button and then re-run the simulation. 

Upon completion of the simulation a message will once again inform the user that 

EXODUS has ‘Generated trace file trace.out’. Once again, since the Overwrite option 

was enabled within the Trace Output Control dialogue box, the new trace data file will 

have over-written the trace data generated previously within example 2. Open the file 

‘trace.out’ containing the new trace data from the location specified previously. If 

undertaken correctly the new data within the file should resemble that shown below. 
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Here it can be seen that each of the attributes previously selected by the user (i.e. Sim 

Time, Distance, FIH, Temperature etc.) have been output for (and only for) each of the 

two individuals selected previously. This is apparent from looking at the ID value for 

each set of output data. In this example, each set of output data clearly corresponds to 

either ID value 26 (i.e. Person_26) or ID value 82 (i.e. Person_82). It can also clearly 

be seen that the data is output for each individual every time they move within the 

geometry. This is once again apparent not only by looking at the values output within 

the Sim Time attribute which appear to show no regular time increment, but also by the 

comment “Output per nodal event change” within the file header.  

 

Copying, sorting (first by ID and then by Sim Time) and then plotting this trace data 

into a spreadsheet program enables graphs to be generated for each of the selected 

attributes against time (i.e. Sim Time). Figure 9-321 below shows a graph plotting the 

distances travelled by the two selected individuals (namely Person_26 and Person_82) 

against time. Here it can be seen that the use of the Trace Control facility has enabled 

the experiences of two separate individuals to be collected and compared to potentially 

offer a greater insight into the overall evacuation. 
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Figure 9-321: A plot of the distances travelled by Person_26 and Person_82 

throughout the simulation. 

 

Within this example attribute data was output for two selected individuals thereby 

enabling a direct comparison of their experiences within a single simulation. Within the 

next example we will instead look at collecting the output data from multiple 

simulations to enable a direct comparison of the experiences of a single individual 

within different evacuations. 

 

9.15.1.4 Outputting Attribute Data From Multiple Simulations  

Reset the simulation, open the Trace Output Control dialogue box and then deselect the 

Over Write option (see Figure 9-322). Ensure that all of the existing settings remain 

unchanged from those outlined previously within example 3, and confirm the changes 

made by clicking the OK button.  

 

Once complete, re-run the simulation. Upon completion of the simulation a message 

will inform the user that EXODUS has ‘Generated trace file trace0.out’. Since the Over 

Write option was deselected, output data can therefore not be written to files which 

already exist at the location specified by the user. Since the specified file (i.e. trace.out) 

already existed at the given location, the data was instead simply saved to a new file 

with a number appended to its filename (i.e. trace0.out). The appending of numbers to 

the end of filenames, ensures that user is able to distinguish between the results of 

different simulations, thereby enabling a direct comparison of experiences within 

separate evacuations. The format of the data within ‘trace0.out’ should be identical to 

that produced previously within example 3, although obviously the actual data values 

will vary between simulations.  
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Figure 9-322:  The Trace Control Output dialogue box showing the Overwrite 

option deselected. 

 

Copying, sorting (first by ID and then by Sim Time) and then plotting this trace data 

into a spreadsheet program once again enables graphs to be generated for each of the 

selected attributes against time (i.e. Sim Time). Importing trace data from multiple 

simulations into a spreadsheet program also enables a direct comparison of the 

experiences within different runs. Figure 9-323 below shows a graph plotting the 

distances travelled against time for a single person (i.e. Person_26) within two separate 

simulations (i.e. trace.out and trace0.out). Here it can be seen that the experiences of 

the individual (i.e. the distance travelled and time taken to evacuate) differ wildly 

between simulations. The use of the Trace Control facility to gather individual 

experience data from separate simulations therefore enables direct comparisons to be 

undertaken to potentially offer a greater insight into the overall evacuation. 

 

 
Figure 9-323:  A plot of the distance travelled by Person_26 during two separate 

simulations (i.e. Sim_1 and Sim_2).  
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9.15.2 Tutorial 15(b): Advanced Data Collection 

This section of the tutorial develops the basic data collection presented in Tutorial 2. 

This tutorial focuses on issues associated with data generation and manipulation.  

Topics covered include the type of data that can be produced by EXODUS, the nature 

of the control that the user has on data output and the type of analysis that can be 

undertaken with EXODUS data. Features addressed include:  

 

9.15.2.1 Configuring the Data Produced 

Generate the geometry shown in Figure 9-324. An internal exit should be positioned as 

shown: centrally between two 10m x 10m rooms. 

 

 
Figure 9-324: The geometry used during this tutorial. 

 

Select the left-hand room by dragging out an area around it. Once selected, select 

[Edit>Substitute->Nodes] option (see Figure 9-325a). Enter ‘Room 1’ into the Title 

text box. The same procedure should be repeated for the right hand room, re-labelling 

the nodes as ‘Room 2’ (see Figure 9-325b).  

 

  
(a)   (b) 

Figure 9-325: (a) Selection of the Substitute function (b) Providing a new Label 

value. 
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Move to Population mode and fill Room 1 with 50 people and Room 2 with 100 people 

using the Panel Populate functionality [Tools>Panel Populate]. Once completed the 

user should move to Simulation mode. 

 

In Simulation mode, from the Rulebase menu access the Data Output Options dialogue 

box [Rulebase>Data Output Options]. The checkboxes should then be configured as 

shown in Figure 9-326. From here the user will be able to determine the nature of the 

output produced by the EXODUS model for each of the runs. In this instance only a 

sub-set of the overall data output facility is required and so the user should implement 

the settings identified in Figure 9-326. The fact that the Generate and Save options have 

been selected indicates the data will be produced by the model and that the user will be 

given the option to save this data to a text (*.sim) file. 

 

   
(a) Attributes tab (b) Variables tab (c) Hazards tab 

Figure 9-326: Data Output Control dialogue box. 

 

Click on the Graphs button to gain access to Graph Ctrl dialogue box. Here you may 

determine the data-sets that will be generated in order to produce graphs in third party 

software. In this case, we are only interested in the graphs generated by the internal and 

external exits and so these options should be selected (see Figure 9-327). Click on OK 

to return to the main dialogue box. 

 

 
Figure 9-327: Graph Ctrl dialogue box. 

 

It will be of use to produce curves representing the arrival of evacuees within the model. 

This can be achieved by first making sure that this data is produced (which we have 
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just done) and then having this data echoed to the screen; this can be achieved by 

selecting [View>Display>Graphs].  

 

Run the simulation five times. In each case, once the simulation is complete an option 

will be presented allowing the data to be saved to an external file. The user should 

accept this. This file will be placed in the same directory as the original *.EXO file. 

Open the *.SIM files with any available text editor (i.e. Notepad). If Notepad is already 

associated with *.SIM files then the user should double-click on a file to open it.  

 

9.15.2.2 Interrogating Output Data 

The first sections of the simulation file provide information on various general aspects 

of the simulation including general population parameters (see Figure 9-328a), 

environmental and behavioural conditions - effectively this represents the set-up 

conditions. These are of particular use in determining the conditions employed within 

the scenario that led to the results produced, especially when a number of different 

scenarios are examined (see Figure 9-328b). It is important to remember that the user-

determined the nature of the data presented in the following sections when they 

accessed the dialogue box (see Figure 9-327). The user therefore can determine the data 

produced according to their needs. 

 

 

 
(a) (b) 

Figure 9-328: (a) Population parameters (b) Behavioural and Hazard Parameter 

settings. 

 

Following this section the overall result of the simulation is produced. This relates to 

the overall performance of the structure (see Figure 9-329). 

 

 
Figure 9-329: Overall results produced. 

 

The user is able to gain a much more detailed understanding of the evolving dynamics 

within the simulation through the examination of the attributes associated with each of 

the evacuees. For instance, as we had earlier named the nodes within the structure, it is 

a trivial task to determine where each of the individuals started their evacuation as it is 
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echoed to the simulation file within the Start Node column (see Figure 9-330). This 

provides a means to categorise the data according to starting location (amongst other 

categories). 

 

 
Figure 9-330: Results produced for each individual. 

 

Information is also provided relating to the performance of the exits within the 

structure, in terms of the numbers using them, the time that the exit was being used, the 

flow rate through it and other user-defined settings (see Figure 9-331). 

 

 
Figure 9-331: Results produced for each exit. 

 

Due to the options selected in the Graph Ctrl dialogue box as shown in Figure 9-327, 

information is produced relating to the flow of individuals through the internal and 

external exits. This enables the user to export this data to third party software in order 

to present this data (or rely on the graphs produced by the model, see Figure 9-333). 
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Figure 9-332: Curves produced by each of the exit components 

 

Depending on the previous interaction of the user with the model, several graph 

windows will either be immediately apparent, be situated behind the main window or 

will be minimised (see Figure 9-333). These reflect the performance of each of the 

configurational components (i.e. exits in this example) selected in the Graph Ctrl 

dialogue box and can be seen to develop during the simulation itself. 

 

 
Figure 9-333: Curves produced for each of the configurational components. 

 

The curves represented in these graphs can be switched between the cumulative arrival 

of the evacuees and the flow rates produced across user-specified time periods. First 

gain access to the graph produced by evacuees using the internal exit. To do this the 

user should expand the object tree in the Navigation Window, by clicking on the “+” 

next to Floors branch of the tree. The user will then gain access to the Internal Doors 

branch, which should be clicked on and finally ends in the InDoor_1 object. By right-

clicking on this object and then selecting Graph from the menu that appears, the user 

can produce a graph for that object (see Figure 9-334a). The arrival curve of the 

evacuees at the internal door should now be evident. To access the flow rate curve, the 

user should select the TimeSpan option from the Status menu (see Figure 9-334b) and 

then set the time interval across which the flow rate is calculated by selecting Set 

TimeSpan from the same menu and ensure that the interval is 5 seconds (see Figure 

9-334c). 
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(a) (b) (c) 

Figure 9-334: (a) Generating the graph from the menu (b) Changing the graph to 

Time-Span (c) Providing a time interval of 5 seconds. 

 

The graph produced should be similar to that shown in Figure 9-335. 

 

 
Figure 9-335: Flow rate graph produced by the evacuees moving through the 

internal exit. 

 

9.15.2.3 Using the askEXODUS Tool 

EXODUS has a tool provided with it that is designed specifically to ease the analysis 

of a large number of simulation files simultaneously. Once the askEXODUS tool has 

been run, the user should select from the File menu the Open option or click on the Add 

files button. This will display the Open File dialogue box where the user should select 

all five simulation files generated for this scenario and then click the Open button (see 

Figure 9-336). 
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Figure 9-336: Selecting the files that are to be imported into the model. 

 

askEXODUS will then start processing the simulation files and sorting the data they 

contain. While doing so it will display a progress bar indicating that it is processing the 

files (see Figure 9-337) 

 

 
Figure 9-337: The progress bar indicating that askEXODUS is processing the 

imported files. 

 

Once the simulation files have been processed they will appear in the Loaded files list 

(see Figure 9-338). 
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Figure 9-338: The five imported files shown within the Loaded files list. 

 

At this stage the imported simulation files can be analysed. To start analysing the 

simulation files the user should click on the Analyse button. This will display the Select 

Data To Output dialogue box (see Figure 9-339).  

 

 
Figure 9-339: The Select Data to Output dialogue box. 
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This window gives access to a very powerful tool that allows the user to select and 

output specific data from multiple simulation files. For more detailed information on 

what kind of data can be extracted using askEXODUS the user should refer to the 

askEXODUS User Guide. 

 

Three simple ways of extracting data will be presented in this tutorial. These three 

methods of analysing Simulation files are: 

 

 Population Averages and Simulation Performance  
This option produces a table containing all of the average population 

characteristics (static, dynamic and experiential) and the key performance 

attributes of the entire Simulation.  

 Individual Attributes for entire Population  
This option produces tables representing the final achieved values of each 

individual’s attributes for each simulation file. 

 Internal/External Exit Point & Census Data 
This option will produce tables containing the evacuation performance data, the 

usage times and the time span data of the entire structure, of each internal and 

external exit as well as for each census region and census line. 

 

Click on the Performance and averages button. This will move the appropriate fields 

from the Available fields into the Fields to output list (see Figure 9-340). The items 

selected include: 

 

 Egress results 

 Simulation performance results 

 Door performances 

 Internal doors and census points performances 

 Compartment zone performances 

  



Chapter 9 - Tutorial 15 

 

©2017 University of Greenwich 408 

 

 
Figure 9-340: The data added to the fields to output list relating to the 

population averages and simulation performance. 

 

It should be noted that the amount of data shown within askEXODUS depends solely 

on the configuration of the simulated model. The amount and types of objects created 

within the model (exits, staircases, internal doors, etc)  is reflected in the number of 

items shown in the Fields to output list.  

 

To extract the selected data the user should press the Export button. This will display 

the Results window containing all the selected data (see Figure 9-341). 

 

 
Figure 9-341: The results produced relating to the population averages and 

simulation performance. 

 

The generated data includes the average values for each of the individual attributes 

represented in the simulation file, the performance characteristics of the entire structure 

as well as the performance of individual components such as exits, internal doors and 

compartments. With this data the user is able to gain an understanding as to the values 

generated across all of the attributes; it provides a means by which the user might 

comprehend the conditions across the evacuation. In Figure 9-341 it is apparent that for 

each of the attributes represented a value is produced that is associated with each of the 

five runs. 
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9.15.2.4 Use Of Third-Party Software 

The presentation of data in a tabular format (see Figure 9-341) is of enormous use as it 

enables the export of data to third-party spread sheet software in order to conduct 

further analysis of the data. In the following sections it will be assumed that the user 

has access to Microsoft Excel 2010. Although all examples will be shown within this 

spread sheet application it should be noted that all spread sheet applications should be 

more than capable of producing equivalent results.  

 

To copy the data into Excel the data must first be selected. To do this the user should 

first click with the mouse the first row and then while holding down the SHIFT key 

click on the last row. Pressing CTRL-C will then copy the data, ready to be pasted into 

Excel. The user should then select the first cell (A1) within Excel and press the CTRL-

V key combination to paste the data into the spread sheet (see Figure 9-342). 

 

 
Figure 9-342: The results formatted within askEXODUS exported to a spread 

sheet application. 

 

The data should now appear as it was presented within askEXODUS. This data is now 

accessible to the statistical and graphical tools available within the spread sheet 

application. A simple analysis that could be performed on this data is to determine the 

average, minimum and maximum values of the average overall evacuation time, the 

average distance travelled by the evacuees and the average cumulative wait time within 

each of the simulations. To achieve this the user should first locate the data columns 

containing this data. Browsing right using the scroll bar the user should locate the 

Avg.CWT, Avg.Distance and Avg.PET columns. These correspond to the cumulative 

wait time, distance travelled and personal evacuation time values. The user should then 

use the min, average and max functions within Excel to calculate the minimum, average 

and maximum values of all average CWT, Distance and PET attributes. The results are 

presented in Figure 9-343 where the aforementioned values have been calculated. 

 

 
Figure 9-343: The minimum, maximum and average CWT, Distance and PET 

within all five simulation files as displayed within Excel 
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The user should now return to the askEXODUS tool and click again the Analyse button. 

This time the attributes of all individuals will be extracted from the simulation files. To 

do this click on the Select Data to Output window the Individual attributes button. This 

will move all the Egress Results into the Fields to output section. Clicking the Export 

button will then display the Results window containing all the attributes associated with 

each individual for all loaded simulation files (see Figure 9-344). 

 

 
Figure 9-344: The results produced relating to the Individual attributes. 

 

Perhaps a better representation of this data is achieved if the table is transposed. To 

transpose the table click on the Transpose button. The transposed table is shown in 

Figure 9-345. 
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Figure 9-345: The results produced relating to the Individual attributes after 

having been transposed. 

 

The user should then scroll down the window until the first instance of the PET attribute 

is found (see Figure 9-346). 
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Figure 9-346: The PET data within the transposed individual attributes results 

 

The PET data should be selected by clicking on the first PET row, holding the SHIFT 

key down and then clicking on the last PET row. In total 150 entries should exist, i.e. 

one for each agent within the structure. Pressing the CTRL-C key combination will then 

copy this data to the clipboard which can then be pasted into Excel (see Figure 9-347). 

It should be noted that when the Save headers option is enabled then copying the data 
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will also copy the headers. In the example presented here the headers represent the 

simulation filenames.  

 

 
Figure 9-347: The PET values generated for each individual across each of the 

five scenarios after being copied into Excel 
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Since the PET values represent the personal evacuation time of an agent and since the 

table contains these values for all agents across all simulation files the evacuation time 

graphs for the five loaded simulation files can be plotted.  

 

To create the graph in Excel the user should select the entire table. With the PET table 

selected the user should click on the Insert tab and then on the Line chart tool. Several 

options for line charts will appear. The user should select the Simple Line Chart option. 

This will generate a chart similar to the one shown in Figure 9-348. At this stage the 

user can format the graph by adding a chart title as well as axis titles. These tasks can 

be performed by clicking on the Layout tab. To add a title for the entire graph the user 

should press the Chart title button. To add titles on the axis the user should press the 

Axis Titles tool. 

 

 
Figure 9-348: Evacuation graphs from five simulations 

 

9.15.2.5 Generating Individual Cwt vs Individual Pet Graph: 

In this section the method for generating a graph showing the individual time spent in 

congestion (CWT) versus the personal evacuation time (PET) for each individual is 

discussed.  

 The user should return to askEXODUS, scroll up in the Results window to 

the section in the data where the CWT values start. All CWT data should be 

selected in the same manner as described in the previous section.  

 The CWT data should then be copied using the CTRL-C key combination - 

and pasted into Excel, next to the PET data, using the CTRL-V key 

combination (see Figure 9-349). 
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Figure 9-349: PET and CWT data for all agents achieved in five simulation runs 

 

At this point both the PET and CWT data co-exist on the same sheet. In this instance a 

single set of CWT data will be associated with a single set of PET data in order to 

demonstrate the type of insight that can be gained into the evolving experiences of the 

evacuees during the simulation. 

 

To create the CWT versus PET graph the user should select the first column of the PET 

data and the first column of the CWT data. The easiest way of selecting these two data 

sets is to click on the first cell in the PET data set, then press CTRL-SHIFT-

DOWN_ARROW and then using the mouse wheel or scroll bars move back to the top. 

The PET data is now selected. To select the CWT data the user should press the CTRL 

button and while keeping it pressed should select the first cell of the CWT data. Then 

the user should press CTRL-SHIFT-DOWN_ARROW to select the CWT column. Now 

both PET and CWT columns should be selected (see Figure 9-350). 

 



Chapter 9 - Tutorial 15 

 

©2017 University of Greenwich 416 

 
Figure 9-350: Selecting the CWT and PET data that will be plotted on a graph 

 

Now that the data is selected the graph can be plotted. Since the CWT and PET values 

of each agent need to be associated the graph that will have to be plotted should be a 

scatter graph. To plot this graph the user should click on the Insert tab and then on the 

Scatter graph tool. Several options will be displayed however the user should select the 

first option called Scatter with only Markers. This will display a graph similar to the 

one shown in Figure 9-351. At this stage the user can format the graph by adding a chart 

title as well as axis titles. These tasks can be performed by clicking on the Layout tab. 

To add a title for the entire graph the user should press the Chart title button. To add 

titles on the axis the user should press the Axis Titles tool. 
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Figure 9-351: CWT versus PET plot, as the evacuation progresses the congestion 

experienced by the evacuees is increasing 

 

Other packages apart from Excel can be used to manipulate the data. As an example the 

same data has been exported into the SPSS statistical package. In this case, the data has 

been separated according the starting location of the individuals involved; a task that 

although possible, requires much more user expertise within Excel. 

 

 
Figure 9-352: The curve generated in the SPSS package. 

 

The analysis shown above demonstrates how it is possible to examine the general data 

produced across a number of simulations in order to understand the conditions that are 
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evident across all of the scenarios, as well as examining the evolving conditions within 

a single simulation file. This provides two different insights into the simulated 

conditions; conditions that might be of equal value. 
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9.16 Tutorial 16: Escalator and Stair Transit Nodes 

During this tutorial two regions connected by both a stair and an escalator are created in order 

to demonstrate the use of Transit Nodes and the various route selection algorithms (and 

behaviours) that can be used in modelling the movement of people. This will require: 

 

Generating two regions, generating stair and escalator transit nodes, connecting the regions 

to the staircase and escalator, defining the route selection algorithms when negotiating 

transit node groups and defining the behaviour exhibited by individuals while traversing 

the escalator. 

 

9.16.1 Creating the Geometry 

1. The user should create two separate regions within the same Window, each 10m 

(horizontal) x 8m (vertical) (i.e. 20 x 16 nodes) in dimension. The region on the left of the 

screen relates to the lower region, while the region on the right of the screen relates to the 

upper region (i.e. the region agents will reach by traversing the stairs/escalator from the 

lower region). 

2. Connect a Door to all of the nodes along the rightmost edge of the upper region as shown 

in Figure 9-353. 

3. Cut out a 1m x 1m square (i.e. 2 x 2 nodes) entry area within each region in the locations 

shown in Figure 9-353. These removed areas correspond to the regions where the escalator 

level run will be located on each level, and hence will be represented within the 

corresponding connecting Escalator Transit Node. 

 
Figure 9-353: Geometry – Removing the escalator level run sections 

 

4. Create a single run staircase as illustrated in Figure 9-354 (the Stair appears with three 

lanes).  To create the staircase, click on the Stair Transit Node button  on the toolbar 

and click at the approximate location of the staircase within the geometry window. 

Alternatively, generate a Stair Transit Node by selecting [Tools>Generate>Transit Node] 

from the menu while in Geometry mode.   
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Figure 9-354: The final geometry 

 

5. Once the Stair Transit Node has been created, double-click on it to display its 

corresponding dialogue box and enter the values shown below in Table 9-11. Attributes 

not specified should assume the default values. 

 

Table 9-11: Stair information. 

Attribute Value 

Properties Tab 

Node Type Stair 

Direction 90 

Travel Direction Up/Forward 

No. Of Lanes 3 

Riser Number 15 

Width 2.28m 

Height 3m 

Length 6m 

Nosing 0m 

Behaviour Tab 

Catchment 3m 

Advanced Tab 

Handrail Disabled 

Effective Width Disabled 

 

6. Next, create an Escalator Transit Node by first creating a Stair Transit Node in the same 

manner outlined previously. Once a new Stair Transit Node has been created double-click 

on it to display its corresponding dialogue box and enter the values shown below in Table 

9-12. Defining a transit node's corresponding Node Type to Escalator will, as the name 

suggests, effectively transform the transit node from its initial Stair type to an Escalator. 

By default, all transit nodes are initially defined as a Stair. Users wishing to model other 

transit nodes are therefore required to first create a Stair Transit Node and then redefine its 

Node Type in the manner outlined previously. Once again, attributes not specified within 

Table 9-12 should assume the default values.  
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Table 9-12: Escalator information. 

Attribute Value 

Properties Tab 

Node Type Escalator 

Direction 90 

Travel Direction Up/Forward 

No. Of Lanes 2 

Lane Capacity 14 

Width 1m 

Height 3m 

Length 8m 

Behaviour Tab 

Catchment 3m 

Advanced Tab 

Speed 0.5m/s 

Level Run 1.2m 

 

7. Turn both Object Lock [Edit>Object Lock] and Node Snap [Edit>Node Align>Snap] off. 

Having done this, align the Escalator and the upper and lower regions to the positions 

indicated within Figure 9-354. Having correctly positioned the Escalator, connect the top 

and bottom of it to two free space nodes within the upper and lower regions. This is done 

by selecting both Escalator and the corresponding nodes to be connected to it and selecting 

[Tools>Auto Connect>Stairs and Transit Nodes]. Users requiring further information on 

how to correctly connect transit nodes should refer to Tutorial 3. 

8. Align the Stair transit node next to the Escalator transit node but half a metre (i.e. a single 

node) apart as shown in Figure 9-354. Connect the stairs to both the upper and lower 

regions (connecting 5 free space nodes to each end) in the same manner as the Escalator. 

9. Next, move to Population mode and place 50 people from the standard population in the 

first 3m (i.e. 6 node) area of the lower region. This is achieved by selecting the region to 

be populated, then selecting [Tools>Person>Random Generate] from the menu and 

defining 50 within the resulting dialogue box. The geometry should now look like that 

shown in Figure 9-354. 

10. The next stage is to group the two transit nodes (i.e. the staircase and the escalator) together.  

Display the Transit Node Subgroup Editor by moving to Scenario mode and then selecting 

[Tools>Transit Node Grouping]. 

11. Within the Transit Node Subgroup Editor click the Create button to create a new transit 

node group (see Figure 9-355). Then double click on the newly created group panel (i.e. 

“Group_1”) within the Transit Node Group List. This will display the Transit Node 

Grouping dialogue box (see Figure 9-356), showing both the transit node components 

assigned to a given group and the variables used to control the algorithm agents use when 

deciding which component to use during egress. 
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Figure 9-355: The Transit Node Subgroup Editor 

 

12. Within the Transit Node Grouping dialogue box, click on each transit node in turn within 

the Transit Node list to the right of the dialogue box and then click the <-Add button. 

Adding each of the available transit nodes (i.e. the stair and the escalator) effectively adds 

them to the currently selected transit node group (i.e. Group_1). Alternatively the user can 

merely click the <-All button to add all of the available transit nodes into the current group. 

The dialogue box should now resemble that shown in Figure 9-356. 

  
(a) (b) 

Figure 9-356: The Transit Node Grouping dialogue box  

 

13. Having added both of the transit nodes to the group, next set the direction in which the 

defined group is required to operate. This is defined via the list box positioned between the 

OK and Cancel buttons (see Figure 9-356). By default, this should be set to Both Ways 

(instead of using the default setting, select the Up/Forward option from the list box).  This 

option allows the user to specify in which direction the transit node selection behaviour is 

utilised. If for example the Up/Forward option is selected then people approaching the 

transit node group in the forward direction will choose which device to use based on the 

parameters specified here; however, in the backward direction they will simply use the 

standard movement in buildingEXODUS, which is to select a route based solely on the 

potential or distance map to destination.  The dialogue box should now resemble that shown 

in Figure 9-357. Having done this, click the OK button to confirm the transit node group 

settings. The transit nodes have now been grouped together. Note that further transit nodes 

can be added or removed to/from a transit node group in the same manner. 
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Figure 9-357: The Transit Node Grouping dialogue box with the direction set to 

Up/Forward.  

 

14. Next, move to Simulation mode, and display the Behavioural Options dialogue box by 

selecting [Rulebase>Behaviour Options] from the menu. Within the Route tab of this 

dialogue box select the Maintain Itinerary, Maintain Target Exit and Transit Node 

Grouping options.  Selecting the Maintain Itinerary option ensures that the itineraries 

assigned to each individual instructing them which transit node to use will be adhered to 

by the individual throughout the simulation (i.e. they will not abandon their itineraries as a 

result of interaction with congestion or smoke etc.). Similarly, selecting the Transit Node 

Grouping option ensures that the various transit nodes are selected/negotiated in 

accordance with the defined transit node selection method and the associated attributes. 

Now the geometry is completed a number of scenarios can be run to demonstrate the various 

capabilities of the Escalator Transit Node model and the methods agents use when selecting 

between grouped transit nodes (i.e. in this instance the staircase and the escalator). 

 

9.16.2 Transit Node Selection 

When agents approach a set of grouped transit nodes (i.e. stairs/escalators/travelators, etc.) they 

are required to select which transit node to use in order to traverse the area. In EXODUS there 

are 3 transit node selection methods users can employ for a transit node group to allow agents 

to perform this task:  

 

 Proportion System, 

 Assessed System, and  

 Hybrid System. 
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9.16.2.1 Proportion System 

This transit node component selection system is best used either when: 

 

 Low levels of congestion occur in the transit node group catchment area,  

 Sub optimal component transit node selection behaviour is required (e.g. circulation) 

i.e. occupants choose which transit node to use based on factors other than speed, or  

 The proportion of occupants using each component is known. 

 

This system functions by assigning a Proportion that an agent will use each transit node in a 

given transit node group. 

 

15. Move to Scenario mode, and open the Transit Node Grouping dialogue box [Tools>Transit 

Node Grouping] (see Figure 9-357).  

16. Set the Selection System to Proportion (this will automatically set the Congestion 

Threshold to 100%). This ensures that the Proportion System will always be used 

irrespective of the levels of congestion in the transit node catchment area. 

17. Set the Proportion of escalator users to 100 in the Up/Forward direction and ensure that 

the Proportion of staircase users is conversely set to 0. The Transit Node Grouping 

dialogue box should now resemble that shown in Figure 9-358. 

 

Figure 9-358: The Transit Node Grouping dialogue box with Selection system set to 

Proportion and the Proportion of people using Escalator_1 set to 100.  

 

18. Run the simulation and observe what happens. All agents will use the escalator. 

19. Return to Scenario mode and again open the Transit Node Group dialogue box. This time 

set the Proportion of escalator users to 50 and Proportion of staircase users to 50. Run the 

simulation and observe what happens. Approximately an even number of agents will use 

each transit node (Note that agents do not consider local conditions e.g. crowds/queues for 

each transit node when this transit node selection system is used). 
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9.16.2.2 Assessed System 

This transit node selection system is the default within EXODUS. It is best used when: 

 

 High levels of congestion are expected (i.e. low congestion levels are infrequent) in the 

transit node group catchment area, 

 Agents attempt to optimize their performance, assessing which transit node they expect 

will take them the shortest amount of time to traverse.  

 

This system functions by agent’s assessing which transit node in a given group will allow them 

to move both to and pass through the transit node in the shortest expected time. The agent not 

only considers the travel distance both to and on each transit node for their given speed, but 

also takes into account other agents that are waiting for each transit node (i.e. potential obstacles 

to their movement) when deciding which transit node to use. Agents reassess their decision 

whilst in the transit node catchment area so that they can alter their decision according to local 

conditions e.g. crowding. 

 

20. Move to Scenario mode, and again open the Transit Node Group dialogue box.  

21. Set the Selection System to Assessed (this will automatically set the Congestion Threshold 

to 0%). This ensures that the Assessed System will always be used.  

22. Run the simulation and observe what happens. Approximately an even number of agents 

will use each transit node. Initially most agents elect to use the escalator however, as the 

crowd at the base of the escalator increases more agents elect to use the stairs, responding 

to the expected increased wait time of using the escalator. 

23. Set the escalator Speed to 0 m/s (i.e. disable the escalator so that it behaves like a 

conventional staircase). Repeat the scenario above and observe what happens. In this 

instance, more agents will use the stairs since the queue for the escalator will be of more 

influence due to the increased travel time on the escalator. 

 

NOTE:  

The user can also manipulate the relative attractiveness of the components within the same 

group by modifying the Penalty attribute associated with each component. This linearly reduces 

the attractiveness of a component as the Penalty is raised, in much the same way as the 

Potential attribute operates with an exit. 
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9.16.2.3 Hybrid System 

This transit node selection system is best used when: 

 

 A variety of both low levels and high levels of congestion are expected in the transit 

node group catchment area (or the congestion levels are not known),  

 Sub-optimal transit node selection is required to be represented during low levels of 

congestion,  

 All agents are required to elect to use a given transit node prior to a given level of 

congestion being reached (e.g. all use the escalator).  

 

This system functions by using a combination of the Proportion system (see Section 9.16.2.1) 

and the Assessed system (see Section 9.16.2.2). A user sets the Selection System to Hybrid (this 

will automatically enable the Congestion Threshold). A user can then define a Congestion 

Threshold value (0-100%) which represents the percentage of nodes in a transit node Catchment 

area that are occupied by agents (i.e. the levels of congestion in the catchment area). For 

example, with a typical free space node size of 0.5m, the following percentages translate to the 

following occupant densities: 100%=4 people/m2, 75%=3 people/m2, 50%=2 people/m2, 

25%=1 people/m2. When the levels of congestion in the entire transit node group Catchment 

area are below the Congestion Threshold, agents elect which transit node to use based on the 

Proportion System. When the levels of congestion in the transit node group Catchment area 

reach or exceed the Congestion Threshold, agents instead elect which transit node to use based 

on the Assessed system.  

 

24. Open the escalators corresponding Transit Node dialogue box and in the Advanced Tab set 

the escalator Speed to 0.5m/s.  

25. Move to Scenario mode and open the Transit Node Grouping dialogue box (see Figure 

9-356) and set Congestion Threshold to 24% (0.96 people/m2). In addition, set the 

Proportion of agents using the escalator to 100 and the Proportion of those using the stairs 

to 0. Run simulation and observe what happens. Because the Assessed system is not used 

all of the time, slightly greater levels of escalator use should be seen in comparison to when 

only the Assessed system is used.  

 

9.16.3 Walker/Rider Percentage Likelihood and Rider Side Preference 

When agents board an escalator they are randomly assigned as either being a Walker (i.e. they 

walk on the escalator) or a Rider (i.e. they ride on the escalator). When using the Behavioural 

Model (i.e. as opposed to the Flow Rate Model), the percentage likelihood of agents being a 

Walker can be defined for a given Escalator Transit Node. This is defined within the escalators 

corresponding Transit Node dialogue box in the Behaviour tab in the Behaviour Model section 

(see Figure 9-359). 
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Figure 9-359: The Transit Node dialogue box showing the behavioural attributes for an 

escalator. 

 

The percentage likelihood of an agent being a Walker can be defined within a given escalator 

transit node differentiated according to direction (i.e. Up or Down see Figure 9-359). This 

allows users to change the Travel Direction of a transit node without having to restate the 

adjusted percentage likelihood of an agent being a Walker. An agent is randomly assigned as 

being a Walker or a Rider just before boarding an escalator. 

 

If an agent is assigned as being a Rider, they will then select a side of the escalator to ride on 

(i.e. left/right). The percentage likelihood of a Rider using either side of the escalator can be 

defined by the user within the Behaviour Tab of the escalator’s corresponding Transit Node 

dialogue box within the Rider Side Preference section (see Figure 9-359). Here the user can 

define a percentage likelihood that a given Rider (i.e. travelling in an up or down direction) will 

use either the left or right side of the escalator. 

 

26. First, move to Scenario mode and set 100% of agents to use the escalator by setting both 

the Proportion of escalator users to 100, the Proportion of stair users to 0, and the 

congestion Threshold to 100% within the Transit Node Group dialogue box [Tools>Transit 

Node Grouping].  
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27. Next set all agents using the escalator to be Riders. This is achieved by setting the Walker 

Up percentage to 0% within the escalators corresponding Transit Node dialogue box (i.e. 

there is a 0% chance that they will be Walkers hence all will be Riders). In addition, set 

both the Rider Bias to Right and the Compliance to 100%.  

28. Run the simulation and observe the results. All agents will elect to use the escalator and all 

will ride on the right hand side. Note the total evacuation time. 

29. Now set Walker Up percentage to 100% (thereby ensuring that all agents who use the 

escalator will be Walkers). Run the simulation and observe the results. This time all agents 

will instead elect to use the escalator and all walk on the escalator adopting any available 

side. Note that the total evacuation time should be less than the above scenario. 

30. Repeat the above scenario again but now set the Walker Up percentage to 50%. Run the 

simulation and observe the results. Compare the total evacuation time to the two previous 

scenarios. 
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9.17 Tutorial 17: Modelling the Use of Lifts/Elevators 

The following tutorial provides a demonstration of building a simple ten floor structure and 

conducting an evacuation simulation that utilises lifts and stairs within buildingEXODUS.  The 

building contains two dog-leg staircases located on opposite sides of the structure, each of 

which service every floor.  In addition, the building is also serviced by two banks of lifts, with 

each lift bank comprising 6 lifts (i.e. 12 lifts in total).  For simplicity, furniture and internal 

compartments are not represented in this example as the focus is to provide a simple 

demonstration of the lift model and its capabilities (see Figure 9-360). 

 

 
Figure 9-360: The 10 floor structure used within this tutorial as depicted within the 3D 

View 

 

9.17.1 Building a Geometry with Lifts 

1) Create a 42 x 42 node square floor (this will be the ground floor, Floor_0). 

2) Cut out a 4 x 12 node rectangle from the centre of both the left and right sides of the 

geometry (see Figure 9-353). 

3) Cut out a 18 x 12 node rectangle from the centre (see Figure 9-353). 
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Figure 9-361: The ground floor of the geometry (i.e. Floor_0) 

 

NOTE: At this point the geometry should resemble that within the geometry file T17_1.exo 

provided 

 

4) Create clockwise dog-legged stairs in the top left and bottom right corners of the 

geometry connected to a 3 x 6 node landing (see Figure 9-362). 

a) Each leg of the stairs should have the following dimensions: Length 3.78m, 

Width 1.4m, Height 1.5m 

b) The stairs connect to the floor above so connect the bottom of the dog legged 

stairs to the ground floor. Also ensure that each flight of stairs is connected to 

its corresponding landing. 

c) Convert the Free Space nodes of the landings to type Landing. This is required 

to ensure even stair usage and also for accurate vrEXODUS display. 
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Figure 9-362: The ground floor of the geometry with two dog legged stairs 

 

NOTE: At this point the geometry should resemble that within the geometry file T17_2.exo 

provided 

 

5) Generating Lift Shaft Opening transit nodes: 

a) Generate a transit node, open its properties and in the Transit Node dialogue box 

change the node type from Staircase to Lift Shaft Opening. 

b) Change its Direction to 90 (i.e. so that is facing to the right of the screen). 

c) Under the Behaviour tab, ensure the Catchment size is 3m. This defines where 

agents will wait for a lift. 

d) The remaining default Lift Shaft Opening transit node settings will be used. It is 

important to note that the transit node represents an opening to a lift shaft and 

not the lift car itself (this will be created later). 

e) Position the Lift Shaft Opening transit node in the same position to that shown 

in Figure 9-363. 
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Figure 9-363: The ground floor of the geometry showing the addition of a single Lift 

Shaft Opening transit node 

 

f) Ensure the transit node’s Title is ‘LiftShaft_1’ (this should be the default name). 

g) Repeat this process so that there are 12 lifts in the locations shown in Figure 

9-364. Note you can copy and paste the previously created transit nodes to make 

this task easier (using CTRL-C/CTRL-V). Ensure each Lift Shaft Opening transit 

node is called ‘LiftShaft_X’ where X represents an incremental counter (each 

lift shaft should have a unique name). LiftShaft_1–LiftShaft_6 should be located 

on the left while LiftShaft_7-LiftShaft_12 should be located on the right. (Note 

that the Lift Shaft Opening transit nodes represent the opening to the lift shaft 

and not the lift itself which will be created later). 

h) Select all of the Lift Shaft Opening transit nodes (using the CTRL-key and 

mouse). Then while holding down the CTRL key right click on one of the transit 

nodes and select the Auto-connect option from the pop-up menu. This will 

proceed to connect each Lift Shaft Opening transit node to the adjacent Free 

Space nodes.  
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Figure 9-364: The ground floor of the geometry showing all 12 Lift Shaft Opening 

transit nodes. 

 

6) Group the Lift Shaft Opening transit nodes into 2 separate transit node groups. 

a) Select the 6 Lift Shaft Opening transit nodes on the left side of the geometry. 

b) Right click on one of the selected transit nodes and select the Group option from 

the pop-up menu. This groups the selected Lift Shaft Opening transit nodes into 

a transit node group that will be used by agents to decide which lift to use when 

they enter into a lift waiting area. 

c) Repeat the same process for the 6 Lift Shaft Opening transit nodes on the right 

side of the geometry. 

d) Verify that the Lift Shaft Opening transit nodes have been grouped correctly. 

Right click on any Lift Shaft Opening transit node and select the Group Dialogue 

(Bank) option from the pop-up menu. This displays the transit node group that 

the selected lift belongs to. 

 

NOTE: At this point the geometry should resemble that within the geometry file T17_3.exo 

provided 
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7) Create the remaining floors. 

a) In Geometry mode, right click on Floor_0 in the left Navigation window and 

select the Copy option from the pop-up menu. This will display the Floor Copy 

Control dialogue box (See Figure 9-365). Untick all of the checkboxes and leave 

the How many? field as 1. Click the OK button. This will copy all the nodes on 

the ground floor (i.e. Floor_0) onto the floor above and label it Floor_1. 

 

Figure 9-365: Copying the ground floor via the Floor Copy Control dialogue box. 

 

b) Connect both stairs from Floor_0 to the corresponding Free Space nodes on 

Floor_1.  

c) Right click on Floor_1 in the left Navigation window and select the Copy option 

from the pop-up menu. Untick all of the checkboxes except for the Floor 

Connections option. Enter 8 into the How many? field. This will copy and 

automatically link the stairs between each floors. In total there should be 10 

floors: Floor_0 to Floor_9. 

(NOTE: For the purpose of this tutorial you will manually create the transit node 

groups and lift shafts on each floor (see steps 9-11). However, it is possible to 

automatically generate these when a floor is copied if the Transit Node Groups and 

Lift Connections checkboxes are ticked in the Floor Copy Control dialogue box (see 

Figure 9-365). In the current example, for these functions to be used, the transit node 

groups and lift shafts for Floor_0/Floor_1 would need to have been created prior). 

 

NOTE: At this point the geometry should resemble that within the geometry file T17_4.exo 

provided 
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8) On Floor_0, create a 2m wide exit (i.e. 4 nodes) at the centre of the north wall (see 

Figure 9-366). 

 
Figure 9-366: The ground floor of the geometry (i.e. Floor_0) with a 2m wide exit added. 

 

NOTE: At this point the geometry should resemble that within the geometry file T17_5.exo 

provided 

 

9) Build the lift shafts.  

a) In Geometry mode, right click on any Lift Shaft Opening transit node in the left 

group on Floor_0. Select the Create Lift Shafts for Group option from the pop-

up menu (see Figure 9-367). For all Lift Shaft Opening transit nodes in the transit 

node group, this builds the lift shafts vertically between each floor (i.e. Lift Shaft 

Opening transit nodes that have the same XY coordinates on different floors are 

assumed to form part of the same lift shaft) and creates a Lift associated with 

each lift shaft. A lift moves vertically within a geometry between the Lift Shaft 

Opening transit nodes. Upon selecting the Create Lift Shafts for Group option 

the user will be asked “Do you wish to automatically rename the lifts 

corresponding Lift Shaft Opening transit nodes?”. Click Yes. This will ensure 

that the names of each Lift Shaft Opening transit node are automatically updated 

to reflect both the name of the lift of which they are a part and the floor on which 

they are based (i.e. <LiftName>_<FloorName>). 
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b) Repeat this process for the Lift Shaft Opening transit nodes in the right group. 

You will notice that the entrance to the Lift Shaft Opening transit nodes changes 

colour from black to red when the lift shafts are created. The colour of the Lift 

Shaft Opening transit node signifies both if a lift is currently at the given floor 

and the state of the lift:  

 Black: the Lift is not at the current floor (or there is no Lift associated 

with the Lift Shaft Opening transit node),  

 Red: the Lift is at the current floor and the doors are closed,  

 Green: the Lift is at the current floor and the doors are open. 

 
Figure 9-367: Creating the lift shafts for each of the Lift Shaft Opening transit nodes 

within the left transit node group 

 

c) To view/edit a Lift’s attributes, move to Scenario mode, right click on any Lift 

Shaft Opening transit node and select the Lift Properties option from the pop-up 

menu. The will display the Lift Properties dialogue box (see Figure 9-369). 

Within the Lift Properties dialogue box, the Attributes tab defines the direction, 

status, capacity and current occupancy of a Lift. The Movement tab defines the 

kinematic parameters of the lift. The Nodes tab defines which Lift Shaft Opening 

transit nodes make up the lift shaft that the Lift moves in. The Sequence tab 

defines which floors the Lift will service during an evacuation simulation. The 
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Floor Requests tab defines the sequence of floors that the lift currently still has 

to service. 

d) The default Lift attributes will be used for this tutorial. 

(NOTE: If you wish to view the lift shafts that have been created or view lifts moving during a 

simulation, then this can be achieved using the 3D viewer. The 3D viewer can be accessed in 

any mode by selecting the Interface option from within the View menu and then selecting the 

3D View option within the resulting submenu (see Figure 9-368). To navigate about the space 

in the 3D View, the key combinations stated in Table 9-13 can be used whilst the 3D viewer 

window is selected). 

 

 
Figure 9-368: Opening the 3D view within buildingEXODUS 
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Table 9-13: The default movement controls within the 3D View 

Action Primary Key Alternate Keys Mouse Control 

Forward W Numpad 8 n/a 

Backward S Numpad 5, Numpad 2 n/a 

Strafe Left A Numpad 4 n/a 

Strafe Right D Numpad 6 n/a 

Up Space bar Numpad 9 n/a 

Down Ctrl Numpad 3 n/a 

Turn Left Left Arrow n/a Mouse Drag Left3 

Turn Right Right Arrow n/a Mouse Drag Right3 

Look Up Up Arrow n/a Mouse Drag Up3 

Look Down Down Arrow n/a Mouse Drag Down3 

Increase Speed1 = Numpad + n/a 

Decrease Speed1 - Numpad - n/a 

Zoom In Page Up n/a Mouse Wheel Forward 

Zoom Out Page Down n/a Mouse Wheel Backwards 

Speed Boost2 Shift n/a n/a 

Increase Floor Separation Shift & = Shift & Numpad + n/a 

Reduce Floor Separation Shift & - Shift & Numpad - n/a 

Rotate Clockwise4 Shift & L n/a n/a 

Rotate Anti-clockwise4 Shift & J n/a n/a 

1  Increasing and decreasing the movement speed does not affect the mouse sensitivity for 

rotating the view. 

2  The speed of the movement will be temporarily increased while the Shift key is held down. 

3  While holding the right mouse button down. 

4  If an EXODUS object (i.e. node, line etc.) is selected within the 3D View then the camera 

will rotate around this point. If no object is selected the camera will simply rotate around the 

centre of the geometry. 

 

NOTE: At this point the geometry should resemble that within the geometry file T17_6.exo 

provided 

 

10) Defining the sequence of floors the lifts will service during a simulation in Scenario 

mode: 

a) Right click on a Lift Shaft Opening transit node in the left transit node group and 

select the Lift Properties option from the pop-up menu. 

b) Within the Attributes tab make a note of the Title of the selected lift. 

c) On the Sequence tab within the Lift Properties dialogue box and ensure that the 

lift Procedure is defined as being a Shuttle floor sequence (see Figure 9-369).  
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Figure 9-369: Setting the lift’s Procedure as being a Shuttle floor sequence within the 

Lift Properties dialogue box. 

 

d) Add the following lift sequence: 9 0 8 0 7 0 6 0 5 0 4 0 3 0 2 0 1 0 (see Figure 

9-370). This represents the floors that the lift will serve. The first floor served 

(i.e. Floor 9) should be added by first clicking the Add button and then selecting 

the corresponding Lift Shaft Opening transit node within the lift shaft located on 

Floor 9. Once this has been added, the user can select the newly added floor by 

clicking on its corresponding Floor ID within the sequence list and then press 

the Enter key to generate an additional floor within the sequence. Once 

generated the user can then change the Floor ID of the new floor within the 

sequence by typing in its corresponding floor number. In this manner the user 

can use the enter-key and numbers on the keyboard to quickly and easily insert 

new floors into the sequence list. Once the floor sequence has been created, click 

the OK button in the Lift Properties dialogue box. 
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Figure 9-370: The Lift Properties dialogue box with a floor sequence defined 

 

e) Assign all Lifts the same attributes and floor sequence. 

i. In the Lift Properties dialogue box the user can assign all Lifts to have 

the same attributes and floor sequence by clicking on the Apply to all 

button (see Figure 9-370). If the user requires only the Lifts in the 

selected transit node group to have those attributes they can alternatively 

click the Apply to group button. However, the following alternative 

method provides greater flexibility to assign specific groups of Lifts 

identical attributes and floor sequences. 

ii. In Scenario mode, select the Lift Control option from within the Tools 

menu. This will display the Lift Control dialogue box. This dialogue box 

shows all Lifts within a geometry. 

iii. Using the Shift key and mouse, highlight all the Lifts within the Lift 

Control dialogue box. Right click on the Lift that you just entered the 

floor sequence for previously, then select the Assign to others option 

from the pop-up menu (see Figure 9-371). This copies all of the attributes 

and floor sequence list from the selected Lift to the other Lifts. This can 

be checked by viewing the floor sequence of the other Lifts. 
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Figure 9-371: Assigning attributes to selected Lifts via the Lift Control dialogue box 

 

NOTE: At this point the geometry should resemble that within the geometry file T17_7.exo 

provided 

 

11) Building the transit node groups for the remaining floors in Scenario mode: 

a) Right click on any Lift Shaft Opening transit node in the left lift group on 

Floor_0 and select the Replicate Group Vertically option from the pop-up menu. 

This copies the transit node group on the current floor for all Lift Shaft Opening 

transit nodes in the shaft (i.e. it creates a transit node group for all Lifts on all 

floors for the selected Lift bank i.e. transit node group). 

b) Repeat the same process for the right lift group.  

 

NOTE: At this point the geometry should resemble that within the geometry file T17_8.exo 

provided 

 

12) Populate each floor with 50 agents from the standard population in Population mode: 

a) In Population mode, select the Panel Populate option from the Tools menu. 

b) Within the Allocation section select the Floor option.  

c) Enter 500 as the Total Pop. Size and then click the Assign button. 

d) Adjust the population size for Floor_0 to be 0 (this tutorial does not require 

agents to be initially located on the ground floor). Click on the Calc. % button; 

this should update the % Size for each floor (see Figure 9-372) and adjust the 

total population size to 450. Click the OK button. 
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Figure 9-372: Allocating specific numbers of people to given floors via the Floor 

Assignment dialogue box 

 

e) Click the Populate button in the Population panel editor. Then click on YES in 

the displayed dialogue box to confirm the action. This will then populate each 

floor with the stated number of agents. 

 

13)  Defining the correct floor heights within the structure 

a) In Geometry mode, select the Construction option from within the Tools menu 

and then select the Floor Heights option from the resulting sub-menu. 

b) Within the resulting Floor Heights dialogue box ensure that Floor To Floor 

Heights of each floor are set to 3.0m (see Figure 9-373).  It is important to note 

that within buildingEXODUS the default height of each floor is 3.0m. 

Consequently in this instance the user should not be required to change the 

values. 

(NOTE: When using lifts it is important for the user to ensure that the heights of 

each floor are correctly defined. Within buildingEXODUS the heights of each 

floor define the distance that a lift will travel when moving between floors. As a 

result, incorrectly defining this height will mean that the distance travelled by 

the lift, and hence the time taken for it to traverse that distance, will be incorrect 

thereby negatively affecting the validity of the results produced). 

 



Chapter 9 - Tutorial 17 

©2017 University of Greenwich 446 

 
Figure 9-373: Defining the Floor To Floor Heights of each floor within the structure 

 

NOTE: At this point the geometry should resemble that within the geometry file T17_9.exo 

provided 

 

14) In Simulation mode, select Behaviour Options from the Rulebase menu. The following 

attributes should be set within the Behaviour Control dialogue box: 

 

Table 9-14: The options selected within the Behaviour Control dialogue box 

Attribute Tab Value 

Maintain Itinerary Route Check 

Transit Node Grouping Route Check 

Specified Response Behaviour Check 

Time(s) Behaviour 0 

 

9.17.2 Simulations 

The following scenarios represent typical cases that might be simulated for an evacuation 

analysis using lifts.  

 

1) Stair Only: This is usual practice during an evacuation and will be used as a basis for 

comparison for the remaining scenarios to ascertain the benefits of using lifts.  

a) Within Simulation mode select Behaviour Options from the Rulebase menu to 

display the Behaviour Control dialogue box. In the Lifts tab, ensure that both the 

Lift Evacuation and All Use Lifts options are unchecked. Also, check the Evenly 

Use Stairs option. This will ensure that agents will not use the lifts and evenly 

use the available stairs on their current floor. If this option is not selected then 

agents will elect to use a stair based on the Potential map to the exit - often 

resulting in prolonged evacuation times due to uneven stair usage.  

b) Run the simulation. 

(NOTE: if you click on the Advanced tab on one of the Floor_0 stair transit node 

dialogue boxes you should notice that approximately an even number of agents 

use the north and south stairs). 
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2) 2 Lift Banks: 

a) In this case both lift groups will be used.  

b) Within Simulation mode select Behaviour Options from the Rulebase menu to 

display the Behaviour Control dialogue box. In the Lifts tab, ensure that both the 

Lift Evacuation and All Use Lifts options are checked. All agents will now 

choose to use a Lift. 

c) Run the simulation. There may be some delay before the simulation starts and 

whilst it is running. This is because the agents are being assigned to use a Lift 

prior to the simulation starting and also distance maps are calculated for the entry 

point to each lift (i.e. for each Lift Shaft Opening transit node). 

d) After the simulation has run, save the sim file. 

e) Within the sim file the Lift performance and Lift Agent Interaction sections can 

be seen after the main output table (see Figure 9-374). 

 

 
Figure 9-374: Example output related to lift usage/performance within the simulation 

output file (.sim) 

 

The Lift performance section, displays for each Lift, the total number of agents that used the 

Lift, total number of trips made, total travel distance, average travel distance per trip and 

the last out time (i.e. the time the last agent alighted the Lift). 

 

In the Lift Agent Interaction table, each row represents an instance when an agent interacted 

with a Lift. The Lift field states the name of the lift that the agent interacted with. The 

Interaction field states how an agent interacted with a Lift (LFT=Lift user, LCR=Redirect 

due to congestion, LWR=Redirect due to wait time, MLR= Redirect due to missing a lift). 

If an agent redirected to the stairs (i.e. LCR, LWR or MLR) then the details of their 

interaction are stored in the first Lift in the transit node group. 

 

The Agent ID field defines the Label of the agent who interacted with the lift, while the 

Start Node field defines the Label of the node on which they started the simulation.  The 

Start Floor field defines what floor the agent initially started on. The Board Floor field 

defines what floor an agent boarded a lift (these maybe different for Sky Lobby cases). The 

Alight Floor field defines what floor an agent exited a Lift. The Start field defines what time 

the agent entered into the lift waiting area. The End field defines what time the agent decided 

to leave the lift waiting area i.e. decided to board a Lift or decided to redirect to the stairs. 
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The LWT field defines the Lift Wait Time and represents how long an agent waited to use a 

Lift (i.e. the End time minus the Start time). The LTT field defines the Lift Travel Time and 

indicates the total time in seconds that an agent spent travelling in the lift to their destination 

floor (i.e. Alight Floor).  

 

3) 1 Lift Bank: 

a) In this case only the left lift group will be used. As such, all Lifts in the right lift 

group should have their Is in service attributes set to No. This can be achieved 

by altering opening the Lift Properties dialogue box for a lift in the right lift 

group,  setting its Is in service attribute to No and then applying the settings to 

all Lifts in the group (i.e. clicking the Apply to group button similar to stage 

10(d)). 

b) Run the simulation. 

c) You should notice the average Lift Wait Time (LWT) and Total Evacuation Time 

(TET) increase compared to case 2. This is because fewer Lifts are available/used 

and hence agents have to wait longer to use a Lift. 

 

4) 2 Lift Banks with a Single Sky Lobby:  

a) Assign all Lifts to shuttle between Floor_5 (i.e. Sky Lobby floor) and Floor_0. 

To achieve this, move to Scenario mode, right click on a Lift Shaft Opening 

transit node and select the Lift Properties option from the pop-up menu.  In the 

Attributes tab ensure that the Is In Service attribute is set to Yes. In the Sequence 

tab, remove all existing floors and enter the following floor sequence: 5 0. 

Ensure the Sky Lobby option is selected within the Procedure list box. Once the 

Lift attributes have been set for a single Lift, assign all Lifts the same attributes 

by clicking on the Apply to all button. This will assign all Lifts in the simulation 

the same attributes and floor sequence. 

b) In Simulation mode, select Behaviour Options from the Rulebase menu to 

display the Behaviour Control dialogue box. In the Lifts tab, ensure that the 

Evenly Use Stairs option is checked. This will ensure that all agents below the 

Sky Lobby floor (i.e. Floor_5) will evenly use the stairs to evacuate. 

c) Run the simulation and save the simulation file. 

d) You should notice that agents above Floor_5 evenly use the stairs to travel to 

Floor_5 before using their nearest Lift. Agents already on Floor_5 also use the 

Lifts. 

e) Agents below Floor_5 randomly/evenly use the stairs to travel to the exit floor 

(i.e. Floor_0). 

f) Open the simulation file. Users will notice in the Lift Agent Interaction section 

that the floor agents start on and the floor they board the Lift is different for 

agents above Floor_5. The Start time indicates how long it took each Lift user 

to reach the lift waiting area on the Sky Lobby (i.e. Floor_5). 

g) In Simulation mode, select Behaviour Options from the Rulebase menu to 

display the Behaviour Control dialogue box. In the Lifts tab, ensure that the Sky 

Lobby Up Floors variable is set to 1. This enables agents to walk up a maximum 

of 1 floor in order to reach a Sky Lobby lift. 
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h) Run the simulation. You should notice that the behaviour of the agents is 

identical to that observed previously, with the exception of those agents initially 

located on Floor_4. Previously these agents randomly/evenly used the stairs to 

travel to the exit floor (i.e. Floor_0) since by default they were not permitted to 

travel up in order to reach the Sky Lobby lifts.  However in this scenario agents 

initially located on Floor_4 instead use the stairs to travel up to the Sky Lobby 

lifts on Floor_5.  This is permitted since the number of floors agents on Floor_4 

are required to travel up in order to reach the Sky Lobby lifts is less than or equal 

to the user defined limit (i.e. 1 floor as defined by the Sky Lobby Up Floors 

variable)  

 

(NOTE: Many high rise buildings contain Sky Lobbies where shuttle Lifts are 

used to service only the ground floor and the Sky Lobby. Since sky lobbies are 

often used as refuge floors (i.e. they are protected areas from fire/smoke etc.) 

they are often considered a more preferable place to wait for a lift. Past studies 

have shown that lift evacuation scenarios involving Sky Lobbies are more 

efficient as large crowds do not typically form and occupant wait times are 

decreased).  

 

5) 2 Lift Banks with Two Sky Lobbies:  

a) For the left lift bank, delete the existing floor sequence (i.e. Floor 5 and Floor 

0) and assign all Lifts within the group to instead shuttle between Floor_7 and 

Floor_0. Ensure that the Sky Lobby option is selected within the Procedure list 

box in Sequence tab of the Lift Properties dialogue box. 

b) For the right lift bank, delete the existing floor sequence (i.e. Floor 5 and Floor 

0) and assign all Lifts within the group to instead shuttle between Floor_3 and 

Floor_0. Ensure that the Sky Lobby option is selected within the Procedure list 

box in Sequence tab of the Lift Properties dialogue box. 

c) In Simulation mode, select Behaviour Options from the Rulebase menu to 

display the Behaviour Control dialogue box. In the Lifts tab, ensure that the Sky 

Lobby Up Floors variable is once again set to its default value of 0, thereby 

ensuring that agents will not consider walking up in order to reach a Sky Lobby 

lift. 

d) Run the simulation 

e) Users should notice that agents initially located on floors 7, 8 and 9 use the Sky 

Lobby on Floor_7. Agents initially located on floors 3, 4, 5 and 6 use the Lifts 

on Floor_3. Agents initially located on floors 1 and 2 only use the stairs. 

 

6) 2 Lift Banks with Manual Assignment: in addition to automatic assignment of agents 

to lifts, they can also be manually assigned using itineraries. 

a) For all Lifts, assign the floor sequence 9 0 and ensure that the Shuttle floor option 

is selected within the Procedure list box in Sequence tab of the Lift Properties 

dialogue box. 

b) Move to Population mode and delete all agents (Edit/Delete/Everyone). 

Populate the top floor (i.e. Floor_9) with 50 agents on the top side (see Figure 

9-375(a)) and 50 agents on the bottom side (see Figure 9-375(b)). 
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c) Select all agents on the top side. Use the population substitute function 

(Edit/Substitute/People) to assign those agents to use one of the Lift Shaft 

Opening transit nodes in the left lift group using the Auto Insert function. Set the 

itinerary task to Lift Bank. Click on the OK button. 

d) Repeat the same process for agents on the bottom except assign them to use one 

of the Lift Shaft Opening transit nodes in the right lift group. 

 

  
(a) (b) 

Figure 9-375: Populating Floor_9 with a) 50 agents on the top side and b) 50 agents on 

the bottom side. 

 

e) In Simulation mode, select Behaviour Options from the Rulebase menu to 

display the Behaviour Control dialogue box. In the Lift tab, uncheck the All Use 

Lifts option and check the Lift Evacuation option. 

f) Run the simulation. 

 

(NOTE: Agents do not explicitly use the Lift (i.e. the Lift Shaft Opening transit 

node) they were assigned, but can use any Lift within the same transit node group 

as the Lift that they are assigned.) 

 

 

7) All Lifts with Proportional Assignment: in certain cases it may be desirable to have a 

proportion of a floor’s occupants to initially consider using a Lift and adapt their 

behaviour in the lift waiting area according to local conditions. 

a) Move to Population mode, delete all the agents and assign 50 agents to each 

floor above the ground floor in the same manner as outlined previously in item 

12 within Section 9.17.1. 

b) Assign all Lifts (in both Lift banks) to Shuttle between all floors once and the 

ground floor (i.e. 9 0 8 0 7 0 6 0 5 0 4 0 3 0 2 0 1 0). 

c) In Scenario mode, select Tools from the menu and then select the Lift Usage 

Control option from the resulting menu (see Figure 9-376(a)). Alternatively, 

right click on the Floors tree item in the left Navigation window and select the 

Lift Usage Control option from the pop-up menu (see Figure 9-376(b)). The Lift 

Usage Control dialogue box will then be displayed (see Figure 9-377). 
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(a) (b) 

Figure 9-376: Accessing the Lift Usage Control dialogue box via a) the Tools menu, or b) 

the left Navigation window 

 

 
Figure 9-377: The Lift Usage Control dialogue box 

 

d) Set the percentage of agents to use the lifts on each floor as shown in Table 9-15. 

To do this change the % Choose Lift Definition option from Equation to User 

def. This will allow the % Choose Lift values to be modified. Once the values 

have been changed to those shown in Table 9-15 click OK, move to simulation 

mode and run the simulation. Observe how the agents use the lifts. The higher 

the floor the more likely it is that the agents will use the lifts.  
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Table 9-15: The percentage of agents on each floor that will choose to use a lift 

Floor % Choose Lift 

0 0% 

1 10% 

2 20% 

3 30% 

4 40% 

5 50% 

6 60% 

7 70% 

8 80% 

9 90% 

 

i. Move back to Scenario mode and open the Lift Usage Control again. 

Whilst the values for % Choose Lift can be set individually for each 

floor, an alternative method is to use the assignment formula at the 

bottom of the dialogue box. Here, the user can specify various 

parameters (A-G) in a formula where the ‘X’ value represents the floor 

number.  This generic but complex function allows the user to specify 

various types of functions including quadratic, linear, logarithmic, 

exponential to define the percentage of agents that will use the lifts on 

each floor. In this example the percentages will be set similar to those 

within Table 9-15, with the exception of floors 8 and 9 where the 

percentage of people that will use lifts will be capped at 70%. 

ii. Ensure that the % Choose Lift Definition is set to Equation 

iii. Set parameter B to 10 and the remaining parameters (A, C-G) to 0 (see 

Figure 9-378).  

iv. Set the Max Floor value to 7.  

v. Setting these values will make the formula equate to: % Choose Lift = 

10 x Floor number’ and automatically update the respective fields in 

the table. For all floors above Floor_7, the formula will use X=7 to 

calculate the percentage of agents that will choose a Lift (i.e. those 

floors will all have the same percentage as Floor_7).  
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Figure 9-378: The Lift Usage Control dialogue box displaying the % Choose a Lift for 

each floor based upon a defined equation 

 

NOTE: The Lift Usage Control dialogue box can be used to assign a percentage 

of agents on each floor to consider using a Lift (i.e. % Choose Lift).  The agents 

that will consider using a Lift, will be assigned a Lift Wait Time which defines 

how long they will be prepared to wait to use a Lift. The agents are also assigned 

a Congestion Threshold value which defines the maximum level congestion they 

are prepared to wait in for a Lift.  If either of these are exceeded then the agent 

will redirect to the stairs. Both values are assigned to agents using probability 

distributions which can be added/edited from within the Lift Usage Control 

dialogue box. 

 

e) Click on the OK button in the Lift Usage Control dialogue box. 

f) In Simulation mode, select Behaviour Options from the Rulebase menu to 

display the Behaviour Control dialogue box. Set the following behavioural 

options: 
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Table 9-16: The options selected within the Behaviour Control dialogue box 

Attribute Tab Value 

Maintain Itinerary Route Check 

Transit Node Grouping Route Check 

Specified Response Behaviour Check 

Time(s) Behaviour 0 

Lift Evacuation Lifts Check 

All Use Lifts Lifts Uncheck 

Shuttle Floor Return Lifts Uncheck 

Sky Lobby Up Floors Lifts 0 

Congestion Redirection Lifts Uncheck 

Wait Redirection  Lifts Uncheck 

Even Stair Redirection Lifts Check 

Evenly Use Stairs Lifts Check 

 

When the All Use Lifts option is unchecked EXODUS will use the % Choose 

Lift values for each floor defined in the Lift Usage Control dialogue box.  

 

g) Run the simulation. The higher the floor, the more agents use the Lift as per the 

percentages defined in the Lift Usage Control dialogue box. 

 

h) Using the Lift Usage Control dialogue box, with the exception of Floor_0, set 

100% of agents on each floor to choose to use a Lift. This can most easily be 

achieved by setting the % Choose Lift Definition to Equation, setting parameter 

B to 100 and the remaining parameters (A, C-G) to 0 and setting the Max Floor 

value to 1. 

 

i) In Simulation mode, select Behaviour Options from the Rulebase menu to 

display the Behaviour Control dialogue box. Set the following behavioural 

options: 

 

Table 9-17: The options selected within the Behaviour Control dialogue box 

Attribute Tab Value 

Maintain Itinerary Route Check 

Transit Node Grouping Route Check 

Specified Response Behaviour Check 

Time(s) Behaviour 0 

Lift Evacuation Lifts Check 

All Use Lifts Lifts Uncheck 

Shuttle Floor Return Lifts Uncheck 

Sky Lobby Up Floors Lifts 0 

Congestion Redirection Lifts Check 

Wait Redirection  Lifts Check 

Even Stair Redirection Lifts Check 

Evenly Use Stairs Lifts Check 
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When the Congestion Redirection and Wait Redirection options are checked 

then agents that choose to use a Lift will assess both the levels of congestion in 

the lift waiting area and how long they wait for a Lift when they enter into the 

lift catchment area. If these values are exceeded then an agent will redirect to 

the stairs. The default values for these distributions were collected via an online 

survey. The data suggests that very few people would consider waiting in high 

levels of congestion or for long periods of time. As people are located higher in 

a building, the greater the tolerance they would have for waiting in higher levels 

of congestion for longer periods of time.  

 

j) Run the simulation and save the simulation file. 

 

k) Open the simulation file and view the Lift performances section. All agents that 

redirect from a lift bank will be associated with the first lift in the bank in this 

table. 

 

Whilst all agents initially choose to use a Lift, many of them redirect to the stairs 

due to not being prepared to wait long for a Lift or in high levels of congestion 

i.e. either their Congestion Threshold or Lift Wait Time are exceeded. This is 

because in the data which the default wait times and congestion thresholds were 

based, very few participants on floors 10 and below said they would wait for 

extended periods of time in high levels of congestion in lift wait areas. Also, as 

the floor height increases, you will notice that more agents who elect to use a 

Lift are prepared to wait longer and in higher levels of congestion, because 

travelling on the equivalent stairs would take progressively longer and requires 

more energy. 
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